
Chapter 1

Introduction to 
Solid Edge ST4

After completing this chapter, you will be able to:
• Know the basic properties and different environments.
• Know the system requirements.
• Understand important terms and defi nitions.
• Know about the user interface.
• Save the Solid Edge designs automatically after regular intervals.
• Modify the color scheme.

Learning Objectives
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INTRODUCTION TO Solid Edge ST4
Welcome to the world of Solid Edge ST4, a product of SIEMENS. If you are a new user of this 
software, you will join hands with thousands of users of this high-end CAD tool worldwide. 
The previous releases of this software helped the users improve their design skills. In this 
latest release, the user interaction has been taken to a new level, thus making Solid Edge the 
easiest and fastest mechanical CAD product. 

Solid Edge is a powerful software that is used to create complex designs with great ease. The 
design intent of any three-dimensional (3D) model or an assembly is defi ned by its specifi cation 
and use. You can use the powerful tools of Solid Edge to capture the design intent of any 
complex model by incorporating intelligence into the design. With Synchronous Technology, 
Solid Edge redefi nes the rules of 3D modeling. It combines the speed and fl exibility of 
modeling with precise control of dimension-driven design, thereby generating tremendous 
productivity gains over traditional methods. 

In Solid Edge, the synchronous and traditional (now called Ordered) modeling environments 
are combined into a single modeling environment. This means, you do not need two separate 
environments to work with synchronous and traditional modeling technologies. The most 
interesting feature is that you can switch between the Synchronous and Ordered environments 
and can convert a particular Ordered feature into a Synchronous feature.

To make the design process simple and effi cient, this software package divides the steps of 
designing into different environments. This means each step of the design process is completed 
in a different environment. Generally, a design process involves the following steps:

• Sketching by using the basic sketch entities and converting them into features or parts.  
These parts can be sheet metal parts, surface parts, or solid parts.

• Assembling different parts and analyzing them.
• Generating drawing views of the parts and the assembly.

All these steps are performed in different environments of Solid Edge, namely 
Synchronous Part/Ordered Part, Assembly, Synchronous Sheet Metal/ Ordered Sheet 
Metal, Weldment, and Draft.

Solid Edge provides Software Development Kit (SDK) that helps you customize Solid Edge 
according to your requirement. Solid Edge also provides assistance, tutorials, and technical 
support to users. The tutorials can be browsed from the welcome screen. You can view as well as 
work on the models simultaneously. Solid Edge helps you fi nd commands quickly by using the 
Command Finder. Also, the enhanced tooltips in this version provide complete information of 
a tool such as its name and description as well as the shortcut keys used to invoke the tool.
 
Solid Edge supports data migration from various CAD packages such as IDEAS, AutoCAD, 
Mechanical Desktop, Pro/E, Inventor, CATIA, and NX. As a result, you can convert all fi les 
and documents created in these software into a Solid Edge document. You can also view or 
change the settings of a fi le while importing it. Solid Edge allows you to evolve a 3d model 
from a 2d drawing created in the Draft environment of Solid Edge or imported from any 
other software.
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Solid Edge ST4 is a combination of synchronous, parametric and feature-based solid modeling 
software. The bidirectional associative nature of this solid modeling tool makes the design 
process very simple and less time-consuming. The synchronous, parametric, feature-based, 
and bidirectional properties of this software are explained next.

Synchronous Technology
The Synchronous Technology of Solid Edge ST4, with its new commands and workfl ow 
concepts, has made modeling much easier, faster, and accurate than in the other parametric 
modeling as this technology enables you to create sketches as well as to develop features in 
the same environment. Note that the features created in this environment do not depend on 
the order of their creation. Therefore, the editing of the model becomes a lot easier. This 
state-of-the-art technology makes Solid Edge ST4 a completely feature-based 2D/3D CAD 
software package.

 Parametric Nature
Parametric nature of a solid modeling package means that the sketch is driven by dimensions, 
or in other words, the geometry of a model is controlled by its dimensions. For example, to 
model a rectangular plate of 100X80 units, you can draw a rectangle of any dimension and 
then modify its dimensions to the required dimensions of the plate. You will notice that the 
dimensions drive the geometry of the sketch.

Therefore, using this parametric property, any modifi cation in the design of a product can be 
accomplished at any stage of the product development. This makes the design fl exible.

Feature-based Modeling
A feature is defi ned as the smallest building block of a model. Any solid model created in Solid 
Edge is an integration of a number of features. Each feature can be edited individually to 
make any change in the solid model. As a result, the feature-based property provides greater 
fl exibility to the created parts.

The advantage of dividing a model into a number of features is that it becomes easy to modify 
the model by modifying the features individually. For example, Figure 1-1 shows a model with 
four simple holes near the corners of the plate. 

Figure 1-1  Model with simple holes
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Now, consider a case where you need to change all outer holes to counterbore holes. In a 
non-feature based modeling package, you need to delete all the holes and then create the 
counterbore holes. However, in Solid Edge, you can modify some parameters of the holes in 
the same part and convert the simple holes into counterbore holes, see Figure 1-2.  

 Figure 1-2  Model with counterbore holes

Bidirectional Associativity
The bidirectional associativity of a software package is defi ned as its ability to ensure that any 
modifi cation made in a particular model in one environment is also refl ected in the same 
model in the other environments. For example, if you make any changes in a model in the 
part environment, the changes will refl ect in the same model in the Assembly environment 
and vice-versa.

Figure 1-3 shows the top view and the sectioned front view of the part shown in Figure 1-1.

Figure 1-3  Drawing views of the model before modifi cation
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These drawing views are generated in the Draft environment. The views show that the part 
consists of a simple hole at the center and four simple holes near the corners. Now, when the 
model is modifi ed in the part environment, the modifi cations are automatically refl ected in 
the Draft environment, as shown in Figure 1-4. This fi gure shows that the four simple holes 
are converted into counterbore holes. This implies that the part environment and the Draft 
environment of Solid Edge are bidirectionally associative.

Figure 1-4  Drawing views of the model after modifi cation

Consider the assembly shown in Figure 1-5. The piston is connected to the connecting rod 
through a pin. It is clear from the assembly that the diameter of the hole is more than what 
is required. In an ideal case, the diameter of the hole on the piston should be equal to the 
diameter of the pin.

Figure 1-5  Piston, connecting rod, and pin assembly

Now, when you open the piston in the part environment and modify the diameter of the 
hole on it, the same modifi cation is also refl ected in the Assembly environment, as shown in 
Figure 1-6. This is due to the bidirectional associative nature of Solid Edge.
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Similarly, if the modifi cation is made in the Assembly environment, the piston, when opened 
in the part environment, is also modifi ed automatically. This shows that all environments of 
Solid Edge are associative by nature.

Figure 1-6  Assembly after modifying the diameter of the hole on the piston

Solid Edge ENVIRONMENTS
To reduce the complicacies of a design, this software package provides you with various design 
environments. You can capture the design intent easily by individually incorporating the 
intelligence of each design environment into the design. The design environments available 
in Solid Edge are discussed next.

Part Environment
This environment of Solid Edge ST4 is used to create solid as well as surface models. The part 
environment consists of two environments namely Synchronous Part and Ordered Part. You 
can switch between these environments and create a model which consists of both synchronous 
and ordered features. To invoke this environment, start Solid Edge ST4 by choosing Start > 
All Programs > Solid Edge ST4 > Solid Edge ST4 from the taskbar. After Solid Edge ST4  
starts, a welcome screen is displayed. From this screen, choose the ISO Part option from the 
Create area; the part environment gets started with the ISO units. By default, the Synchronous 
Part environment is invoked. However, you can switch to the Ordered Part environment by 
choosing the Ordered radio button from the Tools tab.

Synchronous Part
Solid Edge ST4 with the Synchronous Technology makes it a complete feature-based 2D/3D 
CAD system. This technology combines the speed and fl exibility of direct modeling with precise 
control of dimension-driven design. In this environment, there is no separate environment to 
draw sketches; rather the sketching tools are available in the Synchronous Part environment 
itself. It includes direct model creation and modifi cation through precision sketching, region 
selection, face selection, and handle selection. 
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Ordered Part
The Ordered Part environment of Solid Edge ST4 is used to create parametric and 
feature-based solids as well as surface models. You can draw sketches of models or features by 
invoking the sketching environment. Once the sketch is drawn, you can convert it into a solid 
model using simple but highly effective modeling tools. One of the major advantages of using 
Solid Edge is the availability of command bar. The command bar is displayed in the drawing 
window. In this environment, you can create a feature step by step by using the command 
bar. You can also use the command bar to easily go one or more steps backward to modify a 
parameter. You can also convert the features created in this environment to the synchronous 
features for editing them directly. The models created in the part environment can also be 
used in the other environments of Solid Edge to complete the model’s life cycle, also known 
as the Product Life Cycle.

Assembly Environment
This environment of Solid Edge is used to create an assembly by assembling the components 
that were created in the Synchronous/Ordered Part environment. Both the synchronous 
and ordered tools are combined in this environment. This environment supports animation, 
rendering, piping, and wiring. Other visualization and presentation tools are also available 
in this environment. In addition to that, you can apply a relation between the faces of two 
different synchronous components in an assembly. For example, you can make the selected 
face of a component tangent with the target face of another component.

Draft Environment
This environment is used for the documentation of the parts or the assemblies in the form of 
drawing views. The drawing views can be generated or created. All the dimensions added to the 
component in the part environment during its creation can be displayed in the drawing views 
in this environment.

Sheet Metal Environment
This environment is used to create sheet metal components. If you are conversant with the 
part environment, then modeling in this environment becomes easy. This is because in 
addition to the sheet metal modeling tools, this environment works in a way similar to the 
part environment. To invoke this environment, start Solid Edge ST4; a welcome screen  will be 
displayed. Choose the ISO Sheet Metal option from the Create area in the welcome screen; 
the Sheet Metal environment gets started with the ISO units. By default, the Synchronous 
Sheet Metal environment is invoked. However, you can switch to the Ordered Sheet Metal 
environment by choosing the Ordered radio button from the Tools tab.

Synchronous Sheet Metal
The Synchronous Sheet Metal environment is used to create and edit sheet metal 
components in a history-free approach. The procedure of selection of faces introduced in this 
environment allows you to model sheet metals directly. Also, the method of dimensioning 
the sheet metal components has been introduced in Solid Edge ST4 to enable you to create 
a dimension-driven design.
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Ordered Sheet Metal
The Ordered Sheet Metal environment is used to create parametric and feature-based sheet 
metal components.

Weldment Environment
This environment enables you to insert components from the part or the Assembly 
environment and apply weld beads to the parts or the assembly. This environment is associative 
with the part and Assembly environments. 

SYSTEM REQUIREMENTS FOR Solid Edge ST4
The system requirements for Solid Edge ST4 are as follows:

1. An Intel Pentium or AMD processor-based computer.
2. Windows XP Professional (32-bit or 64-bit), Windows Vista Business or Vista Enterprise 

(32-bit or 64-bit), Windows 7 (Professional, Ultimate or Enterprise).
3. Microsoft Internet Explorer 6.0 or later.
4. 2GB RAM minimum.
5. Disk space for installation = 3 GB. 
 

IMPORTANT TERMS AND DEFINITIONS
Some important terms that are used in this textbook are discussed next.

Relationships
Relationships are the logical operations that are performed on a selected geometry to make it 
more accurate by defi ning its position and size with respect to the other geometry. There are 
two types of relationships available in Solid Edge and these are discussed next. 

Geometry Relationships
These logical operations are performed on the basic sketched entities to relate them to the 
standard properties such as collinearity, concentricity, perpendicularity, and so on. Although 
Solid Edge automatically applies these relationships to the sketched entities at the time 
of drawing, you can also apply them manually. You can apply eleven types of geometry 
relationships, which are discussed next.

Connect
This relationship connects a point to another point or entity.

Concentric
This relationship forces two selected curves to share the same center point. The curves 
that can be made concentric are circles, arcs, and ellipses.

Horizontal/Vertical
This relationship forces the selected line segment or two points to become horizontal or 
vertical. 
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Collinear
This relationship forces two line segments to lie on the same line.

Parallel
This relationship is used to make two line segments parallel.

Perpendicular
This relationship makes a line segment perpendicular to another line segment or series 
of line segments.

Lock
This relationship is used to fi x an element or a dimension such that it cannot be 
modifi ed.

Tangent
This relationship is used to make the selected line segment or curve tangent to the selected 
line or curve.

Equal
This relationship forces the selected line segments to be of equal length. It also forces two 
curves to be of equal radius.

Symmetric
This relationship is used to force the selected sketched entities to become symmetrical 
about a sketched line segment, which may or may not be a center line.

Rigid Set
This relationship is used to group the selected sketched entities into a rigid set so that 
they behave as a single unit.

Feature Relationships (Only in Synchronous Part Environment)
The feature relationships are the relationships that are applied on a selected face to make 
it geometrically related to the target face. These relationships are used to modify the parts 
created in the Synchronous Part environment. The following types of feature relationships 
can be applied between faces:

Concentric
 This relationship makes the selected faces concentric with the target face.

Coincident
 In this relationship, the selected faces coincide with the target face.

Parallel
 This relationship enables you to make the selected faces parallel to the target face.
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Perpendicular
 This relationship helps you to make the selected faces perpendicular to the target face.

Tangent
 This relationship makes the selected faces tangent with the target face.

Rigid 
 This relationship is used to make all the faces in the selection set rigid with respect to each 

other. This means, if either of the face is moved or rotated, then all the related faces will 
also move or rotate, thereby maintaining the distance and orientation between them.

Ground
 This relationship grounds or constrains the selected face in the model space. As a result, 

the grounded faces can be neither moved nor rotated.

Symmetric about
 This relationship makes a selected face symmetric to a target face about a 

symmetry plane.

Equal Radius
 This relationship makes the radius of a selected cylindrical face equal to the radius of a 

target cylindrical face.

Coplanar Axis
 This relationship allows the selected entities to be coplanar to the theoretical plane you 

defi ne.

Assembly Relationships
The assembly relationships are the logical operations that are performed on the components 
to assemble them at their respective working positions in an assembly. These relationships 
are applied to reduce the degrees of freedom of the components. 

Flash Fit
This relationship minimizes the efforts of applying various relationships like: Mate, Planer 
Align, and so on by automatically positioning the component wherever required.

Mate
This relationship is used to make the selected faces of different components coplanar. You 
can also specify some offset distance between the selected faces.

Planar Align
This relationship enables you to align a planar face with the other planar face.

Axial Align
This relationship enables you to make a cylindrical surface coaxial with the other cylindrical 
surface.
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Insert
This relationship is used to mate the faces of two components that are axially symmetric 
and also to make their axes coaxial.

Connect
This relationship enables you to connect two keypoints, line, or a face on two different 
parts. 

Angle
This relationship is used to place the selected faces of different components at some angle 
with respect to each other.

Tangent
This relationship is used to make the selected face of a component tangent to the cylindrical, 
circular, or conical faces of the other component.

Cam
This relationship applies the cam-follower relationship between a closed loop of tangent 
face and the follower face. 

Parallel
The Parallel relationship is used to force two edges, axes, or an edge and an axis parallel 
to each other.

Gear
The Gear relationship allows you to apply rotation-rotation, rotation-linear, or a 
linear-linear relationship between two components. 

Entity
An element of a geometry is called an entity. An entity can be an arc, line, circle, point, and 
so on. 

Concept of a Profi le and a Sketch
In Solid Edge, there are two methods of drawing a sketch. The fi rst method is to draw a sketch 
in the sketching environment by invoking the Sketch tool from the Home tab. The second 
method is to invoke a feature creation tool such as Extrude, Revolve, and so on and then 
draw the sketch for the feature. The sketch drawn using the fi rst method is called a Sketch 
and the sketch drawn using the second method is called a Profi le. You will learn more about 
this in later chapters of this book.

Note
In case, you are working in the Synchronous Part environment, there is no separate sketching 
environment in it, and the sketching tools are added to the same environment.

Intent Zone
The intent zone is defi ned by a circular area that is divided into four quadrants. It is used 
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while drawing an arc or a circle from a line, or vice-versa. The quadrants defi ne whether the 
element is perpendicular, tangent or at some other orientation from the other element. This 
zone enables you to draw or modify various elements of a geometry within the same tool. For 
example, while drawing a line tangent to an arc, you can draw a tangent arc or a perpendicular 
arc by moving the cursor in the intent zone. The movement of the cursor in the intent zone 
determines the creation of a tangent or a perpendicular arc. The intent zone while drawing 
a tangent arc and a three point arc is shown in Figure 1-7 and 1-8, respectively.

Figure 1-8  Intent zone displayed while 
drawing a three point arc

Figure 1-7  Intent zone displayed while 
drawing a tangent arc

GETTING STARTED WITH Solid Edge ST4
After you have installed Solid Edge on your computer, choose Start > All Programs 
(or Programs) > Solid Edge ST4 > Solid Edge ST4, as shown in Figure 1-9; the welcome 
screen will be displayed. In this screen, links for various environments will be displayed in 
the Create area. You can start a new document in the desired environment by clicking on the 
corresponding link in this area. As discussed earlier, Solid Edge divides the designing steps 
into various environments.

Figure 1-9  Starting Solid Edge ST4 from taskbar
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You can open the existing documents by choosing the Open Existing Documents button 
located above the Create area. The links for the recently used documents are displayed in 
the Recent Documents area. You can click on the link of the required document in this area 
to open that document. The welcome screen also displays the link for step-by-step tutorials 
in the Tutorials area. The Favorite Links area contains the links for the home page and the 
technical support page of Solid Edge. However, you can add or remove links from this area.  

USER INTERFACE OF Solid Edge
Solid Edge provides you a Ribbon with different tabs and groups while working in 
different environments. This means that the tabs and groups available while working in the 
Synchronous Part /Ordered Part, Assembly, Draft and Synchronous Sheet Metal/Ordered 
Sheet Metal environments are different. Also, every environment has the PathFinder and the 
prompt line that assist you in creating the design. These user interfaces are discussed next.

Prompt Line
If you invoke a tool, the prompt line is displayed below the command bar. This line is very useful 
while creating a model because it provides you with the prompt sequences to use a tool.

PathFinder
The PathFinder, as shown in Figure 1-10, is present on the 
left of the drawing area. It lists all occurrences of features 
and sketches of a model in a chronicle sequence. 

Note
Remember that though the profi les of the features are 
not displayed in the PathFinder, but the sketches are 
displayed. You will learn about the difference between 
sketches and profi les later in this textbook. 

Docking Window
The docking window is available on the left of the screen and remains collapsed by default. It has 
different tabs on the top. These tabs can be used to activate the feature library, family of parts, 
and so on. The docking window expands when you move the cursor over the left pane of the 
screen. In case, any tab is missing in it, choose the Panes button from the Show group in the 
View tab; a fl yout will be displayed with various options. Choose the required option; the tab 
corresponding to that option will be added to the docking window. The options available in 
the docking window are discussed later in this textbook.

Ribbon
The Ribbon is available at the top of the Solid Edge window and contains all application tools. 
It is a collection of tabs. Each tab has different groups and each group is a collection of similar 
tools. You can increase the drawing area by minimizing the Ribbon. To do so, right-click on a 
tab in the Ribbon and choose Minimize the Ribbon from the shortcut menu displayed.

Figure 1-10  The PathFinder
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Quick Access Toolbar
The Quick Access toolbar is available on the top-left of the title bar of the Solid Edge window. It 
provides you an access to the frequently used commands such as New, Open, Undo, Redo, Save 
and Print. However, by default, only the Save option is displayed in the Quick Access toolbar. 
To add commands such as New, Open, and so on, choose the black arrow on the right of the 
Quick Access toolbar; the Customize fl yout will be displayed. Choose the required command 
from the fl yout to add it to the Quick Access toolbar, refer to Figure 1-11. On deselecting any 
command from the fl yout, the selected command will be removed from the toolbar. 

You can also customize the Quick Access toolbar 
to add more commands to it. To do so, invoke the 
Customize flyout again and then choose More 
commands from it; the Customize dialog box will be 
displayed with the Quick Access tab chosen by default. In this dialog box, select the required 
option from the Choose commands from drop-down list; the corresponding menus will be 
available in a list box displayed below it. Select the required tool from the list box and then 
choose the Add button to add the tool to the Quick Access toolbar. Similarly, you can also 
remove commands by using the Customize dialog box. To do so, select the required command 
from the list box at the right of this dialog box; the Remove button will be activated. Choose 
the Remove button; the selected command will be removed from the Quick Access toolbar. 

To remove any tool from the Quick Access toolbar, right-click on the required tool; a 
shortcut menu will be displayed. Choose Remove from Quick Access Toolbar from the 
shortcut menu; the corresponding tool will be removed from the toolbar. 

Application Button
The Application Button is available on the top left corner of the Solid Edge window. It is 
present in all environments. On choosing this button, the Application menu containing the 
options for creating, opening, saving, and managing documents will be displayed.

Status Bar
The status bar is available at the bottom of the Solid Edge window. It enables you to quickly 
access all the view controls like Zoom Area, Zoom, Fit, Pan, Rotate, Sketch View, View 
Orientation, and View Styles. A slider on the right of the status bar controls the amount of 
zooming. Most importantly, it consists of the Command Finder that helps you to locate the 
required command.

QuickBar
The QuickBar provides the command options for the active tool. The QuickBar that is 
available by default in the Synchronous Part environment is shown in Figure 1-12. It contains 
all possible tools to perform various operations, thereby increasing speed and fl exibility.

Figure 1-12  The QuickBar

Figure 1-11  The Quick Access toolbar
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Command Bar
The command bar provides the command options for the active tool. It enables you to 
switch back and forth while creating a model, an assembly, or a drawing. It is available in all 
environments of Solid Edge and contains different buttons/steps. The command bar that is 
available for the Extrude tool is shown in Figure 1-13. However, the buttons displayed in the 
command bar depend upon the tool invoked from the Part environment. For example, on 
invoking the Extrude tool, the buttons/steps displayed will have different options.

Figure 1-13  The command bar

 QuickPick
This tool enables you to select elements from the drawing window. This tool is used when the 
elements or the components are overlapping and you need to make a selection. The following 
steps explain the procedure of using this tool:

1. Bring the cursor near the element or the component that you need to select. Now, pause 
the cursor, and when three dots appear close to it, 
right-click on the screen. On doing so, the QuickPick 
dialog box will appear with an entry of each possible 
selection, as shown in Figure 1-14.

2. In the QuickPick dialog box, each entry represents an 
element. As you move your cursor over the elements in 
this list, the corresponding components get highlighted 
in the drawing window.

3. To exit the QuickPick dialog box, simply click on the screen. 

Tip: You can use the Options button available on the bottom right in the QuickPick 
dialog box to invoke the QuickPick Options dialog box. You can use the options in 
this dialog box to modify the QuickPick options.

Part Environment Tabs
There are several tabs in the Ribbon that can be invoked in the part environment. The tabs that 
are extensively used during the designing process in this environment are discussed next. 

The View Tab
This tab is available in all environments of Solid Edge. The View tab of the Ribbon is shown 
in Figure 1-15. 

Figure 1-15  The View tab

Figure 1-14  The QuickPick 
dialog box
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The Home Tab
This tab consists of the modeling tools that are used to convert a sketch into a solid model. 
The Home tab along with all its tools is shown in Figure 1-16. 

Figure 1-16  The Home tab in the Part environment

The Surfacing Tab
This tab contains the modeling tools that are used to create surface models. This tab is 
available only when you are in the Part / Synchronous Part environment. The Surfacing tab, 
along with all its tools, is shown in Figure 1-17.

Figure 1-17  The Surfacing tab in the Part environment

Assembly Environment Tabs
There are several tabs that can be invoked to create and manage assemblies in the Assembly 
environment of Solid Edge. 

The Assemble Group
The Assemble group is available in the Home tab of the Ribbon. The tools in this tab are 
used to create and manage assemblies. The Home tab in the Assembly environment is shown 
in Figure 1-18. 

Figure 1-18  The Home tab in the Assembly environment

Draft Environment Tabs
The Ribbon in the Draft environment provides you with various tools to generate and 
create drawing views. Various drafting tools available in the Home tab are shown in 
Figure 1-19.

Figure 1-19  The Home tab of the Draft environment
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Radial Menu
The radial menu is a set of tools arranged radially, as 
shown in Figure 1-20. To invoke a tool from the radial 
menu, press the right mouse button and drag the 
cursor; the radial menu will be displayed. Keeping the 
right mouse button pressed, move the cursor over the 
tool to be invoked and then release the mouse button; 
the tool will be invoked. You can add or remove tools 
from the radial menu. To do so, right-click on the 
Ribbon and choose the Customize the Ribbon option 
from the shortcut menu displayed; the Customize 
dialog box will be displayed. Choose the Radial Menu 
tab and select the Use Custom radio button. Next, 
select the category that contains the tool that you want 
to add to radial menu from the Choose commands 
from drop-down list. On doing so, the categories and the commands are displayed in the 
Command tree. Next, drag and place the tool onto the radial menu image in the dialog box; 
the tool will be displayed in the radial menu. To remove a tool from the radial menu, click on 
the tool in the radial menu image and drag it into the white space. Next, choose the Close 
button to exit the Customize dialog box.

 SIMULATION EXPRESS
Solid Edge ST4 provides you an analysis tool called Simulation Express. This tool is used to 
execute the linear static analysis and to calculate the displacement, strain, and stresses applied 
on a component with respect to the material, loading, and restraint conditions applied to a 
model. A component fails when the stress applied to it reaches a certain permissible limit. 
The Static Nodal displacement plot of the Master rod of the engine, designed and analyzed 
by using the Simulation Express tool is shown in the Figure 1-21. A new tab, Simulation, 
is added in the Ribbon of the part, Assembly, and Sheet Metal environments with all basic 
analysis tools in it. Both the Femap and industry standard NX Nastran solvers are used in 
Solid Edge’s Simulation Express.

 USING INTELLISKETCH
Intellisketch is a dynamic drawing tool that allows you to draw a sketch with accuracy 
by specifying various relations like endpoint, midpoint, perpendicular, parallel, tangent, 
horizontal, vertical, and so on. The Intellisketch shows the dynamic display of the relation 
while drawing a sketch. Moreover, while sketching a relationship indicator will be displayed at 
the cursor; click when the indicator is displayed to apply the respective relation to the drawing. 
You can also apply a relation after drawing the sketch. Additionally, these relationships are 
maintained even when you modify the sketch. In the Sketch environment, the Intellisketch 
tool is available in the Home tab, whereas in the Synchronous environments, it is available 
in the Sketching tab.

Figure 1-20  The Radial Menu
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Figure 1-21  The Master Rod analyzed using Simulation Express

 UNITS FOR DIMENSIONS
The units for dimensioning a sketch or feature can be the Metric and English templates. 
The Metric templates are prefi xed as ansi mm, din, iso, jis, metric and uni and the English 
templates are prefi xed as ansi. 

AUTOMATIC SAVING OPTION
In Solid Edge, you can set the option for saving the fi les automatically after a regular interval 
of time. While working on a design project, if the system crashes, you may lose the unsaved 
design data. If the option of automatic saving is on, your data is saved automatically after regular 
intervals. To set this option, choose Application Button > Solid Edge Options; the Solid 
Edge Options dialog box will be displayed. Choose the Save tab and select the Automatically 
preserve documents by check box. You can also select the Saving all documents every radio 
button and set the minutes in the spinner. You can also select to save uniquely named copies 
of the documents at a specifi ed location. By default, the fi les will be saved in the default folder. 
You can change the default backup folder location by selecting the File Locations tab from 
the dialog box. 

COLOR SCHEME IN Solid Edge
In Solid Edge, you can use various color schemes as the background color of the drawing 
window and for displaying the entities in it. Note that this book uses white as the background 
color. To change the background color, choose Application Button > Solid Edge Options; 
the Solid Edge Options dialog box will be displayed. Choose the Colors tab from this dialog 
box to display various colors, as shown in Figure 1-22. 
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Figure 1-22  The Colors tab of the Solid Edge Options dialog box

From the Background drop-down list in the Colors tab, select the White color; the background 
color will change to white. Next, choose OK from the Solid Edge Options dialog box to exit 
from it. 

Next, choose the View Overrides tool from the Style group of the View tab; the  Format View 
dialog box will be displayed. Choose the Background tab and select Solid Edge default from 
the Type drop-down list, as shown in Figure 1-23. Choose OK to exit this dialog box. Note 
that the current fi le will use this color scheme.

Figure 1-23  The Format View dialog box
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 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1. The Ordered Part environment of Solid Edge is a feature-based parametric environment 
in which you can create solid models. (T/F)

2. Any solid model created in Solid Edge is an integration of a number of features. (T/F)

3. The welcome screen of Solid Edge displays the link for step-by-step tutorials in the Tutorials 
area. (T/F)

4. In Solid Edge, the solid models that are not created by integrating a number of building 
blocks are called features. (T/F)

5. The __________ property ensures that any modifi cation done in a model in any one of the 
environments of Solid Edge is automatically refl ected in the other modes immediately.

6. The __________ relation forces two selected arcs, circles, a point and an arc, a point and 
a circle, or an arc and a circle to share the same center point.

7. The __________ relation is used to make two points, a point and a line, or a point and an 
arc coincident.

8. The __________ relation forces two selected lines to become equal in length.

9. The __________ lists all occurrences of features and sketches of a model in a chronicle 
sequence. 

Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. F, 5. Bidirectional associativity, 6. Concentric, 7. Coincident, 8. Equal, 
9. PathFinder


