
Chapter 3

Working with 
Surfaces-I

Learning Objectives       

After completing this chapter, you will be able to:
• Create revolved surfaces.
• Create extruded surfaces.
• Create skin surfaces.
• Create planar surfaces.
• Cut, copy, and paste objects.
• Undo and redo the executed commands.
• Edit keypoint curves.
• Create construction objects.
• Set construction planes.
• Preset grids.
• Control the visibility of objects.

Learning Objectives        
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CREATING SURFACES
In the previous chapter, you learned about creating curves and primitives, and transforming 
objects. In this chapter, you will learn to create revolved, extruded, skin, and planar surfaces. 
The methods of creating these surfaces are discussed next.

Creating a Revolved Surface
 Palette:	 Surfaces > Revolve  

A revolved surface is created by sweeping a curve around an axis through a specified 
angle. In Alias Design, you can create a revolved surface by using the Revolve tool. 
To create a revolved surface, first create a curve, as shown in Figure 3-1. Note that by 

default the X-axis acts as the axis of revolution. So, you need to create the curve in the Left 
or Top window. Also, you may need to change the pivot point position to create the desired 
revolved feature. Next, choose the Revolve tool from the Surfaces tab in the Palette; you will 
be prompted to select the curve to revolve. Select the curve from the active window; the re-
volved surface will be created, as shown in Figure 3-2.  

Figure 3-2  Revolved surfaceFigure 3-1  Profile for the revolved surface

To set the parameters of the Revolve tool, double-click on the Revolve tool; the Revolve 
Control dialog box will be displayed, as shown in Figure 3-3.

The options in the Revolve Control dialog box are discussed next.

Periodic
Select this check box to create a full-revolution (360 degrees) revolved feature. When you 
select this check box, the Per segment check box, Sweep angle, Segments, and Pitch edit 
boxes will become unavailable.

Sweep Angle
The Sweep Angle edit box is used to specify the angle of revolution for the revolved surface. 
By default, 360 is displayed in this edit box. Enter the desired value in this edit box to create 
a revolved surface. 
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Tip: You can also modify the sweep angle of an existing revolved surface by using 
its manipulator handle. To display the manipulator handle, choose the Query edit 
tool from the Object Edit tab in the Palette and then select the revolved surface. 
Next, drag the manipulator handle to the desired position. Alternatively, select the 
manipulator and enter the desired sweep angle in the promptline or in the Sweep 
angle edit box. The use of the Query edit tool will be discussed in detail in Chapter 8.

Figure 3-4 shows the revolved surface with the manipulator handle and sweep angle of -150 
degrees. 

Figure 3-3  The Revolve Control dialog box

Per segment
Select this check box to specify the sweep angle per segment instead of the entire revolution.

Segments
This edit box is used to specify the number of segments or individual surfaces that will be 
used to create the revolved surface. Note that the segments of a revolved surface are always 
curvature continuous with the adjacent segments. All the segments of a revolved surface are 
grouped together and revolve through the same angle. Figure 3-5 shows the revolved surface 
with 5 segments.
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Figure 3-5  Revolved surface having 5 segments Figure 3-4  Revolved surface with the manipulator 
handle and sweep angle of -150 degrees

Degree
This edit box is used to specify the degree of the revolved surface. The degree of the revolved 
surface affects its shape. If you enter 1 in this edit box, a rough surface will be created, as 
shown in Figure 3-6. If you enter a value higher than 1, a smooth surface will be created, as 
shown in Figure 3-7. 

Figure 3-7  Degree 1 applied on the revolved 
surface

Figure 3-6  Degree 1 applied on the revolved surface

Spans
This edit box is used to specify the number of spans in each segment of the revolved surface. 
You can also change the number of spans by using the slider bar given on the right of this 
edit box. Generally, the number of sections is kept between 6 to 8. It is recommended that 
the number of sections should not be more than 12.

Pitch
This edit box is used to specify the displacement of the curves along the axis of revolution 
and the pitch value entered in the edit box is for one complete revolution.
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Axis Options
The Options in this area are discussed next.

Axes 
The options in this drop-down list are used to specify the axis of revolution. In the Axes 
drop-down list, there are two options: Local and Global. These options are discussed next.

Local 	
The Local option is selected by default and is used to revolve the curve around its pivot 
point or local coordinate axes. While creating a revolved surface using this option, 
you cannot select multiple curves. To select multiple curves, you need to group them 
first and then revolve the grouped curves. 

Global
Select this option to revolve the curve around the global coordinate system of the 
current construction plane or axes. 

X 
This radio button is selected by default and is used to revolve the curve around the 
X-axis.

Y
Select this radio button to revolve the curve around the Y-axis. 

Z
Select this radio button to revolve the curve around the Z-axis. 

Picked
Select this radio button to specify the axis of the revolved surface. On selecting this radio 
button, the Picked Vector text box will be displayed in the Revolve Control dialog box. 
Select the desired vector from the view window; the name of the selected vector will be 
displayed in the Picked Vector text box. Alternatively, enter the name of the vector in 
this area and then press ENTER to select the vector. 

Manip
This radio button is selected automatically if you use the manipulator to change the 
revolution axis.

Refresh Vector
Choose this button to update the vector if the axis has been modified. This button is 
activated only when X, Y, or Z  radio button is selected in the Axis Options area.

Retain Vector
Choose this button to create a vector for the specified revolution axis.

Create Vector
This button is used to create a vector to use as the revolution axis.
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Control Options
The Options in this area are discussed next.

Auto update
This check box is selected by default and updates the revolved surface automatically 
whenever its parameters are changed. If you clear this check box and modify any parameter 
in the Revolve Control dialog box, then the Update button will be activated. Next, choose 
the Update button to update the revolved surface.

Continuity check
Select this check box to display the continuity locators between different segments of the 
revolved surface. The continuity locators are represented by the alphabet C. 

Create history
Select this check box to save the history of the revolved surface so that it can be modified 
later. If you create a revolved surface with the Create history check box selected, you can 
modify the profile of the revolved surface by modifying edit points or CVs of the curve. 
Modifications made on the curve will be reflected in the revolved surface.

Chain select
This check box is available in the Control Options area of the Revolve Control dialog 
box. After selecting this check box, if you select a curve, all other curves that are tangent 
continuous with the selected curve will be selected.

Creating an Extruded Surface
  Palette:	 Surfaces > Swept Surfaces > Extrude  

An extruded surface is created by extruding a curve or a profile along a specified path. 
The curve or profile selected for extrusion is termed as the profile curve. The curve 
selected for guiding the surface is termed as path curve. Figure 3-8 shows a path curve 

and a profile curve. You can create an extruded surface by using the Extrude tool. To invoke 
this tool, choose the Extrude tool from the Swept Surfaces flyout of the Surfaces tab in the 
Palette; a flyout will be displayed. Choose the Extrude tool from this flyout; you will be 
prompted to select curve(s) to extrude. These curves can be free curves, curves-on-surface, 
isoparametric curves, and so on. You can select open, closed, single, or multiple curves as 
profile curves. Select the profile curve; the Go button will be displayed at the lower right 
corner of the active window. Choose the Go button; you will be prompted to select the path 
curve. Select the path curve; the profile curve will be extruded along the path curve to create 
an extruded surface, as shown in Figure 3-9.
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Figure 3-9  Extruded surfaceFigure 3-8  Profile and path curves

To set the parameters of the Extrude tool, double-click on

Figure 3-10  The Extrude Options 
dialog box

 
the Extrude tool; the Extrude Options dialog box will 
be displayed, as shown in Figure 3-10.

The options in the Extrude Options dialog box are 
discussed next.

Style
The Style area is used to specify the profile of the 
surface when the profile curve is extruded along the 
path curve. The type of surface that is generated by 
specifying the profile depends on the orientation of 
the curve. The radio buttons in the Style area are 
discussed next.

Tube
This radio button is selected by default and is used to extrude the surface with the profile, 
maintaining its orientation with the path curve. In other words, the profile rotates with 
respect to the path curve, as shown in Figure 3-11.

Flat
Select the Flat radio button to extrude the surface such that the profile maintains its 
original orientation. In other words, the profile does not rotate while extruding along the 
path curve, as shown in Figure 3-12.

Create Caps
The Create Caps area is used to specify whether the caps will be created at the ends of the 
extruded surface.  The radio buttons in this area play a significant role in case of surfaces that 
are created by using the closed profile curves. The radio buttons in this area are discussed next.

Off 
This radio button is selected by default and is used to create an extruded surface that is 
open at both ends. 
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Figure 3-12  Surface extruded with the Flat radio 
button selected

Figure 3-11  Surface extruded with the Tube 
radio button selected

Cap Start
Select this radio button to create the extruded surface with a cap at the first end, as shown 
in Figure 3-13. 

Cap Both
Select this radio button to create the extruded surface with caps at both ends, as shown 
in Figure 3-14. 

Figure 3-14  Extruded surface created with the  
Cap Both radio button selected

Figure 3-13  Extruded surface created with the 
Cap Start radio button selected

Extrude Pivot
This area is used to choose the pivot point if there are more profile curves. This area will be 
available only when the Tube radio button is selected from the Style area. The radio buttons 
in the Extrude Pivot area are discussed next.
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Closest
The Closest radio button is selected by default. As a result, the profile curves are pivoted 
at the endpoint of the path curve that is closest to the bounding box of all profile curve. 
For better results, create the profile near the start point or endpoint of the path curve.

Component
On selecting the Component radio button, the profile curves pivot around their individual 
pivot points.

Figure 3-15 shows the profile and path curves and Figure 3-16 shows the closest pivot and 
component pivot extruded surfaces. 

Figure 3-16  The closest pivot and component pivot 
extrude surfaces

Figure 3-15  The profile and path curves

Tip: Create the path curve with less number of twists and bends to avoid creating 
an unwanted twisted surface. Also, it is not mandatory for the profile curve to lie 
on the path curve.

Create History
Select this check box to save the history of the extruded surface so that it can be modified later. 
If you create the extruded surface with the Create History check box selected, you can modify 
the profile of the extruded surface by modifying the edit points and CVs of the profile curve. 
The modifications made in the profile curve will be reflected in the extruded surface.

Creating a Skin Surface Using the Skin 2012 Tool
  Palette:	 Surfaces > Skin Surfaces > Skin 2012  

You can create a surface between two or more profile curves by using the Skin 2012 
tool. This tool allows you to create a freeform surface between the selected curves. 
Before invoking this tool, create two or more curves. Next, choose the Skin 2012 tool 

from the Skin Surfaces flyout of the Surfaces tab; you will be prompted to select the first 
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curve. Select one of the curves; you will be prompted to select the next curve or re-select the 
first curve to undo its selection. Select the other curve from the active window; the skin surface 
will be created, as shown in Figure 3-17.
 

Note
1. The display of CVs, hulls, and edit points 

Figure 3-17  Skin surface

 
in Figure 3-17 has been turned off by using 
the options in the Display area of the 
Control Panel.

2. For creating a skin surface with more 
than two curves, press the SHIFT key while 
selecting the curves after the selection of the 
second curve.

To set the parameters of the Skin 2012 tool, 
double-click on the Skin 2012 tool; the 
Skinning Options dialog box will be displayed, 
as shown in Figure 3-18.

The options in the Skinning Options dialog box are discussed next.

Skinning Mode
A curve consists of a number of points that can be defined       

Figure 3-18  The Skinning Options 
dialog box

 
with the help of the U and V parameters. The value 
of the U and V parameters ranges from 0 to 1. A curve 
with constant U or constant V parameter is known as 
isoparametric curve. These parameters are used in 
mathematical definition of the surface and also for 
defining paths on the surface. These parameters are 
not spaced proportionally along the surface. The 
Skinning Mode area is used to control the V parameter 
of the skin surface. The radio buttons in this area are 
discussed next.

Interpolate
This radio button is selected by default and is used 
to place V isoparametric curves on original curves. 
This option gives results only in the case of the 
curves that have more than one degree.  

Cubic Fit
On selecting this radio button, V isoparametric 
curves will be placed on surfaces according to the 
fitting algorithm.  
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Note
You can increase the number of V isoparametric curves by changing the number of spans in the 
Pick area of the Control Panel.  

Topology
Topology specifies the relationship between objects such as curves, surfaces, boundaries, and 
so on in a model. The options in the Topology area are used to control the spatial relationship 
between curves used for creating the skin surface. The radio buttons in this dialog box are 
discussed next.

Open
This radio button is selected by default and is used to create an open skin surface. 

Closed
Select this radio button to create a closed periodic skin surface. Using this radio button, 
you can connect the first curve to the last curve. Figure 3-19 shows the three lines to be 
selected for creating a skin surface. Figure 3-20 shows the open and closed skin surfaces 
created.

Figure 3-20  Open and closed skin surfaces 
created

Figure 3-19  Lines to be selected for creating a 
skin surface

Note
The skin surfaces in Figure 3-20 have been created by selecting lines with the SHIFT key pressed. 
Therefore, a continuous skin surface is created from a set of more than two curves.
  

U Knot Spacing
A surface has two directions, U and V. The U direction runs along the length of the curve. 
The U Knot Spacing area controls the U parameters in relation to the actual surface. The 
options in this area are used to control the texture mapping while rendering a model. These 
options are discussed next.
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Uniform
The Uniform radio button is selected by default. As a result, the isoparametric curves 
in the U direction will have parameter values in the integer format such as 1.0, 2.0, 3.0, 
and so on. Isoparametric curves are spaced unevenly across the surface. As a result, the 
texture assigned to the curves stretches to fit evenly between the isoparametric curves, as 
shown in Figure 3-21.
  
Arc Length
On selecting this radio button, the edit points of isoparametric curves will be parameterized 
by average length through original construction curves. The parameter value of the starting 
edge of the surface is 0.0 and the parameter value at the opposite edge of the surface is 
equal to the average total length through original construction curves. As parameterization 
is based on length, isoparms are spaced evenly. As a result, the assigned texture is spaced 
evenly across the entire surface without stretching, as shown in Figure 3-22.

Figure 3-22  Assigned texture spaced evenly across 
the entire surface without stretching

Figure 3-21  Assigned texture stretched to fit 
evenly between the isoparametric curves

V Knot Spacing
The V Knot Spacing area is used to control the V parameter in relation to the actual surface. 
The V direction runs across the original construction curves that connect the edit points of 
the original construction curves. The radio buttons in this area are discussed next.

Uniform
On selecting the Uniform radio button, the parameter values of isoparametric curves 
in the V direction will be in the integer format such as 1.0, 2.0, 3.0, and so on. In other 
words, the isoparametric curves will be parameterized uniformly among the original 
construction curves through their edit points. This option will be applied only when you 
select the Interpolate radio button from the Skinning Mode area. 

Chord Length
This radio button is selected by default. As a result, the edit points of the isoparametric 
curves will be parameterized by the chord length of the surface. The parameter value of 
the surface at starting edge is 0.0 and at the opposite edge is equal to the total length of 
the surface.
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Surface Degree
This area will be displayed only when you select the Interpolate radio button from the Skinning 
Mode area. The Surface Degree area can be used to specify the degree of surface in the V 
direction. By default, the 3 radio button is selected and is used to create a cubic surface.

Number of Spans
The Number of Spans edit box is used to specify the number of spans between original 
isoparametric curves of the skin surface. You can create a surface with a number of spans 
ranging from 1 to 100. You can also change the number of spans by using the slider bar given 
on the right of the Number of Spans edit box. The default value in this edit box is 1. With 
this value, only one span can be created on the surface and no additional isoparametric curve 
will be inserted in the surface. On entering 2 in the edit box, a surface with two spans will be 
created. In this case, one additional isoparametric curve will be inserted into the surface, as 
shown in Figure 3-23. Similarly, on entering 3 in the edit box, a surface with three spans will 
be created. In this case, two additional isoparametric curves will be inserted into the surface, 
as shown in Figure 3-24.

Figure 3-24  Surface with three spans createdFigure 3-23  Surface with two spans created

Rebuild
Select the Rebuild check box to match the parameterization of the surface with the first curve. 
This check box should be selected only when you are sure that the parameterization of the 
curve and the surface created match each other.  

Auto Update
The Auto Update check box is selected by default and is used to update a surface while adding 
curves to it. If you clear this check box and select the curves, the Go button will be displayed 
at the lower right corner of the active window. In this case, you need to choose the Go button 
to create the surface.

Create History
This check box is selected by default and is used to save the history of the skin surface so that 
it can be modified later. If you create the skin surface keeping the Create History check box 
selected, you can modify the profile of the skin surface by modifying the edit points and CVs 
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of the curves that were used to create it. Modifications made on the curves will be reflected 
in the skinned surface.

Creating a Skin Surface Using the Skin Tool
  Palette:	 Surfaces > Skin Surfaces > Skin  

The Skin tool is the enhanced version of the Skin 2012 tool. Using this tool, you can 
create single skin with G1 continuity by using multiple curves. Also, you can redefine 
the construction of a surface. To create a skin surface, choose the Skin tool from the 

Skin Surfaces flyout of the Surfaces tab; you will be prompted to select the first curve. Select 
one of the curves from the active window; you will be prompted to select the next curve or 
re-select the first curve to undo its selection. Select the other curve from the active window; 
the skin surface will be created. You can also select multiple curves to create skin surface. To 
select multiple curves, press the SHIFT key. Figure 3-25 shows skin surface created by selecting 
multiple curves.

To set the parameters of the Skin tool, double-click on the Skin tool; the Skin Control dialog 
box will be displayed, as shown in Figure 3-26.

Figure 3-25  Skin surface created using enhanced 
Skin tool

Figure 3-26  The Skin Control dialog 
box

The options in the Skin Control dialog box are discussed next.
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Proportional crown
Select this check box to raise or lower the midpoint of the surface between two input curve sets 
so that the height or crown of the surface increase or decrease proportionally to the distance 
between the curves. This option is not available when more than two curve sets are selected. 

To adjust the height or crown of the surface, you can use the slider or directly put the value 
in the edit box.

Flip
Select this check box to flip the direction of crown.

Flow Control
The options in this area are discussed next.

Start
The options in this drop-down list are used to define the extent of the surface through a 
snapping point on each input curve set. The different snapping point options present in 
the Start drop-down list are discussed next.

Default
Use this option to create a type of surface in which the extent of the surface is defined 
as the closest point from one curve set endpoint to the second curve set, so that the 
control layout remains normal to curve sets.

Extend
On selecting this option, you can create a surface in which surface can be extended 
to match the endpoint of the opposite surface. In this case also, the control layout 
remains normal to the curve sets.

Connect ends
The Connect ends option is selected by default and it allows you to connect endpoint 
of the initial curves set to the endpoint of the second curve set.

Note
The options present in the End drop-down list are similar to the options in the Start drop-down 
list.

Modify range
Select this check box to modify the input curve of the surface by using the range 
manipulators.

Surface Structure
The options in this area are discussed next.



3-16				                                     Learning Autodesk Alias Design 
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Surface type
The options in this drop-down list are used to define the type of the surface to be used 
to create the skin surface. The different options present in the Surface type drop-down 
list are discussed next.

Single surface
Select the Single surface option from the Surface type drop-down list to create a 
single skin surface.

Multiple surface
This option is chosen by default and is used to create multiple skin surfaces for each 
of the input curves you selected.

Short Edge Tolerance
The minimum distance that is allowed in the span of a surface where cross-knot occurs is 
called short edge tolerance. You can change the short edge tolerance value by using the 
Short Edge Tolerance edit box. 

Topology
The options in this area have been already explained in the Skin 2012 tool section.

Control Options
The options in this area are discussed next. 

Auto update
This check box is selected by default and updates the skin surface automatically whenever 
its parameters are changed. If you clear this check box and modify any parameter in 
the Skin Control dialog box, then the Update button will be activated. Next, choose the 
Update button to update the skin surface.

Continuity check
Select this check box to display the continuity locators between different segments of the 
revolved surface. The continuity locators are represented by the alphabet P, T, and C for 
positional, tangent, and curvature continuity respectively. 

Create history
Select this check box to save the history of the skin surface so that it can be modified later. 
If you create a skin surface with the Create history check box selected, you can modify 
the profile of the skin surface by modifying edit points or CVs of the curve. Modifications 
made on the curve will be reflected in the skin surface.

Deviation
Select this check box to display the maximum deviation indicator. But the indicator will 
only be displayed when deviation is set not 0.

Chain select
If you select this check box and then select a curve, all other curves that are tangent 
continuous with the selected curve will be selected.
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Creating a Planar Surface
  Palette:	 Surfaces > Planer Surfaces > Set Planar  

Planar surfaces are the trimmed NURBS surfaces that are created from the curves 
lying on the same plane. You can create these surfaces by using the Set Planar tool. 
This tool functions only when the selected curves form a closed profile. To create a 

planar surface, choose the Set Planar tool from the Planer Surfaces flyout of the Surfaces 
tab in the Palette; you will be prompted to select the first curve. Select the first curve from the 
active window; you will be prompted to select the other curve(s). You will notice that the Go 
button is displayed on selecting the profile curve(s), refer to Figure 3-27. Select the curves in 
such a way that they form a closed profile. Choose the Go button after selecting all curves; 
the planar surface will be created, as shown in Figure 3-28.

Figure 3-28  Planar surface createdFigure 3-27  Profile curves selected

Note
The display of CVs, hulls, and edit points in Figures 3-27 and 3-28 has been turned off for a 
better display of curves and surface. Also, the planar surface in Figure 3-28 has been shaded.

To set the parameters of the Set Planar tool, double-click on the Set Planar tool; the 
Planar Surface Options dialog box will be displayed, as shown in Figure 3-29. The options 
in this dialog box have already been explained in the previous  topic. 

Figure 3-29  The Planar Surface Options dialog box
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EDITING FEATURES
You can cut, copy, and paste the objects created by using the options in the Edit menu. These 
options are discussed next.

Removing an Object
  Menu bar:	 Edit > Cut  

You can temporarily remove an object, component, or feature from the active window. After 
removing the object, you can copy it to a temporary memory location and paste to other 
location. To remove an object, select it and then choose Edit > Cut from the menu bar; the 
selected object will be removed from the active window. Alternatively, press CTRL+X to cut 
the selected object from the active window.  

Copying an Object
  Menu bar:	 Edit > Copy  

You can copy an object, component, or a feature from the active window. To do so, first select 
an object and then choose Edit > Copy from the menu bar; the selected object will be copied. 
Alternatively, press CTRL+C to copy the selected object from the active window. 

Pasting an Object
  Menu bar:	 Edit > Paste  

You can paste a copied or cut object in the active window. To do so, first cut or copy an object 
and then choose Edit > Paste from the menu bar; the object will be pasted at the location of 
the original object. Alternatively, press CTRL+V to paste a copied or cut object in the active 
window. You can move the copied object away from the original object by using the Move tool. 

To set the parameters of the Paste option, click on the

Figure 3-30  The Paste Options dialog box

 
box given on its right; the Paste Options dialog box 
will be displayed, as shown in Figure 3-30. 

The options in this dialog box are discussed next.

Layers options
This area is used to specify the layers in which the 
copied or cut objects will be pasted. The radio 
buttons in this area are discussed next.

Same layers
This radio button is selected by default and is 
used to paste the object in the same layer from 
where it was copied or cut.
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Creation layer
Select this radio button to paste the object in the current layer. The current layer will be 
highlighted in yellow color in the layers bar. 

Always ask
Select this radio button and then choose the Go button; the Paste

Figure 3-31  The Paste 
options menu

 
options menu will be displayed, as shown in Figure 3-31. The 
options in this menu are used to specify the layer where the objects 
will be pasted. Choose the same layers option to paste the object 
in the layer from where it was copied or cut. Choose the duplicate 
layers option to paste the object in a duplicate layer. This layer 
is named identical to the existing layer. For example, if the 
existing layer is named as Line, the object will be pasted in a 
duplicate layer named Line#2. Choose the new layer option to 
paste the object in a new layer. You can specify the name of a new 
layer in the Create a new layer edit box of the confirm message box that will be displayed 
when you choose the new layer option from the menu. Choose the DefaultLayer option 
to paste the copied or cut object in the default layer. If there are existing layers, the menu 
will allow you to choose the required layer in which the copied or cut object will get 
pasted. You can cancel the pasting of the selected object by choosing the Cancel option.

Reverting to the Previous Command
  Menu bar:	 Edit > Undo  

You can reverse the effect of the previous command by choosing Edit > Undo from the menu 
bar. Alternatively, you can undo the previous command by pressing CTRL+Z keys. Also, you 
can specify the  number of undos in the Miscellaneous tab of the General Preferences dialog 
box. The General Preferences dialog box has been discussed earlier in Chapter 1.

Re-applying the Previous Command
  Menu bar:	 Edit > Redo  

If you undo the previous command by mistake, you can re-apply the previous command. To 
do so, choose Edit > Redo from the menu bar. 

Reinvoking the Last Command
  Menu bar:	 Edit > Reinvoke Last  

You can repeat the last command by choosing Edit > Reinvoke Last from the menu bar. 
Alternatively, press ALT+1 keys to repeat the last command. For example, if the last command 
executed was Cut, choose Edit > Reinvoke Last to repeat the Cut command.   

EDITING KEYPOINT CURVES
In Chapter 2, you have created keypoint curves. You can move, reshape, or edit the attributes 
of these keypoint curves. These editing operations are discussed next.
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Moving the Keypoints
  Palette:	 Curves > Keypoint Curve Toolbox > Drag keypoints  

To move keypoints, choose the Drag keypoints tool from the Keypoint Curve Toolbox; 
you will be prompted to use the mouse to drag the keypoint or enter the new position 
of the keypoint. Select the keypoint; the keypoint will be highlighted in green, as shown 

in Figure 3-32. Next, drag the cursor in the required direction; the keypoint will be moved, 
as shown in Figure 3-33. You can move a keypoint in the horizontal and vertical directions by 
dragging it with the middle and right mouse buttons, respectively. 

Figure 3-33  New position of the keypointFigure 3-32  Keypoint selected

Breaking the Keypoint Curves
  Palette:	 Curves > Keypoint Curve Toolbox > Break Curve at Keypoint  

You can detach keypoint curve at keypoints. To do so, choose the Break Curve at 
Keypoint tool from the Keypoint Curve Toolbox; you will be prompted to select 
keypoints to break curve at. Select the keypoint where you want to break the curve; 

the curve will be broken at that point. The broken curve will act as a separate object.

Joining the Keypoint Curves
  Palette:	 Curves > Keypoint Curve Toolbox > Break Curve at Keypoint > Join Curves  

You can attach different keypoint curves to form a single curve by using the Join 
Curves tool. This tool can also be used to attach regular curves by joining their edit 
points. To attach curves, choose the Join Curves tool from the Keypoint Curve 

Toolbox; you will be prompted to select the keypoints or edit points to join at. Select keypoints 
or edit points; the curves will join to form a single curve. Note that the keypoints of two curves 
to be joined need to be coincident. The joined curves will act as a single object. 
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Modifying the Attributes of a Keypoint Curve
  Menu bar:	 Windows > Information > Information Window  

You can edit the attributes of a keypoint curve such as name, length, radius, sweep angle, and 
so on. To do so, select the keypoint curve from the active window and then choose Windows > 
Information > Information Window from the menu bar; the Information Window dialog 
box will be displayed, as shown in Figure 3-34. Alternatively, select the keypoint curve and 
then  press CTRL+5 keys to display the Information

Figure 3-34  The Information Window dialog 
box

 
Window dialog box. To change the name of the 
curve, enter a new name in the Name edit box. 
You can select the Bounding Box check box to 
display the bounding box of the curve. Select the 
Invisible check box to hide the curve in the active 
window. To change the attributes of the curve, 
click in the Attributes area; different edit boxes, 
depending upon the type of the keypoint curve, 
will be displayed. You can change the length, 
radius, and sweep angle of the keypoint curve by 
entering new values in these edit boxes. If the 
keypoint curve is an arc, you can even change this 
arc to its complement by choosing the Arc 
Complement tool in the Attributes area. 

Tip: The Information Window dialog box can also be used to view the pivot point, 
bounding box, layer, and surface geometry information. 

Note
Another way to invoke the Information Window is by using the Marking menu. Press 
SHIFT+CTRL and right-click; a Marking menu is displayed. Choose Information 
Window from it.

CONSTRUCTION OBJECTS
Construction objects act as a reference for creating features of a model. The construction 
objects used in Alias Design are point, vector, plane, and grid. The creation of these objects 
is discussed next.

Placing a Point
  Palette:	 Construction > Point  

You can place reference points in the view windows by using the Point tool. The 
reference points act as an input to other tools, and are also used as snapping targets 
and place-holders. To create a reference point, choose the Point tool from the 

Construction tab in the Palette; you will be prompted to select the object or enter the position 
of the point. If you select a curve as a reference for positioning the point, the point will be 
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defined by three parameters, N1, N2, and du, as shown in Figure 3-35. If you select the 
boundary edge of the surface as a reference for positioning the point, the point will be defined 
by three parameters, N, du, and dv, as shown in Figure 3-36. You can also specify the position 
of the point by entering coordinates in the promptline or by clicking in the active window.

Figure 3-36  Points on a surfaceFigure 3-35  Points on a curve

 

To place a point with its name in the view windows,

Figure 3-37  The Construction Point 
Options dialog box

 
double-click on the Point tool; the Construction Point 
Options dialog box will be displayed, as shown in 
Figure 3-37. Select the Show Name check box to 
display the name of the point in the view windows.

Creating a Vector   

  Palette:	 Construction > Vector   

You can create a reference vector by using the Vector tool. Reference vector is used as 
an input for tools that require starting point and directions such as Project, 
Multi-surface draft, and Draft/Flange. To create a vector, choose the Vector tool from 

the Construction tab in the Palette; you will be prompted to pick a point or enter coordinates 
of the vector. Click in the active window or enter coordinates in the promptline; the manipulator 
will be displayed and you will be prompted to adjust the manipulator or enter the end position 
of the vector. Also, the Next Vector button will be displayed at the lower right corner of the 
active window. Choose the Next Vector button; the vector with the default setting will be 
created. You can change the position and length of the vector by dragging the arrow head 
manipulator to the required position before choosing the Next Vector button. If you select 
an existing object from the window to specify the vector’s origin; the vector will be set in 
geometry space, as shown in Figure 3-38. Also, the XYZ and Next Vector buttons will be 
displayed at the lower right corner of the active window. If you move the origin of the vector 
along the geometry, its orientation will get changed with respect to the change in the geometry, 
as shown in Figure 3-39. Choose the XYZ tool to set the vector in world space, as shown in 
Figure 3-40. If you move the origin of the vector along the geometry, the vector will not change 
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its orientation with respect to the change in the geometry, as shown in Figure 3-41. You can 
switch back to the geometry space by choosing the GEOM tool. 

To create a vector with its name in the view windows, double-click on the Vector tool; the 
Construction Vector Options dialog box will be displayed, as shown in Figure 3-42. Select the 
Show Name check box to display the name of the vector in the view windows. 

Figure 3-38  Vector set in geometry space Figure 3-39  Changed orientation of the vector

Figure 3-41  Unchanged orientation of the vectorFigure 3-40  Vector set in world space

Figure 3-42  The Construction Vector Options 
dialog box 
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Creating a Reference Plane
  Palette:	 Construction > Plane  

A construction plane is used as a reference for creating advanced surfaces. The 
construction plane is also used as an input for other tools such as Curve Planarize, 
Curve Section, and so on. You can create a reference/construction plane by using the 

Plane tool. A reference plane that is used to create an object or a feature is known as construction 
plane. To create a reference plane, choose the Plane tool from the Construction tab in the 
Palette; you will be prompted to select the plane construction method. Also, five buttons, 
View, Slice, 3 Pt, Geom, and World will be displayed at the lower right corner of the active 
window. These buttons are discussed next.

View
Choose this button to create a plane by specifying its center point. The Z-axis of the plane 
will be parallel to the view vector. When you choose this button, you will be prompted to 
specify the center point or the geometry point. Specify the position of the center point in the 
promptline or click in the active window; the plane with the manipulators will be displayed 
in the active window, as shown in Figure 3-43. Also, the Next Plane and Set Construction 
Plane buttons will be displayed in the active window. Next, choose the Next Plane button to 
create the construction plane, as shown in Figure 3-44. If you choose the Set Construction 
Plane button, the reference plane will be set as the construction plane. This construction 
plane can be set to an arbitrary coordinate system that can be oriented with respect to the 
world coordinate system. You can also modify the size, angle, or position of the plane by using 
different manipulator handles that will be discussed later in this chapter. 

Slice
Choose this button to create a plane by specifying two points. When you choose this button, 
you will be prompted to specify the center point or the geometry point of the plane. Specify 
the position in the promptline or click in the active window at the required point; the plane 
will be created in the active window and you will be prompted to specify the second point in 
the plane. Specify the second point; the plane passing through the center point and second 
point will be created. This plane will be perpendicular to the view window. Figure 3-45 shows 
two points specified for creating the plane and Figure 3-46 shows the plane passing through 
these points. 
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     Figure 3-44  Reference plane created     Figure 3-43  Plane with manipulators

  

Figure 3-46  Plane passing through two 
points

Figure 3-45  Two points specified for creating 
the plane

3 Pt
Choose this button to create a plane by specifying three points. On choosing this button, you 
will be prompted to specify the center point or the geometry point of the plane. Specify the 
position in the promptline or click in the active window at the required point; the plane will 
be created in the active window and you will be prompted to specify the second point in the 
plane. Specify the second point by clicking in the active window or entering coordinates in the 
promptline; you will be prompted to specify the third point in the plane. Specify the third point; 
a plane passing through the specified points will be created. Figure 3-47 shows three points 
specified for creating the plane and Figure 3-48 shows the plane passing through these points. 

Geom
Choose this button to create a plane on a geometry such that its Z-axis is oriented along 
the surface normal or the curve tangent. On choosing this button, you will be prompted to 
specify the center point or the geometry point of the plane. Click on the curve or surface at 
the required position; the plane will get snapped to the clicked object with the Z-axis oriented 
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Figure 3-48  Plane passing through three 
points

Figure 3-47  Three points specified for creating 
the plane

along the surface normal or the curve tangent. To view the changing orientation of the plane, 
move the plane along the curve or across the surface by using the manipulator. Figure 3-49 
shows the plane snapped to a curve and Figure 3-50 shows the changed orientation of the 
plane after moving it to the other location along the curve. 

Figure 3-50  Changed orientation of the planeFigure 3-49  Plane snapped to a curve

World
Choose this button to create a plane which is oriented along the world axes, as shown in 
Figure 3-51. On choosing this button, you will be prompted to specify the center point or 
the geometry point of the plane. Specify the center point or the geometry point by clicking 
in the active window or by entering coordinates in the promptline; the plane with its axes 
oriented along the world axes will be created in the active window as shown in Figure 3-52.
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Figure 3-52  Construction planeFigure 3-51  Plane oriented along the world 
axes

To create a construction plane with its name displayed in the view windows, double-click on 
the Plane tool; the Construction Plane Options dialog box will be displayed, as shown in 
Figure 3-53. Select the Show Name check box to display the name of the construction plane 
in the view windows. 

You can edit a plane with the help of a plane manipulator. Different handles of a plane 
manipulator are shown in Figure 3-54. The significance of these handles is discussed next.

Figure 3-54  Different handles of a plane 
manipulator

Figure 3-53  The Construction Plane Options 
dialog box 

Move handle
The Move handles (arrows) are visible on all three axes. Click and drag these handles to 
move the plane along their respective axes. You can also enter the translation amount in 
the promptline. 

Scale handle
The Scale handles (cubes) are visible on the two axes that lie on the plane. Click and drag 
one of the handles to scale the plane along it. You can also enter the scale factors in the 
promptline. Figure 3-55 shows the construction plane scaled along the X-axis. 
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Rotation handle
The Rotation handles (spheres) are visible on all the three axes. Click and drag these 
handles on one of the axes to rotate the plane about it. You can also enter the rotation 
angles in the promptline to rotate the plane. Figure 3-56 shows the construction plane 
rotated about X-axis.

Figure 3-56  Construction plane rotated about 
the X-axis

Figure 3-55  Construction plane scaled along 
the X-axis

Direction handle
The Direction handles (rectangular boxes) are visible on two axes that lie on the plane. 
Click one of the handles to flip the direction of the plane. Click on the dotted line that 
lies opposite to the axis to reflect the plane.

Center handle
The Center handle is used as the pivot point for moving, rotating, scaling, and flipping 
the plane. It also acts as the origin of the construction plane. You can drag this handle to 
change the position of the plane.

Setting the Construction Plane
  Palette:	 Construction > Set Construction Plane  

The Set Construction Plane tool is used to set the reference plane as the construction 
plane. To do so, choose the Set Construction Plane tool from the Construction tab 
in the Palette; you will be prompted to select a construction plane. Select a plane to 

set it as the construction plane. At a time, only one plane can be set as the construction plane; 
the rest of the planes will act as the reference planes. You can set any of the reference planes 
as the construction plane by using this tool. Note that when you set a reference plane as the 
construction plane, the axis triad changes accordingly. Also, the name of the construction 
plane will be displayed at the lower left corner of all view windows in the interface. 

Note
The Plane tool allows you to set the reference plane as the construction plane without using the 
Set Construction Plane tool. To do so, choose the Set Construction Plane tool that is displayed 
when you specify the center point or the geometry position of the plane while using the Plane tool.
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Toggling between the Planes
  Palette:	 Construction > Toggle Construction Plane  

You can toggle between the reference plane that is set as the construction plane and 
the plane defined by world space (XYZ) axes by using the Toggle Construction Plane 
tool. You need to set the reference plane as the construction plane before using this 

tool. Toggling between the construction planes changes the axis triad accordingly.

Presetting the Grid
  Palette:	 Construction > Grid Preset  

Grid is a network of uniformly spaced lines,  

Figure 3-57  The Preset Grid Options 
dialog box

superimposed on the screen. It is used as a 
reference for sketching, placing, snapping 

objects, and so on. You can turn the grid display on or 
off by choosing WindowDisplay > Toggles > Grid 
from the menu bar. Alternatively, press SHIFT+CTRL 
and then right-click; a marking menu will be displayed. 
Choose Toggle Grid from it to turn on/off the grid 
display. The grid lines are spaced horizontally and 
vertically with some spacing between them. You can 
change this spacing by using the Grid Preset tool. 

To set the parameters of the Grid Preset tool, 
double-click on the Grid Preset tool; the Preset 
Grid Options dialog box will be displayed, as shown 
in Figure 3-57. The options in this dialog box are 
discussed next.

Windows
The Windows area is used to specify the window in which the grid settings will be changed. 
The radio buttons in this area are discussed next.

All
This radio button is selected by default and is used to change the grid settings in all   
windows of the interface screen.

Current
Select this radio button to change the grid settings in the current or active window.

Grid Spacing
This edit box is used to specify the spacing or distance between grid lines in the current 
linear units. By default, the unit of grid spacing is millimeter. To change the unit spacing 
of the grid, choose Preferences > Construction Options from the menu bar; the 
Construction Options dialog box will be displayed. Next, choose Units > Linear from 
the dialog box to display the options under it. Click on the mm button given on the right 
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of the Main Units; a drop-down list showing different units will be displayed. Choose the 
required unit from the drop-down list and then close the Construction Options dialog box.

Subdivisions
This edit box is used to specify the number of subdivision lines between the two main grid 
lines. The subdivision lines appear light and dotted unlike the main grid lines that appear 
continuous and dark. The subdivision lines are also uniformly spaced with respect to each 
other. You can also specify the subdivisions by using the slider bar given on the right of the 
Subdivisions edit box. Figure 3-58 shows the main grid lines and subdivision grid lines.

Perspective Grid Extent
The Perspective Grid Extent edit box is used to specify the size of the grid in the 
Perspective window in linear units. By default, the grid size of 3200 mm is displayed in 
the Perspective Grid Extent edit box. You can change this value by entering a new value 
in this edit box. Figure 3-59 shows the Perspective window with the perspective grid 
extent of 1000 units. 

Figure 3-59  The Perspective  window with 
the  perspective grid extent of 1000 units

Figure 3-58  Main grid lines and subdivision 
grid lines

Note
When you change the units using the Construction Options dialog box, the default values of 
the respective units also change. If the unit is mm and the default value of the Perspective Grid 
Extent edit box is 3200, then after changing the units to cm, the default value will be 320.   

Corner Perspective Gnomen
Gnomen is an indicator that is placed at the lower left corner of the view window. This is 
significant as it displays the orientation of three mutually perpendicular colored axes. The 
Corner Perspective Gnomen check box is selected by default and displays the gnomen in 
the Perspective window. Clear this check box to hide the gnomen from the Perspective 
window.

Labels
Select this check box to display the labels on main and subdivision grid lines with their 
corresponding unit values. These labels appear only in the orthographic windows.
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Label Font Properties
This area will be available only when you select the Labels check box. The options in this 
drop-down list is used to specify the size of the font of label. By default, the Default option 
is chosen from this drop-down list. As a result, the labels with the default font properties 
are displayed, as shown in Figure 3-60. However, you can change the default settings as 
well. To do so, click on the Default option; a drop-down list will be displayed. You can 
choose the Custom option from this drop-down list to change the font size.

Label Font Size
This area will be available only when you choose the Custom option from the Label Font 
Properties drop-down list. By default, the 10 option is chosen from this area and is used to 
display the labels with the font size of 10. Click on the 10 option to display the drop-down 
list and choose the required label font size from this drop-down list; the label with the 
chosen label font size will be displayed in the orthographic windows. Figure 3-61 shows 
the grid label with label font size of 18.

Figure 3-61  Grid label with label font size 
of 18 

Figure 3-60  Grid label with default label 
font size

WORKING WITH LAYERS
Like other software packages, Alias Design allows you to organize objects. By organizing objects, 
you can control the selection, display, symmetry, and so on of the objects. These actions can be 
performed by using the layers that are displayed in the Layers bar. By default, a layer named 
DefaultLayer will be displayed in the Layers bar. To create a new layer, choose Layers > New 
from the menu bar; a new layer L1 will be displayed in the Layers bar. You can rename the 
layer by double-clicking on the layer and then entering a new name in it. Different operations 
that can be performed on objects by using layers are discussed next.
                                                                                                                        

Assigning the Objects to Layers
You can assign objects to layers. To do so, select the required objects and keep

Figure 3-62  The 
layer flyout

 
the left mouse button pressed on the layer in the Layers bar; a flyout will be 
displayed, as shown in Figure 3-62. Choose the Assign option from this 
flyout; the objects will be assigned to the layer. 

Selecting the Objects                                      
To select objects assigned to a layer, keep the left mouse button pressed on 
the layer in the Layers bar to invoke the flyout associated with the layer. 
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Next, choose the Pick Objects option from the flyout; the objects assigned to the layer will be 
picked. You can also control the selection of objects in the selected layer by using the options 
in the Layers menu. To select objects in the selected layer, choose Layers > Select > Objects 
on Selected Layers from the menu bar. To pick layers with the selected object assigned to it, 
choose Layers > Select > Layers by Picked Objects from the menu bar. To select all layers 
in the Layers bar, choose Layers > Select > All Layers from the menu bar. To select the 
layer within a range, choose Layers > Select > Layer Range from the menu bar and then 
enter the range in the promptline.

Controlling the Visibility of Objects
You can control the display of objects in the layers. By default, objects assigned to a layer will 
be visible. To turn off the visibility of objects in a layer, press and hold the left mouse button 
on the layer; a flyout will be displayed. Choose the Visible option from the flyout; the visibility 
of objects in the layer will be turned off. You can also control the visibility of objects in the 
selected layer by using the options in the Layers menu. To turn on the visibility of objects 
assigned to a selected layer, choose Layers > Visibility > Visible from the menu bar. Similarly,  
to turn off the visibility of objects assigned to a selected layer, choose Layers > Visibility > 
Invisible from the menu bar. You can also toggle between the visibility states of objects in a 
layer by clicking the box given on the right of the layer in the Layers bar.   

Setting the Symmetry of Objects
You can set the symmetry of objects in the layer. By setting the symmetry of objects in the layer, 
you can display the symmetric (mirror) copy of objects in the view window. By default, the 
symmetry of objects will be turned off. To set the symmetry of objects in a layer, press and hold 
the left mouse button on the layer; a flyout will be displayed. Choose the Symmetry option 
from the flyout; the symmetry of objects will be set. You can also set the symmetry of objects in 
the selected layers with the Layers menu. To do so, choose Layers > Symmetry > On from 
the menu bar. To turn off the symmetry of objects in the selected layers, choose Layers > 
Symmetry > Off from the menu bar. To convert the symmetric objects to real geometry, choose 
Layers > Symmetry > Create Geometry from the menu bar.

Deleting the Layers
To delete the selected layers, choose Layers > Delete > Selected Layers from the menu bar. 
To delete the unused layers, choose Layers > Delete > Unused Layers from the menu bar. 
Note that the Delete command will delete only the layer, not objects. 

Controlling the State of Objects
You can control the state of objects in the selected layers. To set the state of the selected layer 
to pickable, choose Layers > Set state > Pickable from the menu bar. Alternatively, keep the 
left mouse button pressed on the layer in the Layers bar; a flyout will be displayed. Choose 
Set state > Pickable from the flyout. The pickable layer and objects assigned to this layer will 
be displayed in grey. You can pick an object assigned to the pickable layer. To set the state of 
the selected layer to reference, choose Layers > Set state > Reference from the menu bar. 
Alternatively, choose Set state > Reference from the flyout that is displayed when you keep 
the left mouse button pressed on the layer in the Layers bar. The reference layer and objects 
assigned to this layer will be displayed in light brown. You can snap to objects assigned to the 
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reference layer without picking them up. To set the state of the selected layer to inactive, choose 
Layers > Set state > Inactive from the menu bar. Alternatively, choose Set state > Inactive 
from the flyout that is displayed when you keep the left mouse button pressed on the layer in 
the Layers bar. The inactive layer and objects assigned to this layer will be displayed in light 
blue and also objects assigned to the inactive layer will be visible. However, you cannot pick 
or snap to objects assigned to the inactive layer. 

Applying the Colors to Layers
You can apply colors to objects assigned to the selected layers. To do so, press and hold the 
left mouse button on the square box on the right of the layer; the color chooser flyout with 
different color swatches will be displayed, as shown in Figure 3-63. Select the required color 
swatch to apply color to the object. To edit the color of the objects, choose the Edit button 
from this flyout; the Layer Color editor will be displayed. Select the required color from this 
editor to assign the color to the object.

Figure 3-63  The color chooser flyout

Toggling between the Visibility States of Layers 
You can toggle between the visibility states of layers to turn on/off the visibility state of the 
entities assigned to them. By default, the visibility state of layers is turned on. To turn the 
visibility state of layers off, choose Layers > Toggle Layers from the menu bar; all layers 
will be disabled. Also, the visibility of layers will be turned off. To turn the visibility of Layer 
bar off, choose Layers > Toggle Layer Bar from the menu bar; the visibility of all layers 
will be turned off. However, you can access layers by using the Object Lister window that 
is displayed on choosing Windows > Object Lister from the menu bar. You can also toggle 
between the visibility states of unused layers by choosing Layers > Toggle Unused Layers 
from the menu bar.  

CONTROLLING THE DISPLAY OF OBJECTS
You can control the display of control vertices, edit points, hulls, and so on of all or active 
objects. To do so, choose the ObjectDisplay option from the menu bar; a menu will be 
displayed. Click on the box given on the right of the Control option; the DisplayControl 
options box will be displayed, as shown in Figure 3-64. The options in the DisplayControl 
options box are discussed next. 

Scope                                                            
The options in this drop-down list are used to specify the objects whose display will be affected 
by using the DisplayControl options box. You can control the display of active objects, entire 
model, new curves, and so on by choosing the respective button from this drop-down list.

Type
This drop-down list will be displayed only when you choose the New crv tool from the Scope 
drop-down list. The options in this drop-down list are used to specify the type of curve to be 



3-34				                                     Learning Autodesk Alias Design 
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

affected by using the DisplayControl option box. You can control the display of a free curve, 
blend curve, or keypoint curve by choosing the corresponding tool.  

All
The All area is used to automatically turn on or off the check boxes in

Figure 3-64  The 
DisplayControl 
options box

 
this area. By default, all check boxes are selected, thereby ensuring that 
the display of all components of an object is turned on in the view window. 
Choose the OFF button from this area to clear all check boxes 
automatically such that the display of the corresponding options in the 
view windows is turned off. You can turn the display of features on or off 
by selecting or clearing the corresponding check boxes manually.

Exit
Choose this button to close the DisplayControl options box.

Go
Choose this button to update changes in the display of objects in the 
view windows.

CONTROLLING THE VISIBILITY OF OBJECTS
You can turn the visibility off or on of objects in the view windows. The methods to control 
the visibility of objects are discussed next.

Turning off the Visibility of Objects
To turn off the visibility of objects, select the objects from the view window; the selected objects 
will be highlighted. Next, choose ObjectDisplay > Invisible from the menu bar; the visibility 
of the selected objects will be turned off. In other words, the objects will be invisible. 

Turning on the Visibility of Objects
To turn on the visibility of hidden objects,    

Figure 3-65 The Visible Options dialog box

choose ObjectDisplay > Visible from the 
menu bar; the hidden or invisible objects 
will be displayed in the view window. You 
can control the visibility of various features 
associated with the object. To do so, click 
on the box on the right of the Visible 
option; the Visible Options dialog box 
will be displayed, as shown in Figure 3-65. 
By default, the All radio button is selected 
from the Scope area of the Visible Options 
dialog box and is used to display all hidden 
objects in the view window. If you select the 
Pick radio button from the Scope area, the 
visibility of hidden objects selected from the 
SBD (Scene Block Diagram) window will be turned on. This radio button is also used to turn 
on the visibility of the objects whose name is entered in the promptline.
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Turning Objects into Templates
You can turn an object into template when you do not want them to be disturbed or affected 
while modifying other objects in the view window. Templates are also used as the reference 
objects or construction objects. To turn objects into templates, select the required objects from 
the window; the selected objects will be highlighted. Next, choose ObjectDisplay > Template 
from the menu bar; the objects will be turned into templates. The templates in the inactive 
state will be displayed in grey color, whereas the selected templates are displayed in pink color. 

Changing the Appearance of Data           
You can change the appearance of surfaces, curves, and section

Figure 3-66  The DrawStyle 
options box

 
data. To do so, choose the ObjectDisplay option from the menu 
bar; a menu will be displayed. Click on the box on the right of 
the Draw Style option in the flyout; the DrawStyle options box 
will be displayed, as shown in Figure 3-66. The areas in this option 
box are discussed next.

Surface
The options in this area is used to modify the appearance of 
features related to a surface. You can change a single surface to 
appear as double surface and vice versa. You can also change 
the icons of control vertices of the surface by selecting the 
corresponding option from the CV Icon area.

Curves 
The options in this area is used to modify the appearance of 
features related to a curve. You can change the line width and 
blend point style of the curve. Also, you can change the icons 
of control vertices and edit points of the curve by selecting the 
required options from the corresponding area.

SectionData
The options in this area is used to modify the appearance of the features related to section 
curves. You can change the line style, section point icon, and so on by selecting the required 
options from the corresponding areas. 

Symmetry
The options in this area is used to specify the appearance of objects that are set to symmetric. 
To do so, choose Layers > Symmetry > On from the menu bar. You can change the symmetric 
object to dashed or solid object by selecting the corresponding options from the Line Style area.

Visual Curves
The options in this area is used to specify the appearance of visual curves that include the 
curves created by evaluation tools, cross-sections, and so on. These curves do not include 
geometry curves.
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TUTORIALS

Tutorial 1

In this tutorial, you will create the model shown in Figure 3-67. After creating the model, you 
will shade it to give it a realistic look.  				      (Expected time: 45 min)

Figure 3-67  Model for Tutorial 1

	 The following steps are required to complete this tutorial: 

a.	 Start Alias and then start a new wire file.
b.	 Create the base feature of the model by using the Torus tool.
c.	 Scale the base feature non uniformly by using the Non proportional scale tool.
d.	 Create the profile and path curves for the extrude feature by using the Circle and Arc 

(two point) tools.
e.	 Create the extrude feature by using the Extrude tool.
f.	 Copy and rotate the extrude feature by using the Edit menu option and the Rotate tool, 

respectively.
g.	 Create the handle of the model by using the Extrude tool.
h.	 Create the cap of the handle by using the Cylinder tool.
i.	 Create the net by using the Line tool. 
j.	 Turn off the display of extrude curves.
k.	 Shade the model by using Diagnostic Shading.
l.	 Save the model and exit.

Starting a New Wire File
1.	 Start Autodesk Alias Design 2015 by double-clicking on its icon on the desktop of your 

system. You need to start a new wire file for creating the model.

2.	 Choose File > New from the menu bar; a new Alias Design file gets started and the 
Perspective window is displayed on the screen. 

Creating the Base Feature
	 The base feature is created by using the Torus tool. Before placing a torus in the active 

window, you need to set the parameters of the torus by using the New Torus Options 
dialog box.
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1.	 Double-click on the Torus tool from the Surfaces tab in the Palette; the New Torus  
Options dialog box is displayed.

2.	 Enter 2 and 0.15 in the Major radius and Minor radius edit boxes, respectively and 
choose the Go button; you are prompted to specify the position of the torus. 

3.	 Enter 0 in the promptline; the base feature is created, as shown in Figure 3-68.

Scaling the Base Feature 
	 As the base feature that you have created is not of the required shape and size, you need 

to scale it by using the transform tools.

1.	 Choose the Non-p Scale tool from the Transform tab in the Palette; you are 
prompted to enter the scale factors along the X, Y, and Z-axes. 

2.	 Enter 100, 75, 100 in the promptline and press ENTER; the base surface is scaled, as 
shown in Figure 3-69. Alternatively, drag the left mouse button downward to scale the 
base surface non uniformly. In this case, you can scale it arbitrarily.

Figure 3-69  Base feature after scaling non-uniformlyFigure 3-68  Base feature

Creating the Profile and Path Curves for the Extrude Feature
	 Next, you need to create the profile curve as well as the path curve for the extrude feature 

at top of the base feature by using the Circle and Arc (two point) tools.

1.	 Choose Layouts > Top from the menu bar; the Top window is expanded.

2.	 Choose the Circle tool from the Curves tab in the Palette; you are prompted to 
specify the position of the circle.
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3.	 If the grid display is off, turn on the display of grid by choosing WindowDisplay > 
Toggles > Grid from the menu bar. Alternatively, press SHIFT+CTRL and right-click; a 
marking menu is displayed. Choose Toggle Grid from the marking menu or choose the 
Show button displayed on the title bar of the window; a flyout is displayed. Choose Grid 
from the flyout to toggle the display on or off.

4.	 Press the ALT key and click at the Grid; a circle is created on the plane on which the base 
feature is placed, as shown in Figure 3-70.

5.	 Next, choose the Move tool from the Transform tab in the Palette; you are  
prompted to specify the new position of the circle. Alternatively, you can use the 
red and green manipulator arrows displayed on the circle to move the circle. 

6.	 Drag the cursor to move the circle to the desired position on the base feature, as shown 
in Figure 3-71.

Figure 3-71  Circle moved on the base featureFigure 3-70  Circle created as a generation 
curve 

7.	 Choose the Rotate tool from the Transform tab in the Palette; you are prompted  
to enter the rotation angles about the X, Y, and Z axes. Alternatively, click on the 
red and green manipulator circles displayed on the circle and then rotate it to the 
desired position. 

8.	 Enter 90, 90, 60 in the promptline and press ENTER; the circle is rotated as specified 
about the X, Y, and Z axes, as shown in Figure 3-72.

9.	 Choose the Scale tool from the Transform tab in the Palette; you are prompted  
to enter the scale factor.

10.	 Enter 20 in the promptline and press ENTER; the circle is scaled uniformly along the X, 
Y, and Z axes.

11.	 Choose WindowDisplay > Toggles > Grid from the menu bar; the grid display is turned 
off. The scaled circle after turning off the grid display is shown in Figure 3-73.
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Figure 3-73  Scaled circle after turning off 
the grid display

Figure 3-72  Circle rotated

12.	 Next, draw the arc by using the Arc (two point) tool from the Curves tab in the Palette, 
as shown in Figure 3-74.

Creating the Extrude Feature
	 The extrude feature can be created by using the circle and the arc as the profile curve and 

the path curve, respectively. 

1.	 Move the cursor to the currently available Swept Surfaces tool and then press and hold 
the left mouse button; the Swept Surfaces flyout is displayed.

2.	 Choose the Extrude tool from the flyout; you are prompted to select the curves to  
extrude.

3.	 Select the circle from the window; you are prompted to select or deselect curves to undo 
the selection of the first curve. Also, the Go button is displayed at the lower right corner 
of the window. 

4.	 Choose the Go button; you are prompted to select the path curve.

5.	 Select the arc from the window; the extrude feature is created, as shown in Figure 3-75.

Copying and Rotating the Extrude Feature
	 Next, you need to copy the extrude feature and then rotate it to place it exactly opposite 

to the original extrude feature at the bottom of the base surface. 

1.	 Select the extrude feature and then choose Edit > Copy from the menu bar to copy the 
extrude feature.

2.	 Next, choose Edit > Paste from the menu bar; the extrude feature is pasted exactly on 
the original feature in the window.
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Figure 3-75  The extrude feature Figure 3-74  Arc created by using the Arc 
(two point) tool

3.	 Choose the Rotate tool from the Transform tab in the Palette; you are prompted  
to enter the rotation angles about the X, Y, and Z-axes.

4.	 Enter 180, 0, 0 in the promptline and press ENTER; the copied feature is rotated about 
the X, Y, and Z axes, as shown in Figure 3-76.

Creating the Handle of the Model
	 In this section, you need to create the handle of the model by using the Extrude tool. 

1.	 Choose Layouts > Left from the menu bar or press the F6 key; the Left window is expanded 
to fill the entire interface screen. Alternatively, choose the Left hotspot from the ViewCube.

2.	 Next, choose the Circle tool from the Curves tab in the Palette; you are prompted 
to specify the position of the circle.

3.	 Click near the end of the two extrude surface features at the point where the two  extruded 
surfaces appear to meet; the circle is placed on the specified position, as shown in 
Figure 3-77.

Figure 3-77  Circle created near the end of 
the extrude surface features

Figure 3-76  The copied feature after rotation
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4.	 Choose the Scale tool from the Transform tab in the Palette; you are prompted  
to enter the scale factor.

5.	 Enter 40 in the promptline and press ENTER; the sphere is scaled uniformly along the 
X, Y, and Z axes, as shown in Figure 3-78.

6. 	 Choose the Rotate tool from the Transform tab in the Palette; you are prompted  
to enter the rotation angles about the X, Y, and Z axes.

7.	 Enter 0, 0, 90 in the promptline and press ENTER; the circle is rotated about the X, Y, 
and Z axes accordingly, as shown in Figure 3-79.

8.	 Choose the Pick nothing tool from the Pick tab in the Palette to exit the Rotate tool.

9.	 Next, choose the Line tool from the Keypoint Curve Toolbox and create the line, refer 
to Figure 3-79.

Figure 3-79  The rotated circle and the line Figure 3-78  Circle after scaling uniformly

10.	 Double-click on the Extrude tool from the Surfaces tab in the Palette; the Extrude 
Options dialog box is displayed.

11.	 Select the Cap Both radio button from the Create Caps area in the dialog box and then 
choose the Go button; you are prompted to select the curve(s) to extrude.

12.	 Select the circle from the window; the Go button is displayed again at the lower right 
corner of the active window.

13.	 Choose the Go button; you are prompted to select the extrude path.

14.	 Select the line; the handle is created, as shown in Figure 3-80.



3-42				                                     Learning Autodesk Alias Design 
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

Creating the Cap of the Handle                 
	 The cap of the handle can be created by using

Figure 3-80  Handle created by extrusion

 
the Cylinder tool. You can also scale the cap 
to the required size by using the Non-p Scale 
tool.

1.	 Choose the Cylinder tool from the
Surfaces tab in the Palette; you are 
prompted to specify the position of 
the cylinder.

2.	 Click at the end of the handle in the Left 
window; a cylinder is created.

3.	 Choose the Rotate tool from the Transform tab in the Palette and rotate the cylinder 
along the Z-axis, as shown in Figure 3-81.  

4.	 Choose the Non proportional scale tool from the Transform tab in the Palette and  
scale the cylinder non-uniformly along the X, Y, and Z axes, as shown in 
Figure 3-82. 

Figure 3-82  Cap created after scaling the 
cylinder non-uniformly 

Figure 3-81  Cylinder created for the cap of 
the handle 

Creating the Net of the Model
	 Next, you need to create the net of the model by using the Line tool. For the creation of 

the net, you need to create a set of horizontal and vertical lines.

1.	 Choose Layouts > Top from the menu bar; the Top window is expanded to fill the entire 
drawing area.

2.	 Choose the Line tool from the Keypoint Curve Toolbox and click on the torus  
to specify the start point and endpoint of the line, as shown in Figure 3-83.
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3.	 Choose the Pick Nothing tool from the Pick tab in the Palette to display the line created 
in the previous step, as shown in Figure 3-84. 

4.	 Create the rest of horizontal lines by pressing the middle mouse button while the Line  
tool is still active.

Figure 3-84  One horizontal line createdFigure 3-83  Start point and endpoint of the 
line

     

 5.	 Similarly, create vertical lines by pressing the right mouse button while the Line tool is 
still active. The model after creating the net is shown in Figure 3-85.

Note
When you draw lines with the Line tool, keypoints are also displayed. You need to turn off the 
display of these keypoints to suit the background color. The procedure to change the color related 
to the interface has been discussed in Chapter 1.

Turning off the Display of Curves Used in the Extrude Feature
	 For clear display of the model, you need to turn off the display of the curves used in the 

extrude feature. You can do so by using layers.

1.	 Choose Layers > New from the menu bar; a new layer, L1 is displayed in the Layers bar.

2.	 Double-click on the layer L1; the layer text edit box is displayed.

3.	 Enter Extrude Curves in the layer text edit box and press ENTER; the layer L1 is renamed 
as Extrude Curves.

4.	 Next, select the profile curve and the extrude path used in the extrude feature; the selected 
curves get highlighted.

5.	 Press and hold the left mouse button on the Extrude Curve layer; a flyout is displayed.

6.	 Choose the Assign option from the flyout; curves are assigned to the Extrude Curves 
layer.

7.	 Press and hold the left mouse button to display the flyout again.
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8.	 Choose the Visible option from the flyout; the visibility of the curves assigned to the 
Extrude Curves layer is turned off.

 Applying the Diagnostic Shading to the Model
	 The model that you have created is in the wireframe mode. For a better view, you need 

to shade the model. 

1.	 Choose ObjectDisplay > Diagnostic Shading from the menu bar; the Diagnostic Shade 
dialog box is displayed. 

2.	 Choose the User Defined Texture Diagnotic Shader tool from the Diagnostic 
Shade dialog box; the model gets shaded, as shown in Figure 3-86.

Figure 3-85  Model after creating the net Figure 3-86  Model after diagnostic shading

Saving the File
	 To save the above model, you need to create a new project directory, c03_tutorials. The 

new directory helps you store all files efficiently.  

1.	 Choose File > Save from the menu bar; the Save As dialog box is displayed. You can also 
invoke this dialog box by pressing the ALT+S keys. 

2.	 Choose the down arrow next to the Go To field and select the Current Home option from 
the drop-down list; the aliasdesign_2015 directory is displayed.

3.	 Choose the New Project button; a folder will be created with the name new_project. 
Rename it to c03_tutorials.

4.	 Next, select the c03_tutorials folder and choose Set Current. 

5.	 Enter c03_tut01 in the File name edit box of the Save As dialog box.

6.	 Choose the Save button; the file is saved as c03_tut01.wire.
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	 The location of this file is given below:

	 /aliasdesign_2015\c03_tutorials\wire\c03_tut01.wire

7.	 Choose File > Exit from the menu bar; the confirm message box is displayed.

8.	 Choose the Don’t Save button to exit the application.

Tutorial 2                 

In this tutorial, you will create the model shown in Figure 3-87. Figure 3-88 shows the model 
in the Left window. After creating the model, you will shade it to give it a realistic look.  		
		          			                                    (Expected time: 1 hr 30 min)

Figure 3-87  Model for Tutorial 2 Figure 3-88  View of the model in the Left 
window

	 The following steps are required to complete this tutorial:

a.	 Start a new wire file.
b.	 Create the base feature of the model by using the Revolve tool.
c.	 Create the central part of the model by using the Skin tool.
d.	 Turn off the visibility of the curves used in the base feature and central part.
e.	 Create the blade joint by using the Cylinder tool. 
f.	 Create the blade of the model by using the Skin Surface tool.
g.	 Close the ends of the blade by using the Set Planar tool.
h.	 Group the blade joint with the closed-end blade by using the Edit menu.
i.	 Copy and rotate the above grouped parts by using the Edit menu and the Rotate tool, 

respectively.
j.	 Create the tail piece by using the Skin tool.
k.	 Close the ends of the tail piece by using the Set Planar tool.
l.	 Shade the model by using the Diagnostic Shading.
m.	 Save the model and exit.
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Starting a New Wire File
1.	 Start Autodesk Alias Design 2015 by double-clicking on its icon on the desktop of your 

system. You need to start a new wire file for creating the model.

2.	 Choose File > New from the menu bar; a new Alias Design wire file gets started and 
perspective window is displayed on the screen.

  
Creating the Base Feature
	 The base feature of the model is created by using the Revolve tool. First, create the sketch 

of the required profile by using the Polyline tool and then revolve the same profile.

1.	 Choose Layouts > Left from the menu bar; the Left window expands to fill the entire 
interface screen. 

2.	 Choose WindowDisplay > Toggles > Grid from the menu bar to turn on the grid display, 
if grids are not displayed already.

 
3.	 Press and hold the left mouse button on the Line button in the Keypoint Curve Toolbox; 

a flyout is displayed. 

4.	 Choose the Polyline tool from the flyout and create the profile, as shown in  
Figure 3-89. You can use the Snap to Grid option to create the profile easily. 

5.	 Double-click on the Revolve tool in the Surfaces tab of the Palette; the Revolve 
Control dialog box is displayed.

6.	 Select the Z radio button and Global option of the Axes drop-down list from the Axis 
Options area and then select the polyline; the base feature is created, as shown in 
Figure 3-90.

Figure 3-90  Base feature of the modelFigure 3-89  Profile of the base feature
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7.	 Choose the Next button to complete the revolved base feature and exit the dialog box.

Note
1. The endpoints of profiles need to lie on the Z-axis. Keeping the endpoints of profiles on Z-axis 
allows you to create the closed revolve feature. Also, the lower endpoint of the profile needs to 
be at the origin. 

2. In Figures 3-89 and 3-90, the grid display has been turned off for clarity of the features.

Creating the Central Part
	 After creating the base feature, you need to create the central part of the model by using 

the Revolve tool.

1.	 Choose the Polyline tool from the Keypoint Curve Toolbox and create a polyline, 
as shown in Figure 3-91. 

2.	 Choose the Arc (two point) tool from the Keypoint Curve Toolbox and create an  
arc, refer to Figure 3-91. Make sure that the start point of the arc snaps to the 
endpoint of the polyline.

3.	 Next, choose the Line-arc tool from the Keypoint Curve Toolbox and create a 
linearc, refer to Figure 3-91. Make sure that the start point of the line-arc snaps to 
the endpoint of the arc.

4.	 Choose Break Curve at Keypoint > Join curves from the Keypoint Curve Toolbox;  
you are prompted to select keypoints.

5.	 Click at a position in the active window where the keypoints of the polyline and the arc 
coincide; the curves are attached. Similarly, attach the linearc with the two point arc.

6.	 Next, choose the Set Pivot tool from the Transform tab in the Palette; you are 
prompted to specify the new position of the pivot point. 

7.	 Drag the pivot point to the desired location, as shown in Figure 3-91.

8.	 Double-click on the Revolve tool from the Surfaces tab in the Palette; the Revolve 
Control dialog box is displayed.

9.	 Select the X and Local radio buttons from the Axis Options area and then select the 
joined curves; the central part of the model is created, as shown in Figure 3-92. 

10.	 Choose the Next button to complete the revolved base feature and exit the dialog box.
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Figure 3-91  Profile of the central part Figure 3-92  Central part 

Turning the Display of Curves off
	 For clear display of the model, you need to turn off the display of the curves that were 

used to create the base feature and the central part. You can do so by using layers.

1.	 Choose Layers > New from the menu bar; a new layer L1 is displayed in the Layers bar.

2.	 Double-click on the layer L1; the layer text edit box is displayed.

3.	 Enter Base Feature Curve in the layer text edit box and press ENTER; the layer L1 is 
renamed to Base Feature Curve.

4.	 Next, select the profile curve used in the base feature; the selected curve is highlighted.

5.	 Press and hold the left mouse button on the Base Feature Curve layer in the Layers bar; 
the layer flyout is displayed.

6.	 Choose the Assign option from the layer flyout; the curve is assigned to the Base Feature 
Curve layer.

7.	 Press and hold the left mouse button to display the layer flyout again.

8.	 Choose the Visible option from the layer flyout; the visibility of the curve assigned to the 
Base Feature Curve layer is turned off.

9.	 Similarly, create a new layer and rename it as Central Part Curve. Assign the joined curves 
(polyline, two point arc, and linearc) to this layer and then turn off its visibility.

Creating the Blade Joint
	 The blade joint is created on top of the central part by using the Cylinder tool.

1.	 Choose Layouts > Top from the menu bar; the Top window is expanded to fill the entire 
drawing area.
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2.	 Choose the Cylinder tool from the Surfaces tab in the Palette; you are prompted 
to specify the position of the cylinder.

3.	 Click in the Top window to specify the position of the cylinder; you will notice that the 
cylinder is created at the base feature in the Perspective window.

4.	 Use the manipulator in the Left window to position the cylinder at the required position. 
 
5.	 Choose the Scale tool from the Transform tab in the Palette; you are prompted  

to enter the scale factor. 

6.	 Enter 40 or a suitable value in the promptline and press ENTER; the blade joint is scaled 
to the specified scale, as shown in Figure 3-93. Figure 3-94 shows the scaled blade joint 
in the Perspective window.

Figure 3-94  Blade joint displayed in the 
Perspective window

Figure 3-93  Blade joint after scaling 

Creating the Blade
	 Blades are created by using the Skin surface tool. You need to create two closed curves 

for the skin surface.

1.	 Choose the Ellipse tool from the Keypoint Curve Toolbox; you are prompted to 
specify the position of the ellipse.

2.	 Click in the window to specify the position of the first ellipse.

3.	 Create another ellipse in line with the first ellipse, as shown in Figure 3-95. Figure 3-96 
shows two ellipses in the Top window.

4.	 Next, choose the Skin surface tool from the Surfaces tab in the Palette; you are 
prompted to select the first curve.

5.	 Select the first ellipse; you are prompted to select the next curve.

6.	 Select the second ellipse; the skin surface is created, as shown in Figure 3-97. 
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Figure 3-96  Ellipses displayed in the Top 
window

Figure 3-95  Two ellipses created in line with 
each other 

Closing the Ends of the Blade
	 The ends of the blade can be closed by using the Set planar tool.

1.	 Choose the Set planar tool from the Surfaces tab in the Palette; you are prompted 
to select the curve.

2.	 Select the top and bottom edges of the skin surface (or two ellipses) and then choose the 
Go button; the planar surfaces are created, as shown in Figure 3-98.

Figure 3-98  Planar surfaces created at the 
top and bottom of the blade

Figure 3-97  Skin surface

Grouping the Blade, Blade Joint, and Planar Surfaces
	 Now, you need to group the blade joint, blade, and its lower and upper planar surfaces. 

1.	 Select the blade joint, blade, and the lower and upper planar surfaces of the blade; the 
selected entities are highlighted.

2.	 Choose Edit > Group from the menu bar; the selected entities are grouped.
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Note
If the pivot point of the grouped entities is not located at the center of the central part feature, 
you need to place it at the center by using the Set pivot tool.
                                                                

Creating the other Instances of the Grouped Entities
	 After grouping the above-mentioned entities, you need to create two more instances of 

grouped entities.

1.	 Select the group created, if not selected already. Next, choose Edit > Copy and then 
Edit > Paste from the menu bar; the grouped entities are copied and placed exactly at 
the original grouped feature.

2.	 Next, choose the Rotate tool from the  Transform tab in the Palette; you are prompted 
to enter the rotation angles about the X, Y, and Z axes.

3.	 Enter 120, 0, 0 in the promptline and press ENTER; the grouped entities are rotated, as  
specified, about the X, Y, and Z axes. 

4.	 Similarly, create the third instance of the grouped entities, as shown in Figure 3-99.

Figure 3-99  Model after creating all instances 
of grouped entities

Creating the Tail Piece
	 The tail piece is created by using the Skin surface tool. You need to create two curves for 

creating a skin surface.

1.	 Choose the Line-arc tool from the Keypoint Curve Toolbox and create the profile.
Note that you need to create the profile at an offset of 10 units or a suitable value 
from the center of the central part of the model, as shown in Figure 3-100.

2.	 Choose Edit > Copy and then Edit > Paste from the menu bar; the linearc profile is 
copied and placed exactly on the original curve.
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3.	 Next, choose the Move tool from the Transform tab in the Palette and then move 
the linearc to a new position, as shown in Figure 3-101.

Figure 3-101  Copied profile moved to a 
new position

Figure 3-100  Profile of the tail piece

4.	 Choose the Skin surface tool from the Surfaces tab in the Palette; you are 
prompted to select the first curve.

5.	 Select the first linearc profile; you are prompted to select the next curve.

6.	 Select the copied linearc profile; the skin surface is created, as shown in Figure 3-102.

Closing the Front and Back Faces of the Tail Piece
	 You can close the front and back faces of the tail piece by using the Set planar tool. 

1.	 Choose the Set planar tool from the Surfaces tab in the Palette; you are prompted  
to select the curve.

2.	 Select both the edges of the skin surface and choose the Go button; the two planar surfaces 
are created, refer to Figure 3-103. Figure 3-104 shows the complete model.

Figure 3-103  Planar surfaces created on 
the front and back faces

Figure 3-102  Skin surface
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Applying the Diagnostic Shading to the Model
	 The model that you have created is in the wireframe mode. For a better view, you need 

to shade the model.

 1.	 Choose ObjectDisplay > Diagnostic Shading from the menu bar; the Diagnostic Shade 
dialog box is displayed.

2.	 Choose the User Defined Texture Diagnostic Shader tool from the Diagnostic 
Shade dialog box; the model is shaded, as shown in Figure 3-105. You can choose 
the rest of the buttons in this area to get other shades.

Figure 3-104  Complete model Figure 3-105  Model after shading

Note
1. After shading the model, select the complete model from the active window and clear the 
Isoparm U and V check boxes from the Display area of the Control Panel. It will hide the 
isoparametric U and V curves, thus giving a more realistic view to the model.

2. You can turn off the visibility of the curves used for creating blades and tail piece by using 
layers, as discussed earlier in this tutorial.

Saving the File
	 You need to save the created model in the c03_tutorials folder with the name c03_tut02. 

As you have already created the c03_tutorials folder in Tutorial 1 and set it as the current 
project, you need not create a new folder. 

1.	 Choose File > Save as from the menu bar; the Save As dialog box is invoked. You can 
also invoke this dialog box by pressing the ALT+S keys.

2.	 Enter c03_tut02 in the File name edit box and then choose the Save button; the file is 
saved as c03_tut02.wire. 
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	 The location of this file is given below:

	 \aliasdesign_ 2015\c03_tutorials\wire\c03_tut02.wire

3.	 Choose File > Exit from the menu bar; the confirm message box is displayed.

4.	 Choose the Don’t Save button to exit the application.

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this 
chapter: 

1.	 In the Axis Options area of the Revolve Control dialog box, the X radio button is selected 
by default. (T/F)

2.	 The Create Caps area is used with open generation curves. (T/F)

3.	 For creating a skin surface, you need at least two curves. (T/F)

4.	 The Set Planar tool is used to create a trimmed surface. (T/F)

5.	 Alias Design allows you to cut, copy, and paste objects. (T/F)

6.	 Press the __________ keys to copy an object or a component. 

7.	 The __________ command is used to repeat the last executed command.

8.	 In case of uniform knot spacing, the __________ of the assigned texture appears to fit 
evenly between the isoparametric curves.

9.	 Selecting the __________ radio button in the Layers options area of the Paste Options 
dialog box allows you to specify the layer where the objects are pasted.

10.	 While pasting an object using the duplicate layers option from the Paste options menu, 
a duplicate layer named __________ will be created, in case the existing layer is named as 
Line.
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Review Questions
Answer the following questions:

1.	 Which of the following degrees is displayed by default in the Degree edit box of the 
Revolve Control dialog box?

	
		  (a) 1					     (b) 2
		  (c) 5					     (d) 7

2.	 How many additional isoparametric curves are created on a surface if you enter 3 in the 
Number of Spans edit box in the Skinning Options dialog box?

		  (a) 1					     (b) 2
		  (c) 3					     (d) 4

3.	 Which of the following keys is pressed to create a single skin surface from a set of 
curves?

		  (a) SHIFT				    (b) ALT
		  (c) CTRL				    (d) TAB

4.	 In the Revolve Control dialog box, the Global radio button is selected by default in the 
Axis Options area. (T/F)

5.	 In the Extrude Options dialog box, the Extrude pivot area is displayed only when the 
Tube radio button is selected from the Style area. (T/F)

6.	 A curve of constant U or constant V parameter is known as isoparametric curve. (T/F)

7.	 The __________ edit box in the Preset Grid Options dialog box is used to specify the 
number of subdivision lines between two main grid lines.

8.	 The __________ area is used to specify the condition at the ends of the extruded surface.

9.	 The Set planar tool works only on the profiles that form a __________ loop. 

10.	 You can reverse the effect of the previous command by choosing __________ from the 
menu bar.
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Exercises

Exercise 1 
Create the model, as shown in Figure 3-106. After creating the model, you will shade it to give it  
a realistic look.						         	  (Expected time: 30 min)

      Hint
1.	 Create the chair padding (legs) by using the Extrude tool.
2.	 Choose the Circle tool from the Curves tab to create the profile curve.
3.	 After creating the generation curve, create the path curve by using the Line-arc tool.
4.	 Specify the position of different segments of the linearc by entering coordinates in the 

promptline.  
5.	 Extrude the circle along the path curve to create the chair padding.
6.	 Create the seat of the chair by using the Skin surface tool.

Exercise 2 
Create the model, as shown in Figure 3-107. After creating the model, you will shade it to give 
it a realistic look.						        (Expected time: 45 min)

Figure 3-106  Model for Exercise 1 Figure 3-107  Model for Exercise 2

Answers to Self-Evaluation Test
1. T, 2. F, 3. T, 4. T, 5. T, 6. CTRL+C, 7. Reinvoke last, 8. stretching, 9. Always ask, 10. Line#2


