
Chapter 2

Drawing Sketches in
the Sketcher
Workbench-I

After completing this chapter, you will be able to:
• Understand the Sketcher workbench of CATIA V5.
• Start a new file in the Part workbench and invoke the Sketcher workbench within it.
• Set up the Sketcher workbench.
• Understand important Sketcher terms.
• Draw sketches using tools in the Sketcher workbench.
• Use some of the drawing display tools.

Learning Objectives
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THE SKETCHER WORKBENCH
Most components designed using CATIA V5 are a combination of sketched features, placed
features, and derived features. The placed features are created without drawing a sketch,
whereas the sketched features require a sketch that defines its shape. Generally, the base
feature of any design is a sketched feature. For example, refer to the solid model of the Link
shown in Figure 2-1. The base sketch to create this solid model is shown in Figure 2-2.

The Sketcher workbench provides the space and tools to draw sketches of the solid model.
Generally, the first sketch drawn to start the design is called the base sketch, which is then
converted into a base feature. However, once conversant with the advanced options of
CATIA V5, you will also be able to use a derived feature or a derived part as the base feature.
In this chapter, you will learn more about the sketching tools in the Sketcher workbench that
are used for drawing and displaying the sketches.

To draw a sketch, invoke the Sketcher workbench in the Part Design workbench or in the
Assembly Design workbench by choosing the Sketch button from the Sketcher toolbar. Next,
select a plane to draw the sketch. Draw the sketch and proceed to the Part Design or the
Wireframe and Surface Design workbench to convert it into a solid model or surface model.

STARTING A NEW FILE
When you start CATIA V5R18, a new Product file with the name Product1 is displayed on
the screen, as shown in Figure 2-3. Close this file and start a new one in the Part Design
workbench. You will learn more about the Product files in the later chapters.

When you choose File > Close from the menu bar, the start screen of CATIA V5 is displayed.
Choose Start > Mechanical Design > Part Design to make sure that you are in the Part
Design workbench. On doing so, the New Part dialog box will be displayed, as shown in
Figure 2-4. Enter the part name in the Enter part name edit box and select the Enable
hybrid design radio button if it is not already selected. Choose OK to start a new file in the
Part Design workbench. Alternatively, you can choose the File > New option from the menu
bar; the New dialog box will be displayed, as shown in Figure 2-5. Select Part from the List of
Types list box in the New dialog box. You can also  write the word Part in the Selection edit

Figure 2-1  Solid model of a Link Figure 2-2  Base sketch for the solid model
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box at the bottom of the List of Types list box. Choose the OK button; the New Part dialog
box will be displayed. Enter the file name in it and choose the OK button.

Tip. If you clear the Enable hybrid design check box from the New Part dialog
box, the new file will be started in the conventional design mode. In the earlier
releases of CATIA V5, the parts were created in the conventional design mode of
the Part Design workbench. In this textbook, the hybrid design mode has been
used. Therefore, it is recommended that you keep the Enable hybrid design check
box selected every time you start a new file.

Figure 2-5  The New dialog boxFigure 2-4  The New Part dialog box

Figure 2-3  Initial screen that appears after starting CATIA V5R18
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A new file in the Part Design workbench is displayed on the screen, as shown in Figure 2-6.
The standard tools like the Specification tree, Compass, and Geometry Axis will help you
complete the design. The Specification tree is displayed on the top left corner of the screen.
The Compass is displayed on the top right corner while the Geometry Axis is displayed on
the bottom right corner of the screen.

Note
You can hide the Compass, the specification tree, or the Geometry Axis by using the View
menu. By default, check marks are displayed on the left of Geometry, Specifications, and
Compass in the menu bar. This suggests that their display is turned on. Choose these options
again to turn off their display. The display of these tools should be turned off only when the
geometry area is too small to view the model, else it is recommended not to hide these standard
tools. You can also use the F3 key to toggle the display of the specification tree.

INVOKING THE SKETCHER WORKBENCH
The sketch is the basic requirement to create the base feature of any solid model. In CATIA
V5, a sketch is drawn in the Sketcher workbench. To invoke the Sketcher workbench, choose
the down arrow on the right of the Sketch button in the Sketcher toolbar; a flyout will appear.
Press and hold the left mouse button on the line at the left or top of the flyout and drag it.
The flyout is detached from its parent toolbar and it becomes an independent toolbar.
Figure 2-7 shows the Sketcher flyout as an independent toolbar. The two buttons in the
Sketcher toolbar are Sketch and Positioned Sketch. The next section focuses on invoking
the Sketcher workbench using these two buttons.

Figure 2-6  A new file in the Part Design workbench
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Invoking the Sketcher Workbench Using the Sketch Button
To invoke the Sketcher workbench using this method, choose the Sketch button
from the Sketcher toolbar; you will be prompted to select a plane, planar face, or
sketch. Select a plane from the three default planes in the specification tree or from

the geometry area. The Sketcher workbench that appears on selecting the yz plane as the
sketching plane is shown in Figure 2-8. The selected plane is oriented parallel to the screen
and you are prompted to select an object or a command. The sketching components that
are displayed in the geometry area are discussed later in this chapter.

Note
Remember that on invoking the Sketcher workbench, you will always be in the Select mode
and therefore, prompted to select an object or a command. To exit the Sketcher workbench,
choose the Exit workbench button from the Workbench toolbar.

Figure 2-7  The Sketcher toolbar

Figure 2-8  The Sketcher workbench invoked using the yz plane as the sketching plane
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Invoking the Sketcher Workbench Using the Positioned
Sketch Button

In CATIA V5, you can also define a user-defined absolute axis while invoking the
Sketcher workbench by using the Positioned Sketch option. To invoke the Sketcher
workbench using this option, choose the Positioned Sketch button from the Sketcher

toolbar; the Sketch Positioning dialog box will be displayed, as shown in Figure 2-9. Also,
you will be prompted to select a plane, planar face, sketch, an axis system, or two lines. You
can set the absolute axis by using the options in this dialog box.

SETTING UP THE SKETCHER WORKBENCH
After invoking the Sketcher workbench, you need to set the workbench as per the
sketching or drawing requirements. These requirements include modifying units, grid settings,
and so on. The next section focuses on setting these parameters.

Modifying Units
To modify units, invoke the Options dialog box by choosing Tools > Options from the menu
bar. Click on the + sign on the left of the General option to expand the tree, if it is not
already expanded. Choose the Parameters and Measure option; the tabs corresponding to
this selection appear on the right side of the Options dialog box. Next, choose the Units tab.
The Options dialog box, after choosing the Units tab, is shown in Figure 2-10.

You can set the units for length, angle, time, mass, and so on, using the options in the Units
area. After specifying the value of the units, choose the OK button from the Options dialog
box.

Modifying the Grid Settings
On invoking the Sketcher workbench, you will observe two types of lines in the geometry

Figure 2-9  The Sketch Positioning dialog box



Drawing Sketches in the Sketcher Workbench-I                                  2-7

E
va

lu
a

ti
o

n 
C

o
p

y
E

va
lu

a
ti

o
n 

C
o

p
y

E
va

lu
a

ti
o

n 
C

o
p

y
E

va
lu

a
ti

o
n 

C
o

p
y

E
va

lu
a

ti
o

n 
C

o
p

y .
 D

o
 n

o
t 

re
p

ro
du

ce
. 

F
. 

D
o

 n
o

t 
re

p
ro

du
ce

. 
F

. 
D

o
 n

o
t 

re
p

ro
du

ce
. 

F
. 

D
o

 n
o

t 
re

p
ro

du
ce

. 
F

. 
D

o
 n

o
t 

re
p

ro
du

ce
. 

F o
r 

in
fo

rm
a

ti
o

n 
vi

si
t 

w
w

w
o

r 
in

fo
rm

a
ti

o
n 

vi
si

t 
w

w
w

o
r 

in
fo

rm
a

ti
o

n 
vi

si
t 

w
w

w
o

r 
in

fo
rm

a
ti

o
n 

vi
si

t 
w

w
w

o
r 

in
fo

rm
a

ti
o

n 
vi

si
t 

w
w

w
.c

a
dc

im
.c

o
m

.c
a

dc
im

.c
o

m
.c

a
dc

im
.c

o
m

.c
a

dc
im

.c
o

m
.c

a
dc

im
.c

o
m

area flowing in the horizontal and vertical directions. These are continuous lines and dotted
black lines. The spacing between the two dotted lines is called graduation, while the spacing
between the two continuous black lines is called primary spacing. The mesh that is formed
because of the intersection of these lines in the vertical and horizontal direction is called
grid. In other words, primary spacing and graduation define the grid.

By default, the value of the Graduations parameter is set to 10 in both horizontal and
vertical direction. The default value of the Primary Spacing parameter is 100mm. Though
you can change the Primary Spacing and Graduations values in the horizontal and
vertical directions individually, yet it is recommended not to change them. If the values of
Primary Spacing or Graduations in the horizontal direction are different from those in the
vertical direction, then the Grid is distorted. To change the values of Primary Spacing and
Graduations, choose Tools > Options from the menu bar; the Options dialog box will be
displayed. Choose the Mechanical Design option from the tree on the left of the dialog box.
Next, choose the Sketcher option to display the Sketcher tab on the right of the Options
dialog box, as shown in Figure 2-11.

The edit boxes of Primary Spacing and Graduations under the H row are already enabled.
Here, H refers to the horizontal direction. To enable the edit boxes of Primary Spacing
and Graduations under the V row, select the Allow Distortions check box. Here, V refers to
the vertical direction. Next, enter the values in the edit boxes corresponding to the H and
V directions. Choose OK to apply the newly formed Grid to the Sketcher workbench. Note,
all the files that you open or start in the Sketcher workbench, henceforth, will use these
values for Grid.

Figure 2-10  The Options dialog box with the Units tab chosen
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UNDERSTANDING THE SKETCHER TERMS
Before learning about the sketching tools, it is important for you to understand some of the
terms that are used in the Sketcher workbench. These terms are discussed next.

Specification Tree
The specification tree is a manager that keeps a track of all the operations performed on the
model. When you invoke the Sketcher workbench, a new member or branch, Sketch.1, is
added to the specification tree. Click on the + sign on the right of the PartBody to expand
it; you can view the Sketch.1 member of the specification tree. A + sign is associated with the
Sketch.1 on the branch. Click on this sign once to further expand the branch. Figure 2-12 shows
the specification tree in the expanded form.

The various levels under Sketch.1 in the specification tree are discussed next.

AbsoluteAxis
In the Sketcher workbench, the default horizontal and vertical axes passing from the
origin (0,0), to infinity are referred to as AbsoluteAxis. These axes will be highlighted in the
geometry area, when AbsoluteAxis is selected from the specification tree. There is a
+ sign available on the left of AbsoluteAxis in the specification tree. Click this + sign once
to expand the branch by one level. The levels associated with this branch are discussed next.

Figure 2-11  The Options dialog box with the Sketcher option chosen
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Origin
The Origin in the Sketcher workbench is the point where the absolute horizontal axis
intersects the absolute vertical axis. The coordinates for Origin are (0,0). Origin is widely
used while applying dimensional constraints to the sketches. You will learn more about
dimensional constraints in later chapters.

HDirection
The direction that is parallel to the horizontal axis is represented by the H icon in the
drawing window and is displayed as HDirection in the specification tree. The HDirection
is mostly used to constrain a sketch.

VDirection
The direction that is parallel to the vertical axis is referred to as the VDirection and is
mostly used to constrain a sketch.

The branches of the specification tree will increase as the design process continues. You will
learn more about the branches associated with the specification tree in the Sketcher workbench
while drawing and constraining sketches.

Grid
This option is used to display or hide the Graduations and Primary Spacing lines
from the graphic area. To activate or deactivate it, choose the Grid button from the
Sketch tools toolbar, which appears only when you invoke the Sketcher workbench.

Figure 2-12  The expanded form of the specification tree

Tip. While expanding the branch of the specification tree, you may accidentally click
on the branch lines. This will activate the specification tree and consequently, the
geometry area will be frozen. Note that the color of the default planes will turn
gray. Now, zooming and panning will resize or reposition the specification tree
instead of the geometry view. The geometry area can be reactivated by clicking on
the branch line again or on the geometry axis available on the bottom right corner
of the geometry area.
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Snap to Point
This option is used to snap to the point of intersection of the primary spacing and
the graduation lines while sketching. By default, the snap mode is active. To activate
or deactivate it, choose the Snap to Point button from the Sketch tools toolbar, which

appears only when you invoke the Sketcher workbench.

Construction/Standard Element
An element that is not a part of the profile while creating features and is used only as
a reference, or to constrain the elements of the sketch in the Sketcher workbench, is
called a Construction element. This element can be used only in the Sketcher

workbench. A Standard element is one that takes part in the feature creation. Depending on
the requirement of the design, you can convert a standard element into a construction element,
or vice-versa, using the Construction/Standard Element button. This button appears only
when you invoke the Sketcher workbench.

Select Toolbar
While drawing a sketch, you often need to select some elements. The tools that are required
to make a selection are available in the Select toolbar, as shown in Figure 2-13. Various tools
such as Select, Rectangle Selection Trap, and so on are available in this toolbar. By default,
the Select tool is activated in the sketcher workbench unless any other tool or object is selected.
The tools in the Select toolbar can be invoked by choosing the down arrow on the right of the

Select tool. When you choose the down arrow, the  Select flyout will be displayed. Detach the
Select flyout from the Select toolbar by holding it from the vertical/horizontal line and placing
it in the geometry area. The Select flyout will now become the Select toolbar, as shown in
Figure 2-14. The methods of selecting entity using the tools in the Select toolbar are discussed
next.

Figure 2-13  The Select toolbar

Figure 2-14  The Select toolbar
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Note
For a better understanding and explanation of the buttons in the flyout, this book will refer to a
flyout as toolbar. This means, whenever you are prompted to choose the down arrow on the right
of any button, the flyout that appears will be called a toolbar. You can detach this flyout from the
parent toolbar and place it in the geometry area.

Select
This tool allows you to make a selection of the elements. As you move the arrow
cursor near the element, with the Select tool activated, the arrow cursor will be replaced
with a hand cursor. Left click on the element to select it.

Rectangle Selection Trap
This is a method of selecting entities by creating a selection trap. A trap is a
rectangular box drawn by dragging the mouse to define the diagonally opposite
corners. All the objects that lie completely inside the selection trap are selected. To

create this trap, choose the Selection Trap button from the Select toolbar. Next, specify the
first corner and then drag the mouse to specify the second corner.

Intersecting Rectangle Selection Trap
An intersecting trap is similar to the selection trap. The difference is that this method
allows you to select elements of a sketch that are inside or are intersected by the trap.
To create the intersecting trap, choose the Intersecting Trap button from the

Select toolbar. Next, specify the first corner and then drag the mouse to specify the second
corner.

Polygon Selection Trap
This method includes selection of elements by drawing a closed polygon as the
selection trap. You can select the elements of a sketch that are completely inside the
polygon by using this method. Choose the Polygon Trap button from the Select toolbar

and draw a closed polygon by specifying its adjacent corners. The polygon creation can be
terminated by double-clicking in the geometry area.

Free Hand Selection Trap
This method includes selection of elements by dragging the mouse to draw a free
sketch across them. The elements intersected by the free sketch are selected.

Outside Rectangle Selection Trap
This method is used to select the elements that are outside the selection trap. The
elements that are intersected by the trap are not selected.

Outside Intersecting Rectangle Selection Trap
The elements that are outside the selection trap or are intersected by the selection
trap are selected by using this method.
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Figure 2-15  An example of the inferencing line

Inferencing Lines
The inferencing lines are the temporary lines that are used to track a particular point on the
screen. They are automatically displayed from the endpoints of the sketched elements or
from the origin, when you select a sketching tool in the sketcher environment. Consider a
case in which you want to draw a line such that its endpoint is tangent to the circle. Specify
the start point of the line and then move the cursor in the direction tangent to the circle. You
will note that the inference line is shown tangent to the existing circle. Next, specify the
endpoint of the line. Figure 2-15 shows the use of the inferencing line to draw a tangent line.
The inferencing lines are available only in the sketcher workbench.

DRAWING SKETCHES USING THE SKETCHER TOOLS
The sketching tools that are used to draw the sketches in the Sketcher workbench are
discussed next.

Drawing Lines

The Line tool is one of the basic sketching tools in the Sketcher workbench. The
general definition of a line is the shortest distance between two points. As CATIA V5
is parametric by nature, it allows the user to first draw a line of any length and at any

angle, and then change it to the desired length and angle. To draw a line, choose the Line
button from the Profile toolbar. The two methods to draw a line in CATIA V5 are discussed
next.

Menu: Insert > Profile > Line > Line
Toolbar: Profile > Line
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Drawing Lines by Specifying Points in the Geometry Area
To draw a line by specifying points in the geometry area, invoke the Line tool by choosing the
Line button from the Profile toolbar. You will observe that as you move the cursor in the
geometry area, the coordinates corresponding to the current location of the cursor are
displayed above it.

After invoking the Line tool, you are prompted to select a point or click to locate the start
point of the line. The prompt sequence is displayed in the current information or dialog box
area of the status bar below the geometry area. Click anywhere in the geometry area to
specify the start point of the line. You are then prompted to specify its endpoint. Move the
cursor away from the start point. You will notice a rubber band line attached to the cursor.
Click anywhere in the geometry area to specify the endpoint of the line. Figure 2-16 shows a
line drawn by selecting the points from the display area. The orange color of the line
specifies that it is selected. Click anywhere on the screen to end the selection mode. You will
notice that the color of the line changes to white. This suggests that it is a standard element.

Note
A line in CATIA V5 consists of three geometric elements: start point, line segment, and endpoint.
The start and endpoint are construction elements, while the line segment is a standard element.

Drawing Lines Using the Sketch tools Toolbar
Lines can also be drawn using the Sketch tools toolbar, which expands when you invoke the
Line tool. Figure 2-17 shows the expanded Sketch tools toolbar after you invoke the Line
tool. The two methods to draw a line using the Sketch tools toolbar are discussed next.

Figure 2-16  A line drawn by selecting the start and
endpoints from the geometry area

Figure 2-17  The expanded form of the Sketch tools toolbar after invoking the Line tool
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Drawing Lines by Entering the Start and End Point Values
To draw a line using the start and endpoint values, invoke the Line tool. The Sketch
tools toolbar will expand. In the Start Point H and V edit boxes, specify the horizontal
and vertical coordinates values of the start point, respectively, and then press ENTER.
You will be prompted to enter the coordinates values for the endpoint. Specify the values
in the End Point H and V edit boxes and press ENTER again. A line is drawn in the
geometry area, corresponding to the entered values of the start and endpoints. Also, the
horizontal and vertical dimensions of the start point and endpoint are displayed from
the origin. On completion of the line, you will observe that the Sketch tools toolbar is
compressed to its original size after the line is drawn. The color of the created line is
orange, suggesting it is selected. To end the selection mode, click anywhere in the
geometry area. The line will appear green in color, which means that it is fully constrained.
You will learn more about constraints in the later chapters.

Similarly, you can draw a line by specifying the start point and entering the length and
angle values.

Note
As the Dimensional Constraint button is chosen in the Sketch tools toolbar, the specified
dimension values for the start and endpoint will be displayed. Let these values remain in the
geometry area.

You will also notice that the color of the construction elements such as the start and endpoints of
the line is green. This suggests that the element is fully constrained.

Drawing Lines with a Symmetrical Extension
To draw a line with a symmetrical extension, invoke the Line tool and choose
the Symmetrical Extension button from the expanded Sketch tools toolbar.
When you draw the line using this option, its total length is double the distance

you moved while specifying the start point and the endpoint.

In CATIA V5, a few more types of lines such as the infinite line, bisecting line, and
bi-tangent line can be drawn. To draw these lines, choose the down arrow on the right of
the Line button from the Profile toolbar. The Line toolbar will appear, as shown in
Figure 2-18. The types of lines that can be drawn using the Line toolbar are discussed next.

Drawing Infinite Lines

To draw an infinite line, invoke the Infinite Line tool from the Line toolbar; the Sketch
tools toolbar will expand. You can draw a horizontal infinite line, vertical infinite line,
and infinite line passing through any two points using the options in this toolbar.

Menu: Insert > Profile > Line > Infinite Line
Toolbar: Profile > Line > Infinite Line

Tip. The Grid button in the Sketch tools toolbar is used to toggle the
display of the grid. While sketching, you can choose the Grid button any
time to turn on or off the display of the grid.
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Drawing Bi-Tangent Lines

Bi-tangent lines are tangent to two circles, arcs, ellipses, conics, or any curved geometry.
You will learn more about these curved geometries later in this chapter. To draw a
bi-tangent line, invoke the Bi-Tangent Line tool from the Line toolbar. Select the

first element or the first curve geometry and then select the second element; a line will be
drawn between the two selected curved elements. You will notice that the tangency symbol is
visible at the endpoints of the bi-tangent line. These are the tangent constraints. You will
learn more about the tangent constraints in later chapters.

Drawing Bisecting Lines

Bisecting lines pass through two intersecting lines such that the angle formed between
them is divided equally. To draw a bisecting line, invoke the Bisecting Line tool from
the Line toolbar. Select the first line and then select the second line; a bisecting line

of infinite length will be drawn.

Drawing Lines Normal to a Curve

To draw a line normal to a curve, choose the Line Normal To Curve button from the
Line toolbar and specify the start point of the line anywhere in the geometry area;
you will be prompted to select the curve. After you select the curve, a line normal to

it will be drawn.

Menu: Insert > Profile > Line > Bi-Tangent Line
Toolbar: Profile > Line > Bi-Tangent Line

Menu: Insert > Profile > Line > Bisecting Line
Toolbar: Profile > Line > Bisecting Line

Menu: Insert > Profile > Line > Line Normal To Curve
Toolbar: Profile > Line > Line Normal To Curve

Tip. You can use the ESC key to exit a currently active tool.

Figure 2-18  The Line toolbar
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Drawing Center Lines

You can draw a center line in CATIA V5 using
the Axis tool. Generally, this tool is used to
create the axis for the revolved feature. You

will learn more about the revolved features in later
chapters. To draw an axis, invoke the Axis tool from
the Profile toolbar; the Sketch tools toolbar will
expand and you will be prompted to specify the start
point of the axis. Click in the geometry area to specify
it. You are then prompted to specify the endpoint of
the axis. Move the cursor and click to specify it. An
axis with the specified points will be displayed in the
geometry area, as shown in Figure 2-19. You can also
draw an axis by entering the parameters in the
respective edit boxes of the expanded Sketch tools
toolbar.

Note
An axis is a construction element. Its applications are discussed in later chapters.

Drawing Rectangles, Oriented Rectangles, and
Parallelograms

The rectangle is a basic geometry that comprises of four sides. The adjacent sides
are perpendicular to each other, while the opposite sides are equal in length. To
draw a rectangle, choose the arrow on the right of the Rectangle button in the Profile

toolbar; the Predefined Profile toolbar will be displayed, as shown in Figure 2-20. The tools
in this toolbar are Rectangle, Oriented Rectangle, Parallelogram, and so on. Some of these
tools are discussed here and the remaining will be discussed in the next chapter.

Drawing Rectangles

To draw a rectangle, invoke the Rectangle tool from the Predefined Profile toolbar,
as shown in Figure 2-20. When you invoke the Rectangle tool, the Sketch tools toolbar
expands and you are prompted to click the first point to create a rectangle. Click in

the geometry area to specify the first point or the first corner of the rectangle. Next, you are
prompted to specify the second point. Move the cursor away from the first point. You will
notice that the preview of the rectangle is displayed as you move the cursor in the
geometry area. Click to specify the diagonally opposite corner of the rectangle. You can also
draw a rectangle by entering the values in the Sketch tools toolbar. On drawing a rectangle by
this method, you will notice that dimensions and constraints are applied to the resulting rectangle.
You will learn more about dimensioning and constraining in later chapters.

Menu: Insert > Profile > Predefined Profile > Rectangle
Toolbar: Profile > Predefined Profile > Rectangle

Figure 2-19  An axis drawn in the
geometry area

Menu: Insert > Profile > Axis
Toolbar: Profile > Axis
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Note
The rectangle drawn in CATIA V5 is a combination of four lines and each line is an individual
element.

Drawing Oriented Rectangles

To draw an oriented rectangle, invoke the Oriented Rectangle tool from the
Predefined Profile toolbar; you will be prompted to locate the start point. Click in
the geometry area to specify it; you are then prompted to locate the first side end

point. Move the cursor away from the first point in any direction and specify the end point of
the first side. The angle formed between the line and horizontal reference is the orientation
angle of the rectangle.

Next, you are prompted to define the second side. Move the cursor in the upward or
downward direction of the first line. You will notice the rectangle is being drawn. Also, the
symbol of the perpendicular constraint is displayed between the line drawn and the line
attached to the cursor. You will learn more about  constraints in later chapters. Click in the
geometry area to specify the third corner of the rectangle. Figure 2-21 shows an oriented
rectangle being drawn.

Menu: Insert > Profile > Predefined Profile > Oriented Rectangle
Toolbar: Profile > Predefined Profile > Oriented Rectangle

Figure 2-20  The Predefined Profile toolbar

Figure 2-21  Selecting the corner points to draw an oriented rectangle
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Note
You can also use the Sketch tools toolbar to enter the coordinate values for the first, second, and
third corner in the respective edit boxes. To specify the orientation of the rectangle, enter the
value of the orientation angle in the A edit box of the Sketch tools toolbar. You need to press the
ENTER key, once you have entered the values.

Drawing Parallelograms

A parallelogram is a quadrilateral whose opposite sides are parallel to each other. To
draw it, invoke the Parallelogram tool from the Predefined Profile toolbar; the Sketch
tools toolbar expands and you are prompted to specify the start point of the

parallelogram. Click in the geometry area to specify its first corner. You are then prompted to
specify the end point of its first side. On moving the cursor away from the first corner, you will
notice a line attached to the cursor. The line shows the first side of the parallelogram. Click in
the geometry area to specify its endpoint. You are then prompted to specify its second side.
Move the cursor away from the second corner; the preview of the parallelogram is displayed.
Click to specify its second side. The parallelogram is created, as shown in  Figure 2-22.

Note
In CATIA V5, a parallelogram is a combination of four lines, where each line is an individual
element. You can also use the Sketch tools toolbar to enter the coordinate values of the corner
points of the parallelogram. You can enter the width, angle, and height values in the respective
edit boxes of the expanded Sketch tools toolbar to specify its parameters.

Creating Points
A point is defined as the geometrical element that has no magnitude, length, width,
or thickness. It is only specified by its position. In CATIA V5, you can create points by
clicking in the geometry area or by specifying the coordinates. You can also locate

Figure 2-22  A parallelogram created by specifying the corner points

Menu: Insert > Profile > Predefined Profile > Parallelogram
Toolbar: Profile > Predefined Profile > Parallelogram
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an intersection point or project a point on an element. To invoke any of these methods,
choose the down arrow on the right of the Point by Clicking button in the Profile toolbar;
the Point toolbar will be displayed, as shown in Figure 2-23.

Creating Points by Clicking

To draw points by clicking, invoke the Point by Clicking tool from the Point toolbar;
the Sketch tools toolbar expands and you will be prompted to click to create the
point. Click anywhere in the geometry area; a plus sign (+) will be displayed in the

geometry area. You can also enter the horizontal and vertical coordinate values in the H and
V edit boxes of the Point Coordinates area displayed in the expanded Sketch tools toolbar.

You can create points by defining their coordinates using the other options in the Point
toolbar. You can also create equidistant points, intersection points, and projection points
using these options.

Drawing Circles
To draw a circle, choose the down arrow on the right of the Circle button in the
Profile toolbar; the Circle toolbar is displayed, as shown in Figure 2-24. The tools
available in this toolbar will help you to draw various types of circles and arcs. These

tools are discussed next.

Figure 2-23  The Point toolbar

Menu: Insert > Profile > Point > Point
Toolbar: Profile > Point > Point by Clicking

Figure 2-24  The Circle toolbar
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Menu: Insert > Profile > Circle > Circle
Toolbar: Profile > Circle > Circle

Menu: Insert > Profile > Circle > Three Point Circle
Toolbar: Profile > Circle > Three Point Circle

Drawing Circles Using the Circle Tool

To draw a circle using this method, invoke the Circle tool from the Circle toolbar;
you will be prompted to specify its center. Click anywhere in the geometry area to
specify the center point; you will be prompted to specify a point that determines

the radius of the circle. Move the cursor away from the center point to specify the radius; the
preview of the circle is displayed. Click in the geometry area to define its radius.

Note
You can also draw a circle by specifying the coordinates of its center point in the Circle Center
edit boxes and the radius value in the R edit box of the expanded Sketch tools toolbar.

Drawing a Three Point Circle

In CATIA V5, a circle can also be drawn by specifying any three points that lie on its
circumference. To draw a three point circle, invoke the Three Point Circle tool from
the Circle toolbar; the Sketch tools toolbar expands and you are prompted to specify

the start point of the circle. Click anywhere in the geometry area to specify it; you are then
prompted to specify the second point through which the circle will pass. As you move the
cursor away from the first point, a dotted line that originates from the first point and moves
along with the cursor, is displayed. This is the chord of the circle. Click in the geometry area
to specify the second point on the circle; you are then prompted to specify the last point. As
you move the cursor to specify the third point, the preview of the circle is displayed. Click to
specify the third point.

Note
You can also enter the radius value in the R edit box of the expanded Sketch tools toolbar.
Remember that when you enter the radius value, the other two points that lie on the circle
should be specified within the reach of the radius value.

Drawing Circles Using Coordinates

In CATIA V5, a circle can also be drawn by specifying the absolute coordinate values
of the center and radius. To do so, invoke the Circle Using Coordinates tool from
the Circle toolbar; the Circle Definition dialog box will be displayed. You can specify

the coordinate values of the center point and radius using the options in this dialog box.

Menu: Insert > Profile > Circle > Circle
Toolbar: Profile > Circle > Circle Using Coordinates
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Drawing Tri-Tangent Circles

A tri-tangent circle is one that is tangent to three sketched elements. The circle thus
formed has a tangent relation with all the three elements. To draw it, you first need
to draw three elements, which can be lines, circles, ellipses, arcs, or any

geometrical element to which a circle can form a tangent relation. Next, invoke the Tri-Tangent
Circle tool from the Circle toolbar and select the three elements one by one. A circle tangent
to all these three elements is displayed in the geometry area. Notice that some constraints
are applied to the circle. You will learn more about them in later chapters.

Note
The location of the elements to be selected for creating a tri-tangent circle is important because
its creation depends on the orientation of these selected elements. Also, the tangents are created
as close as possible to the point where you click to select the elements. In case the element has to
be extended to fulfill the need of the tangent relation, CATIA V5 will form a circle tangent at an
apparent intersection.

Drawing Arcs
An arc is a geometric element that forms a sector of a circle or ellipse. Each arc must include
at least two points. The tools to draw arcs are available in the Circle toolbar. In CATIA V5,
there are three methods to draw arcs. These methods are discussed next.

Drawing Arcs by Defining the Center Point

To draw an arc by defining its center point, invoke the Arc tool from the Circle
toolbar; you will be prompted to specify the center point. Click to specify the arc
center. You are then prompted to define the radius and start point of the arc. Move

the cursor away from the center point; the preview of the circle is displayed in the
geometry area. Click to specify the start point of the arc. You are then prompted to specify
the endpoint of the arc. As you move the cursor, the preview of the arc is displayed. Click in
the geometry area to specify the endpoint. Figure 2-25 shows an arc drawn using this method.

Drawing Three Point Arcs

To draw a three point arc, invoke the Three Point Arc tool from the Circle toolbar;
you will be prompted to specify the start point of the arc. Click anywhere in the
geometry area to specify its start point. Next, you are prompted to select the second

point through which the arc will pass. As you move the cursor away from the first point, a
dotted chord is displayed. Click to specify the second point. You are prompted to specify
the endpoint of the arc. The preview of the arc is displayed as you move away from the

Menu: Insert > Profile > Circle > Tri-Tangent Circle
Toolbar: Profile > Circle > Tri-Tangent Circle

Menu: Insert > Profile > Circle > Three Point Arc
Toolbar: Profile > Circle > Three Point Arc

Menu: Insert > Profile > Circle > Arc
Toolbar: Profile > Circle > Arc
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previous point. Click in the geometry area to specify its endpoint. Figure 2-26 shows the first,
second, and third point being selected to draw a three point arc.

Drawing Three Point Arcs Starting With Limits

While drawing a three point arc starting with limits, you can specify the start and
endpoint of the arc first and then the third point anywhere on it. To draw this arc,
invoke the Three Point Arc Starting With Limits tool from the Circle toolbar; you

are prompted to specify the start point of the arc. Click in the geometry area to specify the
start point. You are then prompted to specify the endpoint of the arc. Move the cursor away

Figure 2-26  Selecting the points to draw a three point arc

Figure 2-25  An arc

Menu: Insert > Profile > Circle > Three Point Arc Starting With Limits
Toolbar: Profile > Circle > Three Point Arc Starting With Limits
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from the start point and click to specify the endpoint. You are then prompted to specify the
second point through which the arc will pass. As you move the cursor to specify this point, the
preview of the arc is displayed. Click to specify the point on the arc. Figure 2-27 shows the
selection of the first, second, and third point to draw an arc using this option.

Drawing Profiles

In CATIA V5, a profile is defined as a combination of continuous lines and arcs.
Drawing a continuous line means that the line automatically starts at the endpoint of
the previous line. A profile can be an open or a closed contour. To draw the profile,

invoke the Profile tool from Profile toolbar; the Sketch tools toolbar expands and the Line
tool is chosen in it. Also, you are prompted to select the start point of the profile.

Click anywhere in the geometry area to specify the start point. Next, move the cursor away
from the first point; a rubber-band line is attached to the cursor with its first point fixed to
the point you had specified. Click anywhere in the geometry area to specify the endpoint of
the line or the second point of the profile. Move the cursor away from the second point to
draw the second line that is in continuation with the first line. You will notice the second line
originates from the endpoint of the first line. Click anywhere in the geometry area to specify
the endpoint of the second line or the third point of the profile. To exit the Profile tool after
drawing an open profile, choose the Profile button again. If you draw a closed profile, you do
not need to exit the Profile tool by choosing the Profile button from the Profile toolbar. This
tool is automatically terminated when you specify the point to close the profile. Figure 2-28
shows an open profile.

Figure 2-27  Selecting the points to draw a three point arc starting with limits

Menu: Insert > Profile > Profile
Toolbar: Profile > Profile
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You will notice that the expanded Sketch tools toolbar has three buttons: Line, Tangent Arc,
and Three Point Arc, as shown in Figure 2-29. When you invoke the Profile tool, the Line
button is chosen by default. The profile that you have been drawing so far, using the Profile
tool, is a combination of continuous lines. The process to draw an arc in continuation with
the line using the Profile tool is discussed next.

Drawing a Tangent Arc Using the Profile Tool
To draw a tangent arc in continuation with the line, invoke the Profile tool from the Profile
toolbar. You will notice that the Tangent Arc button is disabled. This is because you first need
to draw at least one line. After drawing the line, the Tangent Arc button is enabled. Choose
the Tangent Arc button from the expanded Sketch tools toolbar; the preview of the arc is
displayed in the geometry area and you are prompted to specify the endpoint of the arc.
Click in the geometry area to specify the endpoint. An arc, tangent to the line, is drawn and
displayed in the geometry area. Figure 2-30 shows a tangent arc being drawn using the
Profile tool. After drawing the arc, the Line tool is again chosen in the Sketch tools toolbar
and you are prompted to specify the endpoint of the current line.

Note
You will notice a constraint applied between the line and arc. This is the tangent constraint. You
will learn more about constraints in later chapters.

Figure 2-28  An open profile drawn using the Profile tool

Figure 2-29  The Sketch tools toolbar
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Drawing Three Point Arcs Using the Profile Tool
To draw a three point arc using the Profile tool, invoke it from the Profile toolbar. You will
notice the Three Point Arc button available in the Sketch tools toolbar. You have two options.
The first is to draw the line and then draw the three point arc. The second is to choose the
Three Point Arc button first to draw a three point arc and then draw a line. Draw a line using
the Profile tool. Now, instead of specifying the third point of the profile, choose the Three
Point Arc button from the expanded Sketch tools toolbar; you will be prompted to specify
the second point of the arc. Remember that the first point of the three point arc is the
endpoint of the line you have drawn. Click in the geometry area to specify the second point
of the arc. You are then prompted to specify its last point. Move the cursor and click to
specify it. The three point arc is displayed in the geometry area. Also, the Profile tool is still
active and you are prompted to specify the endpoint of the current line. You can choose the
Profile button again to end the Profile tool or continue with the tool by specifying more
points in the geometry area.

DRAWING DISPLAY TOOLS
The drawing display tools for viewing the drawing elements or geometries are available in
the View toolbar shown in Figure 2-31. The basic tools such as Zoom In, Zoom Out, Rotate,
Pan, Normal View, Hide/Show, and Fit All In will be discussed next. You will learn about the
remaining tools in later chapters.

Figure 2-30  A tangent arc being drawn using the Profile tool

Figure 2-31  The View toolbar
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Fit All In

The Fit All In tool is used to increase the geometry area so that all sketched elements
or geometries are included in the visible space. Note, if a drawing consists of
dimensions that are beyond the visible space, invoking this tool will also include

them in the visible space. You will learn more about dimensions in later chapters.

Pan

The Pan tool is used to drag the current view in the geometry area. This option is
generally used to display the elements or part of the elements that are outside the
geometry area without actually changing the magnification of the current drawing.

This is similar to holding a portion of the sketch and dragging it across the geometry area.

Zoom In

The Zoom In tool is used to zoom into the sketches in increments. Choose this
button once to zoom into the sketch.

Zoom Out

The Zoom Out tool is used to zoom out of the sketch in increments. Choose this
button from the View toolbar once to zoom out of the sketch.

Note
You can also dynamically zoom in or zoom out by selecting the Zoom In Out option from the
View menu. To zoom in using this option, press and hold the left mouse button and then drag
the mouse upward. To zoom out of the sketches, press and hold the left mouse button and then
drag the mouse downward. The tool is automatically terminated once you release the mouse
button.

Zoom Area

The Zoom Area tool is used to define an area, which is to be magnified and viewed in the
available geometry area. The area is defined using the two diagonal points of a rectangular
box in the geometry area. Press and hold the left mouse button to specify the first corner

Menu: View > Zoom Area

Menu: View > Modify > Zoom Out
Toolbar: View > Zoom Out

Menu: View > Fit All In
Toolbar: View > Fit All In

Menu: View > Pan
Toolbar: View > Pan

Menu: View > Modify > Zoom In
Toolbar: View > Zoom In
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point. Then, drag the mouse to specify the other corner point of the box. The area that is
enclosed inside the window will be magnified and displayed.

Normal View

The Normal View tool is used to orient the view normal to the sketch plane in the
current Sketcher workbench, if its orientation is changed. If the current view is
already normal to the screen, and you choose the Normal View button from the

View toolbar, the viewing plane is reversed. In other words, on choosing this button, if the
front plane is the current viewing plane, the back plane will become active for viewing.

Note
By default, whenever you invoke the Sketcher workbench without defining any particular
orientation, the positive horizontal reference direction points toward the right of the geometry
area. Also, the positive vertical reference direction points toward its upper side. If you choose the
Normal View button, the direction of the horizontal reference will be reversed by 180-degree.
This means that the positive horizontal reference direction will point toward the left of the
geometry area. Note that the vertical reference direction remains unchanged.

If accidently the sketch view is rotated while working in the Sketcher workbench, you can
choose the Normal View button to reorient it normal to the sketching plane.

Splitting the Drawing Area into Multiple Viewports

The Create Multi-View tool is used to split the drawing area into four viewports. The
model is displayed in different views in all viewports. To restore the single viewport
configuration, choose this button again.

Hiding and Showing Geometric Elements

This tool is used to hide sketcher elements or geometric elements from the current
display. To do so, invoke the Hide/Show tool by choosing the Hide/Show button from
the View toolbar; you are prompted to select an element. Click on the element to be

hidden from the geometry area. You will notice that the selected element is no longer visible.
The following tool explains how to redisplay the hidden element.

Swapping Visible Space

Menu: View > Modify > Normal View
Toolbar: View > Normal View

Menu: View > Hide/Show > Hide/Show
Toolbar: View > Hide/Show

Toolbar: View > Create Multi-View

Menu: View > Hide/Show > Swap visible space
Toolbar: View > Swap visible space
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The hidden elements are stored in a space different from the current display space.
To view the space where the hidden elements are stored, invoke the Swap visible
space tool from the View toolbar; you will notice that the background of the

current geometry area changes to green and only the hidden elements are visible. Invoke
the Hide/Show tool and select the hidden elements to be redisplayed in the visible space. To
return to the geometry area, choose the Swap visible space button again. Note that when
you hide an element, only its display is turned off, but it still participates in the feature
creation.

Note
Even if you draw a sketch in the space containing the hidden elements, it will not be visible
there. It will only be displayed after you return to the visible geometry area.

You can change the standard element to a construction element in this space or vice-versa.

TUTORIALS

In this tutorial, you will draw the sketch of the model shown in Figure 2-32. The sketch is
shown in Figure 2-33. Do not dimension the sketch. The solid model and its dimensions are
given for your reference.     (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Start CATIA V5 and then start a new CATPart file.
b. Draw the sketch of the model using the Profile and the Circle tools, refer to Figures 2-36

and 2-37.
c. Save the sketch and close the file.

Starting a New Part File
1. Start CATIA V5 by choosing Start > Programs (or All Programs, if you are working with

Tutorial 1

Figure 2-33  The sketch for the solid modelFigure 2-32  The solid model for Tutorial 1
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Windows XP) > CATIA > CATIA V5R18 or by double-clicking on the shortcut icon of
CATIA V5R18 on the desktop of your computer. A new Product1 file is started.

2. Choose File > Close from the menu bar; the start screen of CATIA V5 is displayed.
Choose Start > Mechanical Design > Part Design to make sure that you are in the Part
Design workbench; the New Part dialog box is displayed, as shown in Figure 2-34.

3. Enter the name of the file as c02tut1 in the Enter part name edit box.

4. Select the Enable hybrid design check box from the New Part dialog box, if it is not
selected.

5. Choose the OK button; a new file in the Part Design workbench is opened.

6. To invoke the Sketcher workbench, choose the Sketch button from the Sketcher
toolbar and then select the yz plane as the sketching plane. The Sketcher
workbench screen will be displayed, as shown in Figure 2-35.

You will draw the sketch in two sections, first as the outer loop and second as the inside circle.

Drawing the Outer Loop of the Sketch
The outer loop of the sketch will be drawn using the Profile tool. In this sketch, the lower
left corner of the sketch is coincident with the origin of the Sketcher workbench. The
resulting sketch will be drawn in the first quadrant.

1. Choose the Profile button from the Profile toolbar.

2. Choose the Snap to Point button from the Sketch tools toolbar, if it is not chosen.

3. Move the cursor to a location whose coordinates are 0, 0 and specify the start point of
the line.

4. Move the cursor horizontally toward the right and specify the endpoint of the line when
the value of the coordinates is 120, 0.

Figure 2-34  The New Part dialog box
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5. Move the cursor vertically upward and specify the endpoint of the line when the value of
the coordinates is 120, 10.

6. Move the cursor horizontally toward the left and specify the endpoint of the line when
the value of the coordinates is 90, 10.

7. Move the cursor vertically upward and specify the endpoint of the line when the value of
the coordinates is 90, 30.

After drawing these four lines, you need to draw the tangent arc using the Tangent Arc
option from the Sketch tools toolbar.

8. Choose the Tangent Arc button from the Sketch tools toolbar to switch to the
Tangent Arc mode.

9. Move the cursor to a location whose coordinates are 30, 30 and specify the endpoint of
the tangent arc at this location.

The system switches back to the Line mode.

10. Move the cursor vertically downward and specify the endpoint of the line when the value
of the coordinates is 30, 10.

Figure 2-35  The Sketcher workbench screen
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11. Move the cursor horizontally toward the left and specify the endpoint of the line when
the value of the coordinates is 0, 10.

12. Move the cursor vertically downward and specify the endpoint of the line such that the
endpoint is coincident to the start point of the first line.

The sketch, after drawing the outer loop, is shown in Figure 2-36.

Drawing the Inner Loop of the Sketch
The inner loop of the sketch consists of a circle that will be drawn using the Circle tool.
The circle will be concentric to the arc of the outer loop.

1. Choose the Circle button from the Circle or Profile toolbar.

2. Move the cursor to the center point of the circular arc and specify the center point of the circle.

3. Specify 15 as the value of the radius of the circle in the Radius edit box provided in the
Sketch tools toolbar.

The final sketch, after drawing the inner loop, is shown in Figure 2-37. Note that the
display of the constraints is turned on in this figure.

Saving the Sketch
After completing the sketch, you need to save it. Save each tutorial of this chapter in the
c02 folder, which is in the CATIA folder.

Figure 2-36  The sketch after drawing the outer loop

Figure 2-37  The final sketch for Tutorial 1
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1. Choose the Save button from the Standard toolbar to invoke the Save As dialog box.
Create the CATIA folder inside the \My Documents folder. Then create the c02 folder
inside the CATIA folder.

2. Choose the Save button. The file will be saved in the \My Documents\CATIA\c02 folder.

3. Close the part file by choosing File > Close from the menu bar.

In this tutorial, you will draw the sketch of the model shown in Figure 2-38. The sketch is
shown in Figure 2-39. You will not dimension it. The solid model and its dimensions are
given for your reference.   (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Start a new CATPart file.
b. Draw the sketch of the model using the Rectangle, Profile, and Circle tools, refer to

Figures 2-40 through 2-42.
c. Save the sketch and close the file.

Starting a  New Part File
1. Choose File > New from the menu bar; the New dialog box is displayed.

2. Select Part from the List of Types list box from this dialog box. Choose the OK button;
the New Part dialog box is displayed.

3. Enter the name of the file as c02tut2 in the Enter part name edit box and choose the OK
button to open a new file in the Part Design workbench.

4. Choose the Sketch button from the Sketcher toolbar and then select the yz plane as the
sketching plane.

Tutorial 2

Figure 2-39  The sketch for the solid modelFigure 2-38  The solid model for Tutorial 2
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This sketch will be drawn in two parts. Initially, you will draw the outer loop of the sketch,
a rectangle. Next, you need to draw the inner loops of the sketch, which consist of four
holes and an elongated hole. First, you will draw an elongated hole using the Profile tool
and then the four holes using the Circle tool.

Drawing the Outer Loop of the Sketch
The outer loop of the sketch will be drawn using the Rectangle tool.

1. Choose the Rectangle button from the Profile toolbar.

2. Move the cursor to a location whose coordinates are -60, -50 and specify the lower left
corner of the rectangle.

3. Move the cursor to the location whose coordinates are 60, 50 and specify the upper
right corner of the rectangle. Figure 2-40 shows the outer loop of the sketch drawn
using the Rectangle tool.

Drawing the Inner Loop of the Sketch
After drawing the outer loop of the sketch, you need to draw its inner loop.

1. Choose the Profile button from the Profile toolbar.

2. Move the cursor to a location whose coordinates are -30, 10 and specify the start point of
the line.

3. Move the cursor horizontally toward the right and specify the endpoint of the line when
the value of the coordinates is 30, 10.

Next, you need to draw a tangent arc by switching over to the Tangent Arc option using
the Sketch tools toolbar.

Figure 2-40  The outer loop of the sketch
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4. Choose the Tangent Arc button from Sketch tools toolbar to switch over to the
arc mode.

5. Move the cursor to a location whose coordinates are 30, -10 and specify the endpoint of
the tangent arc.

The system switches over to the Line mode.

6. Move the cursor to the location whose coordinates are -30, -10 and specify the endpoint
of the line.

7. Choose the Tangent Arc button from the Sketch tools toolbar to switch over to the arc mode.

8. Move the cursor to the start point of the first horizontal line of the elongated hole.
Specify the endpoint of the arc when it snaps to the start point.

The sketch, after drawing the elongated hole, is shown in Figure 2-41.

9. Choose the Circle button from the Circle toolbar.

Note
If you have closed the Circle toolbar, you can use the Profile toolbar to invoke the Line tool.

10. Move the cursor to a location whose coordinates are 40, 30 and specify the center point
of the circle.

11. Specify the value 10 as the radius in the Radius edit box of the Sketch tools toolbar.

You will observe that a radius dimension is displayed attached to the circle. This is
because you have specified the value of the radius in the Radius edit box of the Sketch
tools toolbar.

12. Choose the Circle button from the Circle toolbar.

Figure 2-41  The sketch after drawing the elongated hole
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13. Move the cursor to a location whose coordinates are 40, -30 and specify the center point
of the circle.

14. Specify 10mm as the value of the radius in the Radius edit box of the Sketch tools toolbar.

15. Similarly, draw the other two circles. The coordinates of the center point of the other two
circles are -40, 30 and -40, -30, respectively. The final sketch, with the display of constraints
turned on, is shown in Figure 2-42.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog

box. Browse the folder named c02 that you created in the first tutorial.

2. Enter the name of the file as c02tut2 in the File name edit box and choose the Save
button. The file will be saved in the \My Documents\CATIA\c02 folder.

3. Close the part file by choosing File > Close from the menu bar.

In this tutorial, you will draw the sketch of the model shown in Figure 2-43. The sketch is
shown in Figure 2-44. Do not dimension the sketch. The solid model and its dimensions are
given for your reference.    (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Start a new CATPart file.
b. Draw the sketch of the model using the Profile and Rectangle tool, refer to Figures 2-46

through 2-48.
c. Save and close the file.

Figure 2-42  The final sketch

Tutorial 3
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Starting a New Part File
1. Choose File > New from the menu bar; the New dialog box is displayed, as shown in

Figure 2-45.

2. Select Part from the List of Types list box from this dialog box and choose the OK
button; the New Part dialog box is displayed.

3. Enter the name of the file as c02tut3 in the Enter part name edit box. Accept the rest of
the default options in the New Part dialog box and choose the OK button to open a new
file in the Part Design workbench.

4. Choose the Sketch button from the Sketcher toolbar and then select the yz plane
as the sketching plane to invoke the Sketcher workbench.

You will draw the sketch in two sections, first the outer loop and next the inner cavity.

Drawing the Outer Loop of the Sketch
You will draw the outer loop of the sketch using the Profile tool. Start drawing the outer
loop from the lower left corner of the sketch. It is recommended to keep the origin in the

Figure 2-45  The New dialog box

Figure 2-44  The sketch of the modelFigure 2-43  The solid model for Tutorial 3
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middle of the drawn sketch, as this will reduce the time required for constraining and
dimensioning the sketches. This will also help you to capture the design intent easily.

1. Choose the Profile button from the Profile toolbar.

2. Move the cursor to the third quadrant; the coordinates of the point will be displayed above
the cursor.

3. Specify the start point of the line at the point whose coordinates are -40, -30 and then
move the cursor horizontally toward the right.

On moving the cursor horizontally, you will notice that the line turns blue.

4. Move the cursor to a location whose coordinates are 40, -30. The coordinates of the point
can be seen on top of the cursor.

5. Specify the endpoint of the line at this location. A rubber band line is attached to the
cursor. Move the cursor vertically upward.

6. Specify the endpoint of the second line on the point whose coordinates are 40mm, -20mm.
A rubber band line is attached to the cursor.

7. Move the cursor horizontally toward the left and specify the endpoint of the third line
where the value of the coordinates is 30, -20.

After drawing these three lines, you need to draw a tangent arc using the Tangent Arc
option in the Profile tool.

8. Choose the Tangent Arc button in the Sketch tools toolbar.

9. Move the cursor to a location whose coordinates are 20, -10 and specify the endpoint of
the tangent arc. Figure 2-46 shows the sketch, after drawing three lines and a tangent arc.
The system switches back to the Line mode.

10. Move the cursor vertically upward to a location whose coordinates are 20, 10. Specify the
endpoint of the line at this location.

Figure 2-46  The sketch after drawing three lines and a tangent arc
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Next, you need to draw a tangent arc by switching to the arc mode using the Tangent Arc
option in the Profile tool.

11. Choose the Tangent Arc button from the Sketch tools toolbar.

12. Move the cursor to a location whose coordinates are 30, 20 and specify the endpoint of
the tangent arc.

The system switches back to the Line mode.

13. Move the cursor horizontally toward the right and specify the endpoint of the line, when
the value of the coordinates is 40, 20.

14. Move the cursor vertically upward and specify the endpoint of the line, when the value of
the coordinates is 40, 30.

15. Move the cursor horizontally toward the left and specify the endpoint of the line, when
the value of the coordinates is -40, 30.

16. Move the cursor vertically downward and specify the endpoint of the line, when the
value of the coordinates is -40, 20.

17. Move the cursor horizontally toward the right and specify the endpoint of the line, when
the value of the coordinates is -30, 20.

Next, you need to draw a tangent arc by switching to the tangent arc mode.

18. Choose the Tangent Arc button from the Sketch tools toolbar to switch to the
tangent arc mode.

19. Move the cursor to a location whose coordinates are -20, 10 and specify the endpoint of
arc at this location.

The system switches back to the Line mode.

20. Move the cursor vertically downward and specify the endpoint of the line, where the
value of the coordinates is -20, -10.

21. Switch to the Tangent mode and move the cursor to a location whose coordinates are
-30mm, -20mm. Specify the endpoints of the tangent arc at this location.

22. Move the cursor horizontally toward the left and specify the endpoint of the line, when
the value of coordinates is -40, -20.

23. Move the cursor vertically downward and specify the endpoint of the line when it snaps
to the start point of the outer loop. The sketch, after completing the outer loop and
hiding the constraints, is shown in Figure 2-47.
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Drawing the Inner Cavity of the Sketch
After drawing the outer loop of the sketch, you need to draw its inner rectangular cavity
using the Rectangle tool.

1. Choose the Rectangle button from the Profile toolbar.

2. Move the cursor to a location whose coordinates are -10, 10. Specify the upper left corner
of the rectangle at this location.

3. Move the cursor to a location whose coordinates are 10, -10. Specify the lower-right
corner of the rectangle at this location.

4. Choose the Fit All In button from the View toolbar to fit the sketch inside the geometry area.

The final sketch, after drawing the inner loop, is shown in Figure 2-48. Note that the
display of the constraints has been turned on.

Saving the Sketch
After completing the sketch, you need to save it. As mentioned earlier, you need to save
each tutorial of this chapter in the c02 folder, which is located inside the CATIA folder.

1. Choose the Save button from the Standard toolbar to invoke the Save As dialog
box. Browse the c02 folder that you created in the last tutorial.

2. Enter the name of the file as c02tut3 in the File name edit box and choose the Save
button. The file will be saved in the \My Documents\CATIA\c02 folder.

3. Close the part file by choosing File > Close from the menu bar.

Figure 2-47  The sketch after drawing the outer
loop of the sketch

Figure 2-48  The final sketch after drawing the
inner loop of the sketch
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In this tutorial, you will draw the sketch of the model shown in Figure 2-49. The sketch is
shown in Figure 2-50. You will not dimension the sketch. The solid model and its dimensions
are given for your reference.   (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Start CATIA V5 and then start a new CATPart file.
b. Draw the sketch of the model using the Line, Arc, and Circle tools, refer to Figures 2-51

and 2-52.
c. Save and close the file.

Starting CATIA V5 and Starting a New Part File
1. Choose File > New from the menu bar; the New dialog box is displayed.

2. Select Part from the List of Types list box from this dialog box and choose the OK
button; the New Part dialog box is displayed.

3. Enter the name of the file as c02tut4 in the Enter part name edit box. Accept the rest of
the default options in the New Part dialog box and choose the OK button.

4. Choose the Sketch button from the Sketcher toolbar and then select the yz plane
as the sketching plane to invoke the Sketcher workbench.

You will draw the sketch in two sections, first as the outer loop and second as the inside circle.

Drawing the Outer Loop of the Sketch
You should create the sketch symmetrically around the origin. This will reduce the time
required to constrain and dimension it. The outer loop of the sketch can be drawn using
the Line and Arc tools. You will start drawing the outer loop from the lower left corner of
the sketch.

Figure 2-49  The solid model for Tutorial 4 Figure 2-50  The sketch of the model

Tutorial 4
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1. Invoke the Line tool by choosing the Line button from the Profile toolbar.

2. Choose the Snap to Point button from the Sketch tools toolbar, if it is not chosen.

3. Move the cursor in the third quadrant. The coordinates of the point will be displayed,
along with the cursor.

4. Click at the point whose coordinates are -50mm, -30mm. Next, move the cursor
horizontally toward the right.

You will notice that the color of the line turns blue.

Note
The line that turns blue while drawing, implies that it is constrained. The constraint may be
horizontal or vertical, depending on the direction in which the line is drawn.

All the constraints that have been applied to the drawn sketch will not be explained in this
tutorial. You will learn about them in later chapters.

Refer to Figure 2-50. The length of the first horizontal line at the lower left corner of the
sketch is 30mm. Therefore, move the cursor until the length of the line is shown as
30mm in the L edit box of the Sketch tools toolbar.

5. Press the left mouse button, when the length of the line in the L edit box of the Sketch
tools toolbar displays a value of 30mm.

The first horizontal line is drawn. You will notice a Horizontal constraint is applied to it.
After the line is drawn, it is still active and is displayed in orange. Click in the geometry
area to remove it from the selection set.

As soon as you specify the endpoint of the line, the Line tool is terminated. Therefore,
you need to choose this button again and again to draw multiple lines. You can avoid this
by double-clicking on the Line button in the Profile toolbar. Now, the line tool will not
be terminated until you press the ESC key twice.

6. Double-click on the Line button to invoke the Line tool and select the endpoint of the
first horizontal line.

7. Press the TAB key thrice to highlight the value displayed in the L edit box of the Sketch
tools toolbar. Type 8 in this edit box and press the ENTER key.

8. Now, move the cursor vertically upward and click when a vertical line is displayed.

A vertical line of length 8mm will be drawn. You will notice that this line is no longer in
the select mode and you are prompted to select the start point of the next line. This is
because of double-clicking on the Line button. It makes the Line tool active, till you
invoke another tool.
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9. Select the endpoint of the vertical line as the start point of the second horizontal line.
Enter 75 in the L edit box of the Sketch tools toolbar. Move the cursor horizontally
toward the right and click when a horizontal line is displayed.

This draws the second horizontal line of length 75mm.

10. Select the endpoint of the second horizontal line as the start point of the second vertical
line and move the cursor vertically downward. Click when the length of the line in the L
edit box shows a value of 8mm.

This draws the second vertical line of length 8mm.

Note
You will notice that while drawing the second vertical line, the inferencing line is displayed in
the geometry area. This line is often displayed, whenever the endpoint of a line is constrained,
with an element already available in the sketch.

11. Select the endpoint of the second vertical line as the start point of the third horizontal
line and move the cursor horizontally toward the right. Click to draw the line, when the
length in the L edit box shows a value of 45mm.

12. Select the endpoint of the previous line as the start point of the third vertical line and
move the cursor vertically upward. Click when the length of the line is 50mm.

This draws the third vertical line of length 50mm. Next, you will draw an arc.

13. To draw the arc, first invoke the Circle toolbar by choosing the down arrow on the right
of the Circle button in the Profile toolbar. Choose the Three Point Arc button to invoke
the Three Point Arc tool.

14. Select the start point of the arc as the endpoint of the previous vertical line and click on it.

15. Move the cursor to a point whose coordinates are 70mm, 50mm. These are displayed in
the Sketch tools toolbar and also on top of the cursor. Click on this point to define the
second point.

16. Move the cursor to specify the third point of the arc. Click on the point when the cursor
snaps to a location 40mm, 20mm in the geometry area. The coordinate values are
displayed on top of the cursor.

This draws the arc for the outer loop. The arc is in the selection mode; click anywhere in
the geometry area to end the selection mode. Now, to continue drawing the outer loop,
you need to invoke the Line tool again.

17. Double-click on the Line button from the Profile toolbar to invoke the Line tool.

18. Select the endpoint of the arc as the start point of the fourth vertical line. Move the
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cursor vertically downward to draw it. Click when the value of the length line is 20mm in
the L edit box of the Sketch tools toolbar.

This draws the fourth vertical line of length 20mm. The line is no longer in the selection
mode. You are prompted to enter the start point of the next line.

19. Select the endpoint of the previous line as the start point of the fourth horizontal line.
Move the cursor horizontally toward the left. Click when the length of the line in the L
edit box of the Sketch tools toolbar shows a value of 80mm.

This draws the fourth horizontal line of length 80mm. Note that the line is green in
color, because it passes through the origin.

20. Select the endpoint of the previous line as the start point of the inclined line. Move the
cursor such that the line is drawn at an angle of 225-degree. The current angle will be
displayed in the A edit box of the Sketch tools toolbar. Click when a vertical inferencing
line is displayed between the endpoint of the inclined line and the start point of the first
horizontal line. This draws the inclined line of a horizontal length of 10mm.

21. Select the endpoint of the inclined line as the start point of the next line. Move the
cursor vertically downward. Click when the length of the line in the L edit box shows a
value of 20mm.

This completes the sketch of the outer loop. It is recommended to modify the geometry
area such that the sketch fits inside the screen. This is done by using the Fit All In tool.

22. Choose the Fit All In button from the View toolbar to fit the current sketch on the
screen. The completed outer loop of the sketch is shown in Figure 2-51. Note that the
display of the constraints and dimensions is turned off using the Hide/Show tool for
clarity.

Drawing the Circle
The circle will be drawn using the Circle tool.

1. Choose the Circle button from the Circle toolbar to invoke the Circle tool; you
are prompted to define the center point of the circle.

Figure 2-51  The completed  outer loop of the sketch
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Figure 2-52  The final sketch for Tutorial 4

Tip. If you open a file that was saved in the Sketcher workbench, it will be opened
in the Sketcher workbench only and not in the Part Design workbench.

2. Move the cursor to a point whose coordinates are 70mm, 20mm. Click when the cursor
snaps to this point.

3. Move the cursor horizontally toward the right and click when the radius of the circle in
the R edit box of the Sketch tools toolbar shows a value of 15mm. Click anywhere to
remove the circle from the selection.

The final sketch, with the display of constraints turned on, is shown in Figure 2-52.

Saving and Closing the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog

box. Browse the c02 folder that you created in the last tutorial.

2. Enter the name of the file as c02tut4 in the File name edit box and choose the Save
button. The file will be saved in the \My Documents\CATIA\c02 folder.

3. Close the part file by choosing File > Close from the menu bar.
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SELF-EVALUATION TEST
Answer the following questions and then compare them to those given at the end of this
chapter:

1. The base feature of any design is a sketched feature, which is created by drawing the sketch. (T/F)

2. You can also draw an arc, while working with the Profile tool. (T/F)

3. To enter the Sketcher workbench, you need to choose the Sketch button. (T/F)

4. When you open a file that has been saved in the sketching environment, it opens in the
part modeling environment. (T/F)

5. You can convert a sketched element into a construction element by using the __________ button.

6. To draw a rectangle at an angle, you need to use the __________ tool.

7. The __________ are the temporary lines that are used to track a particular point on the screen.

8. The __________ tool is used to draw continuous lines.

9. Using the __________ tool, you can create a circle by specifying the coordinates of its
center point.

10. The rectangle is considered as a combination of individual __________.

REVIEW QUESTIONS
Answer the following questions:

1. The 3 point arcs are the ones that are drawn by defining the start point, endpoint, and a
point on the arc. (T/F)

2. The Parallelogram button is available in the Predefined Profile toolbar. (T/F)

3. The Symmetrical Extension button, when selected from the Sketch tools toolbar, draws
a simple line. (T/F)

4. In CATIA V5, circles are drawn by specifying the center point of the circle and then
entering the radius in the dialog box that is displayed. (T/F)

5. When you start CATIA V5, by default, a file in the Product workbench is started. (T/F)
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6. In CATIA V5, a rectangle is considered as a combination of which of the following
elements?

(a) Lines (b) Arcs
(c) Splines (d) None

7. Which tool is not available in the Predefined Profile toolbar?

(a) Rectangle (b) Oriented Rectangle
(c) Parallelogram (d) Circle

8. Which one of the following elements will not be considered, while converting a sketch
into a feature?

(a) Sketched circles (b) Sketched lines
(c) Construction elements (d) None

9. Which one of the following tools is available in the Line toolbar?

(a) Line (b) Infinite Line
(c) Bisecting Line (d) All of these

10. In which workbench of CATIA V5 can you draw the sketches that can be used to create
features?

(a) Part (b) Assembly
(c) Shape (d) None

EXERCISES

Draw the sketch of the model shown in Figure 2-53. The sketch to be drawn is shown in
Figure 2-54. Do not dimension it. The solid model and dimensions are given for your reference.

   (Expected time: 30 min)

Exercise 1
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Figure 2-55  The solid model for Exercise 2 Figure 2-56  The sketch of the model

Exercise 2

Figure 2-53  The solid model for Exercise 1 Figure 2-54  The sketch of the model

Draw the sketch of the model shown in Figure 2-55. The sketch to be drawn is shown in
Figure 2-56. Do not dimension it. The solid model and dimensions are given for your reference.

               (Expected time: 30 min)
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Answers to Self-Evaluation Test
1. T, 2. T, 3. T, 4. F, 5. Construction/Standard Element, 6. Oriented Rectangle, 7. inferencing
lines, 8. Profile, 9. Circle Using Coordinates, 10. lines


