
Chapter 2

Drawing Sketches 
for Solid Models

 Learning Objectives
After completing this chapter, you will be able to:
• Start a new template fi le to draw sketches.
• Set up the sketching environment.
• Use various drawing display tools.
• Understand the sketcher environment in the Part module.
• Get acquainted with sketcher entities.
• Specify the position of entities by using dynamic input.
• Draw sketches by using various sketcher entities.
• Delete sketched entities.
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THE  SKETCHING ENVIRONMENT
Most designs created in Autodesk Inventor consist of sketched and placed features. A sketch is 
the combination of a number of two-dimensional (2D) entities such as lines, arcs, circles, and 
so on. The features such as extrude, revolve, and sweep that are created by using 2D sketches 
are known as sketched features. The features such as fi llet, chamfer, thread, and shell that are 
created without using a sketch are known as placed features. In a design, the base feature or 
the fi rst feature is always a sketched feature. For example, the sketch shown in Figure 2-1 is 
used to create a solid model, as shown in Figure 2-2. In this fi gure, the fi llets and chamfers 
are the placed features.

Once you have drawn the basic sketch, refer to Figure 2-1, you need to convert it into a solid 
model using solid modeling tools.

The sketching environment of Autodesk Inventor can be invoked at any time in the Part 
module or in the Assembly module. Unlike other solid modeling programs, here you just need 
to invoke the Create 2D Sketch tool and specify the plane to draw the sketch; the sketching 
environment will be activated. Also, when you start a new fi le in the Part module, fi rst the 
sketching environment will be activated. You can draw a sketch in this environment and then 
proceed to the part modeling environment for converting the sketch into a solid model. The 
options in the sketching environment will be discussed later in this chapter.

 The Open Dialog Box
On starting a new session of Autodesk Inventor, the initial screen will be displayed. Now, 
choose the Open tool from the Launch panel of the Get Started tab; the Open dialog box 
will be displayed, as shown in Figure 2-3. 

The options in the Open dialog box are used to create new fi les and open existing fi les. You 
can browse and select the fi le that you want to open from the list displayed in the dialog 
box. The preview of the selected fi le is displayed in the preview window located at the lower 
left portion of this dialog box, as shown in Figure 2-4. By default, you can open any fi le 
created in Autodesk Inventor. This is because by default, the Files of type drop-down list 
displays the Autodesk Inventor Files (*.iam;*.idw;*.dwg;*.ipt;*.ipn, and *.ide) option. 

Figure 2-1  The basic sketch for the solid model Figure 2-2  A solid model created using the 
sketched and placed features
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You can also open the fi les created in other solid modeling programs such as AutoCAD, 
Pro/ENGINEER, Alias, SolidWorks, NX, and so on, by selecting the respective options from 
the Files of type drop-down list. 

Figure 2-3  The Open dialog box

Figure 2-4  The Open dialog box showing the preview of the selected fi le
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In Autodesk Inventor, a project defi nes all the fi les related to a design project you are working 
on. You can create new projects or retrieve the previously created projects by choosing the 
Projects button available on the right of the Project File drop down list in the Open dialog box. 
When you choose the Projects button, the Projects dialog box will be displayed, as shown in 
Figure 2-5. All the project folders will be displayed in the upper half of the dialog box and the 
options regarding the selected project folder will be displayed in the lower half of the dialog box. 
To add another project folder to this list, choose the New button; the Inventor project wizard 
dialog box will be displayed. The New Vault Project radio button is selected by default in this 
dialog box. Choose the Next button from the Inventor project wizard dialog box. Specify the 
name of the project in the Name text box and the location in the Project (Workspace) Folder 
text box. You can also choose the Browse for project location button to specify the location 
of the project. Next, choose the Finish button. Once you have specifi ed the project folder, it 
will be added in the upper part of the dialog box and its location will be displayed. When you 
select a project, the options related to it will be shown in the lower part of the dialog box. The 
Projects dialog box with various projects is displayed, refer to Figure 2-5.

On starting a new session in Autodesk Inventor, only the Start a new fi le button will be 
available in the Quick Launch area of the Open dialog box. Choose this button; the New 
File dialog box will be displayed, as shown in Figure 2-6. To exit the Open dialog box, choose 
the Cancel button.  

Figure 2-5  The Projects dialog box



Drawing Sketches for Solid Models      2-5

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

To view help about topics, press F1; the Autodesk Inventor Help window will be displayed. 
In this window, you will fi nd help topics explaining how to use a particular tool or option of 
Autodesk Inventor. You can select the Show Help on startup check box available on the right 
of  the Autodesk Inventor Help window to make this window appear whenever you start a new 
session. You can exit the Autodesk Inventor Help window by choosing the Close button.

Starting a New File 
In Autodesk Inventor, you can start a new fi le by choosing New from the Get Started 
tab or by choosing the New option from the Application Menu. On doing so, the 
New File dialog box will be displayed, refer to Figure 2-6. Alternatively, you can start 

a new fi le by choosing the New tool from the Quick Access Toolbar.

Note
If you invoke the New File dialog box by choosing the New tool from the Quick Access Toolbar 
or by choosing New > New from the Application Menu, only the Open button will available 
in the Quick Launch area. You can choose the Open tool to invoke the Open dialog box and 
open an existing fi le in Autodesk Inventor.

The options in the New File dialog box are used to select a template fi le for starting a design. 
You can select a template in the Default, English, Metric, or Mould tabs. To start a new metric 
part fi le, choose the Metric tab, as shown in Figure 2-7. The templates that are available on 
choosing the Metric tab are discussed next. 

Figure 2-6  The New File dialog box
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.ipt Templates 
Select any .ipt template to start a new part fi le for creating a solid model or a sheet metal 
component. When you start a new part fi le, the sketching environment will be automatically 
active and you can directly start drawing sketches.

.iam Templates
Select any .iam template to start a new assembly fi le for assembling various parts. Similarly, 
use the Weldment.iam template to weld two different components in the Weldment module.

.ipn Templates
Select any .ipn template to start a new presentation fi le for animating the assembly. The 
Presentation module marks the basic difference between Autodesk Inventor and other design 
tools. This module allows you to animate the assemblies created in the Assembly module. For 
example, you can create a presentation in the Presentation module that shows a Drill Press 
Vice assembly in motion. 

.idw Templates
Select any .idw template to start a new drawing fi le for generating the drawing views. You can 
use the drawing templates of various standards that are provided in this tab, such as ANSI, 
ISO, DIN, GB, JIS, GOST, and BSI.

.dwg Templates
Select any .dwg template for creating AutoCAD drawing fi les. You can use the drawing 
templates of standards such as JIS, ISO, GB, DIN, BSI, and ANSI.

Figure 2-7  The Metric tab of the New File dialog box
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The Project File drop-down list in the New File dialog box displays the active project in 
which the new fi le has been started.  The Projects dialog box can be invoked by choosing the 
Projects button from the New File dialog box.

 INTRODUCTION TO THE SKETCHING ENVIRONMENT
The initial screen appearance in the sketching environment of a Standard (mm).ipt fi le is shown 
in Figure 2-8. By default, the Ribbon is placed at the top of the graphics window, refer to 
Figure  2-8. You can move this Ribbon anywhere in the graphics window. To do so, right-click 
on the Ribbon; a shortcut menu will be displayed. Select the Undock Ribbon option from 
the shortcut menu; the Ribbon will be undocked. Now you can drag the Ribbon anywhere in 
the graphics window. It is recommended to place (dock) the Ribbon at the top of the graphics 
window so that you can use the space effi ciently. To do so, right-click on the Ribbon and choose 
Docking Position > Top from the shortcut menu. Alternatively, double-click on the title bar 
of the Ribbon to dock it.

 SETTING UP THE SKETCHING ENVIRONMENT
It is very important to fi rst set up the sketcher environment. This has to be done before you 
start drawing a sketch. Setting up the sketcher environment includes modifying the grids of a 
drawing. It is unlikely that the designs that you want to create consist of small dimensions. You 

Figure 2-8  Initial screen appearance in the sketching environment
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will come across a number of designs that are large. Therefore, before starting a drawing, you 
need to modify the grid settings. These settings will depend on the dimensions of the design. 
The process of modifying the grid settings of a drawing is discussed next.

 Modifying the Document Settings of a Sketch
Before  sketching, you may need to modify the setting of the sketching environment as per your 
requirement. You can change the snapping distance, grid spacing, and various attributes related 
to line display of the sketching environment. You must have noticed that the drawing window 
in the sketching environment consists of a number of light and dark lines that are normal to 
each other. These normal lines are called grid lines. The grid lines help you locate an entity, 
thereby helping you to draw a sketch correctly or modify an existing sketch precisely. 

You can modify the document settings of a sketch. To do so, choose the Document Settings 
tool from the Options panel of the Tools tab; the Document Settings dialog box will be 
displayed. In this dialog box, choose the Sketch tab to display the options related to the 
sketching environment, see Figure 2-9. The options under this tab are discussed next.

Figure 2-9  The Sketch tab of the  Document Settings dialog box
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Snap Spacing Area
The options under this area are used to specify the snap distances.
 

X
This edit box is used to specify the snap spacing in the X direction. 

Y
This edit box is used to specify the snap spacing in the Y direction. 

Grid Display Area
The options in this area are used to control the number of major and minor lines. The minor 
lines are the light lines that are displayed inside the dark gray lines. The dark gray lines are 
called the major lines. 

snaps per minor
This spinner is used to specify the number of snap points between each minor line.

Major every minor lines
This spinner is used to specify the number of minor lines between two major lines.

Line Weight Display Options Area
The options in the Line Weight Display Options area allow you to control the line weight in 
the sketching environment. The Display Line Weights check box is selected by default and 
displays the sketches with the set line weights. If this check box is cleared, then the differences in 
the line weights will not be displayed in the sketch. The Display True Line Weights radio 
button, if selected, displays the line weights on screen as they would appear on paper when 
printed. The Display Line Weights by Range (millimeter) radio button, if selected, displays 
the line weights according to the values entered.

Note
You will have to increase the drawing display area after increasing the grid spacing. The options 
to do so are discussed next.

UNDERSTANDING  THE DRAWING DISPLAY TOOLS
The drawing display tools or navigation tools are an integral part of any design software. 
These tools are extensively used during the design process. These tools are available in the 
Navigation Bar located on the right in the graphics window and in the Navigate panel of the 
View tab. Some of the drawing display tools in Autodesk Inventor are discussed next. The 
rest of these tools will be discussed in the later chapters.

Tip. You can also turn off the display of the major and minor grid lines and the 
axes. To turn off the display of the grid line and the axes, choose the Application 
Options tool from the Options panel; the Application Options dialog box will 
be displayed. Next, choose the Sketch tab and clear the Grid lines, Minor grid 
lines, and Axes check boxes from the Display area.
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Zoom All

The  Zoom All tool is used to increase the drawing display area to display all the 
sketched entities in the current display. 

 Zoom Window

The Zoom Window tool is used to defi ne an area to be magnifi ed and viewed in the 
current drawing. The area is defi ned using two diagonal points of a box (called window) 
in the drawing window. The area inscribed inside the window will be magnifi ed and 

displayed on the screen.

Zoom

The  Zoom tool is used to interactively zoom in and out of the drawing view. When you 
choose this tool, the default cursor is replaced by the zoom cursor. You can zoom into 
the drawing by pressing the left mouse button and dragging the cursor down. Similarly, 

you can zoom out of the drawing by pressing the left mouse button and then dragging the 
cursor up. You can exit this tool by choosing another tool or by pressing ESC. You can also 
choose Done from the shortcut menu, which is displayed on right-clicking. You can also zoom 
into the drawing by rolling the scroll wheel of the mouse in the reverse direction. Similarly, 
you can zoom out of the drawing by rolling the scroll wheel in the forward direction.

Zoom Selected

When you choose the Zoom Selected tool, you will be prompted to select an entity to 
zoom. Select an entity from the drawing area; it will magnifi ed to maximum extent 
and placed at the center of the drawing window. This tool can also be invoked by 

pressing the END key.

Ribbon:      View > Navigate > Zoom drop-down > Zoom All
Navigation Bar:    Zoom fl yout > Zoom All

Ribbon:      View > Navigate > Zoom drop-down > Zoom Window
Navigation Bar:    Zoom fl yout > Zoom Window

Tip. The size of the dimension text always remains constant even if you magnify 
the area that includes some dimensions. 

To switch to the previous view, right-click in the drawing window and then choose 
Previous View from the shortcut menu or press the F5 key. You can restore nine 
previous views in the current sketching environment by using this option.

Tip. You need to increase the drawing display area by zooming out from the 
drawing using the Zoom tool after increasing the grid spacing.

Ribbon:      View > Navigate > Zoom drop-down > Zoom 
Navigation Bar:    Zoom fl yout > Zoom 

Ribbon:    View > Navigate > Zoom drop-down > Zoom Selected
Navigation Bar:  Zoom fl yout > Zoom Selected
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Pan

The  Pan tool is used to drag the current view in the drawing window. This option is 
generally used to display the contents of the drawing that are outside the display area, 
without actually changing the magnifi cation of the current drawing. It is similar to 

holding the drawing and dragging it across the drawing window. You can also invoke the Pan 
tool by pressing and holding the middle scroll wheel of the mouse. 

 SKETCHING ENTITIES
Getting acquainted with the sketching entities is an important part of learning Autodesk 
Inventor. A major part of the design is created using the sketched entities. Therefore, this section 
can be considered as one of the most important sections of the book. In Autodesk Inventor, 
the sketched entities are of two types: Normal and Construction. The normal entities are 
used to create a feature and become a part of it, but the construction entities are drawn just 
for reference and support, and cannot become a part of the feature. By default, all drawn 
entities are normal entities. To draw construction entities, choose the Construction tool from 
the Format panel of the Sketch tab. All entities drawn after choosing the Construction tool 
will be the construction entities. Deselect this tool by choosing it again to draw normal entities. 

SPECIFYING THE POSITION OF ENTITIES 
DYNAMICALLY BY USING THE DYNAMIC INPUT
With this release of Autodesk Inventor, you can specify the position of sketching entities 
dynamically by using the Pointer Input and the Dimension Input. The Pointer Input is displayed 
when you invoke the sketching tools such as Line, Rectangle, Arc, and it displays the coordinates 
of the current location of the cursor. As you move the cursor, the coordinates change dynamically. 
When you specify the fi rst point, the Pointer Input is displayed. The Pointer Input is displayed in 
the form of Cartesian Coordinates (X and Y). If you specify the second point or the subsequent 
points of entities, the Dimension Input will be displayed. The Dimension Input is displayed 
in the form of polar coordinates (Length and Angle).  

To specify the position of sketching entities dynamically, invoke the required sketching tool 
and then move the cursor in the drawing window; the location of the cursor will be displayed 
in the cartesian coordinate in the Pointer Input. Press the TAB key and enter the X and Y 
coordinate values in the Pointer Input to specify the fi rst point; you will be prompted to specify 
the endpoint or second point of the entity. Alternatively, you can specify the fi rst point of the 
entity by clicking in the drawing window. On doing so, the Pointer Input will be modifi ed to 
the Dimension Input and the polar coordinate input fi elds will be displayed. To specify the 
endpoint or second point of the entity, enter the length and angle values in the input fi elds. 
To toggle between the length and angle input fi elds, use the TAB key. If you specify input 
values by using the Dimension Input and then use the TAB key, lock icons will be displayed on 
the right of the input fi elds. The lock icons indicates that the values defi ned are constrained. 
Figure 2-10 shows the Pointer Input of a line and Figure 2-11 shows the Dimension Input of 
the endpoint of a line of length 20 mm at an angle of 45-degree. 

Ribbon:    View > Navigate > Pan
Navigation Bar:  Pan



2-12                               Autodesk Inventor for Designers

E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

If some sketched entities exist in the drawing window and you start creating new entities in 
the drawing window, an appropriate constraint symbol will be displayed near the cursor. You 
can control the display of the Pointer Input and Dimension Input by using the Application 
Options dialog box. This dialog box can be invoked by choosing the Application Options 
tool from the Options panel. To control the display of Pointer Input and Dimension Input, 
choose the Sketch tab in the Application Options dialog box. Clear the Enable the Heads-Up 
Display (HUD) check box from the Sketch tab and choose the OK button from this dialog 
box. As a result, the display of Pointer Input and Dimension Input will be turned off and now 
you cannot enter the input values of the entities dynamically. 

The sketcher entities in Autodesk Inventor are discussed next. 
  

 Drawing Lines

Lines are the basic and one of the most important entities in the sketching 
environment. As mentioned earlier, you can draw either normal lines or construction 
lines. A line is defi ned as the shortest distance between two points. The two points 
are the start point and the endpoint of the line. Therefore, to draw a line, you need 

to defi ne these two points. The parametric nature of Autodesk Inventor allows you to draw 
the initial line of any length or at any angle by just picking the points on the screen. After 
drawing the line, you can drive it to a new length or angle by using parametric dimensions. 
You can also create the line of actual length and angle directly by using the Inventor Precise 
Input toolbar. Both these methods of drawing the lines are discussed next.

Drawing Lines by Picking Points in the Drawing Window
This is a very convenient method to draw lines and is used extensively while sketching. When 
you invoke the Line tool from the Draw panel, the cursor (which was initially an arrow) is 
replaced by crosshairs with a yellow circle at the intersection. Also, you are prompted to 
select the start point of the line or drag off the endpoint for the tangent arc. In addition, the 
coordinates of the current location of the cursor are displayed in the Pointer Input and also at 

Figure 2-11  Dimension input of the endpoint 
of a line of length 20 mm at 45-degree 

Figure 2-10  Pointer input of a line

Ribbon:  Sketch > Draw > Line
Toolbar: 2D Sketch Panel >  Line drop-down > Line
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Figure 2-12  Drawing a line using the 
Perpendicular Constraint

Figure 2-13  Drawing a line using 
the Parallel Constraint

the lower right corner of the Autodesk Inventor window. The point of intersection of the X 
and Y axes (black lines among grid lines) is the origin point. If you move the cursor close to 
the origin, it will snap to the origin automatically. To draw a line, specify a point anywhere in 
the drawing window; the Pointer Input will display both length and angle values as zero. Move 
the cursor; a rubber-band line will start from the specifi ed point and the length and angle 
values will change accordingly in the Pointer Input. One end of this rubber-band line is fi xed 
at the point specifi ed in the drawing window and the other end is attached to the yellow circle 
in crosshairs. As you move the cursor after specifying the start point of the line, the Pointer 
Input will display the length and angle of the current location of the line. Click at the required 
position in the drawing window. Alternatively, enter the required length and angle values in the 
Pointer Input to specify the endpoint of the line. You can use the TAB key to toggle between 
the length and angle values in the Pointer Input. After specifying the endpoint of the line, a 
line is drawn and a new rubber-band line starts. The start point of the new rubber-band line 
is the endpoint of the last line and you are again prompted to specify the endpoint of the line. 
You can continue specifying the endpoints to draw continuous lines.

When you draw entities in Autodesk Inventor, valid constraints are applied automatically to 
entities. Therefore, when you draw continuous lines, the horizontal, vertical, perpendicular, and 
parallel constraints are applied automatically to them. The symbol of the applied constraint 
is displayed on the line while drawing it. You can exit the Line tool by pressing the ESC key. 
You can also right-click in the drawing window, and then choose Done from the shortcut 
menu displayed. Figures 2-12 and 2-13 display the Perpendicular Constraint and Parallel 
Constraint being applied to the lines while they are being drawn.  

Note
The default screen appearance in the sketcher environment has been modifi ed for clarity. To 
change the screen appearance, choose the Application Options tool from the Options panel; 
the Application Options dialog box will be displayed. Choose the Colors tab and then select 
the Presentation option from the Color scheme list box. Select 1 Color from the Background 
drop-down list. Next, choose the Apply button from the Application Options dialog box to 
change the default appearance of the screen in the sketcher environment.
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With this release of Autodesk Inventor, you can close a sketch that has two or more than 
two lines. To do so, create two or more than two continuous lines and then right-click in the 
drawing window; a shortcut menu will be displayed. Choose the Close option from the shortcut 
menu; a line joining the endpoint of the current line and the start point of the fi rst line will be 
created and the sketch will be closed. Figure 2-14 shows the Close option being chosen from 
the shortcut menu to close the sketch and Figure 2-15 shows the closed sketch created. 

Drawing Lines by Specifying Exact Values
This is another method of drawing lines in Autodesk Inventor. In this method, you use the 
Inventor Precise Input toolbar to defi ne the coordinates of the start point and the endpoint 
of lines. To display the Inventor Precise Input toolbar for the line, fi rst invoke the Line tool. 
Next, click on the down arrow displayed at bottom of the Draw panel in the Sketch tab; the 
Draw panel will expand. Choose the Precise Input tool from this panel. As mentioned earlier, 
the origin of the drawing lies at the intersection of the X and Y axes. The X and Y coordinates 
of this point are 0, 0. You can take the reference of this point to draw lines. There are two 
methods to defi ne the coordinates using this toolbar. Both the methods are discussed next.

Specifying Coordinates with respect to the Origin
The system of defi ning the coordinates with respect to the origin of the drawing is termed 
as the absolute coordinate system. By default, the origin lies at the intersection of the X 
and Y axes. All the points in this system are defi ned with respect to this origin. To defi ne 
the points, you can use the following four methods.

Defi ning the Absolute X and Y Coordinates. In this method, you will defi ne the X and 
Y coordinates of the new point with respect to the origin. To invoke this method, select 
the Indicate a point location by typing X and Y values option from the drop-down 
list in the Inventor Precise Input toolbar. The exact X and Y coordinates of the point 
can be entered in the X and Y edit boxes provided in this toolbar.

Tip. While drawing a sketch, constraints are displayed dynamically and are applied 
to it. To turn off the display of these constraints, press and hold the CTRL key and 
draw the sketch.

Figure 2-15  Closed sketch createdFigure 2-14  Choosing the Close option from 
the shortcut menu 
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Defi ning the Absolute X Coordinate and the Angle from the X Axis. In this method, 
you will defi ne the absolute X coordinate of a point with respect to the origin and 
the angle that this line makes with the positive X axis. The angle will be measured 
in the counterclockwise direction from the positive X axis. To invoke this method, 
select the Specify a point using X coordinate and angle from X axis option from 
the drop-down list. The X coordinate of the new point and the angle can be defi ned 
in the respective edit boxes in the Inventor Precise Input toolbar.

Defi ning the Absolute Y Coordinate and the Angle from the X Axis. In this method, 
you will defi ne the absolute Y coordinate of a point with respect to the origin and 
the angle that this line makes with the positive X axis. To invoke this method, select 
the Specify a point using Y coordinate and angle from X axis option from the 
drop-down list. The Y coordinate of the new point and the angle can be defi ned in 
the respective edit boxes in the Inventor Precise Input toolbar.

Specifying the Distance from the Origin and the Angle from the X Axis. In this 
method, you will defi ne the distance of the point from the origin and the angle that 
this line makes with the X axis. To invoke this method, select the Specify a point using 
distance from the origin and angle from X axis option from the drop-down list. The 
distance and the angle can be defi ned in the respective edit boxes.

Specifying Coordinates with respect to the Last Point
This system of specifying the coordinates with respect to the previous point is termed as 
the relative coordinate system. Note that this system of defi ning the points cannot be used 
for specifying the fi rst point (the start point of the line). All absolute coordinate methods 
for specifying a point with respect to the origin can also be used with respect to the last 
specifi ed point by choosing the Precise Delta button along with the respective method. 
This button will be available only after you specify the start point of the fi rst line.

Note
While drawing continuous lines, when you move the cursor close to the start point of the fi rst 
line, the yellow circle changes to green and the cursor snaps to the start point. On selecting the 
point at this stage the loop will be closed and you will exit the current line chain.

To draw centerlines, fi rst choose the Centerline tool from the Format panel and then create 
the line. Alternatively, select the required entities from the drawing window and then choose the 
Centerline tool; the selected entities will become centerlines.  

 Restarting a Line
To restart a line, right-click and choose Restart from the shortcut menu. The start point of 
the line is canceled and you are prompted to select the start point of the line.

 Drawing Circles
In Autodesk Inventor, you can draw circles using two methods. You can draw a 
circle by defi ning the center and the radius of the circle or draw a circle that is 
tangent to three specifi ed lines. Both these methods of drawing the circle are 
discussed next.
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Drawing Circles by Specifying the Center Point and Radius

This is the default method of drawing circles. In this method, you need to defi ne the 
center point and radius of a circle. To draw a circle using this method, choose the 
Circle Center Point tool from the Draw panel, see Figure 2-16; you will be prompted 
to select the center of the circle. Specify the center point 

of the circle in the drawing window; you will be prompted to specify 
a point on the circle. Click at the required location in the drawing 
window to specify a point on the circumference of the circle. This 
point will defi ne the radius of the circle. Alternatively, enter the 
required value in the Pointer Input to specify the diameter of the 
circle. You can also specify the center and the radius using the 
Inventor Precise Input toolbar. Figure 2-17 shows a circle drawn 
by using the center and the radius.

Drawing Circles by Specifying  Three Tangent Lines

This is the second method of drawing circles and is used to draw a circle  tangent to 
three selected lines. To draw a circle using this method, choose the Circle Tangent 
tool from the Draw panel, see Figure 2-16; you will be prompted to select the 
fi rst, second, and third line, sequentially. As soon as you specify the third line, a circle 
tangent to all the three specifi ed lines will be drawn, as shown in Figure 2-18.

Figure 2-17  Circle drawn using the center 
point and the radius of the circle

Figure 2-18  Circle drawn using three tangent 
lines

 Drawing Ellipses

To draw an ellipse, choose the Ellipse tool from the Draw panel; you will be 
prompted to specify the center of the ellipse. Select a point to specify the center 
of the ellipse; you will be prompted to specify the fi rst axis point. Specify a point 

Ribbon:  Sketch > Draw > Circle drop-down > Circle Center Point
Toolbar: 2D Sketch Panel > Circle drop-down > Center Point Circle

Ribbon:  Sketch > Draw > Ellipse
Toolbar: 2D Sketch Panel > Circle drop-down >  Ellipse

Figure 2-16  Tools in the 
Circle drop-down

Ribbon:  Sketch > Draw > Circle drop-down > Circle Tangent
Toolbar: 2D Sketch Panel > Circle drop-down > Tangent Circle
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to defi ne the fi rst axis of the ellipse; you will be 
prompted to select a point on the ellipse. Select a 
point on the ellipse; the ellipse will be created. You 
can also specify these points using the Inventor 
Precise Input toolbar. However, remember that 
you cannot use the relative options for defi ning 
the points of the ellipse. Therefore, if you use 
the Inventor Precise Input toolbar for drawing 
the ellipse, all the values will be specifi ed from 
the origin. However, you can redefi ne the origin 
by choosing the Precise Redefi ne button and 
placing it at the point that you want to defi ne as 
the origin. Figure 2-19 shows an ellipse. 

 Drawing Arcs
Autodesk Inventor provides three methods for drawing arcs, which are discussed 
next.

Drawing an Arc by Specifying Three Points

This is the default method of drawing arcs. To create an 
arc with three points, choose the Arc Three Point tool 
from the Draw panel, see Figure 2-20, and then specify 
three points.  The fi rst point is the start point of the arc, 

the second point is the endpoint of the arc, and the third point 
is a point on the arc. You can defi ne these points by specifying 
them in the drawing window or by using the Inventor Precise 
Input toolbar. You can also use the Pointer Input for specifying 
the second and the third point of the arc. Figure 2-21 shows an 
arc drawn using this method.

Drawing an Arc Tangent to an Existing Entity

This method is used to draw an arc that is tangent to an existing open entity. The 
open entity can be an arc or a line. To draw an arc using this method, choose the 
Arc Tangent tool from the Draw panel (see Figure 2-20); you will be prompted to 
select the start point of the arc. The start point of the arc must be the start point or 

endpoint of an existing open entity. Once you specify the start point, a rubber-band arc will 
start from it. Note that this arc is tangent to the selected entity. Now, you will be prompted to 
specify the endpoint of the arc. Click on the drawing window to specify the endpoint of the 
arc. Alternatively, enter the radius and the angle values in the Pointer Input to specify the 
endpoint of the arc. Here, it is very important to mention that the Inventor Precise Input 

Ribbon:  Sketch > Draw > Arc drop-down > Arc Tangent
Toolbar: 2D Sketch Panel > Arc drop-down >  Tangent Arc

Figure 2-19  An ellipse drawn in the sketching 
environment

Ribbon:  Sketch > Draw > Arc drop-down > Arc Three Point
Toolbar: 2D Sketch Panel > Arc drop-down > Three Point Arc

Figure 2-20  Tools in the Arc 
drop-down
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toolbar or the Pointer Input cannot be used to select the start point of this arc. However, 
you can use this toolbar to specify the endpoint of this arc. Figure 2-22 shows an arc drawn 
tangent to the line.

Drawing Tangent/Normal Arcs Using the Line Tool
You can also draw a tangent or a normal arc when you are inside the Line tool. At least a line 
or an arc should be drawn before drawing an arc using this method. To draw an arc using the 
Line tool, draw a line or an arc and then invoke the Line tool. When you are prompted to 
select the start point of the line, move the cursor close to the point from where you want to 
start the tangent or normal arc; the yellow circle in the cursor turns green. Select the point at 
this stage; the green circle in the cursor turns gray. Press the left mouse button and drag the 
mouse; four construction lines appear at the start point displaying the normal and tangent 
directions. If you drag along the tangent direction, a tangent arc is drawn. But if you drag 
along the normal direction, an arc normal to the selected entity is drawn.

Drawing an Arc by specifying the Center, Start, and Endpoint

This method is used to draw an arc by specifying the center point, start point, and 
endpoint of the arc. To draw an arc using this method, choose the Arc Center Point 
tool from the Draw panel (see Figure 2-20). On doing so, you will be prompted to 
specify the center point of the arc. Once you specify the center point of the arc, you 

will be prompted to specify the start point and then the endpoint of the arc, see Figure 2-23. 
You can also specify the start point and endpoint of the arc by using the Pointer Input. In 
case of start point, you need to specify the radius and angle of the arc from the center point. 
Whereas, in case of endpoint, you need to specify the arc length in terms of angle value. You 
can use the TAB key to toggle between the input values of the Pointer Input. As you defi ne 
the center point and the start point, the radius of the arc will be defi ned automatically. So, the 
third point is just used to defi ne the arc length. An imaginary line is drawn from the cursor 
to the center of the arc. The point at which the arc intersects the imaginary line will then be 
taken as the endpoint of the arc, see Figure 2-24. You can also use the Inventor Precise Input 
toolbar to specify these three points of the arc. 

Figure 2-22  Drawing the tangent arcFigure 2-21  Drawing the three points arc

Ribbon:  Sketch > Draw > Arc drop-down > Arc Center Point
Toolbar: 2D Sketch Panel > Arc drop-down >  Center Point Arc
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 Drawing Rectangles
In Autodesk Inventor, rectangles can be drawn by using two methods that are 
discussed next.

Drawing Rectangles by Specifying Two Opposite Corners

This is the default method used to draw a rectangle by 
specifying its two opposite corners. To draw a rectangle 
by using this method, choose the Rectangle Two Point 

tool from the Draw panel, see Figure 2-25; you will be prompted 
to specify the fi rst corner of the rectangle and the Pointer Input 
will be displayed. Click at the required location to specify the fi rst 
corner of the rectangle. Once you specify the fi rst corner, you will 
be prompted to specify the opposite corner of the rectangle and 
the Pointer Input will be modifi ed. Click to specify the second 
corner or enter the length and height of the rectangle in the 
Pointer Input. Figure 2-26 shows a rectangle drawn using the 
Rectangle Two Point tool.

Drawing Rectangles by Specifying Three Points on a Rectangle

You can draw a rectangle by specifying its three points. In this method, the fi rst two 
points are used to defi ne the length and angle of one of the sides of the rectangle and 
the third point is used to defi ne the length of the other side. To create a rectangle 

by using this method, choose the Rectangle Three Point tool from the Draw panel of the 
Sketch tab, see Figure 2-25; you will be prompted to specify the fi rst corner of the rectangle. 
Once you specify it, you will be prompted to specify the second corner of the rectangle. Both 
these corners are along the same direction. As a result, you can use these points to defi ne the 

Figure 2-23  The arc created by specifying 
the center point, start point, and endpoint

Figure 2-24  The imaginary line created 
while drawing the center point arc

Ribbon:  Sketch > Draw > Rectangle drop-down > Rectangle Two Point
Toolbar: 2D Sketch Panel >  Rectangle drop-down > Two Point Rectangle

Ribbon:  Sketch > Draw > Rectangle drop-down > Rectangle Three Point
Toolbar: 2D Sketch Panel > Rectangle drop-down >  Three Point Rectangle

Figure 2-25  Tools in the 
Rectangle drop-down
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length of one side of the rectangle. After specifying the second corner, you will be prompted 
to specify the third corner. This corner is used to defi ne the length of the other side of the 
rectangle. Note that if you specify the second corner at a certain angle, then the resultant 
rectangle will also be inclined. You can also specify the fi rst, second, and third points of the 
rectangle by using the Pointer Input. In case of second point, you need to specify the length and 
angle of rectangle in the input value fi elds of the Pointer Input. Whereas, in case of endpoint, 
you need to specify the height of the rectangle. You can use the TAB key to toggle between 
the input values of the Pointer Input. You can also specify the three points for drawing the 
rectangle using the Inventor Precise Input toolbar. Figure 2-27 shows an inclined rectangle 
drawn by using the Three Point Rectangle tool.

 Drawing Polygons

The polygons drawn in Autodesk Inventor 
are regular polygons. A regular polygon is a 
multi-sided geometric fi gure in which the length of 

all sides and the angle between them are the same. In Autodesk 
Inventor, you can draw a polygon with the number of sides ranging 
from 3 to 120. When you invoke the Polygon tool, the Polygon 
dialog box will be displayed, as shown in Figure 2-28, and you will 
be prompted to select the center of the polygon. The options in 
this dialog box are discussed next.

 Inscribed
This is the fi rst button in the Polygon dialog box and is chosen by default. This option is 
used to draw an inscribed polygon. An inscribed polygon is the one that is drawn inside an 
imaginary circle such that its vertices touch the circle. Once you have specifi ed the polygon 
center, you will be prompted to specify a point on the polygon. In case of an inscribed polygon, 
the point on the polygon specifi es one of its vertices, see Figure 2-29.

Figure 2-26  Drawing a rectangle using two points Figure 2-27  Drawing the three-point 
rectangle at an angle

Ribbon:  Sketch > Draw > Polygon
Toolbar: 2D Sketch Panel >  Polygon

Figure 2-28  The  Polygon 
dialog box
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 Circumscribed
This is the second button in the Polygon dialog box and is used to draw a circumscribed 
polygon. A circumscribed polygon is the one that is drawn outside an imaginary circle such 
that its edges are tangent to the imaginary circle. In case of a circumscribed polygon, the point 
on the polygon is the midpoint of one of the polygon edges, see Figure 2-30.

Number of Sides
This edit box is used to specify the number of sides of the polygon. The default value is 6. 
You can enter any value ranging from 3 to 120 in this edit box.

Note
The rectangles and polygons are a combination of individual lines. All the lines can be separately 
selected or deleted. However, when you select one of the lines and drag, the entire rectangle or 
polygon will be considered as a single entity. As a result, the entire object will be moved or stretched.

 Placing Points

In Autodesk Inventor, you can place the sketched points in a sketch using the 
Point tool. To place a point, choose the Point tool from the Draw panel; you 
will be prompted to select the center point. Specify the center point; a point 

will be placed. You can specify the location of a point in the sketch by picking a point from 
the graphics window or by entering the value in the Inventor Precise Input toolbar.

 Creating Fillets

Filleting is defi ned as the process of rounding the sharp corners of a sketch. This 
is done to reduce the stress concentration in the model. Using the Fillet tool, you 
can round the corners of the sketch by creating an arc tangent to both the selected 

Figure 2-30  Drawing a fi ve-sided 
circumscribed polygon

Figure 2-29  Drawing a six-sided inscribed 
polygon

Ribbon:  Sketch > Draw > Point
Toolbar: 2D Sketch Panel >  Point, Center Point

Ribbon:  Sketch > Draw > Fillet/Chamfer drop-down > Fillet
Toolbar: 2D Sketch Panel > Fillet/Chamfer drop-down >  Fillet
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entities. The portions of the selected entities that comprise the sharp corners are trimmed 
when the fi llet is created. When you invoke this tool from the Fillet/Chamfer drop-down, refer 
to Figure 2-31, the 2D Fillet dialog box will be displayed with the default fi llet radius, as shown 
in Figure 2-32, and you will be prompted to select the lines or the arcs to be fi lleted. If you 
have already created some fi llets, their radius values will be stored as preset values. You can 
select these preset values from the list that is displayed when you choose the arrow provided 
on the right of the edit box.

You can create any number of fi llets of similar or dissimilar radii. If the Equal button in the 2D 
Fillet dialog box is chosen, the dimension of the fi llet will be placed only on the fi rst fi llet and 
not on the other fi llets created by using the same sequence, see Figure 2-33. On modifying the 
dimension of the fi rst fi llet, all instances of fi llet will be modifi ed. To create fi llets of independent 
radii values, deactivate the Equal button before creating fi llets. The fi llets thus created will 
show individual dimensions, see Figure 2-34. As a result, you can modify the dimension of one 
fi llet without affecting the other. You can fi llet two parallel or perpendicular lines, intersecting 
lines or arcs, non-intersecting lines or arcs, and a line and an arc.

 Creating Chamfers

Chamfering is defi ned as the process of beveling the sharp corners of a sketch. 
This is the second method of reducing stress concentration. To chamfer sketched 

entities, choose the Chamfer tool from the Draw panel (see Figure 2-31); the 2D Chamfer 
dialog box will be displayed, as shown in Figure 2-35. Also, you will be prompted to select 

Figure 2-33  Rectangle fi lleted using the same 
radius with the Equal button chosen

Figure 2-34  Rectangle fi lleted using different 
radii with the Equal button deactivated

Ribbon:  Sketch > Draw > Fillet/Chamfer drop-down > Chamfer
Toolbar: 2D Sketch Panel > Fillet/Chamfer drop-down >  Chamfer

Figure 2-31  Tools in the Fillet/
Chamfer drop-down

Figure 2-32  The  2D 
Fillet dialog box
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the lines to be chamfered. Select the lines; the chamfer will 
be created. The options in the 2D chamfer dialog box are 
discussed next.

 Create Dimensions
The Create Dimensions button is chosen to show the 
dimensions of the chamfer on the sketch. When you 
chamfer two lines, the dimensions of the chamfer 

are shown in the sketch. If you choose this button again, the 
chamfer dimensions will not be displayed in the sketch when 
you create another chamfer.

Equal
The Equal button is chosen to create multiple chamfers with the same parameters. 
This button is enabled only if the Create Dimensions button is chosen.

 Equal Distance
The Equal Distance button is chosen to 
create an equal distance chamfer. The 
distance of the vertex along the two selected 

edges is the same. As a result, a 45-degree chamfer 
is created using this method. The distance value 
is specifi ed in the Distance edit box. If the Create 
Dimension button is chosen, two dimensions of the 
same value will be shown in the sketch, as shown 
in Figure 2-36.

 Unequal Distances
The Unequal Distances button is chosen to create a chamfer with two different 
distances. The distance values are specifi ed in the Distance1 and Distance2 edit boxes. 
The distance value specifi ed in the Distance1 edit box is measured along the edge 

selected fi rst. Similarly, the value in the Distance2 edit box is measured along the edge selected 
next. Figure 2-37 shows a chamfer created by using the Unequal Distances method.

 Distance and Angle
The Distance and Angle button is chosen to create a chamfer by specifying a distance 
and an angle. On choosing this button, the distance needs to be specifi ed in the 
Distance edit box and the angle in the Angle edit box. The specifi ed angle is measured 

from the fi rst edge selected to chamfer, see Figure 2-38.

Tip. If multiple chamfers are created with same values, the dimension value is 
displayed only at the fi rst instance. At the remaining chamfers, the dimension will 
be displayed as fx of the value, which means the function of the original value.

You can also select the vertex to create a fi llet or chamfer. The two entities forming 
the selected vertex will be fi lleted or chamfered using the current parameters.

Figure 2-35  The  2D Chamfer 
dialog box

Figure 2-36  Chamfer with dimension values
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 Drawing Splines

To draw a spline, choose the Spline tool from the Draw 
panel, see Figure 2-39; you will be prompted to specify the 
fi rst point of the spline. Specify the start point; you will 

be prompted to specify the next point of the spline. This process will 
continue until you terminate the spline creation. To end the spline at 
the current point, double-click in the drawing window or right-click to 
display the shortcut menu and choose Create. Note that if you choose 
Done from the shortcut menu, the spline will not be drawn. You can 
also end the spline creation by pressing the ENTER key. Note that after 
creating a spline, the square and diamond points will be displayed on the spline along with 
the tangent handles, as shown in Figure 2-40. You can drag these square and diamond points 
to modify the shape of the spline.

You can undo the last drawn spline segment while drawing a spline. This can be done by 
choosing the Back option from the shortcut menu that is displayed when you right-click.

You can also draw a spline tangent to an existing entity. To draw the tangent spline, select 
the point where the spline should be tangent. Next, hold the left mouse button and drag it; a 
construction line will be drawn, which displays the possible tangent directions for the spline. 
Drag the mouse in the required direction to draw the tangent spline and release the left mouse 
button. Figure 2-40 shows a spline drawn by specifying different points and Figure 2-41 shows 
a spline drawn tangent to an existing line.

Tip. Autodesk Inventor allows you to invoke the last used tool by right-clicking anywhere 
in the drawing window. For example, create a line using the Line tool. If you want 
to create another line, right-click anywhere in the drawing window and choose the 
Repeat Line option from the shortcut menu. Alternatively, you can invoke the last 
used tool by pressing the SPACEBAR key.

Ribbon:  Sketch > Draw > Spline drop-down > Spline
Toolbar: 2D Sketch Panel > Line drop-down >  Spline

Figure 2-38  The distance and angle chamfer 
created

Figure 2-37  The unequal distances chamfer 
crteated

Figure 2-39  Tools in 
the Spline drop-down
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 Creating a Smooth Curve between Two Existing 
Curves

In Autodesk Inventor, you can create a smooth (G2) continuous curve between two 
existing curves. The existing curves can be arcs, lines, splines, or projected curves. 
To create a smooth curve, choose the Bridge Curve tool from the Draw panel (see 

Figure 2-39); you will be prompted to select the curves one after the other. Select the two 
curves; a smooth G2 continuous curve, known as bridge curve, will be created between the 
selected curves. The profi le of the bridge curve depends on the position where two existing 
curves are selected. Figure 2-42 shows the point of selection of two curves and the resulting 
bridge curve. Figure 2-43 shows different points of selection of the same curve and the resulting 
bridge curve.  

Figure 2-41  A spline drawn tangent to a lineFigure 2-40  A spline drawn by specifying 
different points

Ribbon:  Sketch > Draw > Spline drop-down > Bridge Curve

Figure 2-43  Bridge curve created between 
curves at different selection points

Figure 2-42  Bridge curve created between 
curves at the selection points
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DELETING SKETCHED ENTITIES
To delete the sketched entity, fi rst ensure that no drawing tool is active. If it is, press the ESC 
key. Now, select the entity you want to delete using the left mouse button and then right-click 
to display the shortcut menu. Choose the Delete option from this shortcut menu. You can also 
press the DELETE key to delete the selected entities. To delete more than one entity, you can 
use a window or a crossing. Deleting entities using these methods are discussed next.

 Deleting Entities by Using a Window
A window is defi ned as a box created by pressing and holding the left mouse button and 
dragging the cursor from the left to the right in the drawing window. The window has a 
property that all the entities that lie completely inside the window will be selected. The box 
defi ned by the window consists of continuous lines. All the selected entities will be displayed in 
cyan color. After selecting the entities, right-click and choose Delete from the shortcut menu 
or press the DELETE key to delete all the selected entities. 

 Deleting Entities by Using a Crossing
A crossing is defi ned as a box created by pressing and holding down the left mouse button 
and dragging the cursor from the right to the left in the drawing window. The crossing has a 
property that all entities that lie completely or partially inside the crossing or the entities that 
touch the crossing will be selected. The box defi ned by the crossing consists of dashed lines. 
Once the entities are selected, right-click and choose Delete from the shortcut menu.

FINISHING A SKETCH
After creating the required sketch, you need to save it. But before you save the 
sketch, you need to fi nish the sketch and come out of the sketching environment. 
To do so, choose the Finish Sketch tool from the Exit panel of the Sketch tab; 
the sketch will be fi nished and you will switch to the Home view. This view enables you to view 
and create the modeling features with ease. After switching to the Modeling environment, 
you can save the document.
  

TUTORIALS
Although Autodesk Inventor is parametric in nature, in this chapter you will use the 
Inventor Precise Input toolbar and the dynamic input method to draw objects. This is to make 
you comfortable with various drawing options in Autodesk Inventor. From the next chapter 
onward, you will use the parametric feature of Autodesk Inventor to size or draw the entities 
as per the desired dimension values.

Although the sketches for the tutorials in this chapter are to be drawn on the other sketching 
planes, you will draw them on the default XY plane. In the later chapters, you will learn how 
to change a sketching plane.

Tip. You can add or remove an entity from the selection set by pressing the SHIFT 
or the CTRL key and then selecting the entity by using the left mouse button. If the 
entity is already in the current selection set, it will be removed from the selection 
set. If not, it will be added to set.
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In this tutorial, you will draw the sketch of the model shown in Figure 2-44. The sketch to 
be drawn is shown in Figure 2-45. Do not dimension it, as the dimensions are given only for 
reference.          (Expected time: 30 min)

 The following steps are required to complete this tutorial: 

a. Start a new Autodesk Inventor session and then start a new metric part fi le.
b. Invoke the Line tool and draw the sketch by specifying the coordinates of the points in 

the Inventor Precise Input toolbar.
c. Save the sketch with the name Tutorial1 and close the fi le.

Starting Autodesk Inventor
1. Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop of 

your computer. Alternatively, choose Start > Programs > Autodesk > Autodesk 
Inventor 2011 > Autodesk Inventor Professional 2011 from the taskbar; a new session 
of Autodesk Inventor is started. 

2. Choose the New tool from the Launch panel of the Get Started tab; the New File 
dialog box is displayed. 

3. Choose the Metric tab and then double-click on the Standard (mm).ipt icon to 
start a standard metric template; a new metric standard part fi le is started in the 
Sketching environment. 

 The major and minor grid lines are also displayed in the drawing window, along with the 
X and Y axes.

Note
You can also open a standard metric template by selecting Standard.ipt from the Default tab 
of the New File dialog box.

Tutorial 1

Figure 2-45  Sketch of the modelFigure 2-44  Model for Tutorial 1
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Drawing the Sketch
 As mentioned earlier, Autodesk Inventor is parametric in nature. Therefore, you can 

draw the sketch from any point in the drawing window. However, it is recommended 
that you initially use the Inventor Precise Input toolbar to specify the points. Once you 
are conversant with this design tool, you can specify the points directly in the drawing 
window. 

1. Choose the Line tool from the Draw panel in the Sketch tab. Next, choose 
Precise Input from the Draw panel in the Sketch tab; the Inventor Precise Input 
toolbar is displayed. Double-click on the title bar of this toolbar to dock it. If you 
want, you can also leave this toolbar fl oating on the screen.

 Initially, the Precise Input button is not enabled. This button is enabled only when you 
invoke a sketching tool. Since all initial settings are confi gured, you can now start drawing 
the sketch.

 When you invoke the Line tool, the cursor is replaced by the drawing cursor that has a 
yellow circle at the intersection of crosshairs. This circle is used to snap to the points in 
the drawing window. 

2. Specify 0 as the start point of the sketch in both the X and Y edit boxes of the Inventor 
Precise Input toolbar and then press ENTER; you are prompted to specify the endpoint 
of the line.

3. In the Inventor Precise Input toolbar, enter -3 and 3 in the X and Y edit boxes, respectively 
and then press ENTER to defi ne the endpoint of the line. On doing so, the fi rst line of 
the sketch is drawn and you are prompted to select the endpoint of the line or drag off 
to create a tangent arc.

 You will notice that the line is very small because the dimensions of the sketch are very 
small and the drawing display area is large. Therefore, you need to modify the drawing 
display area by using the drawing display tools. To modify this area, you can use the Zoom 
tool. 

4. Choose the Zoom tool from the Navigation Bar; the drawing cursor is changed 
to an arrow cursor.

5. Move the cursor to the top of the drawing window, press and hold the left mouse button 
and then drag the cursor downward. Stop dragging the cursor once you notice that the 
display is adjusted.

6. Right-click to display the shortcut menu, and then choose Done to exit the Zoom tool. 

 You will notice that the creation of line is resumed and you are prompted to specify the 
endpoint of the next line.
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7. The coordinates of the remaining points (see Figure 2-46) in the sketch are given next.

  Point             Coordinates (X, Y)
     3        -3.5,3
     4        -3.5,0
     5        -5.5,0
     6        -5.5,-1
     7        -2.5,-1
     8        -2.5,-1.75
     9        -2,-1.75
     10        -2,-1.5
     11         2,-1.5
     12         2,-1.75
     13         2.5,-1.75
     14         2.5,-1
     15         5.5,-1
     16         5.5,0
     17         3.5,0
     18         3.5,3
     19         3,3
     20         0,0

8. After specifying all points, right-click to display 
the shortcut menu. Choose Done from the 
shortcut menu or press ESC to exit the Line 
tool. The fi nal sketch for Tutorial 1 is shown 
in Figure 2-46. However, the points in the fi nal 
sketch in this fi gure have been numbered for 
reference only.

 While specifying various points, you will 
notice that some of the constraints are applied 
automatically to the lines. These constraints 
help you reduce the number of dimensions to 
be specifi ed to complete the sketch.

Note
The method of applying additional constraints and using them to fully constrain the sketch will 
be discussed in Chapter 3. 

Figure 2-46  Final sketch for Tutorial 1

Tip. You can use the TAB key to switch from the X edit box to the Y edit box and 
vice versa in the Inventor Precise Input toolbar.
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Saving the Sketch
 Remember that you cannot save a sketch in the sketching environment. This is because 

the sketching environment is just a part of the Part module in Autodesk Inventor. This 
environment is used only for drawing the sketches of features. Therefore, you need to 
exit the sketching environment to save the sketch for further use. The sketches in the Part 
module are saved in the .ipt format.

1. Choose the Finish Sketch button from the Exit panel; the Sketching environment is closed 
and you will switch to the Home view of the part modeling environment. Also, notice that 
the Model tab is activated in place of the Sketch tab. The options in the Model tab are 
used to create features. The options under this tab will be discussed in later chapters.

2. Choose Save from the Quick Access Toolbar; the Save As dialog box is displayed. 

 Whenever you invoke the Save As dialog box for the fi rst time, all fi les are saved in the 
My Documents folder, by default. 

3. Create a new folder with the name Inventor_2011 in the C drive of your computer. In this 
folder, create a folder with the name c02.

 
4. Enter Tutorial1 as the fi le name in the File name edit box, refer to Figure 2-47, and then 

choose the Save button from the Save As dialog box to save the sketch.

5. Choose Close > Close from the Application Menu to close this fi le.

Figure 2-47  The Save As dialog box
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In this tutorial, you will draw the sketch for the model shown in Figure 2-48. The sketch to 
be drawn is shown in Figure 2-49. Do not dimension it, as the dimensions are given only for 
reference.           (Expected time: 30 min)

 The following steps are required to complete this tutorial:

a. Start a new metric standard part fi le.
b. Draw the outer loop by specifying the length and angle lines by using the dynamic 

input method.
c. Draw the inner closed loop by using the dynamic input method, refer to Figure 2-51.
d. Save the sketch with the name Tutorial2.ipt and close the fi le.

Starting a New File
1. Choose the New tool from Launch panel of the Get Started tab to display the New File 

dialog box. In this dialog box, choose the Metric tab and then double-click on the Standard 
(mm).ipt icon to start a standard metric template.

Drawing the Sketch
 As evident from Figure 2-49, the sketch consists of two nested loops: inner loop, and outer 

loop. While extruding a nested loop, the inner loop can be subtracted from the outer 
loop. In this way, a cavity will be created automatically in the model when you extrude the 
sketch. This reduces the time and effort required in creating the inner cavity as another 
feature. Therefore, you can draw both the loops together for this tutorial.

 The Inventor Precise Input toolbar was invoked in the previous tutorial; and therefore, 
it is available on the screen. You need to close it before drawing the sketch.

Tutorial 2

Figure 2-49  Dimensionsed sketch for Tutorial 2Figure 2-48  Model for Tutorial 2
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1. Close the Inventor Precise Input toolbar and then choose the Line tool from the 
Draw panel; you are prompted to specify the start point of the line or drag off an 
endpoint to create a tangent arc. Also, the coordinates of the current location of 
the cursor are displayed in the Pointer Input. 

2. Move the cursor and click when the cursor displays -40 and -25 in the Pointer Input or 
enter the X and Y coordinate values in the Pointer Input. As you specify the fi rst point, 
you are prompted to specify the endpoint of the line and the Pointer Input is changed to 
Dimension Input. 

3. Enter 80 in the length input fi eld of the Dimension Input and press the TAB key; the 
angle input fi eld becomes active. Enter 0 and then press ENTER; the fi rst line is created 
and the Dimension Input is displayed again.

4. Move the cursor up and then enter 10 in the length input fi eld of the Dimension Input. 
Next, press the TAB key and enter 90 in the angle input fi eld and then press ENTER; 
the second line is created and the Dimension Input is displayed again. 

5. Move the cursor toward left and then enter 15 in the length input fi eld. Next, press the 
TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the third line is cre-
ated and the Dimension Input is displayed again. 

6. Move the cursor up and then enter 30 in the length input fi eld. Next, press the TAB key 
and enter 90 in the angle input fi eld. Then, press ENTER; the fourth line is created and 
the Dimension Input is displayed again. 

7. Move the cursor toward right and then enter 15 in the length input fi eld. Next, press 
the TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the fi fth line is 
created and the Dimension Input is displayed again.  

8. Move the cursor up and then enter 10 in the length input fi eld. Next, press the TAB key 
and enter 90 in the angle input fi eld. Then, press ENTER; the sixth line is created and 
the Dimension Input is displayed again. 

9. Move the cursor toward left and then enter 80 in the length input fi eld. Next, press the 
TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the seventh line is 
created and the Dimension Input is displayed again.

10. Move the cursor down and then enter 10 in the length input fi eld. Next, press the TAB 
key and enter 90 in the angle input fi eld. Then, press ENTER; the eighth line is created 
and the Dimension Input is displayed again. 

11. Move the cursor toward right and then enter 15 in the length input fi eld. Next, press 
the TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the ninth line is 
created and the Dimension Input is displayed again.
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12. Move the cursor down and then enter 30 in the length input fi eld. Next, press the TAB 
key and enter 90 in the angle input fi eld. Then, press ENTER; the tenth line is created 
and the Dimension Input is displayed again.

13. Move the cursor toward left and then enter 15 in the length input fi eld. Next, press the 
TAB key and enter 90 in the angle input fi eld. Then, press ENTER; the eleventh line is 
created and the Dimension Input is displayed again.   

14. Move the cursor down and then enter 10 in the length input fi eld. Next, press the TAB 
key and enter 90 in the angle input fi eld. Then, press ENTER; the twelfth line is created 
and the Dimension Input is displayed again. 

15. Right-click to display the shortcut menu. Choose Done from the shortcut menu to exit 
the Line tool. The sketch of the outer loop is shown in Figure 2-50. You need to arrange 
the position of dimensions in the sketch by dragging them to view the sketch clearly.

 Next, you need to draw the inner loop. You can draw the loop by using the Two Point 
Rectangle tool. 

16. Choose the Rectangle Two Point tool from Sketch > Draw > Rectangle 
drop-down; you are prompted to specify the fi rst corner of the rectangle. 

17. Press the TAB key and then enter -15 and -10 in the Pointer Input. Alternatively, move the 
cursor and click when the cursor displays -15 and -10 in the Pointer Input. As you click to 
specify the fi rst corner, you are prompted to specify the opposite corner of the rectangle 
and the Pointer Input is changed to Dimension Input.  

18. Move the cursor diagonally upward in the right direction and enter 30 and 20 in the 
horizontal and vertical input fi elds of the Dimension Input, respectively. Press ENTER 
and right-click; a shortcut menu is displayed. 

19. Choose Done from the shortcut menu; the sketch is created, as shown in Figure 2-51.

Figure 2-51  Completed sketch for Tutorial 2Figure 2-50  Sketch of the outer loop
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Note
The angular dimensions have not been shown in Figures 2-50 and 2-51 for clarity of sketches. 
You can control the display of the linear and angular dimensions of the sketch by using the Sketch 
tab of the Application Options dialog box. This dialog box is displayed when you choose the 
Application Options tool from the Options panel. Alternatively, choose Options from the 
Application Menu to invoke the Application Options dialog box. In the Sketch tab of the 
Application Options dialog box, choose the Settings button; the Heads-Up Display Settings 
dialog box is displayed. Clear the Create dimensions when inputting dimension value check 
box in the Persistent Dimensions area of the Heads-Up Display Settings dialog box and then 
choose OK. Next, choose the Apply and Close buttons from the Application Options dialog 
box to turn off the visibility of the dimension during sketching. 

Saving the Sketch
 Next, you need to save the sketch. As mentioned earlier, you cannot save the sketch in the 

sketching environment. First, you need to exit the sketching environment and then save it.

1. Choose the Finish Sketch button from the Exit panel; the sketching environment is closed 
and you will switch to the Home view of the part modeling environment.

2. Choose the Save tool and save the sketch with the name Tutorial2 at the location given 
below:

 C:\Inventor_2011\c02

3. Choose Close > Close from the Application Menu to close this fi le.

In this tutorial, you will draw the sketch for the model shown in Figure 2-52. The sketch of the 
model is shown in Figure 2-53. Do not dimension the sketch as the dimensions are given only 
for reference.                                                                                 (Expected time: 30 min)

Tutorial 3

Figure 2-53  Sketch for Tutorial 3Figure 2-52  Model for Tutorial 3
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 The following steps are required to complete this tutorial:

a. Start a new metric standard part fi le.
b. Draw the sketch by using the Arc and Line tools, refer to Figure 2-55.
c. Save the sketch with the name Tutorial3 and close the fi le.

Starting a New File
1. Choose the New tool from the Launch panel of the Get Started tab to invoke the New 

File dialog box.

2. Start a new metric standard part fi le by double-clicking on Standard (mm).ipt in the 
Metric tab.

Drawing the Sketch
 The upper arc of the sketch can be drawn by specifying the center point, start point, and 

endpoint of the arc. Therefore, you need to use the Center Point Arc tool to draw this arc.

1. Choose the Arc Three Point tool from Sketch > Draw > Arc drop-down; you are 
prompted to specify the center of the arc. 

2. Enter 0, 15 in the Inventor Precise Input toolbar and press ENTER; you are prompted 
to specify the start point of the arc. 

3. Enter -12,15 in the Inventor Precise Input toolbar and press ENTER.

 Next, you need to defi ne the endpoint of the arc. The arc drawn after you specify the 
endpoint, can be in the clockwise or counterclockwise direction. 

4. Move the mouse from the start point of the arc to a small distance in the counterclockwise 
direction. Now, enter 12,15 as the endpoint in the Inventor Precise Input toolbar and 
press ENTER; the upper arc is drawn.

 Next, you need to draw lines in the sketch.

5. Choose the Line tool from the Draw panel; you are prompted to specify the start 
point of the line. 

 It is evident from Figure 2-53 that the lines start from the endpoints of the arc. You can 
specify the coordinates of the start point of the arc in the Inventor Precise Input toolbar 
or select the start point of the line in the drawing window. 

6. Move the cursor close to the start point of the arc; the yellow circle snaps to the endpoint 
of the arc and turns green. When the yellow circle turns green, it indicates that the cursor 
has snapped to the endpoint of the arc. Press the left mouse button to select this point as 
the start point of the line. 
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 As it is easier to defi ne the points by using relative coordinates, it is recommended that 
you use the Precise Delta button in the Inventor Precise Input toolbar to draw lines. 
Choose the Precise Delta button, if it is not already chosen. 

7. If the Precise Delta button is not chosen automatically, you need to specify the start point 
of the line and then choose this button. Next, press the ESC key to exit the Line tool. Now, 
invoke the Line tool again; a triad is placed at the origin (0,0). Enter -12, 15 as the start 
point of the line in the Inventor Precise Input toolbar. Next, enter -12, 0 as the endpoint 
of the line in the Inventor Precise Input toolbar. 

8. Enter 0, -30  as the second point and 12, 0 as the third point in the Inventor Precise 
Input toolbar. As mentioned earlier, Autodesk Inventor provides you with the option to 
draw tangent or normal arcs while drawing lines. This is done by dragging the cursor 
from the point where you want to start the arc. You can directly draw it within the Line 
tool.

9. Move the cursor close to the endpoint of the last line until the yellow circle snaps to that 
point. When the yellow circle snaps to the endpoint, it turns gray. However, you will not 
be able to view the gray circle because of the triad. Now, press and hold the left mouse 
button and drag the mouse through a small distance in the upward direction. 

 You will notice that four imaginary lines are displayed, showing the four directions in 
which you can draw the arc. 

10. As you need to draw the arc normal to the line, drag the cursor vertically upward in the 
direction of the vertical imaginary line to a small distance and then drag the cursor toward 
the right. While drawing the arc by dragging the cursor, you cannot use the Inventor 
Precise Input toolbar. 

 To specify the endpoint of the arc precisely, you can use the temporary tracking option. 
The temporary tracking option allows you to select a point by using two different points. 
For example, in this case, the right endpoint of the lower arc has to be vertically in the 
same line as that of the right endpoint of the upper arc, and horizontally in the same line 
as that of the start point of the lower arc. Now, assume a vertical imaginary line drawn 
from the endpoint of the upper arc and a horizontal imaginary line drawn from the start 
point of the lower arc. Both these imaginary lines intersect at a point that is essentially the 
endpoint of the lower arc. The temporary tracking option is used to draw these imaginary 
lines and to remove them after the point has been selected.

11. With the left mouse button pressed to defi ne the endpoint of the arc, drag the cursor 
close to the right endpoint of the upper arc; the cursor snaps to the endpoint of the arc 
and turns green. Now, move the cursor vertically downward. 

 You will notice that a vertical imaginary line appears at the right endpoint of the upper 
arc. You do not need to snap to the horizontal point, because this point was automatically 
selected when you started drawing the lower arc. As you move the cursor downward, you 
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will notice a point where both the vertical and horizontal imaginary lines intersect each 
other, see Figure 2-54. This point is the endpoint of the lower arc. The cursor automatically 
snaps to the point where both the imaginary lines intersect. Do not release the left mouse 
button until the entire process is completed.

Note
In Figure 2-54, the major and minor grid lines and triad have not been displayed for a better 
display of the sketch and the imaginary lines.

12. When the cursor snaps to the intersection of the imaginary lines, release the mouse button 
to complete the lower arc.

13. Enter 12,0 as the coordinates of the next point in the Inventor Precise Input toolbar. 

14. For the next point, you can enter coordinates in the Inventor Precise Input toolbar or use 
the temporary tracking option. To use this option, move the cursor close to the endpoint 
of the upper arc. Once the cursor snaps to this point and turns green, move it horizontally 
toward the right. As a result, a horizontal imaginary line is drawn. Using the left mouse 
button, select the point at which the vertical line becomes perpendicular to the horizontal 
imaginary line. This point is the endpoint of the right vertical line.

Note
While using the temporary tracking option to draw lines, you do not need to press the left mouse 
button and drag it. You need to press the left mouse button once to select the endpoint of the line 
after you get the intersection point of the imaginary lines.

Figure 2-54  Use of the temporary tracking option to draw an arc
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15. Complete the sketch by snapping to the 
endpoint of the upper arc as the endpoint 
of the line. Next, right-click to display the 
shortcut menu, and then choose Done from 
it to exit the Line tool.

16. The fi nal sketch for Tutorial 3 is shown in 
Figure 2-55.

Saving the Sketch
1. Choose the Finish Sketch button from the 

Exit panel; the sketching environment is 
closed and you will switch to the Home view 
of the part modeling environment.

2. Choose the Save button and save the sketch with the name Tutorial3 at the location given 
below:

 C:\Inventor_2011\c02

3. Choose Close > Close from the Application Menu to close this fi le.

In this tutorial, you will draw the basic contour of the revolved solid model shown in Figure 2-56. 
The contour that you will draw for creating this revolved solid is shown in Figure 2-57. Do not 
dimension the sketch as the dimensions are given only for reference.  
          (Expected time: 30 min)

Tutorial 4

Figure 2-57  Sketch for the revolved modelFigure 2-56  Revolved model for Tutorial 4

Figure 2-55  Final sketch for Tutorial 3
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 The following steps are required to complete this tutorial:

a. Start a new metric standard part fi le.
b. Invoke the Line tool and draw the sketch by specifying the coordinates of points in the 

Inventor Precise Input toolbar, refer to Figure 2-57.
c. Save the sketch with the name Tutorial4 and close the fi le.

Starting a New File
1. Choose the New tool from the Quick Access Toolbar to display the New File dialog 

box. 

2. Choose the Metric tab to display the standard metric templates. Double-click on 
Standard (mm).ipt to start a new metric part fi le.

Drawing the Sketch
1. Choose the Line tool from the Draw panel; you are prompted to specify the 

start point of the line. Enter 22,0 as the coordinates of the start point in the 
Inventor Precise Input toolbar and press ENTER; you are prompted to specify 
the endpoint of the line. You can specify the coordinates of the next point relative 
to the previous point, as it becomes easier to defi ne points. 

 If the same session of Autodesk Inventor is used, the Precise Delta button is chosen 
automatically in the Inventor Precise Input toolbar. However, if you use a new session, 
you need to choose this button to invoke this toolbar. 

2. Choose the Precise Delta button, if it is not chosen automatically and then press 
the ESC key. Invoke the Line tool and enter 22, 0 as the start point of the line 
in the Inventor Precise Input toolbar. Next, enter the following coordinates of 
the remaining points in the Inventor Precise Input toolbar.

            Point      Coordinates (X, Y)
   2    0,30
   3    -20,0
   4    0,-5
   5    16,0
   6    0,-9
   7    -40,0
   8    0,-6
   9    8,0
   10    0,-6
   11    14,0
   12    0,-4
   13    22,0
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3. Right-click to display the shortcut menu, and then choose Done from it to complete the 
sketch. The sketch should look similar to the one shown in Figure 2-58. For your reference, 
the lines in the sketch are numbered.

 You will create the arcs at the end of lines 4 and 5, 5 and 6, and 8 and 9 by using the Fillet 
tool. This tool draws the arcs at the point of intersection of the lines and removes sharp 
corners.

4. Choose the Fillet tool from Sketch > Draw > Fillet/Chamfer drop-down; the 
2D Fillet dialog box is displayed with some default fi llet radius. Enter 1.5 in 
the Radius edit box of this dialog box. Do not press ENTER.

5. Select line 4 and then line 5, refer to Figure 2-58; a fi llet is created between these lines 
and the radius of the fi llet is displayed in the sketch.

6. Similarly, select lines 5 and 6 and then lines 8 and 9 to create a fi llet between these lines. 
Right-click, and then choose Done from the shortcut menu to exit the Fillet tool after 
creating all fi llets.

 As all lines are fi lleted with the same radius value, the radius of the fi llet is not displayed 
on other fi llets. This completes the sketch. The fi nal sketch for this tutorial after fi lleting is 
shown in Figure 2-59.

Note
In Figures 2-58 and 2-59, the display of axes has been turned off for a better visibility of the 
lines of the sketch.

Figure 2-59  Final sketch after fi lletingFigure 2-58  Sketch after drawing the lines
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Self-Evaluation Test

Saving the Sketch
1. Choose the Finish Sketch button from the Exit panel.

2. Choose the Save button and save this sketch with the name Tutorial4 at the location given 
below:

 C:\Inventor_2011\c02

3. Choose Close > Close from the Application Menu to close this fi le.

Answer the following questions and then compare them to those given at the end of 
this chapter:

1. Most designs created in Autodesk Inventor are a combination of sketched features and 
placed features. (T/F)

2. Whenever you start a new fi le in the Part module, the sketching environment is invoked 
by default. (T/F)

3. You cannot turn off the display of grid lines. (T/F)

4. You cannot draw an arc within the Line tool. (T/F)

5. In Autodesk Inventor, the two types of sketching entities that can be drawn are __________ 
and __________.

6. In the sketching environment, the __________ tool is used to place a sketch point or a 
center point.

7. Filleting is defi ned as the process of __________ the sharp corners and sharp edges of 
models.

8. You can also delete sketched entities by pressing the __________ key.

9. In Autodesk Inventor, rectangles are drawn as the combination of __________ entities.

10. You can undo the last drawn spline segment when you are still inside the spline drawing 
option by choosing __________ from the shortcut menu displayed.
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Answer the following questions:

1. In most designs, generally the fi rst feature or the base feature is the placed feature. 
(T/F)

2. You can invoke the options related to sheet metal parts from the .ipt fi le. (T/F)

3. You can change the current project directory and the project fi les by choosing Projects 
from the Open dialog box. (T/F)

4. You can specify the position of entities dynamically by using the Dynamic Input. (T/F)

5. In Autodesk Inventor, you can save a fi le in the sketching environment. (T/F)

6. In Autodesk Inventor, you can start a new fi le by using the Open dialog box. (T/F) 

7. Which of the following tools in the Tools tab is used to invoke additional toolbars?

  (a) Application Options  (b) Customize
  (c) Document Setting  (d) None of these

8. Which of the following drawing display options is used to interactively zoom in and out 
a drawing?

  (a) Zoom All   (b) Pan
  (c) Zoom   (d) Zoom Window

9. Which of the following keys is used to restore the previous view?

  (a) F5    (b) F6
  (c) F7    (d) F4

10. Which of the following drawing display options prompts you to select an entity whose 
magnifi cation has to be increased?

  (a) Zoom   (b) Pan
  (c) Zoom Selected  (d) None of these

Review Questions
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Exercise 2

Figure 2-63  Sketch for Exercise 2Figure 2-62  Model for Exercise 2

Figure 2-61  Sketch for Exercise 1Figure 2-60  Model for Exercise 1

Exercises

Exercise 1

Draw the basic sketch of the model shown in Figure 2-60. The sketch to be drawn is shown in 
Figure 2-61. Do not dimension it, as the dimensions are given only for reference.
               (Expected time: 30 min)

Draw the basic sketch of the model shown in Figure 2-62. The sketch to be drawn is shown in 
Figure 2-63. Do not dimension it, as the dimensions are given only for reference.
              (Expected time: 45 min)
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Figure 2-65. Do not dimension it, as the dimensions are given only for reference.

              (Expected time: 45 min)

Exercise 3

Figure 2-65  Sketch for Exercise 3Figure 2-64  Model for Exercise 3

Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. F, 5. normal, construction, 6. Point, 7. rounding, 8. DELETE, 9. individual, 
10. Back 


