
Chapter 1

Exploring Maya 
Interface

 Learning Objectives 
After completing this chapter, you will be able to:
• Start Autodesk Maya 2014
• Work with menusets in Autodesk Maya
• Understand various terms related to Maya interface
• Work with tools in Autodesk Maya 2014
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INTRODUCTION TO Autodesk Maya 
Welcome to the world of Autodesk Maya 2014. Maya is a 3D software, developed by Autodesk 
Inc., which enables you to create realistic 3D models and visual effects with much ease. Although 
Maya is quite a vast software to deal with, yet all the major tools and features used in Autodesk 
Maya 2014 have been covered in this book. 

STARTING Autodesk Maya 2014
To start Autodesk Maya 2014, choose All Programs > Autodesk > Autodesk Maya 2014 > 
Autodesk Maya 2014 from the Start menu, refer to Figure 1-1; the default interface of Maya 
will be displayed with its different components.

 Figure 1-1  Starting Autodesk Maya 2014 using the Start menu

Alternatively, you can start Autodesk Maya 2014 by double-clicking on its shortcut icon 
displayed on the desktop of your computer. This icon is automatically created on installing 
Autodesk Maya 2014 on your computer. Double-click on the icon; four windows namely, the 
Output Window, the main Autodesk Maya 2014 interface window, the 1-Minute Startup 
Movies window, and the What’s New Highlight Settings window will be displayed on the 
screen. The Output Window, as shown in Figure 1-2, displays information regarding the 
version of the mental ray renderer that will be used in Autodesk Maya 2014. The 1-Minute 
Startup Movies window, as shown in Figure 1-3, provides access to video tutorials that are 
helpful in learning the basics of Autodesk Maya 2014. By default, all the new tools and icons 
are highlighted in green in Maya 2014. The What’s New Highlight Settings window, as shown 
in Figure 1-4, is used to toggle the visibility of highlights. 
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Figure 1-2  The Output Window

Figure 1-3  The 1-Minute Startup Movies window
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Figure 1-4  The What’s New Highlight Settings window

Note
To view the video tutorials, you need to have Quick Time 7.7 or its later versions installed on 
your system. To play a video tutorial from the 1-Minute Startup Movies window, choose the 
button corresponding to it; the video tutorial will be displayed in a separate window. However, 
if you do not want to play the video tutorials, choose the Close button on the upper right corner 
of the 1-Minute Startup Movies window. In case, you do not want this window to appear 
the next time you start Autodesk Maya 2014, then clear the Show this at startup check box.

Tip: To view the 1-Minute Startup Movies window again, choose Help > 1-Minute 
Startup Movies from the menubar.

Autodesk Maya 2014 SCREEN COMPONENTS
Autodesk Maya interface consists of viewports, title bar, menubar, Status Line, Shelf, Tool Box, 
and so on. All these components will be discussed later in this chapter. When you start 
Autodesk Maya 2014 for the first time, the persp viewport is displayed by default, refer to 
Figure 1-5.

Workspace is the part or the work area where you can create a 3D scene. Workspaces are also 
known as viewports or views. In this textbook, the workspaces will be referred to as viewports. 
Every viewport has a grid placed in the center. The grid acts as a reference that is used in 
aligning the 3D objects or 2D curves. A grid is a pattern of straight lines that intersect with 
each other to form squares. The center of the grid is intersected by two dark lines. The point 
of intersection of these two dark lines is known as the origin. The origin is an arbitrary point, 
which is used to determine the location of the objects. All the three coordinates, X, Y, and Z 
are set at 0 position on the origin. Note that in Maya, the X, Y, and Z axes are displayed in 
red, green, and blue colors, respectively.

Autodesk Maya 2014 is divided into four viewports: top, front, side, and persp. These 
viewports are classified into two categories, orthographic and isometric. The orthographic 
category comprises the top, front, and side viewports and the isometric category consists of 
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the persp viewport. The orthographic viewport displays the 2-dimensional (2D) view of the 
objects created in it, whereas the isometric viewport displays the 3-dimensional (3D) view of 
the objects created. Every viewport can be recognized easily by its name, which is displayed 
at the bottom of each viewport. Figure 1-6 shows the screen displaying various components 
of the Maya interface.

Figure 1-5  The default screen of Autodesk Maya 2014

Figure 1-6  Displaying various screen components of the Maya interface

Every viewport has its own Panel menu that allows you to access the tools related to that 
specific viewport. The Axis Direction Indicator located at the lower left corner of each viewport 
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indicates about the X, Y, and Z axes. Similarly, every viewport in Maya has a default camera 
applied to it through which the viewport scene is visible. The name of the camera is displayed 
at the bottom of each viewport. In other words, the name of the viewport is actually the name 
of the camera of that particular viewport.

The title bar, which lies at the top of the screen, displays the name and version of the software, 
the name of the file, and the location where the file is saved. A Maya file is saved with the .mb 
or .ma extension. The three buttons on the extreme right of title bar are used to minimize, 
maximize, and close the Autodesk Maya 2014 window, respectively. Various screen components 
of the Autodesk Maya 2014 interface are discussed next.

Tip: To toggle between single viewport and four viewport views, move the cursor over one 
of the viewport and press the SPACEBAR key.

Menubar 
The menubar is available just below the title bar. The type of menubar displayed depends 
on menusets. In Maya, there are different menusets namely Animation, Polygons, Surfaces, 
Dynamics, Rendering, and nDynamics. These menusets are displayed in the Menuset 
drop-down list located on the extreme left of the Status Line. On selecting a particular menuset, 
the menus in the menubar change accordingly. However, there are nine common menus in 
Maya that remain constant irrespective of the menuset chosen. Figure 1-7 shows the menubar 
corresponding to the Polygons menuset.

Figure 1-7  Menubar displayed on choosing the Polygons menuset

On invoking a menu from the menubar, a pull-down menu is displayed. On the right of some 
options in these pull-down menus, there are two types of demarcations, arrows and option 
boxes. When you click on an option box, a dialog box will be displayed. You can use this 
dialog box to set the options for that particular tool or menu item. On clicking the arrow, the 
corresponding cascading menu will be displayed.

Tip: You can also select different menusets using the hotkeys that are assigned to them. The default 
hotkeys are F2 (Animation), F3 (Polygons), F4 (Surfaces), F5 (Dynamics), and F6 (Rendering).

Status Line
The Status Line is located below the menubar. The Menuset drop-down list is located at the left 
of the Status Line. You can select menusets from this drop-down list. The Status Line consists 
of different graphical icons. The graphical icons are further grouped and these groups are 
separated by black vertical lines with either a box or an arrow symbol in the middle. These 
vertical lines are known as Show/Hide buttons, refer to Figure 1-8. You can click on a Show/
Hide button with a box symbol to hide particular icons on the Status Line. On doing so, the 
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corresponding icons will hide and the box will change to an arrow symbol. Similarly, if you click 
on a Show/Hide button that has an arrow symbol in the middle, the icons of the corresponding 
group will be displayed. Various groups separated by Show/Hide button are discussed next.

Figure 1-8  The Status Line

Menuset
As mentioned earlier, the Menuset drop-down list in the Status Line 
has different menusets such as Animation, Polygons, Surfaces, 
Dynamics, and nDynamics, as shown in Figure 1-9. The options 
displayed in the menubar depend upon the menuset selected 
from this drop-down list. For example, if you select the Rendering 
menuset from the Menuset drop-down list, all commands related 
to it will be displayed in the menus of the menubar. You can also 
select the menusets from the viewport by pressing and holding 
the h key and then left-clicking in the viewport; a marking menu 
consisting of different menusets will be displayed.

File buttons Group
The options in this group are used to perform different file related operations, refer to 
Figure 1-10. The tools in this group are discussed next.

New scene
The New scene button is used to create a new scene. To create a new scene, choose 
the New scene button from the Status Line; the Warning: Scene Not Saved message 
box will be displayed with the message Save changes to untitled scene?, as shown 

in Figure 1-11. This warning message will only appear if the current scene is not saved. 
Choose the Save button to save the scene. Choose the Don’t Save button to create a new 
scene without saving the changes made in the current scene. Choose the Cancel button 
to cancel the saving procedure.

Figure 1-10  The File buttons Group Figure 1-11  The Warning: Scene Not 
Saved message box

Open scene
The Open scene button is used to open a file created earlier. To open an existing 
file, choose this button from the Status Line; the Open dialog box will be displayed, 

as shown in Figure 1-12. In this dialog box, specify the location of the file that you want 
to open and then choose the Open button; the selected file will open in the Maya interface. 
This dialog box is divided into different sections and some of them are discussed next.

Figure 1-9  The Menuset 
drop-down list



1-8					         Autodesk Maya 2014: A Comprehensive Guide
E

va
lu

at
io

n 
C

op
y.

 D
o 

no
t r

ep
ro

du
ce

. F
or

 in
fo

rm
at

io
n 

vi
si

t w
w

w
.c

ad
ci

m
.c

om

Folder Bookmarks
The bookmarks section is used to access the folders in your computer. You can also 
rearrange the default location of the folders in this section by dragging them up and 
down using the left mouse button.

Set project
This button is used to set a new project by replacing the current project. On choosing this 
button, a new window named Set Project is displayed. You will learn about this window 
later in this book. 

Figure 1-12  The Open dialog box

Save scene
The Save scene button is used to save the current scene. On choosing the Save scene 
button, the Save As dialog box will be displayed. Enter a name for the file in the File 

name text box, specify the location to save the current scene, and then choose the Save As 
button to save the current scene. Maya provides you with various options that can be used 
while saving a file. These options are given on the right side of the dialog box in the Options 
section.

Selection set icons group
The Selection set icons group shown in Figure 1-13 is used to define the selection of objects 
or the components of objects from the viewport. This menu comprises of three buttons that 
are discussed next.

Figure 1-13  The Selection set icons group

Select By Hierarchy And Combinations
The Select By Hierarchy And Combinations button is used to select a group of 
objects in a scene in a hierarchial order. For example, if four objects are combined 
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under a single group, clicking on a single object with this button chosen will select the 
entire group of objects.

Select By Component Type
The Select By Component Type button is used to select the components of an object, 
such as vertices or faces. You can also select the control vertices of the NURBS 

surfaces using this button.

Select By Object Type
The Select By Object Type button is used to select only a single object from a group 
of  objects in a scene. For instance, if four objects are combined under a single group, 

this button will enable you to select only the desired object from the group, and not the 
entire group.

Tip: To switch between the object and component modes of  the selection type, press the F8 key. 

Selection Mask Icons Group
The Selection Masks Icons group comprises of selection filters that help you in selecting 
objects or their components in the viewport. The selection mask helps you decide which 
filters/icons should be displayed in the viewport. The selection masks icons group depends 
on the selection mode button chosen. If the Select By Hierarchy And Combinations button 
is chosen, then the icons under this group will change, as shown in Figure 1-14. These icons 
represent the tools that enable you to select the objects based on their hierarchy. Similarly, on 
choosing the Select By Component Type button and the Select By Object Type button, the 
icons under these groups will change accordingly, and this will enable you to select either the 
entire object, or its components, refer to Figures 1-15 and 1-16. You can select the required 
object from a group by using these icons. The most commonly used group is the icons group 
displayed on choosing the Select By Object Type button. Various buttons in this selection 
masks icons group are discussed next.

Figure 1-14  The Select By Hierarchy And Combinations group 
displayed on choosing the Select By Hierarchy And Combinations button

Figure 1-15  The Select By Component Type group displayed 
on choosing the Select By Component Type button

Figure 1-16  The Select By Object Type group displayed 
on choosing the Select By Object Type button

    
Set the object selection mask

The Set the object selection mask button is used to switch all selection icons on or 
off. To do so, choose the Set the object selection mask button from the Status Line; 

a flyout will be displayed, as shown in Figure 1-17. Choose the All objects on option from 
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the flyout to make all selection icons on or select the All objects off option to switch off 
all selection icons from the menu.

Figure 1-17 Flyout displayed on choosing the 
Set the object selection mask button

Note
If the All objects off option is chosen, you cannot select any object in the viewport. 

Select handle objects
The Select handle objects button allows you to select IK handles and selection 
handles. You will learn more about this tool in the later chapters.

Select joint objects
The Select joint objects button is used to select only the joints of the objects while 
animating or rigging them.

Select curve objects
The Select curve objects button is used to select the NURBS curves, curves on 
surface, and paint effects strokes in the viewport. 

Select surface objects
The Select surface objects button is used to select the NURBS surfaces, poly 
surfaces, planes, and GPU cache in the viewport.

Select deformations objects
The Select deformations objects button is used to select the lattices, clusters, 
nonlinear, and sculpt objects in the viewport.

Select dynamic objects
The Select dynamic objects button is used to select the dynamic objects in the 
viewport. 

Select rendering objects
The Select rendering objects button is used to select the lights, cameras, and 
textures in the viewport.

Select miscellaneous objects
The Select miscellaneous objects button is used to select miscellaneous objects 
such as IK End Effectors, locators, and dimensions in the viewport.
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Lock/Unlock current selection
The Lock/Unlock current selection button is used to lock the tool manipulators 
to the selected object. Select an object in the viewport and choose the Lock/
Unlock current selection button from the Status Line; the tool manipulators will 
be locked to the object and no other object can be selected from the viewport.

Highlight Selection mode
The Highlight Selection mode button is used to turn off the automatic display of 
components.

Snap buttons Group
The Snap buttons group comprises of different snap tools, as shown in Figure 1-18. The snap 
tools are used to snap the selected objects to specific points in a scene. The tools in this group 
are discussed next.

Figure 1-18  The Snap buttons group

Snap to grids
The Snap to grids tool is used to snap an object to the closest grid intersection 
point. For example, to  snap  a  sphere to the closest grid intersection point, choose 
Create > NURBS Primitives > Sphere from the menubar and then click in the 

viewport; a sphere will be created. Choose the Snap to grids tool from the Status Line 
and invoke Move Tool from the Tool Box. Next, press the middle mouse button over the 
sphere and drag it; the sphere will be snapped to the closest grid intersection point, refer 
to Figure 1-19.

Figure 1-19  The sphere snapped to the closest grid intersection point

Snap to curves
The Snap to curves tool is used to snap an object to the curve in the viewport. For 
example, to snap a cube on a curve, choose Create > NURBS Primitives > Cube 
from the menubar and then click in the viewport; a cube will be created. Next, 
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choose Create > EP Curve Tool from the menubar and then create a curve in the top 
viewport. Press ENTER to exit the EP Curve Tool. Next, choose Move Tool from the Tool 
Box and align the cube over the curve. Choose the Snap to curves tool from the Status 
Line. Press the middle mouse button over the cube and drag it; the cube will move over 
the curve while remaining snapped to the curve, refer to Figure 1-20.

Figure 1-20  The cube snapped to the curve

Snap to points
The Snap to points tool is used to snap the selected objects to closest control vertex 
or pivot point. For example, to snap a cube to the vertices of a polygonal plane, 

choose Create > Polygon Primitives > Plane > Option Box from the menubar; the Tool 
Settings (Polygon Plane Tool) window will be displayed. Now, set the Width divisions 
and Height divisions to 10, and then click in the viewport to make a plane. Next, create 
a cube in the viewport, as discussed earlier. Next, select the cube and choose the Snap to 
points tool from the Status Line and drag the cube with the middle mouse button; the 
cube will snap to the closest control vertex of the polygonal plane.

Snap to Projected Center
The Snap to Projected Center tool is used to snap the selected object to 
the center of the other object. For example, to snap a cube to the center 

of a polygonal plane, choose Create > Polygon Primitives > Plane from the menubar 
and drag the cursor; a plane will be created. Next, choose Create > Polygon Primitives > Sphere 
from the menubar; a sphere will be created. Now, select the sphere and choose the Snap 
to Projected Center tool from the Status Line; the sphere will snap to the center of the 
polygonal plane.

Snap to view planes
The Snap to view planes tool is used to snap the selected object to the view plane 
of the viewport.

Tip: You can also use the shortcut keys to perform particular snap functions. For example, 
press x for Snap to grids, c for Snap to curves, and v for the Snap to points tools.

 Make the selected object live
The Make the selected object live tool is used to make the selected surface a live 
object. A live object is used to create objects or curves directly on its surface. For 
example, to snap a cube on the surface of a polygonal sphere, choose Create > 
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Polygon Primitives > Sphere from the menubar and drag the cursor; a sphere will be 
created. To create a cube on the surface of the sphere, choose the Make the selected 
object live tool from the Status Line; the sphere will appear in green wireframe. To do 
so, choose Create > Polygon Primitives > Cube from the menubar and drag the cursor; 
a cube will be created on the surface of the sphere.

History Buttons Group
This group of the Status Line helps you to control various objects. The objects with input 
connections are affected or controlled by other objects, whereas the objects with output 
connections affect or control other objects.

Inputs to the selected object
The Inputs to the selected object tool is used to edit all input connections for the 
selected object such that the selected object gets influenced by another object.

Outputs from the selected object
The Outputs from the selected object tool is used to select and edit the output 
operations of an object.

Construction history on/off
The Construction history on/off tool is used to record the construction history. 
The construction history is used to track the changes made on an object at a later 

stage. Sometimes, the construction history may make a particular file size heavy. To decrease 
the file size, it is recommended to deactivate this tool.

Render Tools Group
This group of the Status Line is used to access all render controls in Maya. The tools in this 
group are discussed next.

Open Render View
The Open Render View tool is used to open the Render View window. 

Render the current frame
The Render the current frame tool is used to render the selected viewport at the 
current frame using the Maya Software renderer. Choose the Render the current 
frame tool from the Status Line; the Render View window will be displayed. The 

Render View window shows the rendered view of the selected scene, refer to Figure 1-21, 
whereas the Output Window will display all the rendering calculations made for rendering 
the active scene, refer to Figure 1-22.
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Figure 1-21  The Render View window

Figure 1-22  The Output Window

IPR render the current frame
The IPR render the current frame tool is used to perform an IPR render. Here, 
IPR stands for Interactive Photorealistic Rendering. This tool helps you to adjust 
the lighting or the shading attributes of the rendered scene and then update it as 

per the requirement. To render the current frame, choose this button from the Status 
Line; the Render View window will be displayed. Now, press the left mouse button and 
drag it in the Render View window to set the selection for IPR rendering. As a result, 
Maya will render the selected part only. In other words, it will help you visualize your 
scene dynamically. Now, if you make changes in the color or lightning attribute of the 
scene using the Attribute Editor, the selected part will be rendered automatically.

Display render settings 
On choosing the Display Render Settings  tool, the Render Settings window will 
be displayed, as shown in Figure 1-23. This window comprises of all controls 
needed for rendering. These controls help you adjust the render settings such as 

resolution, file options, ray tracing quality, and so on.
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Input Line Operations Group
This group in the Status Line helps you quickly select, 
rename, and transform the objects that are created in 
the viewport. Some of the options in the Name Selection 
field are in hidden modes. To view them, move the 
cursor over the arrow on the left of the input field and 
then press and hold the left mouse button on it; a flyout 
will be displayed. Now, select the required option from 
the flyout; the corresponding mode will be displayed. 
By default, the Absolute transform mode is displayed 
in the Status Line. All these modes are discussed next.

Absolute transform
The Absolute transform area is used to move, rotate, 
or scale a selected object in the viewport. To do so, 
invoke the required transformation tool from the 
Tool Box and enter values in the X, Y and Z edit 
boxes in the Absolute transform area, as shown in 
Figure 1-24. Now, press ENTER; the selected object 
will be moved, rotated, and scaled according to the 
values entered in the edit boxes. 

Figure 1-24  The Absolute transform area

Note
The Absolute transform area takes the center of the viewport as a reference for transforming an 
object.

Relative transform
The Relative transform area is also used to scale, rotate, or move a selected object in the 
viewport, refer to Figure 1-25. This area is similar to the Absolute transform area with the 
only difference that the Relative transform area takes the current position of the object 
as a reference point for transforming an object.

Figure 1-25  The Relative transform area

Rename
The Rename area is used to change the name of a selected object. To rename an object, 
select the object from the viewport whose name you want to change; the default name 
of the selected object will be displayed in the text box in the Rename area, as shown in 
Figure 1-26. Enter a new name for the object in the edit box and press ENTER. 

   

Figure 1-26 The Rename area

Figure 1-23  The Render Settings 
window
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Select by name
You can select an object in the viewport by entering its name in the text box in the Select 
by name area, refer to Figure 1-27. 

Figure 1-27  The Select by name area

Sidebar Buttons Group
This is the last part of the Status Line. The Sidebar buttons control the properties of the 
objects created in the viewport and the tools required for working with the objects. This group 
consists of four buttons that are discussed next.

Show or hide the Modeling Toolkit
The Show or hide the Modeling Toolkit button is used to open the Modeling 
Toolkit window, as shown in Figure 1-28. The Modeling Toolkit is used to 

perform multiple modeling specific operations from the single window. The tools in the 
Modeling Toolkit window are discussed in later chapters.

Show/Hide Attribute Editor
The Show/Hide Attribute Editor button is used to toggle the visibility of the Attribute 
Editor, refer to Figure 1-29. The Attribute Editor is used to control different 

properties of the selected object. 

Show/Hide Tool Settings
The Show/Hide Tool Settings button is used to display the options for selected tool 
in the Tool Settings window. On choosing this button, the Tool Settings window of 

the selected tool will be displayed on the left of the viewport, adjacent to the Tool Box. 
For example, if you have chosen Move Tool from the Tool Box, then you can control its 
settings by using the Tool Settings (Move Tool) window, as shown in Figure 1-30. 

Show/Hide Channel Box
The Show/Hide Channel Box button is used to toggle the visibility of the Channel 
Box / Layer Editor. This button is similar to the Show or hide the Attribute Editor 

button. On choosing this button, the Channel Box / Layer Editor will be displayed on 
the right of the viewport, as shown in Figure 1-31. The Channel Box is used to control 
the transformation and the geometrical structure of the selected object. The Layer Editor is 
used to organize the objects in a scene when there are many objects in the viewport. 
Multiple objects can be arranged in the layer editor to simplify the scene. 
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Figure 1-29  The Attribute EditorFigure 1-28  The Modeling Toolkit 
window

Figure 1-30  Partial view of the Tool Settings 
(Move Tool) window

Figure 1-31  The Channel Box /
Layer Editor
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Note
By default, the keyable attributes of selected object(s) are displayed in the Channel Box. To add 
more attributes to it, choose Window > General Editors > Channel Control from the menubar; 
the Channel Control window will be displayed. In this window, three areas will be displayed 
in the Keyable tab: Keyable, Nonkeyable Hidden, and Nonkeyable. To add attributes, select 
them from the Nonkeyable Hidden area and then choose the << Move button. Next, choose 
the Close button.  

Shelf 
The Shelf is located below the Status Line, as shown in Figure 1-32. The Shelf is divided into 
two parts. The upper part in the Shelf consists of different Shelf tabs and lower part displays 
the icons of different tools. The icons displayed in this area depend on the tab chosen, refer 
to Figure 1-32. 

Figure 1-32  The Shelf

You can also customize the Shelf as per your requirement. To do so, press and hold the left 
mouse button over the Menu of items to modify the Shelf button, refer to Figure 1-33; a flyout 
will be displayed, as shown in Figure 1-33. Various options in this flyout are discussed next.

Figure 1-33  Flyout displayed on choosing the Menu of 
items to modify the Shelf button

Shelf Tabs
The Shelf Tabs option is used to toggle the visibility of the Shelf tabs. On choosing this option, 
the Shelfs tabs will disappear, and only the tool icons corresponding to the selected tab will 
be visible. 

Shelf Editor
The Shelf Editor option is used to create a Shelf and edit the properties of an existing Shelf. 
When this option is chosen, the Shelf Editor will be displayed in the viewport, as shown in 
Figure 1-34. Alternatively, you can choose Window > Settings/Preferences > Shelf Editor 
from the menubar to display the Shelf Editor. In the Shelf Editor, you can change the name 
and position of shelves and their contents. You can also create a new shelf and its contents 
using the Shelf Editor.
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Figure 1-34  The Shelf Editor

Navigate Shelves
The Navigate Shelves option is used to choose the previous or next Shelf of the 
currently chosen Shelf. On choosing this option, a cascading menu will be displayed, as shown 
in Figure 1-35. The options in the cascading menu are discussed next.

Figure 1-35  Cascading menu displayed on choosing the 
Navigate Shelves option

Previous Shelf
The Previous Shelf option is used to choose the Shelf that comes before the currently 
chosen Shelf. For example, choose the Rendering tab; the rendering specific icons will be 
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displayed. Next, press and hold the left mouse button over the Menu of items to modify 
the Shelf option; a flyout will be displayed. Choose Navigate Shelves from the flyout; 
a cascading menu is displayed. From the cascading menu, choose Previous Shelf; the 
Dynamics tab is chosen displaying the dynamic specific icons.

Next Shelf
The Next Shelf option is used to choose the shelf that comes after the currently chosen 
Shelf. 

Jump to Shelf
The Jump to Shelf option is used to choose the specific Shelf by 
entering its name. On choosing this option, the Jump to Shelf 
dialog box will be displayed, as shown in Figure 1-36. Enter the 
name of the shelf in the Shelf Name text box and choose the 
OK button; the Shelf tab with icons specific to the corresponding 
shelf are displayed. 

New Shelf
The New Shelf option is used to add a new Shelf tab to the existing Shelf. On choosing this 
option, the Create New Shelf dialog box will be displayed, as shown in Figure 1-37. Enter a 
name for the new Shelf and choose the OK button; a new Shelf will be created, as shown in 
Figure 1-38. For adding different tools in the tools area corresponding to the new Shelf created, 
press and hold CTRL+SHIFT and then select the desired tools from the pull-down menus.

Figure 1-37  The Create New Shelf 
dialog box

Figure 1-38  A new Shelf added

Delete Shelf
The Delete Shelf option is used to delete a shelf. On choosing this option, the Confirm 
message box will be displayed, as shown in Figure 1-39. Choose the OK button to delete the 
selected Shelf.

Figure 1-39  The Confirm message box

Figure 1-36  The Jump 
to Shelf dialog box
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Load Shelf
The Load Shelf option is used to load the shelf that was saved previously. When this option 
is chosen, the Open dialog box will be displayed. You can choose the previously saved shelf 
from this dialog box; the desired Shelf tab will be displayed in the shelf. 

Save all Shelves
The Save all Shelves option is used to save the shelves, so that you can use them later while 
working in Maya. 

Tool Box
The Tool Box is located on the left side of the workspace. It comprises of the most commonly 
used tools in Maya. In addition to the commonly used tools, the Tool Box has several other 
options or commands that help you change the layout of the interface. Various tools in the 
Tool Box are discussed next.

Select Tool
The Select Tool is used to select the objects created in the viewport. To select an object, 
invoke the Select Tool from the Tool Box and click on an object in the viewport; 
the object will be selected. On invoking this tool, the manipulators will not be activated. 

Lasso Tool
The Lasso Tool is used to select an object by using a free hand marquee selection. 
This tool is very much similar to the Select Tool. To select an object, invoke the 
Lasso Tool; the cursor will change to a rope knot. Next, press and hold the left mouse 

button and drag the cursor in the viewport to create a selection area around the object. Then, 
release the left mouse button; the object inside the selection area will be selected. To adjust 
the properties of the Lasso Tool, make sure that the Lasso Tool is invoked, and then choose 
the Show/Hide Tool Settings button from the Status Line; the Tool Settings (Lasso Tool) 
window will be displayed. Adjust the Lasso Tool properties from the Tool Settings (Lasso 
Tool) window as per your requirement.

Paint Selection Tool 
The Paint Selection Tool is used to select various components of an object. To select 
various components of an object, invoke the Select Tool from the Tool Box and select 
an object in the viewport. Next, press and hold the right mouse button over the selected 

object; a marking menu will be displayed. Choose Vertex from the marking menu to make 
the vertex selection mode active. Now, choose the Paint Selection Tool from the Tool Box; 
the cursor will change to the paint brush. Next, press and hold the left mouse button and drag 
the cursor over the object to select the desired vertices. To go back to the object mode, press 
and hold the right mouse button over the selected object; a marking menu will be displayed. 
Choose Object Mode from the marking menu to make the vertex selection mode inactive.

You can also increase the size of the Paint Selection Tool cursor. To do so, press and hold the 
B key on the keyboard. Next, press and hold the middle mouse button in the viewport and 
drag the cursor to adjust the size of the brush.
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Move Tool
The Move Tool is used to move an object from one place to another in the viewport. 
To do so, invoke Move Tool from the Tool Box; the cursor will change to an arrow 
with a box at its tip. Select the object in the workspace that you want to move. You 

can move the selected object in the X, Y, and Z directions by using the handles/manipulators over 
the object. You can also adjust the properties of the Move Tool by choosing the Show/Hide 
Tool Settings button from the Status Line or by double-clicking on the Move Tool itself. To 
use the Move Tool, you need to create an object in the viewport. To do so, create a sphere by 
choosing Create > Polygon Primitives > Sphere from the menubar; the text ‘Drag on the 
grid’ will be displayed in the viewport. Next, drag the cursor from one place to the other or 
click anywhere in the viewport; a sphere will be created. Now, invoke the Move Tool from the 
Tool Box and select the object created by clicking on it; the Move Tool manipulator will be 
displayed on the selected object with three color handles, as shown in Figure 1-40. These three 
color handles are used to move the object in the X, Y, or Z direction. The colors of the handles 
represent three axes; red represents the X-axis, green represents the Y-axis, and blue 
represents the Z-axis. At the intersection point of these handles, a box will be displayed that 
can be used to move the object proportionately in all the three directions. Press and hold the 
left mouse button over the box and drag the cursor to move the object freely in the viewport. 
To adjust the default settings of the Move Tool, double-click on it in the Tool Box; the Tool 
Settings (Move Tool) window will be displayed, as shown in Figure 1-41. Change the settings 
as per your requirement in this window. 

If the manipulator is not displayed on the object, then you need to set the pivot point of that 
object. To do so, make sure that the Move Tool is invoked and then press the INSERT key; 
the pivot point will be displayed in the viewport, as shown in Figure 1-42. Move the pivot 
point to adjust its position. Alternatively, choose Modify > Center Pivot from the menubar; 
the pivot point will be adjusted to the center of the object. You can also adjust the pivot point 
by pressing and holding the d key and moving the manipulator.

Figure 1-40  The Move Tool manipulator
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Figure 1-41  Partial view of the Tool Settings (Move Tool) window

Figure 1-42  The pivot point

Note
A pivot is a point in 3D space that is used as a reference point for the transformation of objects.

Rotate Tool
The Rotate Tool is used to rotate an object along the X, Y, or Z axis. To rotate an object 
in the viewport, select the object and invoke the Rotate Tool from the Tool Box; the 

Rotate Tool manipulator will be displayed on the object, as shown in Figure 1-43. The Rotate 
Tool manipulator consists of three colored rings. The red ring represents the X axis, whereas 
the green and blue rings represent the Y and Z axes, respectively. Moreover, the yellow ring 
around the selected object helps you rotate the selected object in the view axis. On selecting a 
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particular ring, its color changes to yellow. You can change the default settings of the Rotate 
Tool by double-clicking on it in the Tool Box. On doing so, the Tool Settings (Rotate Tool) 
window will be displayed, as shown in Figure 1-44. This window contains various options for 
rotation. You can change the settings in this window as required.

Figure 1-43  The Rotate Tool 
manipulator

Figure 1-44  Partial view of the Tool Settings (Rotate 
Tool) window

Scale Tool
The Scale Tool is used to scale an

Figure 1-45  The Scale Tool manipulator

 
object along the X, Y, or Z-axis. To scale an 

object in the viewport, select the object and invoke 
Scale Tool from the Tool Box; Scale Tool 
manipulator will be displayed on the object, as 
shown in Figure 1-45. 

The Scale Tool manipulator consists of three 
boxes. The red box represents the X axis, 
whereas the green and blue boxes represent the 
Y and Z axes, respectively. Moreover, the yellow colored box in the center lets you scale the 
selected object uniformly in all axes. On selecting any one of these colored scale boxes, the 
default color of the box changes to yellow. You can also adjust the default settings of Scale 
Tool by double-clicking on it in the Tool Box. On doing so, the Tool Settings (Scale Tool) 
window will be displayed, as shown in Figure 1-46. Make the required changes in the Tool 
Settings (Scale Tool) window to adjust the basic attributes of Scale Tool.
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Figure 1-46  The partial view of the Tool Settings (Scale 
Tool) window

Note
While rotating, moving, or scaling an object, different 
colored handles are displayed. These  handles indicate 
different axes. You can use this color scheme while 
working with three transform tools as well. The red, 
green, and blue colors represent the X, Y, and Z axes, 
respectively.

Last Tool Used
The Last Tool Used tool is used to invoke the last 
used or the currently selected tool. This tool 
displays the icon of the last used tool or currently 

active tool.

Quick Layout Buttons
Using the buttons in the Quick Layout buttons area, refer 
to Figure 1-6, you can the toggle the display of layouts 
as required. You can also change the display of layout 
buttons. To do so, right-click on one of the Quick Layout 
buttons; a shortcut menu with various layout options will 
be displayed, as shown in Figure 1-47. Next, choose any 
of the layout from the shortcut menu as per your need; 
the current layout will be replaced by the chosen layout. 
Using these buttons, you can also edit the current layout. 
To do so, right-click on a Quick Layout buttons; a shortcut 
menu will be displayed. Choose Edit Layouts from the 
shortcut menu; the Panels window will be displayed, as 
shown in Figure 1-48.

Figure 1-47  Shortcut menu displayed 
on right-clicking on Quick Layout 
button
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Figure 1-48  The Panels window

Time Slider and Range Slider
The Time Slider and the Range Slider, as shown in Figure 1-49, are located at the bottom of 
the viewport. These two sliders are used to control the frames in animation. The Time Slider 
comprises of the frames that are used for animation. There is an input box on the Time Slider 
called Set the current time, which indicates the current frame of animation. The keys in the 
Time Slider are displayed as red lines. 

Figure 1-49  The Time Slider and the Range Slider 

The Time Slider displays the range of frames available in your animation. In the Time Slider, 
the grey box, known as scrub bar, is used to move back and forth in the active range of frames 
available for animation. The Playback Controls at the extreme right of the current frame help you 
to play and stop the animation. The  Range Slider located below the Time Slider is used to adjust 
the range of animation playback. The Range Slider shows the start and end time of the active 
animation. The edit boxes both on the left and right of the Range Slider direct you to the start 
and end frames of the selected range. The length of the Range Slider can be altered using these 
edit boxes. At the right of the Set the end time of the animation input box is the Set the active 
animation layer button. This feature gives you access to all the options needed to create and 
manipulate the animation layers. This option helps you to blend multiple animations in a scene.
The Set the current character set is located on the right of the Range Slider. It is used to gain 
automatic control over the character animated object. There are two buttons on the extreme 
right of the Range Slider: Auto keyframe toggle and Animation preferences. These buttons 
are discussed next.



Exploring Maya Interface		         1-27

E
va

lu
at

io
n 

C
op

y.
 D

o 
no

t r
ep

ro
du

ce
. F

or
 in

fo
rm

at
io

n 
vi

si
t w

w
w

.c
ad

ci
m

.c
om

Tip: You can also set the keys for animation by choosing Animate > Set key from the 
menubar or by pressing the ‘s’ key.

Auto keyframe toggle
The Auto keyframe toggle button is used to set the keyframes. This button sets the 
keyframe automatically whenever an animated value is changed. Its color turns red 
when it is activated.

Animation preferences button
The Animation preferences button is used to modify the animation controls. On 
choosing this button, the Preferences dialog box will be displayed, as shown in 

Figure 1-50. In the Preferences dialog box, the Time Slider option is selected by default in 
the Categories area. You can set the animation controls in the Time Slider and Playback area 
of the Preferences window. Choose the Save button to save the changes and close the dialog 
box.

Figure 1-50  The Preferences dialog box

Command Line
The Command Line is located below the Range Slider. It works in Maya interface by using the 
MEL script or the Python script. The MEL and Python are the scripting languages used in 
Maya. Choose the MEL button to switch between the two scripts. The MEL button is located 
above the Help Line.

Note
MEL stands for MAYA Embedded Language. The MEL command is a group of text strings 
that are used to perform various functions in Maya.
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The Command Line also displays messages from the program in a grey box on the right. At 
the extreme right of the Command Line, there is an icon for the Script Editor. The Script 
Editor is used to enter complex and complicated MEL and Python scripts into the scene.

Help Line
The Help Line is located at the bottom of the Command Line. It provides a brief description 
about the selected tool or the active area in the Maya interface. 

Panel Menu
The Panel menu is available in every viewport, as shown in Figure 1-51. The commands or 
options in the Panel menu controls all the actions performed in the workspace. The Panel 
menu comprises of six menus, which are discussed next.

Figure 1-51  The Panel menu

View
The View menu is used to view the object in the viewport from different angles using 
different camera views.

Shading
The Shading menu is used to view the object in various shading modes such as Wireframe, 
Smooth Shade All, Flat Shade All, X-Ray, and so on. You can also use the Wireframe on 
Shaded option in this menu for working comfortably in the shaded mode.

Lighting
The Lighting menu helps you use different presets of lights that help in illuminating objects 
in the viewport.
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Show
The Show menu is used to hide or unhide a particular group of objects in the viewport.

Renderer
The Renderer menu is used to set the quality of rendering in the viewport. You can also set 
the color texture resolution and the bump texture resolution for high quality rendering using 
the options in this menu.

Panels
The Panels menu is used to switch the active viewport to a different view.

Panel Toolbar
The Panel toolbar, as shown in Figure 1-52, is located just below the Panel menu 
of all viewports. This toolbar consists of the most commonly used tools present in the Panel 
menu. These tools are discussed next.

Figure 1-52  The Panel toolbar

Select camera
The Select camera tool is used to select the active camera in 
the selected viewport. You can also select the current camera in 
a scene by choosing View > Select Camera from the Panel 
menu. To switch between different camera views, right-click 
on the Select camera tool; a shortcut menu will be displayed, 
as shown in Figure 1-53. Now, you can switch to the desired 
camera views by choosing the corresponding option from the 
shortcut menu.

Camera attributes
The Camera attributes tool is used to display the attributes of 
the active camera in the Attribute Editor. The attributes are 
displayed on the right of the viewport in the Attribute Editor. You can also view the attributes 
by choosing View > Camera Attribute Editor from the Panel menu.

Figure 1-53  The shortcut menu 
displayed on right-clicking on the 
Select Camera tool
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Bookmarks
The Bookmarks tool is used to set the current view as a bookmark. To set a bookmark, you 
can set a view in the viewport and then invoke the Bookmarks tool; the set view is bookmarked 
for further reference. You can also edit an existing bookmark. To do so, press and hold the 
right mouse button over the tool; a shortcut menu with a list of bookmarks created will be 
displayed. Choose the Edit 2D Bookmarks option from this shortcut menu. On doing so, 
the Bookmark Editor (persp) dialog box will be displayed, as shown in Figure 1-54. You can 
change the name and other attributes of the selected bookmark from this dialog box.

Figure 1-54  The Bookmark Editor (persp) dialog box

Image Plane
The Image Plane tool is used to import an image to the active viewport. On choosing the 
Image Plane tool, the Open dialog box will be displayed. In the Open dialog box, choose 
the image that you want to insert in the active viewport; the image plane will be inserted in 
the viewport. You can also set the image to the active viewport by choosing View > Image 
Plane > Import Image from the Panel menu.

2D Pan/Zoom
The 2D Pan/Zoom  tool is used to toggle the 2D pan/zoom mode on or off.

Grease Pencil
The Grease Pencil tool is used to draw 2D sketches in the viewport. On invoking this tool, the 
Grease Pencil window will be displayed, as shown in Figure 1-55. You can also invoke this tool 
by choosing View > Camera Tools > Grease Pencil Tool from the Panel menu.

Figure 1-55  The Grease Pencil window
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Grid
The Grid  tool is used to toggle the visibility of the grid in the viewport. You can also invoke 
this tool by choosing Show > Grid from the Panel menu. In addition, you can set the attributes 
for the grid in the viewport by using this tool. To set the grid attributes, press and hold the 
right mouse button on the Grid tool in the Panel toolbar; a flyout will be displayed. Choose 
Grid Options from the flyout; the Grid Options dialog box will be displayed, as shown in 
Figure 1-56. Next, you can set the grid attributes in this dialog box as per your requirement.

Figure 1-56  The Grid Options dialog box

Film gate
The Film gate tool is used to toggle the visibility of Film Gate border on or off in the active 
viewport. You can also choose View > Camera Settings > Film gate from the Panel menu to 
display the Film gate border in the active viewport. 

Resolution gate
The Resolution gate tool is used to toggle the display of the Resolution gate border on or off 
in the active viewport. The resolution gate sets the area in the viewport that will be rendered. 
You can also choose View > Camera Settings > Resolution gate from the Panel menu to set 
the resolution gate in the active viewport.

Gate mask
The Gate mask tool is used to turn on the display of the Gate mask border. It changes the 
color and opacity of the area that lies outside the Film gate or the Resolution gate. The gate 
mask will only work when you have the Film gate or the Resolution gate applied to the active 
viewport. You can also choose View > Camera Settings > Gate mask from the Panel menu 
to display the gate mask in the active viewport.
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Field chart
The Field chart tool is used to turn on the display of the field chart border. On choosing 
the Field chart tool, a grid is displayed, representing twelve standard cell animation field 
sizes. The Field chart tool should be used only when the render resolution is set to NTSC 
dimensions. You can also invoke this tool by choosing View > Camera Settings > Field chart 
from the Panel menu. 

Safe action
The Safe action tool is used to turn on the display of the Safe action border. It is used to 
set the region in the active viewport for TV production. You can also invoke this tool by 
choosing View > Camera Settings > Safe action from the Panel menu.

Safe title
The Safe title tool is used to turn on the display of the safe title border. It is also used to set 
the region for TV production in the active viewport. This tool should be used only when the 
render resolution is set to NTSC or PAL dimensions. You can also invoke this tool by choosing 
View > Camera Settings > Safe title from the Panel menu. 

Wireframe
The Wireframe tool is used to toggle the wireframe display on or off. You can also choose 
Shading > Wireframe from the Panel menu to switch to the wireframe mode. Alternatively, 
press 4 from the keyboard to turn on the Wireframe mode.

Smooth shade all
The Smooth shade all tool is used to set the display to smooth shade. You can also choose 
Shading > Smooth shade all from the Panel menu to switch to smooth shade mode. 
Alternatively, press 5 from the keyboard to turn on the Smooth shade all mode.

Wireframe on shaded
The Wireframe on shaded tool is used to draw wireframes over the smooth shaded objects. You 
can also invoke this tool by choosing Shading > Wireframe on shaded from the Panel menu. 

Textured
The Textured tool is used to set the hardware texturing display of the objects in the viewport. 
Alternatively, press 6 from the keyboard to switch to the textured mode.

Use all lights
The Use all lights tool is used to illuminate objects by using all lights in the viewport. 
Alternatively, choose Lighting > Use all lights from the Panel menu or press 7.

Shadows
The Shadows tool is used to display the hardware shadow maps. Alternatively, choose 
Lighting > Shadows from the Panel menu. This tool is only activated when the Use All Lights 
tool is selected in the Panel menu.
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Toggle Viewport Renderer
The Toggle Viewport Renderer tool is used to switch between the Viewport 2.0, the High 
Quality Renderer, and Default Quality Rendering in the active viewport itself. On choosing 
this button, the objects in the viewport will show all the post render effects in the active 
viewport itself. 

Screen space ambient occlusion
The Screen space ambient occlusion tool is used to toggle the display of the ambient occlusion 
in the viewport. This tool is enabled only when Viewport 2.0 is active. 

Motion blur
The Motion blur tool is used to toggle the display of motion blur in the viewport itself. This 
tool is enabled only when Viewport 2.0 is active.

Multisample anti-aliasing
The Multisample anti-aliasing tool is used to toggle the display of multisample anti-aliasing 
in the viewport itself. This tool is enabled only when Viewport 2.0 is active.

Depth of Field
The Depth of Field tool is used to toggle the display of depth of field in the viewport itself. 
This tool is enabled only when Viewport 2.0 is active.

Isolate select
The Isolate select tool is used to display only the selected object in the viewport. To do so, 
select an object in the viewport and choose the Isolate select button from the Panel toolbar. 
Alternatively, choose Show > Isolate Select from the Panel menu or press SHIFT + I.

XRay
The XRay tool is used to make the objects semi-transparent in the viewport. You can also 
choose Shading > X-Ray from the Panel menu to switch to the XRay mode.

XRay active components
The XRay active components tool is used to display the active components over the top 
of other shaded objects. You can also invoke this tool by choosing Shading > XRay active 
components from the Panel menu.

XRay joints
The XRay joints tool is used to display the skeleton joints over the top of other objects in 
the shaded mode. You can also choose this tool by choosing Shading > XRay joints from 
the Panel menu.

Note
Your system should have a good quality graphic card to support high quality settings.
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Channel Box / Layer Editor
The Channel Box and the Layer Editor are used to edit 
the attributes of an object. The Channel Box consists 
of all object attributes used for editing, and the Layer 
Editor is used for creating layers for objects in the scene. 
To display the Channel Box / Layer Editor, choose 
Display > UI Elements > Channel Box / Layer Editor from 
the menubar. Alternatively, press the CTRL +A  keys to open 
the Channel Box / Layer Editor, if it is not already displayed. 
Select an object; the attributes of the selected object will be 
displayed in the Channel Box / Layer Editor, refer to Figure 
1-57. The Channel Box is further divided into three parts, 
which are discussed next.

Transform node
The Transform node contains the transformation attributes 
of the selected object. Select an object from the viewport; 
the Transform node will become active, refer to Figure 1-57. 
Enter the transform values in different transform param-
eters to transform the object in the viewport. Alternatively, click on an attribute name in the 
Transform node; the background of the attribute will change to blue color. Now, move the 
cursor to the viewport, press and hold the middle mouse button and drag it to make changes 
in the parameters of the selected attribute. You can also adjust the values of more than one 
attribute at a time. To do so, press and hold the SHIFT key and select the attributes that you 
want to adjust and then place the cursor in the viewport. Now, press and hold the middle mouse 
button and drag the cursor to make changes in the selected attributes. Choose the Visibility 
attribute to set the visibility of the object. Enter 0 in the Visibility edit box to make the visibility 
of the selected object off, and enter 1 in the Visibility edit box to set the visibility on.

SHAPES node
The SHAPES node provides a brief information about an object. It displays the shape name 
of the selected object, refer to Figure 1-57. For example, when you create a NURBS sphere in 
the viewport, it is named as nurbsSphereShape1. Here, NURBS indicates that the object has 
been created using the NURBS primitives; Sphere indicates that a sphere has been created; 
and Shape1 indicates that this is the first sphere shape created in the viewport.

INPUTS node
The INPUTS node is used to modify the geometric structure of an object. To do so, create 
a sphere in the viewport and make sure that it is selected in the viewport. Next, select the 
makeNurbSphere1 in the INPUTS node of the Channel Box; the geometric attributes of 
the sphere will be displayed, refer to Figure 1-57. Now, you can adjust the geometric values 
of the sphere as required.

The Layer Editor is located below the Channel Box. To create a new layer in the Layer Editor, 
choose Layers > Create Empty Layer from the Layer Editor, as shown in Figure 1-58; a new 
layer will be created. To add an object to the layer, select the object in the viewport and then 

Figure 1-57  The Channel Box /
Layer Editor
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press and hold the right mouse button over the empty layer; a flyout will be displayed. Choose 
Add Selected Objects from the flyout; the selected object will be added to the layer. The 
Layer Editor is mainly used when there are multiple objects in a scene. You can also change 
the name and color of layers by using the Layer Editor. To do so, double-click on the name 
of a layer; the Edit Layer dialog box will be displayed, as shown in Figure 1-59. Enter the 
name of the layer in the Name text box. You can select the display option of the object from 
the Display type drop-down list. If you select the Normal option from this list, the object will 
be displayed in its object mode and will be selectable. If you select the Template option from 
the drop-down list, the object will be displayed in the wireframe mode and the object will not 
be selectable. Similarly, if you select the Reference option, the object will be displayed in the 
shaded mode and will not be selectable. You can also set the visibility of an object by selecting 
the Visible check box. The Color swatches located at the bottom of the dialog box enables 
you to select a color for the layer to give it a distinct identity as compared to other layers.

Figure 1-58  Creating a new layer 
in the Layer Editor

Figure 1-59  The Edit Layer dialog box

Attribute Editor
The Attribute Editor provides information about various attributes of a selected object, tool, 
or the material applied to the selected object. It is also used to make changes in the attributes 
of the selected object. Choose Display > UI Elements > Attribute Editor from the menubar; 
the Attribute Editor will be displayed on the right of the viewport, refer to Figure 1-60. The 
Attribute Editor comprises of a number of attribute tabs that help you modify an object.

HOTKEYS
In Maya 2014, you can create your own shortcut keys or even change default shortcuts. To 
do so, choose Window > Settings/Preferences > Hotkey Editor from the menubar; the 
Hotkey Editor will be displayed, as shown in Figure 1-61. Choose the required options from 
the Categories and Commands lists to assign a shortcut key. Choose the List All button in 
the Hotkey Editor to access all mapped and unmapped keys; the List Hotkeys window will 
be displayed, as shown in Figure 1-62. At the lower part of the Hotkey Editor, you can enter 
a brief description of all commands or shortcuts that you have created. 
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Figure 1-60  The Attribute Editor

Figure 1-61  The Hotkey Editor
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Figure 1-62  The List Hotkeys window

HOTBOX
Hotbox, as shown in Figure 1-63, helps you access menu items in a viewport. The Hotbox is 
very useful, when you work in the expert mode or the full screen mode. It helps you access 
the menu items and tools by using cursor in the workspace. To access a command, press and 
hold the SPACEBAR key; the Hotbox will be displayed. Now, you can choose the option that 
you need to work from the Hotbox. The Hotbox is divided into five distinct zones, East, West, 
North, South, and Center zone, refer to Figure 1-63.

Figure 1-63  The Hotbox
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Note
You can turn off various UI elements in the Maya interface to get more space and then use 
the Hotbox to access various commands and tools. But you should do it only after you have 
established a workflow for yourself. In the beginning, you should use the menubar at the top 
of the screen instead of using the Hotbox, as it reduces the possibility of confusion in finding a 
command at a later stage.

OUTLINER
The Outliner window is used to display all objects of a scene in a hierarchical manner, as shown 
in Figure 1-64. An object in the scene can be selected by simply clicking on its name in the 
Outliner window. In Outliner window, the objects are placed in order of their creation in the 
viewport. For example, if you create a cube in the viewport followed by a sphere and a cylinder, 
then all these objects will be placed in a sequential manner in the Outliner window, which 
means the object (cube) created first will be placed first and the object created last (cylinder) 
will be placed at the last. To organize the sequence manually, choose the MMB and then drag 
and drop one object below another object. To rename an object, double-click on the name of 
the object. At the top of the Outliner window, there is an edit box known as the Text Filter 
Box. You can use this box to select objects with a particular name. For example, enter *front* 
in the box and press ENTER; all objects having the word ‘front’ in their name will be selected 
in the viewport. By default, there are four cameras in the Outliner window that represent 
four default viewports in Maya. As discussed earlier, everything that you see in the viewport is 
seen through the camera view. These cameras are visible in the Outliner window by default. 
Each object in the Outliner window has an icon of its own. When you double-click on any of 
these icons, the Attribute Editor will be displayed, where you can change the properties of 
various objects.

Figure 1-64  Objects displayed in the Outliner  
window

MARKING MENUS
Marking menus are similar to shortcut menus that consist of almost all tools required to perform 
an operation on an object. There are three types of marking menus in Maya. The first type 
of marking menu is used to create default objects in the viewport. To create a default object, 
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press and hold the SHIFT key and then right-click anywhere in the viewport; a marking menu 
will be displayed, as shown in Figure 1-65. In this marking menu, choose the object that you 
want to create. 

Figure 1-65  Marking menu displaying options 
used for creating default objects

The second type of marking menu is used to switch amongst various components of an 
object such as vertices, faces, edges, and so on. To invoke this marking menu, select an 
object and right-click; the marking menu will be displayed, as shown in Figure 1-66. Now, 
you can select  the desired component of the selected object. This marking menu can also be used  to 
add texture to an object. To do so, choose the Assign New Material option from this marking menu; 
the Assign New Material window will be displayed. Next, choose the required material; the 
material will be applied to the selected object. This method will be discussed in detail in later 
chapters. 

The third type of marking menu is used to modify the components of an object. To invoke this 
marking menu, select a component, press and hold the SHIFT key, and then right-click on the 
selected object; the marking menu will be displayed, as shown in Figure 1-67. After invoking 
this marking menu, you can choose the desired option to perform the corresponding function.
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Figure 1-66  Marking menu displaying 
components of the selected object

Figure 1-67  The marking menu displaying 
various tools for modifying an object

PIPELINE CACHING
In Maya, you can reduce the render time of a complex scene with the help of  pipeline cache 
tools. Using these tools, you can also increase the loading speed of large 3D scenes. The two 
types of the caching tools available in Maya are discussed next.

Alembic Cache
The Alembic Cache tool enables you to save and export complex Maya scenes in alembic file 
format. The alembic file format has been developed to represent a complex 3D geometry as 
a simple geometry. The exported alembic files can then be re-imported into Maya to improve 
playback performance and reduce memory usage. In order to access this tool, choose Pipeline 
Cache > Alembic Cache from the menubar; a flyout will be displayed, as shown in Figure 1-68. 
Various options in this flyout are discussed next.

Figure 1-68  Flyout displayed on choosing the Alembic Cache from 
the menubar
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Open Alembic
The Open Alembic option is used to open an alembic file in Maya. When you choose this 
option, the Import Alembic dialog box will be displayed, as shown in Figure 1-69. In this 
dialog box, you can browse to the location, where the required alembic file has been saved, 
and then you can open the file in Maya using the Import button. 

Figure 1-69  The Import Alembic dialog box

Import Alembic
The Import Alembic option is used to import an alembic file in Maya. When you choose this 
option, the Import Alembic dialog box will be displayed. You can set various options in this 
dialog box for the file to be imported.

Replace Alembic
The Replace Alembic option is used to replace the selected 3D object with the alembic object 
contained in the selected alembic file. 

Export all to Alembic
The Export all to Alembic option is used to export all objects in Maya scene as an alembic 
cache file. By default, alembic cache files are saved in the cache > alembic folder of the 
current Maya project folder.

Export Selection to Alembic
The Export Selection to Alembic option is used to export the selected objects in the Maya 
scene as alembic objects.
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GPU Cache
The GPU Cache tools work similar to the Alembic Cache tools, with the only difference that 
the imported GPU file cannot be edited in Maya. However, in the alembic cache file, the 
geometry in the imported file can be edited.

INTEROPERABILITY OPTIONS IN MAYA                 
Autodesk Maya enables you to exchange data between Maya and different software such as 
3ds Max, Softimage, MotionBuilder, and Mudbox. However, for exchanging data, the same 
version of the software must be available on your system. The Send to 3ds Max, Send to 
Softimage, Send to MotionBuilder, and Send to Mudbox options located in the File menu 
of the menubar are used to send a Maya file to the above mentioned software. Autodesk Maya 
2014 enables you to save the current file with an incremental name using the Increment & 
Save option. On choosing this option from the File menu,the first incremented file is saved 
in the following format: name_of_the_file.0001.mb.

Note
The Send to 3ds Max, Send to Softimage, Send to MotionBuilder, and Send to Mudbox 
options located in the File menu of the menubar will be displayed only if you have matching 
versions installed on your system. For example, 3ds Max 2014 and Maya 2014 are considered 
to be the matching versions.

NAVIGATING THE VIEWPORTS
The persp view is the default camera view in Maya. To look around in a scene, you can move 
the virtual camera associated with the viewport. You can use the following shortcut keys while 
navigating the viewport. 

Keyboard Shortcut	 Function

ALT+MMB+Drag
ALT+RMB+Drag

ALT +LMB+Drag

Helps to pan the viewport
Helps to dolly in and out the viewport. You 
can also use the scroll wheel to dolly in and 
out.
Rotates or orbits the camera around in the 
persp window

 Self-Evaluation Test 
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 Which of the following combinations of shortcut keys is used to select a menuset drop-down 
list?

  		
		  (a) H+MMB				    (b) H+LMB
  		  (c) H+RMB				    (d) None of these
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2.	 Which of the following windows is used to toggle the display of highlights of all menu 
items and tool icons?

  		
		  (a) 1-Minute Startup Movies		  (b) The Output window	
		  (c) What’s New Highlight Settings	 (d) None of these

3.	 The __________ tool is used to snap the selected object to the center of the other object.

4.	 The __________ option helps you select an object by entering its name in the Name Selection 
area.

5.	 The Show or hide the Modeling Toolkit button is used to toggle the __________ window.

6.	 The Panel menu has a set of __________ menus.

7. 	 The keys set for animation are always displayed in red color. (T/F)

8. 	 The MEL command is a group of text strings used for performing various actions in Maya. 
(T/F)

9. 	 The Hotbox is used to assign the shortcut keys to the commands. (T/F)

 Review Questions 
Answer the following questions:

1.	 Which of the following tools helps you move the selected objects in a workspace from one 
place to another?

  		
		  (a) Translate Tool		  (b) Paint Selection Tool
  		  (c) Move Tool			   (d) Scale Tool

2.	 Which of the following combinations of shortcut keys is used to toggle the Panel menu 
on and off ?

  		  (a) SHIFT+M			   (b) CTRL+ SHIFT+M
  		  (c) SHIFT+N			   (d) CTRL+M

3.	 Which of the following shortcut keys is used to invoke the Hotbox?
  		
		  (a) SPACEBAR			   (b) BACKSPACE
  		  (c) INSERT			   (d) ESC

4. 	 Hotkeys are also known as __________ keys.

5.	 The __________ button helps you set keyframes in animation.

6.	 The user-defined shortcuts can be created by using the __________ .
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7.	 The ___________ is an arbitrary point, which is used to determine the location of objects.

8. 	 MEL stands for __________ .

9.	 The options in the Animation Preferences dialog box are used to modify the animation 
controls. (T/F)

10.	 The Absolute transform mode is used to move, rotate, and scale a selected object in the 
viewport. (T/F)

Answers to Self-Evaluation Test
1. b, 2. c, 3. Snap to Projected Center, 4. Select by name, 5. Modeling Toolkit, 6. six, 7. T, 
8. T, 9. F


