
Chapter 9

Using Massing Tools

After completing this chapter, you will be able to:
• Understand the concept of massing in Autodesk Revit.
• Create massing geometries using the Massing tool.
• Cut massing geometries using the Void Form tools.
• Convert a massing geometry into building elements.
• Add other building elements to the converted geometry.

Learning Objectives
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In earlier chapters, you learnt to use various building elements and components to create a
building model. These parametrically associated building elements enable you to generate a
building model based on specific design requirements, such as wall types, door width, window
height and so on. Each of the elements must be assigned specific properties to achieve the
desired element parameters. This makes the building model accurate. Needless to say, this is a
fairly time consuming procedure. Autodesk Revit Building provides an alternative method of
creating the building model using a much simpler method, known as Massing.

UNDERSTANDING THE MASSING CONCEPTS
At the conceptualizing stage of a project, you may want to study it in terms of its building
volumes and shapes. You may also want to convey the basic idea of the structure of the building
in a three-dimensional form, without putting in a lot of detailing. This can be achieved by using
the Massing tool.

The Massing tool in Autodesk Revit Building not only enables you to conceive and create a
variety of building shapes and volumes with relative ease, but it also conveys the potential design
in terms of building masses and geometric shapes. You can create and edit geometric shapes
and amalgamate them to form the building structure. This process can be compared to the
creation of building a model using foam blocks. You have the liberty to add or cut geometric
shapes and join different blocks or masses to form an assembly. For example, Figure 9-1 shows
a grouping of volumes that can be created to represent the building volume and mass.

Autodesk Revit Building also empowers you to convert the building mass into building elements.
The building blocks can be transformed into an assembly of individual building elements, such
as walls, roof, and floor. The transformation, carried out using the tools provided for replacing
the massing faces with a predefined wall, roof and floor types, allows you to convert the same

Figure 9-1  Building blocks created using the massing geometry
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building mass into a building model. You can then develop it into a detailed building model,
by incorporating the individual building elements with specified parameters.

Autodesk Revit Building provides the much needed continuity in the design development of a
building project, using the same building model, from its conceptualization to completion. It
also empowers you to control the visibility of the geometry between the building volumes
(massing) and building elements (shell), during the initial stages of the project development.
Other project information, such as its total area and so on, can also be extracted from the
building massing.

It is, however, important to understand the limitations of the massing tool. It is only meant for
conceptual design development, using simple geometric shapes. You can place the predefined
massing family elements provided in the additional libraries. Autodesk Revit Building attempts
to translate the massing geometry into building elements or shell and so it is not recommended
to be used for the development of a detailed geometry, such as columns, cavity walls, footing,
and so on.

CREATING THE MASSING GEOMETRY
Autodesk Revit Building provides various massing tools to generate
and view the massing geometry. These tools can be accessed from the
Massing tab in the Design Bar, as shown in Figure 9-2. It displays the
basic tools used to create the massing geometry. To activate the
Massing tab, move the cursor over the Design Bar and right-click.
Select Massing from the shortcut menu to display the Massing tab.

Autodesk Revit Building Release 9.0 provides you two methods of
creating a massing geometry. The first method is to create a mass
using the Create Mass tool and its associated tools. The second method
is to use the Place Mass tool to load and place the predefined
massing geometry from Autodesk Revit’s additional library.

When you create shapes in massing, Autodesk Revit Building
simultaneously creates its corresponding building elements. It is,
therefore, imperative to consider the associativity of the massing and
shell elements. The massing elements may need to be transformed
into individual building elements. Therefore, the massing geometry
must be created accordingly.

For example, when you create a complex geometric massing shape and convert the faces into
building elements, you may find that the certain planes do not acquire the desired building
element characteristics. The inclined planes and curved surfaces are converted into in-place
roofs.

Figure 9-2  The Massing
tab in the Design Bar
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Using the Create Mass Tool

The Create Mass tool enables you to create the
massing geometry. When you choose this tool, the
Name edit box is displayed. Enter a name for the

massing geometry to be created. You can create a number of solid and void
forms in a single massing geometry. The Design Bar is replaced by the
Mass tab, displaying the various massing tools shown in Figure 9-3. You
can use the Model Lines and Reference Lines tools to assist you in
creating the massing geometry. The Place Mass tool can be used to place
the predefined massing family elements.

To create a solid form, choose the Solid Form tool. It displays a cascading
menu with four tools, Solid Extrusion, Solid Blend, Solid Revolve, and
Solid Sweep. These are provided to create various solid shapes and profiles.
Similarly, the Void Form tool can be used to create a void form. This tool
also displays a cascading menu with four tools, Void Extrusion, Void Blend,
Void Revolve, and Void Sweep. Massing geometry can be created using a
single or a combination of the Solid Form and Void Form tools. The usage
of these tools for creating simple massing geometries is described next.
However, the designer can select the appropriate tool judiciously,
depending on the massing geometry to be created.

Creating an Extrusion

The Extrude tool is used to create a massing
geometry, by adding height to a sketched profile.
When you choose this tool, Autodesk Revit

Building enters the sketch mode and the Sketch tab is displayed in the
Design Bar, as shown in Figure 9-4.

You first need to define the work plane to sketch the profile. The Set
Work Plane tool, available in the Sketch tab, can be invoked for this
purpose. The Ref  Plane tool can be used to draw reference planes for
locating the exact points for sketching the profile. The Lines tool is used
to sketch the 2D profile to be extruded. On invoking this tool, the
sketching options are displayed in the Options Bar. You can select the
appropriate option(s), depending on the shape of the profile, which must
form a closed loop.

The Extrusion Properties tool is used to invoke the Element
Properties dialog box, in which you can specify the start and end levels

Menu Bar: Modelling > Massing > Create Mass
Design Bar: Massing > Create Mass

Menu Bar: Modelling > Massing > Create Mass > Solid Form > Solid Extrusion
Design Bar: Massing > Create Mass > Solid Form > Solid Extrusion

Figure 9-3 The
Mass tab in the
Design Bar

Figure 9-4  The
Sketch tab for the
Solid Extrusion tool
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of the extrusion and other properties. The Extrusion Start instance parameter in the Element
Properties dialog box indicates the start level of the extrusion from the base level. The
Extrusion End parameter indicates the top level of the extrusion. The difference between these
two parameters is calculated as the depth of the extrusion. You can also enter its value in the
Depth edit box available in the Options Bar. Autodesk Revit Building assumes the depth of
the extrusion from the base level.

After sketching the profile, choose the Finish Sketch tool  to create the extruded massing. The
Quite Sketch tool is used to discard the sketched profile and return to the Massing tab.

For example, to create a high rise building, choose the Create Mass tool from the Massing tab.
Assign a name for the massing geometry in the Name edit box. Enter the value of the height of
the building in the Depth edit box in the Options Bar. The Lines tool (selected by default) in
the Sketch tab of the Design Bar can be used to sketch the extrusion profile. Various sketching
tools available in the Options Bar can also  be used. You can enable the Chain tool to sketch the
base profile, if required. Sketch the base of the specified dimension using the temporary
dimensions, as shown in Figure 9-5. When the profile is completed, choose Finish Sketch to
return to the Mass tab. You can then use the Finish Mass tool from the Design Bar to extrude
the sketched profile to the specified depth. The created building mass can be viewed in the 3D
view, as shown in Figure 9-6.

Tip:  The Modify tool, invoked from the Sketch tab is used to select and edit the sketched
profile.

Figure 9-6  Massing geometry created
using the Solid Extrusion tool

Figure 9-5  An example of sketching a building profile
to be extruded
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Creating a Revolved Geometry

The Solid Revolve tool is used create a solid
geometry that is revolved around an axis. This
tool can be used to create shapes such as domes,

donuts, cylinders, and so on. When you choose this tool, Autodesk
Revit Building enters the sketch mode and the Sketch tab is displayed
in the Design Bar, as shown in Figure 9-7.

Upon choosing the Set Work Plane tool, the Work Plane dialog box
is displayed. You can choose the appropriate option to specify the work
plane.

The Lines tool is used to sketch the profile to be revolved. The sketched
profile must be a single closed loop or multiple closed loops that do
not intersect. The Axis tool can be invoked to select or create the axis
of revolution. The Options Bar displays the Draw and the Pick options.
The Draw option is used to draw a line that can be used as the axis.
Alternatively, use the Pick option to pick a line or an edge to define the
axis of revolution. After completing the sketch and defining the
revolution axis, choose Finish Sketch from the Sketch tab to generate the
revolved geometry.

The Revolution Properties tool is used to set the start and end angles of the revolution. The
default value for these two parameters is 0 degree and 360 degrees respectively.

For example, to create a dome that has a circular puncture in the centre, you can sketch the
profile and define the axis, as shown in Figure 9-8. Before you start the sketch, you need to set
the work plane as a plane perpendicular to the horizontal plane. The generated revolved
geometry is shown in Figure 9-9. Notice that because the profile does not touch the axis, the
cylindrical puncture is generated in the dome.

Menu Bar: Modelling > Massing > Create Mass > Solid Form > Solid Revolve
Design Bar: Massing > Create Mass > Solid Form > Solid Revolve

Tip:  The work plane is defined for the purpose of sketching the profile and it need not
coincide with the start or end plane. It is also used to set the direction of the extrusion.
Autodesk Revit uses the direction vector perpendicular to the work plane as the direction
of the extrusion.

You can also create multiple extrusions by sketching multiple looped profiles and then
choosing the Finish Sketch tool. Autodesk Revit extrudes all the profiles to the same
depth.

You can also specify negative values for the extrusion depth parameter. The sketched profile
is then extruded in the ‘negative’ direction.

Figure 9-7  The Sketch
tab for the Revolve tool
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Figure 9-8  An example of a sketched profile and
the defined axis of revolution

Figure 9-9  Resulting revolved massing

Figure 9-10 shows another example of the sketched profile and the defined axis of revolution.
You can use the Revolution Properties tool to set the End Angle parameter to -180 degrees.
The resulting massing is shown in Figure 9-11.

Axis of
revolution

Profile

Tip:  In order to create the massing, you may need to view the shape from various directions
and work in different work planes, using the Orient and Work Plane tools.

Axis of revolution

Profile

Figure 9-10  Sketching the profile and then defining
the axis of revolution of an arch

Figure 9-11  Resulting arched massing shape
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Figure 9-13  Sketching the profile and the 2D path
for creating a sweep

Figure 9-14  Resulting massing shape

Creating a Sweep

Using the Solid Sweep tool, you can create a geometry
by sketching a profile and then sketching the 2D path,
along which it is sweeped. When you choose this tool,

Autodesk Revit Building enters the sketch mode and the Sketch tab
displays the related tools, as shown in Figure 9-12.

The Sketch 2D Path tool is used to sketch the path to be used for extrusion.
Upon selecting this tool, the sweep sketch tab is replaced by another sketch
tab that contains the tools to draw the path. You can use the Lines tool and
the appropriate sketching tools from the Options Bar to sketch the desired
shape of the path, which can be open or closed. It can be a combination of
lines and curves. After completing the path, choose Finish Path from the
Sketch tab to return to the original sketch tab.

Alternatively, choose the Pick Path tool and select an element to define a
path. Choose the Sketch Profile tool from the Sketch tab. Using various
sketching tools, you can then sketch the profile that needs to be extruded.
Autodesk Revit Building also provides built-in profiles that can be used in
the projects. These are available in the drop-down list in the Options Bar, before the tool is
selected. You can also choose the Load profiles button from the Options Bar and access
additional profiles in the Imperial Library > Profiles folder. After completing the profile,
choose the Finish Sweep and then the Finish Mass options from the Design Bar to generate
the sweep geometry. Figure 9-13 shows an example of a 2D path with a sketched profile and
Figure 9-14 shows the resulting massing shape.

Menu Bar: Modelling > Massing > Create Mass > Solid Form > Solid Sweep
Design Bar: Massing > Create Mass > Solid Form > Solid Sweep

Sketched 2D Path

Sketched Profile

Figure 9-12  The
Sketch tab for the
Solid Sweep tool
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Figure 9-16  Sketching the base and top profile to
create a blend massing

Figure 9-17  Resulting shape after blending the
base and top profiles

Creating a Blend

Using the Solid Blend tool, you can create a massing
geometry by blending or linking two profiles. When
this tool is chosen, the Sketch tab displays the tools to

create and edit the blend, as shown in Figure 9-15.

You can sketch the base profile using the Lines tool, after setting the
desired work plane. The Blend Properties option can be used to set the
levels for the First End and the Second End instance parameters. After
completing the base profile, you can choose the Edit Top tool to sketch the
profile of the top in any work plane. The depth of the blend can be specified
in the Depth edit box available in the Options Bar.

The Vertex Connect tool is available only after both the base and top
profiles have been sketched. This tool enables you to specify the connectivity
between the vertices of their profiles. After completing both the profiles,
choose the Finish Sketch option from the Design Bar to create the blend
geometry. Figure 9-16 shows two circular profiles being sketched as the
base and the top profiles. The resulting geometry is shown in Figure 9-17.

Menu Bar: Modelling > Massing > Create Mass > Solid Form > Solid Blend
Design Bar: Massing > Create Mass > Solid Form > Solid Blend

Tip:  For creating a blended massing geometry, you can not sketch more than two closed
loops, one for the base and one for the top.

Top profile

Base profile

Figure 9-15  The
Sketch tab for the
Blend tool
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Figure 9-18  Selected geometry with the displayed
drag controls

Figure 9-19  Resizing massing geometry using the
drag control

Editing the Massing Geometry
In Autodesk Revit Building, you can easily edit the massing geometry. It can be edited using the
drag controls or by editing the massing parameters.

Resizing the Massing Geometry Using the Drag Controls
Upon selecting the massing geometry, various drag controls are displayed as arrows. You can use
the dragging method to drag the desired face. The entire massing is automatically updated,
based on the dragged face. For example, Figure 9-18 shows a cuboid with the drag controls
displayed on all its eight planes. When you drag the plane of the cuboid using the drag control,
Autodesk Revit Building immediately updates the geometry, as shown in Figure 9-19.

Editing Geometry Parameters
The parameters of the massing geometry can also be modified by selecting it and choosing the
Edit button from the Options Bar. The mass tab is displayed in the Design Bar. Again, select
the massing geometry and choose the Edit button from the Options Bar. The Sketch tab is
displayed, various creation and editing tools are available in this tab. You can then edit the
parameters such as the profile, depth and properties, based on the method used for its creation.

To a certain extent, the massing features can also be modified like other building elements. You
can use the editing tools along with the massing tools including, Mirror, Copy, Group, Array,
and so on.

Direction of
     dragging

Selected geometry

Drag control
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Figure 9-20  Sketching the profile for creating the
void form using the Void Extrusion tool

Figure 9-21  The generated void form and the
resulting massing geometry

Creating Cuts in the Massing Geometry

The Void Form tool is used to cut a massing geometry by creating a void
form, which is cut or subtracted from the massing geometry it intersects.
When you choose this tool, a cascading menu is displayed. It displays four

tools used to create the void form, Void Extrusion, Void Blend, Void Revolve, and Void Sweep.
You can select the appropriate tool to generate the shape and volume of the void form. The
method of creating the void form using these tools is similar to the respective process described
for creating a solid form. The Void Form tool can be invoked, after selecting the solid massing
geometry and choosing the Edit button from the Options Bar. When you complete the void
form, Autodesk Revit Building automatically cuts its shape and volume from the intersecting
massing geometry. Therefore, the Void Form option should not be selected directly from the
Design Bar or menu bar.

For example, Figure 9-20 shows a rectangular profile being sketched using the Void Form and
the Void Extrusion tool. When you choose Finish Sketch, the cutting geometry, in this case
another cuboid, is generated and automatically cut from the larger massing geometry.
Figure 9-21 shows the resulting massing geometry.

Similarly, you can use the Void Revolve, Void Sweep, and Void Blend tools to create the void
form. For example, to create a tunnel through a building block, you can use the Void Sweep tool
to sketch the semicircular profile and specify its path, as shown in Figure 9-22. The resulting
void form is cut from the cuboid to create an arched opening through the building block, as
shown in Figure 9-23.

Menu Bar: Modelling > Massing > Create Mass > Void Form
Design Bar: Massing > Create Mass > Void Form

Sketched profile
for creating the
void form

Massing geometry

Void form cut from the massing geometry
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Figure 9-24  Building mass with a
single void form

Figure 9-25  Resulting massing
geometry with an array of void forms

Figure 9-22  Creating the void form using the Void
Sweep tool

Figure 9-23  Resulting void form and the cut
massing geometry

You can also use various editing tools, such as Copy, Mirror, Array, and so on, to make multiple
copies of the void form profile for a single massing geometry. For example, Figure 9-24 shows a
multistorey building block with a semicircular vertical cut as the void form on one of its sides.
You can select the 2D profile of the void form and use the Array tool with the Radial option to
create its multiple copies. Autodesk Revit Building automatically creates the arrayed void forms
and generates the resulting geometry, as shown in Figure 9-25.

Sweep profile

Massing geometry

Sweep path

Void form
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Placing the Massing Geometry

Autodesk Revit Building Release 9.0 provides you the option of adding a
predefined massing geometry into the project, using the Place Mass tool.
When you invoke this tool, Autodesk Revit Building displays the loaded

massing geometries in the Type Selector Bar. You can use the Load button available in the
Options Bar to load additional massing geometries. In case a massing geometry is not loaded
into the project file, Autodesk Revit Building displays the message box prompting you to load
it. Various predefined massing geometries have been provided in the Imperial Library > Mass
folder. You can select and load a single or multiple massing geometries from this folder and then
select the one from the drop-down list of the Type Selector Bar. The selected mass can then be
placed in the project by simply clicking at the desired location. Autodesk Revit Building also
enables you to edit the predefined geometry. You can select the placed mass and modify its
instance and type properties using the Properties button.

CREATING BUILDING ELEMENTS FROM THE MASSING
GEOMETRY
After generating the shape and volume of the massing forms, you can then convert them into
building elements, such as, walls, floors, roofs and curtain systems. You can select the faces of the
generated massing geometry and replace them with the desired building element. Various tools
are available in the Massing tab in the Design Bar to carry out the conversion of faces into
building elements.

Creating Walls by Selecting Faces

The Wall by Face tool is used to convert vertical planar or arc faces of a
mass into walls. After invoking this tool, select the wall type to be used for
conversion from the Type Selector Bar. To convert the faces into walls,

ensure that the Pick Faces option is selected in the Options Bar. Appropriate values of the
Level, Height, and Loc Line, can be selected from the drop-down list in the Options Bar.

To convert the faces into walls, move the cursor over the massing geometry. You will notice that
the faces that can be converted are highlighted. Click on the desired face to  make the conversion.
You can use the TAB key to select all the faces of the massing geometry that can be converted into
walls. Figure 9-26 shows the selected faces of a massing geometry and Figure 9-27 shows the
created walls.

Menu Bar: Modelling > Massing > Place Mass
Design Bar: Massing > Place Mass

Design Bar: Massing > Wall by Face

Tip:  The Imperial Library > Mass folder provides simple 3D geometries, such as
cuboid, cone, sphere, and so on.
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Figure 9-27  Massing faces converted into wallsFigure 9-26  Selected wall faces

Creating Floors by Selecting Faces

In order to create a floor in a massing geometry, you first need to define
the floor area faces. This can be done by selecting the mass and choosing
the Floor Area Faces button available in the Options Bar. The Floor

Area Faces dialog box is displayed. Select the levels, at which the floor area faces are desired
and choose the OK button. Autodesk Revit Building automatically generates the floor area faces
based on the massing geometry and the defined levels.

Next, invoke the Wall by Face tool from the Massing tab in the Design Bar. The floor type can
be selected from the Type Selector Bar. When you move the cursor over the massing geometry,
the floor area faces are highlighted. You can select the Select Multiple check box in the Options
Bar and use the crossing options to create a selection of multiple floor area faces. Choose the
Create Floors button available in the Options Bar to create the floors. Autodesk Revit Building
converts all the selected floor area faces into the selected floor type.

Figure 9-28 shows the floor area faces generated for a multistorey building. The created floors
are shown in Figure 9-29.

Design Bar: Massing > Floor by Face

Converted
wall faces

All vertical massing
faces selected
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Creating Roofs by Selecting Faces

You can use the Roof by Face tool to convert the massing faces into roofs.
The faces can be horizontal planes of any shape or those created using the
extrusion, revolve, blend, or sweep.

After selecting the Roof by Face tool, select the roof type to be used from the Type Selector Bar.
Move the cursor over the massing geometry and click to select the highlighted face. Choose the
Create Roof button available in the Options Bar to convert it into the roof. Figures 9-30 and
9-31 show an example of the top face of the multistorey building converted into a roof.

Design Bar: Massing > Roof by Face

Figure 9-28  Generated floor area faces Figure 9-29  Floor area faces converted into
floors
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Figure 9-30  Top faces selected for conversion into
a roof

Figure 9-31  The top face of the massing geometry
converted into a roof

Creating Curtain Systems by Selecting Faces

Autodesk Revit Building Release 9.0 provides you the Curtain
System by Face tool to convert planar and non-planar faces
into curtain systems. The Curtain System by Face tool can also

be invoked by choosing Modelling > Curtain System > Curtain System by Face from the
menu bar. It can also be used to create model curtain system families.

After invoking this tool, select the curtain system type from the Type Selector Bar. Use the
Properties button to modify the properties of the curtain system, before creating it. Move the
cursor over the face that needs to be converted into the curtain system and click to select it.
Choose the Create System button from the Options Bar to create the curtain system.
Figure 9-32 shows an example of a curtain system dome. You can then add mullions to it curtain
system using the Mullions tool, as shown in Figure 9-33.

Menu Bar: Modelling > Curtain System > Curtain System by Face
Design Bar: Massing > Curtain System by Face

Selected
massing
face

Converted
massing
face

Figure 9-33  Added mullions to the curtain
system

Figure 9-32  Creating curtain systems using the
Curtain System by Face tool
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Figure 9-34 shows other examples of using the Curtain System by Face tool to convert non-planar
massing faces into curtain systems.

Controlling Visibility of the Massing Geometry

By default, all the massing forms created are not visible in a view. The Show Mass tool
is used display or hide the massing geometry. However, the use of this tool has
a temporary effect on the visibility of the massing forms. When a project file is closed,

the show mass settings are not saved with it. Therefore, the next time you open the project file,
the massing forms will not be visible.

To display the massing form permanently in a project file, choose View > Visibility/Graphics
from the menu bar and select the check box for the Visibility parameter for the Mass model
category.

Adding Other Building Elements
After converting the massing geometry to basic building elements, you can add other building
elements, such as doors, windows, roofs, and so on, to it. You can also use various editing tools
to copy, edit, and delete elements from the building model, just like a model generated using
the building elements.

Figure 9-35 shows an example of the building model in the plan view with the modified wall
type and added windows. You can then use the editing tools, such as Mirror, Array, and Paste

Menu Bar: View > Show Mass
Toolbar: View > Show Mass

Figure 9-34  Converting non-planar massing faces into curtain systems with mullions
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Figure 9-35  Plan view showing the modified
wall type and added windows

Aligned to copy elements and create a building model of the desired shape and parameters, as
shown in Figure 9-36.

Like other building models, you can also create standard building views of the converted
massing model. Autodesk Revit Building also provides the facility to extract the areas and other
statistical figures of the created massing geometry.

Added Windows

Modified wall type

Tip:  With the power of the Massing tool, Autodesk Revit enables you to create a variety
of shapes and volumes. Based on the desired geometry, you can use a combination of tools
to create it. The massing geometry can also be used to generate rendered views of the
concceptual building volumes. This can prove to be an effective tool in communicating
the design intent to the entire project team, before starting the detailed project plans.

Figure 9-36  An example of a multistorey building
with building components
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Create the massing geometry for a five story office building based on the shape shown in Figure 9-37.
It consists of a 50’0” X 50’0” central hall that is 60’0” high. It has a 30’0” diameter cylindrical
atrium with a hemispherical dome at the top level. The central hall  is flanked by the right and
left wings that are 40’0” high. The entrance area is 30’0” high Use the dimensions of the
building given in the floor plan, shown in Figure 9-38 and the elevation, as shown in Figure 9-39.
The dimensions and text have been given for reference and are not to be created. After creating
the massing, convert it into building elements with the parameters given next.

     (Expected time: 45 min)

Tutorial 1     Office Building 2

Figure 9-39  Elevation for the office buildingFigure 9-38  Sketch plan for the office building

Figure 9-37  3D sketch view of the office building

Atrium Dome Central Hall

Left Wing Right Wing



9-20           Autodesk Revit Building for Architects & Designers (Eval Copy RVT 05/06)

1. Project parameters:
Template File- default.rte, file name to be assigned- Office-2.rvt
Floor to floor height of the building - 10’0”

2. Building Element types for the converted shell elements:
Floor: Floor : LW Concrete on Metal Deck
Walls: Central Hall- Basic Wall: Exterior - Brick on CMU

Left Wing, Right Wing and Entrance- Curtain Wall: Exterior Glazing
(Spacing 5’0” horizontal, 10’0” vertical)

Flat Roof: Roof : Generic 9”
Curtain system for dome: Spacing 2’6” horizontal, 5’0” vertical; Mullion type

The following steps are required to completing this tutorial:

a. Open a new project file, using the default template file.
b. Add levels using the Level tool.
c. Create the massing geometry using the Solid Form and Solid Extrusion tools, refer to

Figures 9-40 through 9-43.
d. Cut the geometry based on the sketch plan to create the atrium and the entrance, using the

Void Form and Void Extrusion tool, refer to Figures 9-44 through 9-46.
e. Use the Solid Form and Solid Revolve tools to generate the atrium dome, refer to

Figures 9-47 through 9-49.
f. Convert the massing geometry into the specified building elements, refer to Figures 9-50

through 9-54.

Opening the Project File and Adding Levels
You can first open a new project file using the New tool. As the building is five story high,
you will create four additional levels and rename them according to the floor levels.

1. Choose File > New > Project from the menu bar. The New Project dialog box is displayed.

2. Ensure that the default.rte file is the selected template file.

3. Choose the OK button to close the New Project dialog box. The new project file is opened
in the drawing window.

4. In the Project Browser, double-click on South in the Elevations (Building Elevations)
head to display the corresponding view.

5. Choose Drafting > Level from the menu bar to invoke the Level tool.

6. Add four levels above level 2 at an elevation of 10’0” each.
(For more information on adding levels, see Chapter 5 - Adding Levels)

7. Rename the levels as follows:
Level 1- First Floor
Level 2- Second Floor
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Level 3- Third Floor
Level 4- Fourth Floor
Level 5- Fifth Floor
Level 6- Roof Floor
While renaming, choose the Yes button in the Revit conformation box to rename the
corresponding views.

Creating the Massing Geometry
You can now start creating the massing geometry using the Solid Form tool. The central hall
and the two wings can be generated using the Solid Extrude tool.

Note
The massing geometry can be created using various methods and tools. You must choose the tool
that is the most appropriate to generate the specific geometry. The steps given below describe a
general procedure to create massing. The steps and methods may vary, based on the design intent.

1. Ensure that the Massing tab is available in the Design Bar. If it is not available, then
right-click over the Design Bar and select Massing to display the Massing tab.

2. Double-click on First Floor under the Floor Plans head in the Project Browser to display
the corresponding plan.

3. Choose Create Mass from the Massing tab.

4. In the Name dialog box, enter the name Central Hall, as shown in Figure 9-40, and choose
the OK button.

5. Choose the Solid Form > Solid Extrusion tool from the Mass tab in the Design Bar.

6. In the Options Bar, enter the value 60’0” in the Depth edit box.

7. Select the Rectangle sketching tool from the Options Bar.

8. Move the cursor in the area between the four elevation tags and sketch a square with 50’0”
side.

9. Choose Finish Sketch from the Design Bar.

Figure 9-40  Naming the massing geometry
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10. Choose Finish Mass from the Design Bar to create the central hall massing

Similarly, create the left and right wing of the building using the Solid Extrude tool. You
can sketch the profile in the first floor plan view and extrude it to the height of 40’0”, as
specified in the sketch plan.

11. Choose Create Mass from the Design Bar.

12. In the Name dialog box, enter the name Wings and choose the OK button.

13. Choose the Solid Form > Solid Extrusion tool from the Mass tab in the Design Bar.

14. In the Options Bar, enter the value 40’0” in the Depth edit box.

15. Select the Chain check box in the Options Bar.

16. Ensure that the Lines tool is invoked in the Design Bar.

17. Move the cursor near the lower right corner of the square and sketch the profile shown in
Figure 9-41, based on the dimensions given in the sketch plan.

18. Choose Modify from the Sketch tab.

19. Select the sketch profile.

20. Choose Edit > Mirror from the menu bar to invoke the Mirror tool.

21. Select the Draw option from the Options Bar.

Figure 9-41  Sketched profile for the right wing
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Figure 9-42  Creating a mirror copy of the sketched profile

22. Draw a line from the top right corner to the bottom left corner of the central square to define
the mirror line. The profile is mirrored to the diagonally opposite corner of the square, as
shown in Figure 9-42.

23. Choose Finish Sketch from the Sketch tab.

24. Choose the Finish Mass from the Design Bar. The two sketched profiles are extruded by a
depth of 40’0”.

25. Choose the Default 3D View tool from the View toolbar and then choose View > Orient >
Northeast from the menu bar to display the created massing geometry in 3D, as shown in
Figure 9-43.

Mirrored profile

Mirror line

Sketched profile
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Cutting the Massing Geometry
After creating the desired building block, you can now cut them to create the atrium and the
entrance. The Void Form and the Void Extrusion tool can be used to create the desired
void geometry.

1. Select the central hall massing cuboid.

2. Choose the Edit button from the Options Bar.

3. Double-click on First Floor under the Floor Plans head in the Project Browser to display
the first floor plan view.

4. Choose Void Form > Void Extrusion from the Mass tab in the Design Bar.

5. Choose the Circle sketching tool from the Options Bar by clicking on the down arrow
button.

6. In the Depth edit box, enter the value 60’0”.

7. Move the cursor near the center of the square. Use reference planes to locate the center and
click to specify it.

8. Move the cursor to the right and enter the value 15’0” to create a circle of 30’0” diameter.

9. Choose Finish Sketch from the Design Bar to create the cutting geometry.

Figure 9-43  3D view of the massing geometry
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Figure 9-44  Sketching the cutting geometry

The next step is to create the cutting geometry for the entrance

10. Choose Void Form > Void Extrusion from the Mass tab in the Design Bar.

11. Enter the value 30’0” in the Depth edit box.

12. Select the Arc from center and end points sketching option from the Options Bar.

13. In the drawing window, use the Ref Plane tool from the Design Bar to locate and select the
center of the atrium circle as the center of the entrance arc.

14. Move the cursor horizontally toward the left and enter the value 20’0” to specify the radius.

15. Move the cursor anti-clockwise to create a quarter arc, as shown in Figure 9-44.

16. Choose the Line sketching option and ensure that the Chain option is selected.

17. Sketch the profile of the cutting geometry as shown in Figure 9-45.

18. Choose Finish Sketch from the Sketch tab.

19. Choose Finish Mass from the Mass tab in the Design Bar.

20. Choose the Default 3D View button from the Views toolbar and then choose View >
Orient > Southwest from the menu bar to view the resulting massing, as shown in Figure 9-46.

Start point

Center

End point
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Figure 9-46  3-D shaded view of the cut massing geometry

Figure 9-45  Sketching the cutting geometry

Sketched entrance
void profile
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Figure 9-47  Sketching the dome geometry

Creating the Atrium Dome
The atrium dome can be added using the Solid Revolve tool. It is a hemispherical dome,
having radius of 20’0”, same as the radius of the atrium.

1. Choose Create Mass from the Massing tab of the Design Bar.

2. Enter the name Dome in the Name edit box and choose the OK button.

3. Choose Solid Form > Solid Revolve from the Mass tab in the Design Bar.

4. Choose Set Work Plane from the Design Bar.

5. In the Work Plane dialog box, select the Pick a plane radio button and choose the OK button.

6. Select the right side entrance wall as the work plane, refer to Figure 9-47.

7. Choose the Lines tool from the Design Bar.

8. Sketch the first line from the edge of the circle to the center of the dome and the second line
from the center vertically upward with 15’0” length, as shown in Figure 9-47.

9. Choose the Arc from center and end points sketching option from the Options Bar.

10. Using the centre of the atrium roof as the center of the curve, sketch a quarter arc.

11. Choose Axis tool from the Sketch tab.

Center of dome First line
Second line

Selected work plane
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Figure 9-48  Sketching the axis of revolution for the dome

12. From the center of the dome, sketch a line vertically upward, as shown in Figure 9-48, to
define the axis of revolution.

13. Choose Finish Sketch from the Sketch tab to create the dome geometry.

14. Choose Finish Mass from the Sketch tab to complete the dome, as shown in Figure 9-49.

Axis of revolution

Figure 9-49  3D shaded view of the created dome mass
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Converting the Massing Geometry into Building Elements
You can now convert the massing geometry into building elements using the Floor by Face,
Wall by Face, and the Roof by Face tools. In order to create floors, you must first create
different floor area faces.

1. Ensure that the Modify tool is invoked in the Design Bar.

2. Select the Central Hall and Wings massing geometry by holding the CTRL key.

3. From the Options Bar, choose the Floor Area Faces button.

4. In the Floor Area Faces dialog box, select the check boxes for all the floors and choose the
OK button. The floor area faces are created for the selected floors.

5. Choose the Floor by Face tool from the Design Bar.

6. Select Floor: LW Concrete on Metal Deck from the Type Selector Bar.

7. Using the crossing, select all the floor faces. Choose the Create Floors button from the
Options Bar. Choose View > Shading with Edges from the menu bar. Autodesk Revit
Building creates the floors at the floor area faces, as shown in Figure 9-50.

8. Choose Wall by Face from the Design Bar.

9. In the Type Selector Bar, select the wall type Basic Wall : Exterior - Brick on CMU.

Figure 9-50  Converted floor area faces into floors
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10. Move the cursor over the central hall massing geometry and when an exterior wall is
highlighted, click to convert the wall face into the selected wall type.

11. Similarly, highlight and click on the other exterior walls of the central hall, including the
two side walls of the entrance. The resulting 3D view is shown in Figure 9-51.

12. Select the wall type Curtain Wall : Exterior Glazing from the Type Selector Bar.

13. Choose the Properties button.

14. In the Element Properties dialog box, choose the Edit/New button.

15. In the Type Properties dialog box, enter the values 5’0” and 10’0” for Spacing (Grid 1) and
Spacing (Grid 2) type parameters respectively. Choose the OK button to close the dialog box.

16. Choose the OK button to close the Element Properties dialog box and return to the
drawing window.

17. Highlight and click on the exterior walls of the right and left wings to convert them into the
selected exterior glazing walls.

18. Similarly, convert the curved entrance wall into the exterior glazing wall type. The 3D view
will now appear similar to the illustration shown in Figure 9-52.

19. Choose Roof by Face from the Design Bar.

20. From the Type Selector Bar, select the specified roof type Basic Roof : Generic - 9”.

Figure 9-51  Converting massing into walls
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21. Highlight the roof face of the central hall and click when it is highlighted.

22. Choose the Create Roof button from the Options Bar to create the roof.

23. Similarly, create the roof of the same type for the two wings. After the roofs are created, the
3D view will appear similar to the Figure 9-53.

Figure 9-52  Converting massing into walls

Figure 9-53  Converting massing into roofs
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Next, you will create the dome curtain wall system.

24. Choose the Curtain System by Face tool from the Design Bar.

25. Choose the Properties button.

26. Choose the Edit/New button to display the Type Properties dialog box.

27. Choose the Duplicate button.

28. In the Name edit box of the Name dialog box, enter the name 2’6”X5’0” and choose the
OK button.

29. Enter the values 5’0” and 2’6” for the Spacing (Grid 1) and Spacing (Grid 2) type
parameters, respectively.

30. Return to the drawing window by choosing the OK button in the Type Properties and
Element Properties dialog boxes.

31. Select both faces of the dome.

32. Choose the Create System button in the Options Bar. The curved surfaces of the dome are
converted into curtain systems.

34. Load the curtain wall double  glass door from the Imperial Library > Doors folder. Select
and replace the two curtain grids in the center of the entrance with the loaded door.

33. Choose Modelling > Mullion from the menu bar.

34. From the Type Selector Bar, select the mullion type Rectangular Mullion : 1” Square.

35. Select the All Empty Segments radio button from the Options Bar.

36. Add mullions to all the curtain systems in the project, including the exterior wing walls,  the
curved entrance wall, and the dome. Use the Grid Line Segment option to add grids, if
required.

The completed 3D view of the project will appear similar to the view shown in Figure 9-54.

37. Choose File > Save from the menu bar and save the project file as Office-2.rvt.

38. Choose File > Close from the menu bar to close the Autodesk Revit Building session.



Using Massing Tools        9-33

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r .

 D
o

 n
o

t 
co

p
y

. D
o

 n
o

t 
co

p
y

. D
o

 n
o

t 
co

p
y

. D
o

 n
o

t 
co

p
y

. D
o

 n
o

t 
co

p
y .

 V. V. 
V

. V . 
V i

si
t 

w
w

w
is

it
 w

w
w

is
it

 w
w

w
is

it
 w

w
w

is
it

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s

Answer the following questions and then compare your answers with those given at the end
of the chapter.

1. The Solid Extrusion tool creates the massing perpendicular to the sketched profile.
(T/F)

2. Using the Solid Blend tool, you can link two profiles at different levels. (T/F)

3. You cannot specify a negative value in the Depth edit box. (T/F)

4. A massing geometry, once created, cannot be resized. (T/F)

5. When you use the Void Form tool, the generated massing geometry is cut from the intersecting
massing geometry (T/F).

6. The __________ tool is used to add massing by sketching a profile and defining an axis.

Figure 9-54  Added roof and curtain systems

Self-Evaluation Test
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7. The __________ tool is used to specify the connection of vertices, while using the Solid
Blend tool.

8. Using the __________ tool, you can display or hide the massing geometry.

9. The start and end point of a solid extrusion can be specified in the __________ dialog box.

10. To modify a created massing geometry, you can select it and choose the _________ button
from the Options Bar to modify its profile and properties.

Answer the following questions.

1. The drag controls can be used to resize the massing geometry. (T/F)

2. You can use the editing tools, such as Move, Mirror, Copy, and so on, while sketching the
massing geometry. (T/F)

3. The Solid Blend tool extrudes a profile, along a defined path. (T/F)

4. You can extrude multiple closed profiles using the Solid Extrude tool. (T/F)

5. The Work Plane tool can be used to define the plane, in which the profile is to be sketched
(T/F).

6. You can load additional profiles, while using the Solid Sweep tool. (T/F)

7. Once the massing geometry is converted into building elements, it cannot be viewed as a
massing geometry. (T/F)

8. Which of the following parameters can be used to specify the top of the extrusion level from
the base level in the Element Properties dialog box?

a) Level b) Extrusion End
c) Depth d) Extrusion Start

9. Which of the following tools is used to create a curved tube?

a) Solid Blend b) Solid Revolve
c) Solid Extrude d) Solid Sweep

10. Which of the following tools can be used to create a sphere?

a) Solid Sweep b) Solid Revolve
c) Solid Extrude d) Solid Blend

Review Questions
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Create the massing geometry for a office building that consists of two identical 400’0” high
towers with a connecting passage at 200’0” height. Each tower has a 50’0” X 50’0” base with an
offset of 5’0” at 200’0” and 300’0” levels. There are two masts on each tower with a base radius of
2’6 ” and the top radius of 0’6”  The connecting passage is 150’0” long and has a width and
height of 25’0” with a vault roof. The plan view of the building is shown in Figure 9-55. The 3D
view and the elevation is shown in Figure 9-56 and 9-57 respectively. The dimensions and text
have been given for reference and are not to be created. Assume missing dimensions
proportionate to the building design. After creating the massing, convert it into building
elements with the parameters given next.

(Expected time: 45 min)

1. Project File Parameters:
Template File- default.rte,
File Name to be assigned- Office Towers.rvt

2. Building Element types for the converted shell elements:
Floor: Floor : LW Concrete on Metal Deck
Walls: Towers- Curtain Wall: Exterior Glazing

(horizontal and vertical spacing- 10’0”)
Connecting Passage- Curtain Wall: Curtain Wall 1

Roof: Basic Roof : Generic 9”

After completion, the building model will appear similar to the illustration shown in
Figure 9-58.

Exercise 1  Office Towers

Exercises

Figure 9-55  Sketch plan for the multistorey office building
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Figure 9-56  3D view of the building
Figure 9-57  Elevation view of the building

Passage

Tower 2

Tower 1

Figure 9-58  Elevation view of the completed building
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Exercise 2 Stadium
Create the massing geometry for a stadium. Its plan view is shown in Figure 9-59. It consists of
the field area and the stands. The lower tier in the stands has 3’0” as the tread width and 1’0” as
the riser. The upper tier has 3’0” as the tread width and 1‘6” as the riser. The cross-section view
of the stands is shown in Figure 9-60. The dimensions and text have been given for reference
and are not to be created. Assume the missing dimensions proportionate to the sketch plan. Use
the following building parameters.                  (Expected time: 30 min)

1. Project File Parameters:
Template File- default.rte,
File Name to be assigned- Stadium.rvt

After completion, the building model appears similar to the illustration shown in Figure 9-61.

Figure 9-59  Sketch plan for the stadium project
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Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. F, 5. T, 6. Solid Revolve, 7. Vertex Connect, 8. Show Mass, 9. Element
Properties, 10. Edit

Figure 9-60  Cross-section view of the stands

Figure 9-61  3-dimensional view of the stadium


