
Chapter 12

Generating, Editing,
and Dimensioning

Drawing Views

After completing this chapter, you will be able to:
• Understand the Draft environment.
• Learn the types of views that can be generated in Solid Edge.
• Generate drawing views.
• Manipulate drawing views.
• Add annotations to drawing views.
• Generate exploded views of assemblies.
• Create associative balloons and parts list.

Learning Objectives
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THE DRAFT ENVIRONMENT
After you have created a solid model or an assembly, you can generate its two-dimensional
(2D) drawing views. Solid Edge has a separate environment called the Draft environment,
which is used for generating drawing views. This environment contains the tools to generate,
edit, and modify the drawing views.

To invoke the Draft environment, start Solid Edge and then choose the Drawing option in
the Create area of the welcome screen.

If Solid Edge is running on your computer, invoke the New dialog box and select the
Normal.dft template, see Figure 12-1. The .dft is the extension of the files created in this
environment. After selecting the required template, choose OK in the New dialog box to
enter the Draft environment. You can modify the drawing standards of the current file from
the Draft environment.

When you enter the Draft environment, the drawing sheet and the background sheet with
the borders will be displayed, as shown in Figure 12-2. This sheet is the one on which you will
generate the drawing views. The background sheet is used to add title blocks. As per the
requirement, you can set parameters of the drawing sheet in the Sheet Setup dialog box. To
display the Sheet Setup dialog box, choose the File > Sheet Setup option from the menu
bar.

If you have a part file or an assembly file opened and you want to generate its drawing views,
you can choose File > Create Drawing from the menu bar; the Create Drawing dialog box is
displayed. Select the default template and choose OK; the Drawing View Creation Wizard

Figure 12-1  Selecting a draft template from the New dialog box
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dialog box will be displayed to generate the drawing views. You will learn more about this
dialog box later in this chapter.

TYPES OF VIEWS GENERATED IN SOLID EDGE
In Solid Edge, there are two types of drafting techniques: generative drafting and interactive
drafting. In the generative drafting, the views are generated from the part or assembly that is
already created. In the interactive drafting, the views are sketched using the sketching tools.

Note
The reason for generating the drawing views is that these views are associative with their
respective solid models or assemblies. Therefore, any change in the model updates the drawing
views also. Similarly, any change in the dimensions of the drawing views updates the model. On
the other hand, the sketched view is not associated with any model. Therefore, the editing of the
views is not automatic.

Figure 12-2  The default screen display in the Draft environment

Tip: To use an empty sheet without any margin lines or the title block, choose
File > Sheet Setup from the menu bar; the Sheet Setup dialog box will be
displayed. Choose the Background tab and select the blank space in the
Background sheet drop-down list. The preview of the sheet in the dialog box
shows an empty sheet. Choose the OK button to exit the dialog box.
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In Solid Edge, you can generate six types of views from a model or an assembly. These views
are discussed next.

Base View
The base view is the first view and is generated using a parent model or an assembly. This
view is an independent view and is not affected by the changes made in any other view in the
drawing sheet. Most of the other views are generated taking this view as the parent view.

Principal View
The principal view is an orthographic view that is generated using any other view present in
the drawing sheet. This is the most common view generated after the base view.

Auxiliary View
The auxiliary view is a drawing view that is generated by projecting lines normal to a specified
edge of an existing view. These views are mainly used when you want to show the true length
of an inclined surface.

Section View
The section view is generated by cutting the part of an existing view using a plane or a line
and then viewing the parent view from a direction normal to the section plane. These views
are generally used for the models that are complicated from inside and it is not possible to
display the inner portion of the part using the conventional views.

Detail View
The detail view is used to display the details of a portion of an existing view. This portion is
selected from the parent view. The portion that you select will be scaled and placed as a
separate view. The scale can be modified, if needed.

Broken-Out View
The broken-out view is used for the parts that have a high length to width ratio. The broken-out
area is specified by adding break lines to an existing orthographic view.

GENERATING DRAWING VIEWS

In Solid Edge, the first view that is to be generated is the base view. This view is
generated using the Drawing View Wizard tool. The remaining views are generated
by directly or indirectly using the base view. Before you proceed further, you need to

set the projection type to third angle projection. To do so, choose Tools > Options from the
menu bar to invoke the Options dialog box and choose the Drawing Standards tab. Choose
the Third button from the Projection Angle area and choose OK.

Toolbar: Drawing Views > Drawing Views Wizard
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Generating the Base View
The Drawing View Wizard tool is used to generate the base view. When you invoke this tool,
the Select Model dialog box will be displayed. Using this dialog box, select the model whose
drawing views you need to generate and choose the Open button; the Drawing View
Creation Wizard dialog box will be displayed. Figure 12-3 shows this dialog box when a part
file is selected. The options in this dialog box are discussed next.

Part and Sheet Metal Drawing View Options Page
The options in this page enable you to specify the parameters related to the display of the
drawing view.

Designed part
This radio button is selected by default and is used to specify that you need to generate
the drawing views of an existing part.

Simplified part
This radio button is used to generate the drawing views of the simplified version of a
model. This button will be in the inactive state if the simplified version of a model does
not exist.

Figure 12-3  The Part and Sheet Metal Drawing View Options page of the Drawing
View Creation Wizard dialog box displayed when a part file is selected
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Flat pattern
This radio button is used to generate the drawing views of a flat pattern of the sheet
metal part. It is available only for the sheet metal parts having a flat pattern.

Show tube centerlines
This check box is selected to display the centerlines in the tube components.

Show hidden edges in Orthographic views
This check box is selected by default and is used to display the hidden edges, if any, in
the orthographic drawing views.

Show hidden edges in Pictorial views
Pictorial views are drawing views other than the orthogonal views. This option is used to
display the hidden edges, if any, in the pictorial drawing views. Figures 12-4 and 12-5
show the isometric (pictorial) drawing views with the visible hidden edges and the
suppressed hidden edges, respectively.

Show tangent edges in Orthographic views
Tangent edges are the edges formed by rounds or cylindrical features. This option is
used to display the tangent edges, if any in the part, in the orthographic drawing views.

Show tangent edges in Pictorial views
This option is used to display the tangent edges, if any, in the pictorial drawing views.

Drawing View Orientation Page
When you choose the Next button from the Part and Sheet Metal Drawing View Options
page, the Drawing View Orientation area will be displayed, as shown in Figure 12-6. The
options in this page enable you to specify the standard orientation of the drawing view or
the pictorial view. These options are discussed next.

Figure 12-5  Drawing view without hidden edgesFigure 12-4  Drawing view with hidden edges
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Figure 12-6  The Drawing View Orientation page of the Drawing View Creation
Wizard dialog box

Named Views
This display box consists of options for generating views in the standard orientations.
You can select any options from the standard orientations.

Custom
When you choose the Custom button, the Custom Orientation window will be displayed,
as shown in Figure 12-7. This window displays the part or the assembly that you had
selected earlier from the Select Model dialog box. You can use the drawing display
tools available in this window to set the orientation of the model. You can also spin the
model using the middle mouse button. After setting the orientation, choose the Close
button to exit the window.

Note
The Next button is not activated in the Drawing View Creation Wizard dialog box if the iso,
trimetric, or dimetric options are selected from the Named Views display box.

If you suppress features of a model whose drawing views are generated, the suppressed features
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will not be displayed in the drawing views. When you unsuppress the features, they will be
displayed in the drawing view.

Drawing View Layout Page
When you choose the Next button from the Drawing View Orientation page, the Drawing
View Layout page will be displayed, as shown in Figure 12-8. The button in the middle
represents the orientation of the model that you selected from the Named Views display
box. You can select more than one view from the Drawing View Layout page and choose the
Finish button to place the views in the drawing sheet. If you select two buttons, in addition to
the middle button, three orthogonal views of the model will be displayed.

Figure 12-7  The Custom Orientation window

Tip: When you double-click on a generated drawing view, the part file associated
with that view will be opened.
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Generating the Principal View

The principal view is generated after selecting an existing view. The views that can be
selected include a base view or another principal view. To generate the principal
view, choose the Principal View button from the Drawing Views toolbar; you will be

prompted to select a drawing view. Move the cursor to a drawing view or the source view and
select it as soon as it is enclosed in a red box. On doing so, a red crossed box will be attached
to the cursor. Now, as you move the cursor up, down, left, or right, the box will also move with
it. You can place the view at the bottom, top, left, or right of the source view. Note that if you
move the cursor diagonally, you can generate a pictorial view, such as an isometric view, from
the source view.

Note
The principal views cannot be generated from the detail view, section view, and auxiliary view.

By default, Solid Edge generates drawing views in the first angle projection system. The third
angle projection system has been used throughout this book. To change the default projection
system, choose Tools > Options from the menu bar; the Options dialog box will be displayed.
Choose the Drawing Standards tab and then select the Third radio button.

Figure 12-8  The Drawing View Layout page of the Drawing View Creation Wizard
dialog box

Figure 1-8  The Grid Settings dialog box

Toolbar: Drawing Views > Principal View
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Figure 12-9 shows the drawing sheet with the base view and principal views. The base view is
the front view and the top and isometric views are generated from the front view using the
Principal View tool.

Note
When you generate a drawing view on the drawing sheet, it will be displayed with the visible
and hidden edges. You can also change the display of the drawing view to shaded. To change the
display, select the drawing view; various shading buttons will be available in the Drawing
View Selection ribbon bar. Choose any shading button and update the drawing view.

Generating the Auxiliary View

The auxiliary view is a drawing view that is generated by projecting the lines normal
to a specified edge of an existing view. To generate the auxiliary view, choose the
Auxiliary View button from the Drawing Views toolbar; you will be prompted to

click on a fold line or click for the first point of the fold line. The fold line is an edge of the
model or an imaginary line normal to which the view will be projected. Select an edge of the
model or a keypoint on the edge and then select another keypoint. An imaginary fold line
will be formed and the auxiliary view will be projected normal to this fold line. Move the
cursor and then click to place the view; an arrow pointing in the direction normal to the fold

Figure 12-9  Drawing sheet with the base view and principal views

Toolbar: Drawing Views > Auxiliary View
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Figure 12-10  Auxiliary view generated from the principal view

line will be displayed, as shown in Figure 12-10.

The display of this arrow can be changed to a line with double arrows. To change the display,
select the arrow and right-click to invoke the shortcut menu. Choose the Properties option
from the shortcut menu; the Viewing Plane Properties dialog box will be displayed, as shown
in Figure 12-11. Select the Double radio button from the View Direction Lines area in the
dialog box and choose OK; the arrow will change to double arrows.

Figure 12-11  Partial view of the Viewing Plane Properties dialog box
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Need for Auxiliary View
The need for auxiliary view arises when it becomes impossible to dimension a geometry in
the orthographic views. For example, refer to Figure 12-10. In this model, the profile on the
face of the inclined feature cannot be dimensioned until a view is generated normal to the
inclination. After the auxiliary view is generated, the profile can be easily dimensioned with
the true dimensions.

Generating the Section View

As mentioned earlier, the section view is generated by cutting a portion of an existing
view using a cutting geometry and then viewing the source view from the direction
normal to the cutting geometry. In Solid Edge, various types of section views can be

generated using the Section View tool.

To create a section view, you need a geometry that will be used to cut the source view. To
create a cutting geometry, the Cutting Plane tool is used.

Generating a Simple Section View
The following steps explain the procedure for creating a cutting geometry and generating a
simple section view:

1. Choose the Cutting Plane button from the Drawing Views toolbar; you will be
prompted to select a drawing view. This view will be the source view.

2. Select the source view to activate the sketching environment. This environment contains
the sketching tools that you can use to create the cutting geometry.

Note
When you move the cursor over a drawing view to select the source view, it will be enclosed in
a red box. The box indicates that the view can be selected. But sometimes, when you move the
cursor on the view in the area that does not have any entity, this box will disappear. If you click
at this point, the view will not be selected. So, it should be noted that the red box will appear only
when the cursor is on an entity that composes the drawing view.

3. Draw the sketch for the cutting geometry. Remember that the sketch should be a
continuous open sketch. You can use the alignment indicators to sketch the cutting
geometry.

4. After drawing the sketch for the cutting geometry, choose the Finish button from the
ribbon bar to exit the cutting plane environment.

Note
When you move the cursor across the cutting geometry, the direction of arrows will also change.

5. Specify the direction of viewing by clicking in the direction pointed by the arrows.
6. Choose the Section View button from the Drawing Views toolbar; you will be prompted

to select a cutting plane.

Toolbar: Drawing Views > Section View
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Figure 12-12  Shaded top view and the front section view

7. Select the cutting plane and place the section drawing view at the desired location in the
drawing sheet. A simple section view is shown in Figure 12-12.

Points to Remember for Creating the Cutting Planes
The following points should be remembered while creating the cutting planes:

1. The sketch drawn can be a combination of arcs and lines, but an arc cannot be the start or
the end entity of the sketch.

2. The sketch must be open and all entities should be connected to each other.
3. Relationships and dimensions can be applied between the sketched entities and the

drawing view.
4. The cutting plane can be edited by double-clicking on it or by choosing the Edit button,

which will be displayed in the ribbon bar when you select the cutting plane.

Note
When you place the section view, it does not matter on which side of the source view you place it.
The section view remains the same on either sides of the source view. But it varies with the
direction of arrows on the cutting plane.

Revolved Section Views
The revolved section views are needed when some features in a model are at a certain
angle. In a revolved section view, the section portion revolves around an axis normal
to the viewing plane such that it is straightened. For example, Figure 12-13 shows the

views of a model that has three outer features at an equal angle with respect to each other. If
you want to show the geometry of at least two outer features, you need to generate a
revolved section view.

To generate a revolved section view, select an existing cutting plane. Because the cutting
planes have entities that are at some angle to each other, you need to select the line that will
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Figure 12-14  Two different revolved section views generated by selecting two
different cutting geometries

Figure 12-13  Front view and the right-side revolved section view

be used as a fold line for generating the section view. For example, in Figure 12-14, the
inclined line is used to generate the section view at the top and the vertical line is used to
generate the section view at the right. Before placing the view, choose the Revolved Section
View button from the ribbon bar.

Note
The cutting plane geometries should be multiline and they should be inclined at an angle to
each other.
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Figure 12-15  Section view displaying only the section area

If a multiline cutting geometry exists, you can select only the first and  last entities  as the cutting
plane.

If the cutting plane geometry consists of an arc, the Revolved Section View button in the
ribbon bar cannot be used.

Section View that Displays only the Section Geometry
The Section Only button in the ribbon bar is used to generate a section view that
displays only that area of the model that is sectioned. Figure 12-15 shows the section
view that displays only the section area of the model.

The following steps explain the procedure for creating this type of view:

1. Choose the Section View button from the Drawing Views toolbar; you are prompted to
select a cutting plane.

2. Select the cutting plane and move the cursor; a box attached to the cursor also moves
along with it.

3. Choose the Section Only button from the ribbon bar and place the view by clicking on
the desired side. The section view is placed, as shown in Figure 12-15.

Generating the Broken-Out Section View

The broken-out section view is used when you want to show a particular portion of
the model in section and at the same time, not section the remaining model. The
Broken-Out Section View button is used to generate the broken section view. This

button is available on the flyout that will be displayed when you press and hold the left mouse
button on the down arrow on the right of the Section View button. The steps given next
explain the procedure for creating this type of view.

Toolbar: Drawing Views > Section View > Broken-Out Section View
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1. Choose the Broken-Out Section View button from the Section View flyout and select
the drawing view where you have to draw the profile for the broken view. You automatically
enter the sketching environment where all the tools that are used to draw the profile
are available.

2. Draw the sketch, as shown in Figure 12-16. After drawing the sketch, choose the Finish
button from the ribbon bar to exit.

3. Next, you are prompted to specify the distance for the depth of the cut. This distance can
be specified in the Depth edit box present on the ribbon bar or on the other orthographic
view, as shown in Figure 12-16. After specifying the depth of the cut, you are prompted
to select the view that needs to be broken.

4. Select the isometric view (pictorial view) to generate the broken-out section view, as shown
in Figure 12-17.

Generating the Detail View

Detailed views are used to provide the enlarged view of a particular portion of an
existing view. In Solid Edge, the detailed view is generated by drawing a circle or any
other user-defined sketch around the portion whose details are needed. When you

choose the Detail View button, the Detail View ribbon bar will be displayed and the Circular
Detail View button will be chosen by default, and you will be prompted to select the center of
the circle. After specifying the center of the circle, you will be prompted to click for the edge
of the circle. As soon as you click, a circle, which is actually the detail view, will be attached to
the cursor. Place the view on the drawing sheet at the desired location, see Figure 12-18.

You can also choose the Define Profile button from the ribbon bar to define the boundary of
the detail view. When you choose this button, the sketching environment will be activated.

Figure 12-16  Specifying the profile and the depth of the cut

Toolbar: Drawing Views > Detail View



Generating, Editing, and Dimensioning Drawing Views      12-17

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r .

 D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y .

 V. 
V

. 
V

. 
V

. 
V i

si
t 

w
w

w
is

it
 w

w
w

is
it

 w
w

w
is

it
 w

w
w

is
it

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s

Figure 12-17  Isometric broken section view

Draw the required closed profile using the tools available in this environment. Figure 12-19
shows the user-defined closed profile and the detail view created.

Figure 12-18  Detail view of an isometric view

Tip: If you drag and drop a part file from the EdgeBar on the drawing sheet, then
depending on the projection angle system set for the current file, the top, front, and
right-side views of the part will be generated. If you drag and drop an assembly on
the drawing sheet, then an isometric view of the assembly will be generated.

You can right-click on a detail view and choose Convert to Independent Detail
View to convert the view to an independent view.
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Figure 12-20  Different types of broken views

Generating the Broken View
This view is generated on the existing orthographic or pictorial view. It is created by breaking
the existing view along the horizontal or vertical direction using the horizontal or vertical
lines. This type of view is used for the parts that have a high length to width ratio. Various
types of broken views are shown in Figure 12-20.

The following steps explain the procedure for creating this type of view:

1. Move the cursor over the drawing view where you have to add the break lines. When the
view is highlighted and enclosed in a red box, right-click to invoke the shortcut menu.

2. From the shortcut menu, choose the Add Break Lines option; you are prompted to click
in the drawing view at the point where you need to place the first break line. Notice that
as you move the cursor, the break line also moves with it.

You can set the style for the break lines from the Style drop-down list. By choosing the
Vertical Break or Horizontal Break buttons from the ribbon bar, you can specify whether
the drawing view will be broken vertically or horizontally. In the ribbon bar, there are
four linetypes that can be selected for the break line type.

Figure 12-19  User-defined sketch and the resulting detail view
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3. Before specifying the first point for the break line, you need to specify the line type for
the break lines. Choose the Break Line Type button from the ribbon bar; a flyout is
displayed with four buttons. Choose any of the buttons for selecting a line type. The
Break gap edit box on the ribbon bar is used to set the distance between the pair of break
lines. The Height edit box is used to specify the height of the zig zags in the break lines.
The Pitch edit box is used to specify the pitch of the breaks when you select the short
break line type. The Symbols edit box, which is available for the last break line type, is
used to set the number of symbols that are added to the break lines.

4. Click on the drawing view to specify the location for the first line. After the first break
line is placed, click again to specify the location for the second break line.

5. After specifying the second break line, choose the Finish button to exit.

Note
When you select a view with break lines, the Show Broken View button will be displayed in the
ribbon bar. This button toggles the display of break lines in the selected drawing view.

WORKING WITH INTERACTIVE DRAFTING
As mentioned earlier, you can also sketch the 2D drawing views in the Draft environment of
Solid Edge. In technical terms, sketching 2D drawing views is known as interactive drafting.
The 2D drawing views can be drawn by choosing the Draft View button from the Drawing
Views toolbar, after customizing the toolbar to add this button. When you do so, you will be
prompted to place the view. Select a point on the drawing sheet; the sketching environment
will be invoked. The tools available in the sketching environment are the same as those
available in the sketching environment of the Part environment. After sketching the drawing
view, choose the Return button from the ribbon bar to return to the Drawing environment.

MANIPULATING DRAWING VIEWS
Once the drawing views are generated, it is very important to learn how they can be modified
or edited. The following editing operations can be performed on the existing drawing views:

Aligning Drawing Views
When you generate the principal views from the base views, they are aligned automatically. If
you move one of the views, then the other view will also move along with the first one. This
shows that the two views are aligned. Also, when you select one of the views, a center line that
connects the two views will be displayed.

To unalign a view, select the view and right-click to invoke the shortcut menu. The Maintain
Alignment option has a check mark on its left. Choose this option again from the shortcut
menu; the check mark on its left is removed, suggesting that the view is no more aligned.

Tip. You can add the views of different parts and assemblies on a single drawing
sheet. This helps you view the dimensions of the different models on a single sheet. To
add a new model to the sheet, follow the same procedure that was used to generate the
base view.
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Now, if you move any one of the previously aligned views, the other view will not move.

To completely delete the alignment, choose the Delete Alignment option from the shortcut
menu and then select the alignment line of the current view.

To create a new alignment of the view, choose the Create Alignment option from
the shortcut menu; the Create Alignment ribbon bar will be displayed. You can select
a location for the drawing view alignment using the Alignment position drop-down

list. The buttons available in the ribbon bar are used to specify whether you want to create a
vertical, horizontal, parallel, or a perpendicular alignment. Choose the required options and
buttons from the ribbon bar and then select the view to which you want to align the current
view.

Modifying the Scale of Drawing Views
You can modify the scale of a drawing view by selecting it and changing the value in the
ribbon bar. Alternatively, you can choose the Properties button from the ribbon bar. When
you choose this button, the High Quality View Properties dialog box will be displayed. You
can also invoke this dialog box by choosing the Properties option from the shortcut menu
that will be displayed when you select a view and then right-click on it.

Note
When you modify the scale of a drawing view that was generated by projecting a view, the scale
factors of both the views are modified.

Cropping Drawing Views
Cropping is a technique that is used to view only a particular portion of the drawing view on
the drawing sheet. To crop a drawing view, select a portion of the drawing view such that it is
enclosed inside a boundary. Now, drag one of the boundary’s handles until the portion of the
drawing you want to display is visible. The portion of the view that lies inside the associated
box is retained and the remaining portion is removed.

To bring back the view to its original display, right-click on the view to display the shortcut
menu. Choose the Uncrop option from the shortcut menu; the cropping in the view is
removed.

Note
You cannot crop a detail view and a broken view.

Moving Drawing Views
To move a drawing view, select it and drag it on the drawing sheet. To place the view, release
the left mouse button at the desired location on the drawing sheet.

Rotating Drawing Views
The drawing views can be rotated by invoking the Drawing toolbar. Choose the Rotate
button from this toolbar; you will be prompted to select an element to modify. Select
the drawing view you need to rotate; you will be prompted to select the center of
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rotation. Select a point that acts as the center of rotation. Now, select a point from which you
want to start the rotation and then select a point up to which you want to rotate the view. You
can also specify the angle of rotation value in the dimension boxes present on the ribbon bar.

Applying the Hatch Pattern
You can also apply a hatch pattern to a closed region by using interactive drafting. To
apply the hatch pattern, choose the Fill button from the Drawing toolbar; you will be
prompted to select the area. As you select a closed region, it will be filled with the

hatch pattern. The hatch pattern can be modified by right-clicking on it and selecting the
Properties option.

Modifying the Properties of Drawing Views
After generating a drawing view, you can modify its properties. To set the properties, right-click
on the drawing view to invoke the shortcut menu. Choose the Properties option to display
the High Quality View Properties dialog box, as shown in Figure 12-21. There are eight tabs
in this dialog box.

The General tab contains the options that are used to modify the scale, move the drawing
view to another sheet, add caption or description to the drawing view, rotate the drawing
view by specifying an angle, and so on. You can also select the options to add 3D dimensions
to the pictorial view, retrieve dimensions on the next update of the part, process part
intersections, and so on.

The Display tab contains the options that are used to set the display of the drawing view. The
Parts list list box displays the components, subassemblies, and construction surfaces. You
can select them in this list and choose the display options from this tab. The Parts list options
button enables you to select the items that you want to display in the Parts list list box. From
the Selected Parts(s) Display area, you can set the display style of the entities in the drawing
view. The Restore default display settings button restores the default settings.

The Text and Color tab contains the options that are used to set the dimension style, color of
text, font, font style, and size.

Tip. To modify the hatch pattern style of a section view, select the view and right-click
to invoke the shortcut menu. Choose the Properties option to display the High
Quality View Properties dialog box. Choose the Display tab and then from the
Show fill style drop-down list in the Selected Part(s) Display area, select any one
of the hatch styles. Choose OK to exit the dialog box.

If you need to modify the properties of the hatch such as spacing, angle, and so on,
right-click on the drawing view and choose the Draw in View option; the view will
be opened in a separate window. Now, right-click on the hatch and choose the
Properties option; the Fill Properties dialog box is displayed. Using this dialog
box, you can modify the parameters of the hatch. After modifying the parameters,
choose the Return button from the ribbon bar.
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Figure 12-21  The High Quality View Properties dialog box for a principal view

The Sections tab lists the 3D sections that can be used to generate the section views.

The Annotation tab contains the options that enable you to set the style for the center lines
and flowlines.

The Model Options tab contains the options that are used to specify whether to display the
simplified representation of the part in the drawing view.

The View Shading tab contains the options that enable you to set the shading options for the
shaded drawing view of the part.

The Advanced tab contains the advanced drawing options.
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ADDING ANNOTATIONS TO THE DRAWING VIEWS
Once you have generated the drawing views, you need to add annotations such as dimensions,
notes, surface finish symbols, geometric tolerances, and so on to them. There are two methods
of displaying these annotations in the drawing views. The first method is to generate the
annotations that are defined at the time of creating the model such as dimensions. These
dimensions are associative in nature and so, can be used to modify or drive the dimensions of
a model. The second method of displaying the annotations is to manually add them to the
drawing views.

Note
You can also create dimensions in the Draft environment, but these dimensions cannot drive the
dimensions of the part.

Generating Annotations
Generating annotations is the process of retrieving dimensions, notes, and so on from the
parent model. The annotations that were used to create the model are displayed on the
orthographic views of the model.

To retrieve dimensions, choose the Retrieve Dimensions button from the Drawing
Views toolbar; the ribbon bar will be displayed with various dimensioning options
and you will be prompted to select a drawing view. As soon as you select a drawing

view, the dimensions will be displayed on it. Various buttons available on the ribbon bar are
discussed next.

Dimension Style Mapping
This is a toggle button and is used to specify whether or not the dimension style mapping set
using the Dimension Style tab of the Options dialog box will be used.

Linear
This button is used to retrieve linear dimensions in the selected drawing view.

Radial
This button is used to retrieve radial dimensions in the selected drawing view.

Angular
This button is used to retrieve angular dimensions in the selected drawing view.

Annotations
This button is used to retrieve annotations that are applied to the model.

Retrieve Duplicate Radial Dimensions
This button is used to retrieve duplicate radial dimensions that have the same value.

Hidden Line Dimensions
This button is used to retrieve dimensions of the hidden edges.
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Add Dimensions
If this button is chosen, the dimensions will be added to the drawing view.

Remove Dimensions
If this button is chosen, the dimensions will be removed from the drawing view. However,
note that the dimensions that are applied using the Retrieve Dimension tool can only be
removed using this tool.

Figure 12-22 shows a drawing view after retrieving the dimensions.

Displaying Center Marks and Center Lines in a Drawing View
Solid Edge allows you to display center marks and center lines in the drawing views.
To do this, choose the Automatic Center Lines button from the Drawing Views
toolbar; the ribbon bar will be displayed with various options. If you choose the

Center Line and Center Mark Options button from the ribbon bar, the Center Line and
Center Mark Options dialog box will be displayed. You can select the entities on which you
want to display the center marks and center lines using this dialog box.

You can set the options for adding or removing the center lines and center marks using the
buttons available in the ribbon bar. It is recommended that you choose the Center Mark or
the Center Mark Projection Lines button from the ribbon bar. Choosing both buttons will
place the center lines above the center marks.

Figure 12-23 shows a drawing view with center mark projection lines and Figure 12-24 shows
a drawing view with center lines.

Figure 12-22  Drawing view with dimensions
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Adding Reference Dimensions to the Drawing Views
Although retrieving the dimensions from the parent model is the most effective way of
dimensioning, but sometimes you may also need to dimension the drawing views manually.
The options for dimensioning a drawing view are available in the Drawing Views toolbar.
These options are similar to those discussed in the sketching environment. The only
dimension tool that was not discussed earlier is the Chamfer Dimension tool, which is discussed
next.

Chamfer Dimension
This button is available in the Distance Between flyout in the Drawing Views toolbar.
On choosing this button, you will be prompted to select the dimension base line.
This line is one of the edges of the chamfer. Next, you will be prompted to select

the dimension measure line. Select the chamfer line; you will notice that the dimension is
attached to the cursor. Click to place the dimension.

ADDING NEW DRAWING SHEETS
In Solid Edge, a drawing file can have multiple drawing sheets. A multisheet drawing file is
generally used when you need to generate drawing views of all parts of an assembly in a
single drawing file. You can easily switch between the sheets to refer to the drawing views of
different parts within the same file, thus avoiding the step of opening separate drawing files.

To add a new sheet to the drawing file, right-click on Sheet1 at the bottom of the drawing
window and choose Insert from the shortcut menu. Alternatively, you can also choose
Insert > New Sheet from the menu bar; a new sheet named Sheet2 will be added to the
drawing file. Using the other options available in the shortcut menu, you can rename, delete,
reorder, and set up a sheet.

EDITING THE DEFAULT SHEET FORMAT
You can edit the default standard sheet format according to your design requirement. To edit
the standard sheet format, choose View > Background Sheet from the menu bar and then
choose View > Working Sheets to clear the check mark on the left of this option. You will

Figure 12-24  Center lines on the holes in a
drawing view

Figure 12-23  Center marks on the holes in a
drawing view



12-26              Solid Edge for Designers

notice that all entities, annotations, and views are removed from the drawing sheet and four
sheet tabs, namely A1-Sheet, A2-Sheet, A3-Sheet, and A4-Sheet are displayed at the bottom
of the drawing sheet. Right-click on A1-Sheet at the bottom of the drawing window and
choose Sheet Setup from the shortcut menu to display the Sheet Setup dialog box. You can
use the options in this dialog box to modify the size and units of the sheet. You can also
delete the existing title block and use the sketching tools to draw a new title block. After
editing the sheet, choose View > Working Sheets to activate this option and then choose
View > Background Sheet to clear it.

GENERATING EXPLODED VIEWS OF ASSEMBLIES
The exploded views are generated by selecting the configuration that was saved at the time
of exploding the assembly in the Assembly environment. The following steps explain the
procedure for generating an exploded view:

1. Choose the Drawing View Wizard button from the Drawing Views toolbar to display the
Select Model dialog box.

2. Select the assembly from the dialog box and choose the Open button to display the
Drawing View Creation Wizard dialog box.

3. From the Configuration drop-down list in the dialog box, select the configuration that
represents the exploded state of the assembly.

4. Set the other parameters and then choose the Finish button from the dialog box.
5. Place the view on the drawing sheet; an exploded view is shown in Figure 12-25.

Before placing the view, you can also set the display of the parts in the exploded
drawing view by choosing the Model Display Settings button from the ribbon bar.
When you choose this button, the High Quality View Properties dialog box will be

displayed, as shown in Figure 12-26. The options in the Display tab of this dialog box are
discussed next.

Figure 12-25  Exploded view
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Display Tab of the Drawing View Properties Dialog Box
The Display tab of this dialog box contains various options for controlling the display of the
assembly drawing view. These options are discussed next.

Show
Using the Show check box, you can control the display of one or more parts in the assembly.
You will also notice that all parts, including the assembly, are selected in the Parts list area.

Display as Reference
This check box, when selected, enables you to display the selected part as reference. You can
select the part from the Parts list area. The selected part is displayed as dotted in the assembly
drawing view.

Figure 12-26  The High Quality View Properties dialog box
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Figure 12-27  Exploded view of the assembly with BOM and balloons

Visible edge style
This drop-down list enables you to select the edge style of the parts in the assembly drawing
view. You can also apply different styles to different parts in the assembly drawing view.

CREATING ASSOCIATIVE BALLOONS AND PARTS LIST
Generally, the drawing view of an assembly also contains the list of parts, material of each
part, quantity, and other related information in the form of a table, which is called the bill of
material (BOM). In Solid Edge, it is called the parts list. Balloons are added to the parts of
assembly and each balloon refers to the part in the parts list.

The parts list can be generated by choosing the Parts List button from the Drawing
Views toolbar. The parts list is associative in nature, which means that any
modification made in the part files of the assembly will be reflected in the parts list

also. The following steps explain the procedure for generating a parts list and the balloons:

1. Generate the assembly drawing view.
2. Choose the Parts List button from the Drawing Views toolbar; the ribbon bar is displayed

with the options that can be used to specify whether or not you want to display the
balloons and the table. Also, you are prompted to select a drawing view.

3. Select the assembly drawing view. You can also choose the Properties button from the
ribbon bar and set the display properties of the parts list and balloons.

4. Choose the Auto-Balloon button from the ribbon bar.
5. Choose the Finish button to place the parts list and balloons, as shown in Figure 12-27.
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Figure 12-28  The List Properties dialog box

List Properties Dialog Box
While generating the parts list on the drawing sheet and before choosing the Finish button,
when you choose the Properties button from the ribbon bar, the List Properties dialog box
will be displayed, as shown in Figure 12-28. This dialog box is used to set the parameters of
the parts list and balloons. The options available in this dialog box are discussed next.

General Tab
The options in this tab are used to specify the text properties of the text in the parts list and
are discussed next.

Saved settings
This drop-down list contains the styles that are saved for the parts list. By default, two
styles, ISO and ANSI, are saved. If you need to save a new style, type a name in this
drop-down list and choose the Save button.

Text Area
This area provides the options that are used to set the properties of the text.

Sheet
This drop-down list is used to specify the sheet on which you want to place the parts list.
This option will not be active if there is only one sheet.

Mark un-ballooned items
This check box is selected by default. This indicates that if a balloon is not attached to
any part of the assembly, then that part in the parts list will be marked by an asterisk.
Balloons are not added to parts that are not visible in the assembly drawing view.
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Size/Placement Tab
The options in this tab are used to specify the display of the parts list on the drawing sheet.

Title block
In the title block of a parts list, you can specify titles such as the item number, name,
quantity, and so on. Using this drop-down list, you can specify the location of the title
block in the parts list.

Maximum height of list
You can specify the maximum height of the parts list using this edit box. When the
height of this list exceeds this value, the BOM list is divided into multiple sections.

Section gap
This edit box is used to specify the gap between the different sections of the parts list.
This is used only when the height of the parts list exceeds the maximum height and it is
divided into multiple sections.

Grid color
This drop-down list is used to specify the color of the lines that make up the parts list.

Grid line width
This edit box is used to specify the width of the lines in the parts list.

Text margin
The value in this edit box specifies the gap between the lines and the text in the parts list.

Location Area
The options in this area are used to specify the location of the parts list on the drawing
sheet.

Columns Tab
The options under this tab are used to specify various properties of columns in the parts list.

Available columns
This display box lists all the column headings that you can display in the parts list.

Columns used
This display box lists all the columns that will appear in the parts list. You can add
columns to this box by selecting them from the Available columns display box and
choosing the Add button.

Column Format Area
The options in this area are used to specify different titles for the column headings
selected from the Columns used display box. You can also specify the alignment of the
text in various cells of the parts list.
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Component Types Tab
The options under this tab are used to specify the type of components to be included in the
parts list.

Sorting Tab
The options under this tab are used to specify the criteria to sort the parts in the parts list.

List Control Tab
The options under this tab are used to specify the display of parts in the parts list. From these
options, you can select the parts that you want to exclude from the assembly. These options
are discussed next.

Top-level list (top-level and expanded components)
When this radio button is selected, only the top-level assembly is searched for the parts
to list them in the parts list. If the assembly contains subassemblies, they are listed as a
single part and the parts of the subassemblies are not listed in the parts list.

Note
Remember that the title in the parts list will be listed only if you have entered it in the file
properties of that part.

Atomic List (all parts)
This radio button, when selected, specifies that all parts will be listed in the parts list. If
the assembly contains subassemblies, all parts of the subassemblies will also be listed in
the parts list.

Selected item Area
The options in this area are used to exclude or include the selected part from the parts list.
To exclude a part, select it from the adjacent tree and then select the Exclude radio
button.

Sub-assemblies Area
The options in this area are used to specify if a subassembly exists and also if you want it
to be displayed as a single item or along with its parts in the parts list.

Include only ballooned parts
When this check box is selected, only those parts that were ballooned earlier will be listed
in the parts list. This check box is cleared by default.

Exclude hidden parts
When this check box is selected, the hidden parts will be excluded from the parts list.
This check box is cleared by default.

Exclude reference parts
If this check box is selected, the reference parts will be excluded from the parts list. This
check box is selected by default.
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Balloon Tab
The options under this tab enable you to set the display properties of the balloons that
appear on the assembly drawing view.

Steps to Generate Parts List and Balloons
In this section, you will learn how to generate the parts list and balloons by setting some
options in the List Properties dialog box. An assembly with parts list and balloons  will be
generated, as shown in Figure 12-29. This assembly consists of two subassemblies.

The following steps explain the procedure for generating the parts list and balloons:

1. Choose the Parts List button from the Drawing Views toolbar; you are prompted to
select the drawing view.

2. Select the drawing view that exists on the drawing sheet.
3. Choose the Properties button from the ribbon bar to display the List Properties dialog

box.
4. Choose the Columns tab.
5. In the Columns used display box, select Document Number and choose the Remove

button.
6. Choose the List Control tab.
7. From the Global area, select the Atomic List (all parts) radio button and choose the OK

button to exit the dialog box.
8. Choose the Auto-Balloon button from the ribbon bar, if it is not already chosen.
9. Choose the Finish button from the ribbon bar to display the BOM and balloons.

You will notice that the balloons are displayed showing both the item number
and the quantity.

Figure 12-29  Exploded view of the assembly with BOM and balloons
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10. To remove the quantity from a balloon, select all the balloons by pressing the CTRL key;
the ribbon bar is displayed.

11. Choose the Item Count button from the ribbon bar to clear it. Now, the balloon shows
only the item number.

TUTORIALS

In this tutorial, you will generate the top view, front view, and right-side view of the part that
was created in Exercise 1 of Chapter 8 and is shown in Figure 12-30. Use the standard A4
Landscape sheet format for generating the drawing views. You will also insert your company
logo in the sheet.         (Expected time: 1 hr)

The following steps are required to complete this tutorial:

a. Start a new draft file.
b. Set up the drawing sheet and the background sheet, refer to Figure 12-32.
c. Set the projection angle method and save the draft template file.
d. Generate the drawing views, refer to Figure 12-34.
e. Save the draft file.

Starting a New File in the Draft Environment
1. Start Solid Edge and then select the Drawing option from the Create area of the

welcome screen.

Tutorial 1

Figure 12-30  Top, front, right-side, and isometric views of the model
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2. After entering the Draft environment, choose Tools > EdgeBar from the menu bar to
hide it, if it is displayed. This is because you will not need it and moreover, turning its
display off will increase the work area on the screen.

Setting the Drawing Sheet Options
The drawing sheet in Solid Edge is like a blank sheet of paper on which you can draw.
You can add as many sheets as needed in the same drawing file. When you work in the
Draft environment, you have two sheets by default. The sheet on which you place the
drawing views is called the worksheet and the sheet on which you create the title blocks is
called the background sheet. Based on the size of the worksheet you select, the background
sheet automatically adjusts itself to the size of the worksheet. To set the worksheet and
the drawing sheet for this tutorial, follow the steps given next.

1. Choose File > Sheet Setup from the menu bar to display the Sheet Setup dialog box. In
the Sheet Size area of the Size tab, the Standard radio button is selected by default.

2. From the drop-down list, select A2 Wide (594mm x 420mm), if it is not already selected.
Note that in the dialog box, the units are set in millimeters.

3. Choose the Background tab in the dialog box. Make sure A2-Sheet is selected in the
Background sheet drop-down list. Choose the OK button from the dialog box to exit it.

Next, you will insert a graphic image as an object in the background sheet. Generally, a
company’s logo is inserted using this method. As the image has to be inserted in the
background sheet, therefore, you need to deactivate the working sheet. Also, note that to
insert an image, you should have an image editing program installed on your computer.

4. Choose View > Background Sheet from the menu bar and then choose View > Working
Sheets to clear this option. Notice that four sheets are displayed in the bar below the
drawing window.

5. Choose the A2-Sheet tab from the bottom of the drawing window and then zoom to fit it
on the screen.

6. Select the top table, as shown in Figure 12-31. All entities in the table turn magenta in
color, which indicates that they are selected.

7. Press the DELETE key to delete the selected entities.

8. Choose Insert > Image from the menu bar to display the Insert Image dialog box.

9. Choose the Browse button; the Open a File dialog box is displayed.

10. Browse and select the image file of the logo that you want to use, refer to Figure 12-32.

11. Set the transparency option for the logo, if required.
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Figure 12-31  Selecting the table

12. After selecting the file, choose the OK button from the Insert Image dialog box; the
image will be placed on the sheet.

13. Drag the image and place it, as shown in Figure 12-32. The size of the image can be
modified using the handles available on the image, when it is selected.

14. After placing the image, choose Tools > Options from the menu bar to display the
Options dialog box and then choose the Drawing Standards tab.

15. From the Projection Angle area, select the Third radio button to set the current projection
type to the third angle projection. Choose OK to exit the dialog box.

16. Choose View > Working Sheets from the menu bar and then choose View > Back-

Figure 12-32  Title block with the image
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ground Sheet to clear this option. Now, the drawing views that you generate will be
placed on the worksheet and not on the background sheet.

17. Save the drawing file as Template.dft in the \Program Files\Solid Edge V20\Template folder.

You have successfully created a template file. In this textbook, you will further use this
drawing file as the template to generate the drawing views in the Draft environment.

18. Close this file and then start a new file using the Template.dft template.

Generating the Drawing Views
The Drawing View Orientation page of the Drawing View Creation Wizard dialog box
enables you to generate multiple views in a single attempt. All views required in this
tutorial will be generated at the same time using this option.

1. Choose the Drawing View Wizard button from the Drawing View toolbar to
display the Select Model dialog box.

2. Select the part created in Exercise 1 of Chapter 8 and then choose the Open button to
display the Drawing View Creation Wizard dialog box.

3. Accept the default options and choose the Next button from the Part and Sheet Metal
Drawing View Options page.

4. Select front view from the Drawing View Orientation page and then choose the Next
button.

5. Select the views shown in Figure 12-33 from the Drawing View Layout page and then
choose the Finish button.

6. Place the drawing views on the sheet.

Notice that you need to increase the scale of the views. The scale of any one orthographic
view, when modified, changes the scale of the other two orthographic views also.

7. Select the isometric view to display the ribbon bar.

8. Modify the value of the scale to 1.2 in the Scale value edit box in the ribbon bar.

9. Similarly, select any one of the orthographic views to invoke the ribbon bar. Modify the
value of the scale to 1.2.

10. You can move the views on the sheet by dragging them. Arrange all views, as shown in
Figure 12-34.

Saving the File
1. Choose File > Save As from the menu bar to display the Save As dialog box. Save the file

with the name c12tut1.dft.



Generating, Editing, and Dimensioning Drawing Views      12-37

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r

E
va

lu
a

ti
o

n 
C

ha
p

te
r .

 D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y

. 
D

o
 n

o
t 

co
p

y
. 

D
o

 n
o

t 
co

p
y .

 V. 
V

. 
V

. 
V

. 
V i

si
t 

w
w

w
is

it
 w

w
w

is
it

 w
w

w
is

it
 w

w
w

is
it

 w
w

w
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s
.c

a
dc

im
.c

o
m

 f
o

r 
de

ta
il

s

Figure 12-33  The Drawing View Layout page of the Drawing
View Creation Wizard dialog box

2. Choose File > Close to close the file.

Figure 12-34  Sheet after generating all the drawing views
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Figure 12-35  Left-side view, auxiliary view, and the front view of the model

In this tutorial, you will generate the front view, left-side view, and auxiliary view of the part
that was created in Exercise 2 of Chapter 7. You will also generate the dimensions, as shown
in Figure 12-35. Use the template that was created in Tutorial 1.

   (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Start a new draft file.
b. Generate the drawing views, refer to Figures 12-37 through 12-39.
c. Generate the dimensions.
d. Create the remaining dimensions that are not generated, refer to Figure 12-43.
e. Save the drawing file and close the window.

Starting a New File in the Draft Environment
You will use the template created in the previous tutorial to generate the drawing views
for this tutorial.

1. Choose the New button from the Main toolbar to display the New dialog box.

2. Select Template.dft and choose the OK button to exit the dialog box and enter the Draft
environment. Here, you will use the Template.dft file as the template.

Tutorial 2
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Generating the Base Drawing Views
As mentioned earlier, the drawing views are generated from their parent part. The
following steps are required for generating the drawing views:

1. Choose the Drawing View Wizard button from the Drawing Views toolbar to
display the Select Model dialog box.

2. Select the part created in Exercise 2 of Chapter 7 and choose the Open button to display
the Drawing View Creation Wizard dialog box.

3. Accept the default options and choose the Next button.

4. From the Drawing View Orientation page, select front and choose the Next button.

5. Now, choose the button of the left view in the dialog box and then choose the Finish
button.

6. Place the drawing views on the sheet.

Notice that you need to scale down the views. The scale of any one orthographic view,
when modified, changes the scale of the other orthographic views also.

7. Select one of the views to display the ribbon bar.

8. Modify the value of the scale to 1.2 in the Scale value edit box.

9. You can move the views on the sheet by dragging them. Arrange the views, as shown in
Figure 12-36.

Figure 12-36  Drawing views after reducing the scale
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Figure 12-39  Drawing sheet after generating the auxiliary view

Figure 12-38  Moving the cursor to place the viewFigure 12-37  Edge to be selected

Generating the Auxiliary View
The auxiliary view will be generated by selecting the edge perpendicular to which the
view will be projected. This view is created because the true shape of the cut profile can
be shown in this view. To generate the auxiliary drawing view, follow the steps discussed
next.

1. Choose the Auxiliary View button from the Drawing Views toolbar; you are
prompted to click on the first point of the fold line. The fold line is an imaginary
line that is created when you select two keypoints. The view will be projected
about this imaginary line.

2. Select the edge, as shown in Figure 12-37. An imaginary fold line is formed and the
auxiliary view is projected normal to this fold line. Move the cursor and to place the view,
see Figure 12-38. After you place the view, the arrow pointing in the direction normal to
the fold line is displayed, as shown in Figure 12-39.
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Dimensioning the Views
Now, the dimensions will be generated from the model and then the remaining dimensions
will be created.

1. Choose the Retrieve Dimensions button from the Drawing Views toolbar; you
are prompted to select the drawing view.

2. Select the front view; the dimensions are displayed on it. You will notice that the display
of the dimensions is very small. You need to increase the font size of the dimensions.

3. Exit the current tool and then select a dimension; the current dimension style is displayed
in the first drop-down list in the ribbon bar. You need to modify the text size for this
dimension style.

4. Press the ESC key to remove the dimension from the selection set. Now, choose Format >
Style from the menu bar to display the Style dialog box. Select the dimension style of the
current dimensions from the Styles list box and then choose the Modify button.

5. Choose the Text tab and modify the font size to 8.5 in the Font size edit box. Choose OK
and then choose Apply from the Style dialog box.

6. Place the missing dimensions, as shown
in Figure 12-40, using the dimensioning
tools.

7. Choose the Distance Between
button from the Drawing Views
toolbar and then select the By
2 Points option from the Orientation
drop-down list. Dimension the auxiliary
view with dimensions 90, 42, and 70, as
shown in Figure 12-41.

8. To dimension the auxiliary view with
dimensions 45, 25, and 33, draw an axis
passing through the center of the arc, as
shown in Figure 12-41.

9. Select the center of the arc and then the axis, and place the dimension with a value of 33,
see Figure 12-42.

10. Similarly, apply the remaining dimensions to the auxiliary view so that all dimensions
are displayed.

11. After dimensioning the auxiliary view, choose the Retrieve Dimensions button
and select the left-side view to generate the dimensions. You will notice that only
dimension 50 is generated. Create the remaining dimensions manually.

Figure 12-40  Front view after placing the angular
dimension
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The drawing sheet, after dimensioning the drawing views, is shown in Figure 12-43.

Saving the File
1. Save the file with the name c12tut2.dft.

2. Choose File > Close to close the file.

Figure 12-43  Drawing sheet after dimensioning the views

Figure 12-42  Auxiliary view after dimensioningFigure 12-41  Axis drawn to dimension
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In this tutorial, you will generate an exploded drawing view of the assembly created in
Chapter 9. You will also add the parts list and balloons to the assembly, as shown in Figure 12-44.

  (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Start a new draft file.
b. Generate the exploded drawing view.
c. Generate the parts list and balloons.
d. Edit balloons.
e. Save the drawing file and close the window.

Starting a New File in the Draft Environment
1. Choose the New button from the Main toolbar to display the New dialog box.

2. Select Template.dft and choose the OK button to exit the dialog box. Now, you have
entered the Draft environment.

Generating the Exploded Drawing View
1. Choose the Drawing View Wizard button from the Drawing View toolbar to

display the Select Model dialog box.

Figure 12-44  Parts list and balloons in exploded drawing view

Tutorial 3
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2. Select Assembly Document (*.asm) from the Files of type drop-down list.

3. Select the Stock Bracket assembly and choose the Open button to display the Drawing
View Creation Wizard dialog box.

4. In the Assembly Drawing View Options page, select the Explode configuration from
the Configuration drop-down list. Accept the remaining default options.

5. Choose the Finish button to exit the dialog box.

6. Modify the drawing view scale to 0.18.

Generating the Parts List and Balloons
The parts list and balloons are generated directly from the assembly drawing view.

1. Choose the Parts List button from the Drawing Views toolbar; the Parts List
ribbon bar is displayed and you are prompted to select a view.

2. Select the exploded drawing view.

3. Choose the Properties button from the ribbon bar to display the List Properties dialog
box.

4. In the Text area of the General tab, modify the value in the Size edit box to 7.

5. Choose the Columns tab. In the Columns used display box, select the Document Number
option and choose the Remove button to remove it.

6. Select the Material option from the Columns used display box.

7. Next, in the Column Format area, change the value in the Column width edit box to 42.
Similarly, change the column width value of Quantity to 42.

By default, the balloons that you place display the item number and the item count.
However, in this case, you do not need to display the item count. Therefore, you need to
modify the balloon properties using the Balloon tab.

8. Choose the Balloon tab to display the options related to balloons.

9. Modify the value in the Size edit box to 7.

10. Next, clear the Item count check box to make sure the item counts are not displayed.

11. Choose the OK button to exit the dialog box. Choose Finish from the ribbon bar.

12. Drag the parts list table to the desired location on the drawing sheet and place it.
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The drawing sheet after placing the parts list and balloons is shown in Figure 12-45.

Saving the File
1. Choose File > Save from the menu bar to display the Save As dialog box.

2. Save the file with the name c12tut3.dft.

3. Choose File > Close to close the file.

Figure 12-45  Exploded drawing view with the parts list and balloons
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Review Questions

Self-Evaluation Test
Answer the following questions and then compare them to those given at the end of this
chapter:

1. When you enter the Draft environment of Solid Edge, only the drawing sheet is displayed.
(T/F)

2. You cannot use an empty sheet for drawing. (T/F)

3. The__________ button is used to retrieve annotations that are applied to the model.

4. The base view is the first view that is generated on the drawing sheet. (T/F)

5. A section view is generated by cutting the part of an existing view using a plane or a line
and then viewing the parent view from a direction normal to the section plane. (T/F)

6. The Drawing View Wizard button is used to generate the base view. (T/F)

7. The ____________ is the file extension of the files created in the Draft environment of
Solid Edge.

8. The _____________ view is used for parts that have a high length to width ratio.

9. A cutting plane can be edited by  _____________ or by choosing the ___________ button
from the ribbon bar.

10. To generate a section drawing view of a part, you need a _____________.

Answer the following questions:

1.  In which of the following views,  the dimensions cannot be generated from the part?

(a) Front (b) Right-side
(c) Top (d) None of the above

2. Which of the following buttons in the Drawing Views toolbar is used to generate a BOM?

(a) SmartDimension (b) Parts List
(c) Draft View (d) None of the above

3. The __________ tab contains the options that are used to set the dimension style, color of
text, font, font style, and size.
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Exercises

Exercise 1

Figure 12-46  Exploded drawing view with the BOM and balloons

4. Which of the following dialog boxes is displayed when you choose the Drawing View
Wizard button from the Drawing Views toolbar?

(a) Properties (b) Select
(c) Drawing View Properties (d) None of the above

5. Before placing the BOM on the drawing sheet, when you choose the Properties button
from the ribbon bar, the Parts List Properties dialog box is displayed. (T/F)

6. When you enter the Draft environment, there are two sheets available by default. (T/F)

7. The technique of generating drawing views from a solid model is called generative drafting.
(T/F)

8. A detail view is used to display the details of a portion of an existing view. (T/F)

9. The need for an auxiliary view arises when it becomes impossible to dimension a geometry
in the orthographic view. (T/F)

10. In a revolved section view, the section portion revolves about an axis normal to the viewing
plane such that it is straightened. (T/F)

Create the exploded view of the assembly that was created in Chapter 10, see Figure 12-46.
Generate the BOM and balloons.    (Expected time: 30 min)
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Figure 12-47  Top, front, right-side, and isometric views of the model

Exercise 2
Create the model whose drawing views are shown in Figure 12-47 and then generate the
drawing views of the model. Dimension the drawing views, as shown in Figure 12-47.

    (Expected time: 45 min)

Answers to Self-Evaluation Test
1. F, 2. F, 3. Annotations, 4. T, 5. T, 6. T, 7. .dft, 8. broken, 9. double-clicking, Edit, 10. cutting
plane


