
Chapter 1

Drawing Sketches for
Solid Models

After completing this chapter, you will be able to:
• Understand the requirement of the sketching environment.
• Open a new part document.
• Understand various terms used in the sketching environment.
• Work with various sketching tools.
• Use the drawing display tools.
• Delete the sketched entities.

Learning Objectives
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THE SKETCHING ENVIRONMENT
Most products designed using SolidWorks are a combination of sketched, placed, and derived
features. The placed and derived features are created without drawing a sketch, but the
sketched features require a sketch to be drawn first. Generally, the base feature of any design
is a sketched feature and is created using a sketch. Therefore, while creating any design, the
first and foremost point is to draw the sketch for the base feature. Once you have drawn the
sketch, you can convert it into the base feature and then add the other sketched, placed, and
derived features to complete the design. In this chapter, you will learn to create the sketch for
the base feature using various sketcher entities.

In general terms, a sketch is defined as the basic contour for the feature. For example, consider
a spanner shown in Figure 1-1.

This spanner consists of a base feature, a cut feature, a mirror feature (cut on the back face),
fillets, and an extruded text feature. The base feature of this spanner is shown in Figure 1-2.
It is created using a single sketch drawn on the Front Plane, as shown in Figure 1-3. This
sketch is drawn in the sketching environment using various sketching tools. Therefore, to
draw the sketch of the base feature, you first need to invoke the sketching environment where
you will draw the sketch.

Note
Once you are conversant with various options of SolidWorks, you can also use a derived feature
or a derived part as the base feature.

The sketching environment of SolidWorks can be invoked any time in the Part mode or
Assembly mode. You just have to specify that you want to draw the sketch of a feature and
then select the plane on which you want to draw the sketch.

Note
You will learn how to invoke the sketching environment in SolidWorks 2006 later in this
chapter.

Figure 1-1  Solid model of a spanner
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STARTING A NEW SESSION OF SolidWorks 2006
To start a new session of SolidWorks 2006, choose Start > Programs > SolidWorks 2006
SP0.0 > SolidWorks 2006 SP0.0 from the Start menu or double-click on the SolidWorks
2006 SP0.0 icon placed on the desktop of your computer; the SolidWorks 2006 window will
be displayed. If you are starting SolidWorks application for the first time after installing it,
the Welcome to SolidWorks dialog box will also be displayed, as shown in Figure 1-4. This
dialog box welcomes you to SolidWorks and helps you customize SolidWorks installation.
The options available in this dialog box are discussed next.

Help customization Area
The options available in this area are used to define the type of help you need to invoke while

Figure 1-2  Base feature of the spanner Figure 1-3  Sketch for the base feature of the spanner

Figure 1-4  The Welcome to SolidWorks dialog box
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working with SolidWorks. By default, the I am new user. Show Quick Tips to help me get
started radio button is selected in this area. With this radio button selected, you are provided
with quick tips that will guide you through the process of starting as a new user. Keep this
radio button selected if you are a new user of SolidWorks.

If you are an existing user of SolidWorks, select the I am new to this version of SolidWorks.
Show me Interactive What’s New help radio button. This ensures that the Interactive What’s
New help is displayed while you are working with the tools that are enhanced or introduced
in this release of SolidWorks.

If you do not want to invoke any dynamic help topic, select the Do not show me any dynamic
help radio button.

Work flow customization Area
The options available in the Work flow customization area of this dialog box are used to
customize the default visibility of toolbars and menu bars. These customize the toolbars and
menu bars on the basis of the area of your expertise, such as product design, machine design,
and mold design. Select the check box that belongs to the area of your expertise.

This textbook follows the beginners point of view. Therefore, you need to keep the default
radio button selected in the Help customization area and clear all check boxes in the Work
flow customization area. Next, choose the OK button from the Welcome to SolidWorks
dialog box. The Welcome to SolidWorks dialog will disappear and you can view the
SolidWorks 2006 window, as shown in Figure 1-5.

You will notice that Task Pane is displayed on the right of the SolidWorks 2006 window. This
Task Pane is provided with various options that are used to start a new file, open an existing
file, browse the related links of SolidWorks, and so on. The options available in the Task
Pane are discussed next.

SolidWorks Resources Task Pane
By default, the SolidWorks Resources Task Pane is displayed when
you start the SolidWorks session. Different options provided in the
groups available in this Task Pane are discussed next.

Getting Started
The options available in this group are used to start a new document, open an existing
document, and invoke the interactive help topics.

Online Resources
The options available in this group are used to invoke the discussion forum of SolidWorks,
subscription services, solution partners, manufacturing network, and print 3D Web sites.
With this release of SolidWorks, a search engine is provided in the Online Resource Task
Pane. You just need to type the term on which you need any information and then choose the
Start searching button; you will be redirected to the web site of GlobalSpec search engine.
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Tip of the Day
The Tip of the Day group provides you with a useful tip that will enhance your performance
of using SolidWorks. Choose the Next Tip provided on the lower right corner of the Tip of
the Day dialog box to switch to the next tip.

Design Library
The Design Library Task Pane is invoked by choosing the Design Library tab from
the Task Pane. This Task Pane is used to browse the default Design Library available
in SolidWorks or the toolbox components, and also to access the 3D ContentCentral

Web site. To access the toolbox components, Toolbox Add-in needs to be installed on your
computer. To access the  3D ContentCentral Web site, your computer needs to be connected
to the Internet.

File Explorer
The File Explorer Task Pane is used to explore the files and folders that are saved on
the hard disk of your computer.

Figure 1-5  The SolidWorks 2006 window

Tip. You can also dislodge the Task Pane from its position by double-clicking on
the grey bar at the top where its name is displayed. Now, you can move it at the
desired location. To place it back on its original position, again double-click on the
gray bar or choose the Dock Task Pane button provided on the top-right corner of
the Task Pane.
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STARTING A NEW DOCUMENT IN SolidWorks 2006
To start a new document in SolidWorks 2006, choose the New Document option from the
Getting Started group of the SolidWorks Resources Task Pane; the New SolidWorks
Document dialog box will be displayed, as show in Figure 1-6. You can also invoke this dialog
box by choosing the New button from the Standard toolbar. The options provided in this
dialog box are discussed next.

Part
The Part button is chosen by default in the New SolidWorks Document dialog box. Choose
the OK button to start a new part document to create solid models or sheet metal components.
When you start a new part document, you will enter the Part mode.

Assembly
Choose the Assembly button and then the OK button from the New SolidWorks Document
dialog box to start a new assembly document. In an assembly document, you can assemble
the components created in the part documents. You can also create components in the assembly
document.

Drawing
Choose the Drawing button and then the OK button from the New SolidWorks Document
dialog box to start a new drawing document. In a drawing document, you can generate or
create the drawing views of the parts created in the part documents or the assemblies created
in the assembly documents.

Figure 1-6  The New SolidWorks Document dialog box
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Note
When you start a new file in SolidWorks, the What would you like to do? window is displayed,
which assists you in working with SolidWorks. To close this window, choose the (X) button
available close to the lower right corner of the SolidWorks window. The (X) button changes into
the (?) button, which you can choose to display this window again.

THE SKETCHING ENVIRONMENT
Whenever you start a new part document, by default you are in the part modeling environment.
But, you need to start the design by first creating the sketch of the base feature in the sketching
environment. You can invoke the sketching environment using the Sketch tool available in
the Standard toolbar. You can also choose the Sketch button from the CommandManager
(Figure 1-7) to invoke the Sketch CommandManager.

When you choose the Sketch button from the Standard toolbar or choose any tool from the

Figure 1-7  Different methods of invoking the sketching environment in SolidWorks 2006

Tip. If you invoke the New SolidWorks Document dialog box using the Task
Pane and start a new document, the Task Pane will remain expanded even when
the new document is started. If you invoke the New SolidWorks Document dialog
box using the toolbar or menu bar, the Task Pane will collapse and remain collapsed
after starting the new document. You will learn more about expanding and collapsing
the Task Pane later in this chapter.
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Sketch CommandManager; the Edit Sketch PropertyManager is displayed and you are
prompted to select the plane on which the sketch will be created. Also, the three default
planes available in SolidWorks 2006 (Front Plane, Right Plane, and Top Plane) are temporarily
displayed on the screen, as shown in Figure 1-8.

Depending on the requirement of the design, you can select any plane to draw the sketch of
the base feature. The selected plane is automatically oriented normal to the view so that you
can easily create the sketch. Also, the CommandManager now displays various sketching
tools to draw the sketch.

The default screen appearance of a SolidWorks part document in the sketching environment
is shown in Figure 1-9.

Tip. You will notice that Task Pane is still available on the right of the drawing
area. This decreases the drawing area. To increase the drawing area, you need to
collapse the Task Pane. To collapse the Task Pane, click anywhere in the drawing
area, choose any one of the arrow symbols  available on the right of the Task
Pane, or click on the bar attached to these two arrows. You can also collapse the
Task Pane by clicking once in the drawing area.

To expand the Task Pane at any stage of the design cycle, choose any one of the
arrows provided on the right of the Task Pane.

Figure 1-8  Selecting the plane to draw the sketch of the base feature
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SETTING UP THE DOCUMENT OPTIONS
When you install SolidWorks on your computer, you will be prompted to specify the
dimensioning standards and units for measuring linear distances. The settings specified at
that time are the default settings and whenever you start a new SolidWorks document, it will
use these settings. However, if you want to modify these settings for a particular document,
you can easily do so using the Document Properties dialog box. To invoke this dialog box,
choose Tools > Options. When you invoke this option, the System Options dialog box will
be displayed. In this dialog box, choose the Document Properties tab; the name of this
dialog box will be changed to Document Properties dialog box. Setting the options for the
current document using this dialog box is discussed next.

Modifying the Dimensioning Standards
To modify the dimensioning standards, invoke the System Options dialog box and then
choose the Document Properties tab. You will notice that the Detailing option is selected by
default in the area on the left to display the detailing options, as shown in Figure 1-10.

The default dimensioning standard that was selected while installing SolidWorks will be
selected in the drop-down list provided in the Dimensioning standard area. You can select
the required dimensioning standard from this drop-down list. The standards that are available
are ANSI, ISO, DIN, JIS, BSI, GOST, and GB. You can select any one of these dimensioning
standards for the current document.

Figure 1-9  Default screen display of a part document in the sketching environment
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Modifying the Linear and Angular Units
To modify the linear and angular units, invoke the System Options dialog box and then
choose the Document Properties tab. In this tab, select the Units option from the area on
the left to display the options related to linear and angular units, as shown in Figure 1-11.
The default option for measuring the linear distances that was selected while installing
SolidWorks will be provided in the drop-down list provided in the Length units area. You can
set the units from the options provided in the Unit system area. If you need to specify some
units other than those provided in this area, choose the Custom radio button to invoke the
options available in the Length units area. You can set the units using the drop-down list
provided in this area. The units that can be selected are angstroms, nanometers, microns,
millimeters, centimeters, meters, microinches, mils, inches, feet, and feet & inches. You can
also change the units for angular dimensions by selecting them from the drop-down list in
the Angular units area. The angular units that can be selected are Degrees, Deg/Min, Deg/
Min/Sec, and Radians.

Figure 1-10  Setting the dimensioning standards
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Modifying the Snap and Grid Settings
In the sketching environment of SolidWorks, you can make the cursor jump through a specified
distance while creating the sketch. Therefore, if you draw a sketched entity, its length will
change in the specified increment. For example, while drawing a line, if you make the cursor
jump through a distance of 10 mm, the length of the line will be incremented by a distance
of 10 mm. To do this, choose Tools > Options from the menu bar to display the System
Options dialog box. To ensure that the cursor jumps through the specified distance, you
need to invoke the snap option. Select the Relations/Snap branch of the Sketch option to
display the related options. From the options available on the right, select the Grid check
box and clear the Snap only when grid is displayed check box, if it is selected. This check
box, when selected, snaps the sketched entities only when grid is displayed.

Now, choose the Document Properties tab to invoke the Document Properties dialog box.
Select the Grid/Snap option to display the related options, see Figure 1-12. The distance
through which the cursor will jump is dependent on the ratio between the values in the

Figure 1-11  Setting the dimensioning units
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Major grid spacing and Minor-lines per major spinners available in the Grid area. For
example, if you want that the coordinates should change in the increment of 10 mm, you will
have to make the ratio of major and minor lines to 10. This can be done by setting the value
of the Major grid spacing spinner to 100 and that of the Minor-lines per major spinner to
10. Similarly, to make the cursor jump through a distance of 5 mm, set the value of the Major
grid spacing spinner to 50 and that of the Minor-lines per major spinner to 10.

Tip. If you want to display the grid in the sketching environment, select the Display
grid check box from the Grid area of the Document Properties - Grid/Snap
dialog box.

While drawing a sketched entity by snapping through grips, the grips symbol  is
displayed below the right of the cursor.

Figure 1-12  Modifying the grid and snap settings
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Note
Remember that these settings will only be for the current documents. When you open a new
document, it will have the settings that were defined while installing SolidWorks.

LEARNING ABOUT SKETCHER TERMS
Before you learn about the various sketching tools, it is important for you to understand
some terms that are used in the sketching environment. These terms are discussed next.

Origin
The origin is a red color icon that is displayed in the center of the sketching environment
screen. This icon consists of two arrows displaying the X and Y axes directions of the current
sketching plane. The point of intersection of these two axes is the origin point and the
coordinates of this point are 0,0.

Inferencing Lines
The inferencing lines are the temporary lines that are used to track a particular point on the
screen. These lines are dashed lines and are automatically displayed when you select a sketching
tool in the sketching environment. These lines are created from the endpoint of a sketched
entity or from the origin. For example, if you want to draw a line from the point where two
imaginary lines intersect, you can use the inferencing lines to locate the point and then draw
the line from that point. Figure 1-13 shows the use of inferencing lines to locate the point of
intersection of two imaginary lines.

Figure 1-14 shows the use of inferencing lines to locate the center of an arc. Notice that the
inferencing lines are created from the endpoint of the line and from the origin.

Figure 1-13  Using inferencing lines to locate a point
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Note
The inferencing lines that are displayed on the screen will be either blue or yellow. The blue
inferencing lines suggest that the relations are not added to the sketched entity and the yellow
inferencing lines suggest that the relations are added to the sketched entity. You will learn about
various relations in later chapters.

Select Tool

The Select tool is used to select a sketched entity or exit any sketching tool that is
active. You can select the sketched entities by selecting them one by one using the left
mouse button. You can also hold the left mouse button down and drag the cursor

around the multiple sketched entities to define a box and select the multiple entities. There
are two methods of selection, box selection and cross selection. You can also select multiple
entities by pressing the SHIFT and CTRL keys. In this release of SolidWorks, a new tool is
added that allows you to invert the current selection. All these selection related tools are
discussed next.

Note
You can also invoke the Select tool or exit a sketching tool by pressing the ESC key.

Invert Selection

With this release of SolidWorks, you are provided with an option invert the
selection set. By doing so, you can remove the entities in the current selection
set and select all the other entities that are not in the current selection set. To invert the
selection, select the entities that you do not want to be included in the final selection set and
then choose Tools > Invert Selection from the menu bar. You can also, invoke the Invert
Selection option from the shortcut menu. All the entities that were not selected earlier are
now selected and the entities that were in the selection set earlier are now removed from the
selection set.

Figure 1-14  Using inferencing lines to locate the center of a circle

Toolbar: Standard > Select

Menu: Tools > Invert Selection
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Selecting Entities Using the Box Selection
A box is a window created by pressing the left mouse button and dragging the cursor from
left to right in the drawing area. A box has a property that all entities that lie completely
inside it will be selected. The selected entities will be displayed in green.

Selecting Entities Using the Cross Selection
When you press the left mouse button and drag the cursor from right to left in the drawing
area, the cross selection method is invoked. The box drawn in the cross selection method
consists of dashed lines. The cross selection method has a property that all entities that lie
completely or partially inside the dashed box or the entities that touch the dashed box will
be selected.

Selecting Entities Using the SHIFT and CTRL Keys
You can also use the SHIFT and the CTRL keys from the keyboard to manage
the selection procedure. If you have selected some entities and you need to
select more entities using the windows or crossing selection, press and hold
the SHIFT key. Now, create a window or a crossing selection; all the entities that touch the
crossing or those are inside the window are selected. You can also, invert the current selection
without invoking the Invert Selection tool. To do that, select the entities that you do not
want to be included in the selection set and press the CTRL key. Now, drag a window or
crossing, all the entities that touch the crossing or those are inside the window are selected
and the entities selected earlier are removed from selection set.

Now, you are familiar with the important sketching terms. Next, you will learn about the
sketching tools available in SolidWorks.

DRAWING LINES

Lines are one of the basic sketching entities available in SolidWorks. In general
terms, a line is defined as the shortest distance between two points. As
mentioned earlier, SolidWorks is a parametric solid modeling tool. This property
allows you to draw a line of any length and at any angle and later force it to the

desired length and angle. To draw a line in the sketching environment of SolidWorks, choose
the Line tool from the Sketch CommandManager. You can also invoke the Line tool by
pressing L from the keyboard. You will notice that the cursor, which was an arrow earlier, is
replaced by the line cursor. The line cursor is actually a pencil-like cursor with a small inclined
line below the pencil. Also, the Insert Line PropertyManager is displayed, as shown in
Figure 1-15.

The Message rollout of the Insert Line PropertyManager informs you to edit the settings of
the next line or sketch a new line. Using the options available in this PropertyManager, you
can set the orientation and other sketching options of drawing a line. All these options are
discussed next.

CommandManager: Sketch > Line
Menu: Tools > Sketch Entities > Line
Toolbar: Sketch > Line

c01-solidworks-2006-eval.p65 9/8/2005, 2:28 PM15
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Orientation Rollout
The Orientation rollout is used to define the orientation of the line to be drawn. By default,
the As sketched radio button is selected and you can draw the line in any orientation. If you
select the Horizontal radio button, you can only draw horizontal lines. When you select this
radio button, the Parameters rollout is displayed  and you can specify the length of the line
in the Length spinner provided in this rollout. If you select the Add dimension check box
from this rollout, a dimension displaying the length of the line will be applied to the drawn
line. You will learn more about dimensioning in the later chapters.

If you select the Vertical radio button, you can only draw vertical lines. The Parameters
rollout is also displayed where you can set the parameters for drawing the vertical line.

The Angle radio button is selected to draw lines at a specified angle. When you select this
radio button, the Parameters rollout is displayed, where you can set the values of the length
of the line and the angle or orientation.

Options Rollout
The For construction check box available in this rollout is used to draw a construction line.
You will learn more about construction lines later in this chapter. The Infinite length check
box is used to draw a line of infinite length.

After setting the options in this PropertyManager, you need to draw the line. In SolidWorks,
there are two methods of drawing lines. The first method is to draw continuous lines and the
second method is to draw individual lines. Both these methods are discussed next.

Drawing Chain of Continuous Lines
This is the default method of drawing lines. In this method, you just have to specify the start
point and the endpoint of the line using the left mouse button. As soon as you specify the

Figure 1-15  The Insert Line PropertyManager
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start point of the line, the Line Properties PropertyManager will be displayed. The options
in the Line Properties PropertyManager will not be available at this stage.

After specifying the start point, move the cursor away from it and specify the endpoint of the
line using the left mouse button. A line will be drawn between the two points. You will notice
that the line is green and has filled circles at the two ends. The line will be displayed in green
because it is still selected.

Move the cursor away from the endpoint of the line and you will notice that another line is
attached to cursor. The start point of this line is the endpoint of the last line and the length
of this line can be increased or decreased by moving the cursor. Because this line stretches
like a rubber band as you move the cursor, it is called a rubber-band line. The point that you
specify next on the screen will be taken as the endpoint of the second line and a line will be
drawn such that the endpoint of the second line is taken as the start point of the new line and
the point you specify is taken as the endpoint of the new line. Now, a new rubber-band line is
displayed starting from the endpoint of the last line. This is a continuous process and you can
draw a chain of as many continuous lines as you need by specifying the points on the screen
using the left mouse button.

You can exit the continuous line drawing process by pressing the ESC key from the keyboard,
by choosing the Select tool, or by double-clicking on the screen. You can also right-click to
display the shortcut menu and choose the End Chain option from the shortcut menu.

Figure 1-16 shows a sketch drawn using continuous lines. This sketch is started from the
lower left corner and the horizontal line is drawn first. To close the loop using the last line, as
soon as you move the cursor close to the start point of the first line, you will notice that a red
circle is displayed at the start point. If you specify the endpoint of the line at this stage, the
loop will be closed and no rubber-band line will be displayed now. This is because the loop is
already closed and you may not need another continuous line now. However, the Line tool is
still active and you can draw other lines.

Figure 1-16  Sketch drawn with the help of continuous lines
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Note
When you exit the line drawing process by double-clicking on the screen or by choosing End
chain from the shortcut menu, the current chain is ended but the Line tool is still active and
you can draw other lines.

Drawing Individual Lines
This is the second method of drawing lines. Using this method, you can draw individual lines
and the start point of the next line will not necessarily be the endpoint of the last line. To
draw individual lines, you need to press and hold the left mouse button down and drag the
cursor from the start point of the line to the endpoint. Once you have dragged the cursor to
the endpoint, release the left mouse button; a line will be drawn between the two points.

To make the process of sketching easy in SolidWorks, you are provided with the
PropertyManager. The PropertyManager is a table that will be displayed on the left of the
screen as soon as you select the first point of any sketched entity. The PropertyManager has
all parameters related to the sketched entity such as the start point, endpoint, angle, length,
and so on. You will notice that as you start dragging the mouse, the Line Properties
PropertyManager is displayed on the left of the drawing area. All options in the Line
Properties PropertyManager will be available when you release the left mouse button.
Figure 1-17 shows a partial view of the Line Properties PropertyManager.

Note
The Line Properties PropertyManager will also display additional options about relations.
You will learn more about relations in later chapters.

After you have drawn the line, modify the parameters in the Line Properties PropertyManager
to make the line to the desired length and angle. You can also dynamically modify the line by
holding its endpoints and dragging them.

Figure 1-17  Partial display of the Line Properties
PropertyManager
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Line Cursor Parameters
When you draw lines in the sketching environment of SolidWorks, you will notice that a
numeric value is displayed above the line cursor, see Figure 1-18. This numeric value indicates
the length of the line you draw. This value is the same as that in the Length spinner of the
Line Properties PropertyManager. The only difference is that in the Line Properties
PropertyManager, the value will be displayed with more precision.

The other thing that you will notice while sketching is that sometimes when you are drawing
vertical or horizontal lines, a  or  symbol is displayed below the line cursor. These are the
symbols of the Vertical and Horizontal relations. SolidWorks automatically applies these
relations to the lines. These relations ensure that the lines you draw are vertical or horizontal
and not inclined. Figure 1-19 shows the symbol of the Vertical relation on a line and Figure 1-20
shows the symbol of the Horizontal relation on a line.

Note
In addition to the Horizontal and Vertical relations, you can apply a number of other relations
such as Tangent, Concentric, Perpendicular, Parallel, and so on. You will learn about all
these relations in later chapters.

The other options of the Line Properties PropertyManager will be discussed in later chapters.

Figure 1-20  Symbol of the Horizontal relationFigure 1-19  Symbol of the Vertical relation

Figure 1-18  The length of the line displayed
on the screen while drawing the line
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Drawing Tangent or Normal Arcs Using the Line Tool
SolidWorks allows you to draw tangent or normal arcs originating from the endpoint of the
line while drawing continuous lines. Note that these arcs can be drawn only if you have drawn
at least one line, arc, or spline. To draw such arcs, draw a line by specifying the start point and
the endpoint. Move the cursor away from the endpoint of the last line to display the
rubber-band line. Now, when you move the cursor back to the endpoint of the last line, the
arc mode is invoked and the line cursor is replaced by the arc cursor. The angle and the
radius of the arc is displayed above the arc cursor. You can also invoke the arc mode by
right-clicking and choosing Switch to arc from the shortcut menu or pressing the A key from
the keyboard.

To draw a tangent arc, invoke the arc mode by moving the cursor back to the endpoint of the
last line. Now, move the cursor through a small distance along the tangent direction of the
line; a dotted line will be drawn. Next, move the cursor in the direction in which the arc
should be drawn. You will notice that a tangent arc is drawn. Specify the endpoint of the
tangent arc using the left mouse button. Figure 1-21 shows an arc tangent to an existing line.
To draw a normal arc, invoke the arc mode. Now, move the cursor through a small distance in
the direction normal to the line and then move it in the direction of the endpoint of the arc;
the normal arc will be drawn, as shown in Figure 1-22.

As soon as the endpoint of the tangent or normal arc is defined, the line mode will be invoked

Figure 1-21  Drawing a tangent arc using the Line tool

Figure 1-22  Drawing a normal arc using the Line tool
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again. You can continue drawing lines using the line mode or move the cursor back to the
endpoint of the arc to invoke the arc mode.

Note
If the arc mode is invoked by mistake while drawing lines, you can cancel the arc mode and
invoke the line mode again by pressing the A key from the keyboard. Alternatively, you can
right-click and choose Switch to Line from the shortcut menu or move the cursor back to the
endpoint and press the left mouse button to invoke the line mode.

Drawing Construction Lines or Centerlines

Construction lines or centerlines are those that are drawn only for the aid of
sketching. These lines are not considered while converting the sketches into
features. You can draw a construction line similar to the sketched line by using
the Centerline tool. You will notice that when you draw a construction line, the

For Construction check box in the Line Properties PropertyManager is selected. You can
also draw a construction line by sketching the line using the Line tool and then selecting the
For Construction check box available in the Line Properties PropertyManager. When you
select this check box, the line is turned into a centerline.

DRAWING CIRCLES

In SolidWorks, there are two methods of drawing circles. The first method is by
specifying the center point of a circle and then defining its radius. The second
method is to draw a circle by defining three points that lie on its periphery. Both
these methods are discussed next. To draw a circle, choose the Circle button

from the Sketch CommandManager; the Circle PropertyManager will be displayed, as shown
in Figure 1-23.

Drawing Circles by Defining its Centerpoint
When you invoke the Circle PropertyManager, the Center creation radio button is selected
by default in the Parameters rollout. This radio button is selected to draw a circle by specifying
its center. You will notice that the arrow cursor is replaced by the circle cursor. The circle
cursor consists of a pencil and two concentric circles below the pencil. Specify the center
point of the circle and then move the cursor to define its radius. The current radius of the
circle is displayed above the circle cursor. This radius will change as you move the cursor. The
coordinates of the center point of the circle and the radius, updated dynamically, are shown
in the Circle PropertyManager. You can define any arbitrary radius of the circle and then
modify it to the desired value by using the Circle PropertyManager. Figure 1-24 shows a
circle being drawn using the Center creation option of the Circle tool.

CommandManager: Sketch > Centerline
Menu: Tools > Sketch Entities > Centerline
Toolbar: Sketch > Centerline

CommandManager: Sketch > Circle
Menu: Tools > Sketch Entities > Circle
Toolbar: Sketch > Circle

c01-solidworks-2006-eval.p65 9/8/2005, 2:28 PM21



1-22               SolidWorks for Designers (Evaluation Copy SW009/005)

Drawing Circles by Defining Three Points
The Perimeter creation radio button is used to draw a circle by defining three points on it.

To draw a circle using this option, invoke the Circle PropertyManager and select the Perimeter
creation radio button from the Parameters rollout. The select cursor will be replaced by a
three point circle cursor. Specify the first point of the circle in the drawing area. Now, specify
the other two points on the circle. The resulting circle will be highlighted in green and you
can set its parameters in the Circle PropertyManager. Figure 1-25 shows a circle being drawn
by specifying three points on it.

Drawing Construction Circles
If you want to sketch a construction circle, draw a circle using the Circle tool and then select
the For construction check box available in the Circle PropertyManager.

DRAWING ARCS
In SolidWorks, you can draw arcs using three methods: Tangent/Normal Arc, Centerpoint

Figure 1-24  Drawing a circle using the Center creation option

Figure 1-23  The Circle PropertyManager
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Tip. To convert a construction entity back to the sketched entity, invoke the Select
tool and then select the construction entity; the entity will turn green and the
PropertyManager will be displayed on the left of the drawing area. From the
PropertyManager, clear the For Construction check box; the construction entity
will again be changed into a sketched entity and will be displayed with a continuous
line.

Arc, and 3 Point Arc. All these methods can be invoked separately by choosing their respective
buttons from the Sketch CommandManager. These methods are discussed next.

Drawing Tangent/Normal Arcs

The tangent arcs are those that are drawn tangent to an existing sketched entity.
The existing sketched entities include sketched and construction lines, arcs, and
splines. The normal arcs are those that are drawn normal to an existing entity.
You can draw tangent and normal arcs using the Tangent Arc tool.

To draw a tangent arc, invoke the Tangent Arc tool; the arrow cursor will be replaced by the
arc cursor. Move the arc cursor close to the endpoint of the entity you want to select as the
tangent entity. You will notice that a red circle is displayed at the endpoint. Also, a yellow
symbol displaying two concentric circles appears below the pencil. Now, press the left mouse
button once and move the cursor along the tangent direction through a small distance and
then move the cursor to size the arc. The arc will start from the endpoint of the tangent entity
and its size will change as you move the cursor. Note that the angle and the radius of the
tangent arc are displayed above the arc cursor, see Figure 1-26.

CommandManager: Sketch > Tangent Arc
Menu: Tools > Sketch Entities > Tangent Arc
Toolbar: Sketch > Tangent Arc

Figure 1-25  Drawing a circle using the Perimeter creation option
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To draw a normal arc, invoke the Tangent Arc tool. Move the arc cursor close to the endpoint
of the entity you want to select as the normal entity. A red circle will be displayed at the
endpoint and a yellow symbol displaying two concentric circles appears below the pencil.
Now, press the left mouse button once and move the cursor along the normal direction
through a small distance and then move the cursor to size the arc, refer to Figure 1-27.

While drawing the arc, as soon as you start moving the cursor after specifying the start point,
the Arc PropertyManager will be displayed. However, the options in the Arc PropertyManager

Figure 1-26  Drawing a tangent arc

Figure 1-27  Drawing a normal arc

Tip. You can invoke the list of recently used commands by right-clicking in the
drawing area. The cascading menu that is displayed when you choose the Recent
Command option from the shortcut menu displays the eight most recent commands.
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CommandManager: Sketch > Centerpoint Arc
Menu: Tools > Sketch Entity > Centerpoint Arc
Toolbar: Sketch > Centerpoint Arc

are not enabled at this stage. These options are enabled only after you have completed drawing
the tangent or normal arc.

You can draw an arbitrary arc and then modify its value using the Arc PropertyManager.
Figure 1-28 shows a partial view of the Arc PropertyManager.

Note
When you select a tangent entity to draw a tangent arc, the Tangent relation is applied between
the start point of the arc and the tangent entity. Therefore, if you change the coordinates of the
start point of the arc, the tangent entity will also be modified accordingly.

Drawing Centerpoint Arcs

The center point arcs are those that are drawn by defining the center point,
start point, and endpoint of the arc. When you invoke this tool, the arrow cursor
is replaced by the arc cursor. As mentioned earlier, an arc cursor consists of a
pencil and an arc below the pencil.

To draw a center point arc, invoke the Centerpoint Arc tool and then move the arc cursor to
the point that you want to specify as the center point of the arc. Press the left mouse button
once at the location of the center point and then move the cursor to the point from where
you want to start the arc. You will notice that a dotted circle is displayed on the screen. The
size of this circle will modify as you move the mouse. This circle is drawn for your reference
and the center point of this circle lies at the point that you specified as the center of the arc.

Figure 1-28  Partial display of the Arc PropertyManager
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Figure 1-30  Moving the cursor to specify the start point and the endpoint of the arc

Figure 1-29  Specifying the center point and the start point of the center point arc

Press the left mouse button once at the point that you want to select as the start point of the
arc. Next, move the cursor to specify the endpoint of the arc. You will notice that the reference
circle is no longer displayed and an arc is being drawn with the start point as the point that
you specified after specifying the center point. Also, the Arc PropertyManager, similar to
the one that is shown in the tangent arc, is displayed on the left of the drawing area. Note
that the options in the Arc PropertyManager will not be available at this stage.

If you move the cursor in the clockwise direction, the resulting arc will be drawn in the
clockwise direction. However, if you move the cursor in the counterclockwise direction, the
resulting arc will be drawn in the counterclockwise direction. Specify the endpoint of the arc
using the left mouse button. Figure 1-29 shows the reference circle that is drawn when you
move the mouse button after specifying the center point of the arc and Figure 1-30 shows the
resulting center point arc.
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Figure 1-31  Specifying the start point and the endpoint of the arc

Drawing 3 Point Arcs

The three point arcs are those that are drawn by defining the start point and
endpoint of the arc, and a point somewhere on the arc. When you invoke this
tool, the arrow cursor is replaced by the arc cursor.

To draw a three point arc, invoke the 3 Point Arc tool and then move the arc cursor to the
point that you want to specify as the start point of the arc. Press the left mouse button once at
the location of the start point and then move the cursor to the point that you want specify as
the endpoint of the arc. As soon as you start moving the cursor after specifying the start
point, a reference arc will be drawn and the Arc PropertyManager will be displayed. However,
the options in the Arc PropertyManager will  not be available at this stage.

Using the left mouse button, specify the endpoint of the arc. You will notice that the reference
arc is no longer displayed. Instead, a solid arc is displayed and the cursor is attached to the
arc. As you move the cursor, the arc will also be modified dynamically. Using the left mouse
button, specify a point on the screen to create the arc. The last point that you specify will
determine the direction of the arc. The options in the Arc PropertyManager will be displayed
once you draw the arc. You can modify the properties of the arc using the Arc
PropertyManager. Figure 1-31 shows the reference arc that is drawn by specifying the start
point and the endpoint of the arc and Figure 1-32 shows the resulting three point arc.

CommandManager: Sketch > 3 Point Arc
Menu: Tools > Sketch Entities > 3 Point Arc
Toolbar: Sketch > 3 Point Arc
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Figure 1-33  Drawing a rectangle by specifying two opposite corners

DRAWING RECTANGLES

In SolidWorks, the rectangles are drawn by specifying two opposite corners of
the rectangle. To draw a rectangle, invoke the Rectangle tool; the arrow cursor
will be replaced by the rectangle cursor. Move the cursor to the point that you
want to specify as the first corner of the rectangle. Press the left mouse button

once at the first corner and then move the cursor and specify the other corner of the rectangle
using the left mouse button. You will notice that the length and width of the rectangle are
displayed above the rectangle cursor. The length is measured along the X axis and the width
is measured along the Y axis. Figure 1-33 shows a rectangle being drawn by specifying two
opposite corners.

CommandManager: Sketch > Rectangle
Menu: Tools > Sketch Entities > Rectangle
Toolbar: Sketch > Rectangle

Figure 1-32  Specifying a point on the arc to draw it
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Note
When you draw a rectangle, the PropertyManager will not be displayed. This is because a
rectangle is considered as a combination of four individual lines. Therefore, after drawing the
rectangle, if you select one of the lines of the rectangle using the Select tool, the Line
Properties PropertyManager will be displayed. You can modify the parameters of the selected
line using the Line Properties PropertyManager.

Remember that because the relations are applied to all four corners of the rectangle, if you
modify the parameters of one of the lines using the Line Properties PropertyManager, the
other three lines will also be modified accordingly.

You can convert a rectangle into a construction rectangle by selecting all lines together using a
window and then selecting the For construction check box from the PropertyManager.

DRAWING PARALLELOGRAMS

In SolidWorks, the Parallelogram tool can be used to draw a parallelogram and also to draw
a rectangle at an angle. The methods used to draw both these entities are discussed next.

Drawing a Rectangle at an Angle
To draw a rectangle at an angle, invoke the Parallelogram tool from the menu bar. The
cursor will be replaced by the parallelogram cursor. Move the cursor to the point you want to
specify as the start point of one of the edges of the rectangle. Press the left mouse button
once at this point and move the cursor to size the edge. You will notice that a reference line
is being drawn. Depending on the current position of the cursor, the reference line will be
horizontal, vertical, or inclined at some angle. The current length of the edge and its angle
will be displayed above the parallelogram cursor. Using the left mouse button, specify the
endpoint of the edge such that the resulting reference line is at an angle.

Next, move the cursor to specify the width of the rectangle. You will notice that a reference
rectangle is drawn at an angle. Also, irrespective of the current position of the cursor, the
width will be specified normal to the first edge, either above or below. Using the left mouse
button, specify a point on the screen to define the width of the rectangle. The reference
rectangle will be converted into a sketched rectangle. Figure 1-34 shows a rectangle drawn at
an angle.

Drawing a Parallelogram
To draw a parallelogram, invoke the Parallelogram tool from the menu bar. The cursor will
be replaced by the parallelogram cursor. Specify two points on the screen to define one edge
of the parallelogram. Next, press the CTRL key from the keyboard once and then move the
mouse to define the width of the parallelogram. You will notice that the width is no longer
added normal to the first edge. As you move the mouse, a reference parallelogram will be
drawn. The size and shape of the reference parallelogram will depend on the current location
of the cursor.

Menu: Tools > Sketch Entities > Parallelogram
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Specify a point on the screen to define the parallelogram. Figure 1-35 shows a parallelogram
drawn at an angle.

Note
Similar to rectangles, each edge of a parallelogram is considered as a separate line. Also, in the
case of parallelograms, the PropertyManager is not displayed while you are drawing it.

DRAWING POLYGONS

A polygon is defined as a multisided geometric figure in which the length of all sides and the
angle between them are the same. In SolidWorks, you can draw a polygon with the number of
sides ranging from 3 to 40. The dimensions of a polygon are controlled using the diameter of
a construction circle that is either inscribed inside the polygon or circumscribed outside the
polygon. If the construction circle is inscribed inside the polygon, the diameter of the
construction circle will be taken from the edges of the polygon. If the construction circle is
circumscribed about the polygon, the diameter of the construction circle will be taken from
the vertices of the polygon.

To draw a polygon, invoke the Polygon tool; the Polygon PropertyManager will be displayed,
as shown in Figure 1-36.

Set the parameters such as the number of sides, inscribed or circumscribed circle, and so on,
in the Polygon PropertyManager. You can also modify these parameters after drawing the
polygon. When you invoke this tool, the arrow cursor will be replaced by the polygon cursor.
Press the left mouse button at the point that you want to specify as the center point of the
polygon and then move the cursor to size the polygon. The length of each side and the

Menu: Tools > Sketch Entities > Polygon

Tip. You can also invoke the tools to draw lines, arcs, circles, or rectangles using
the shortcut menu that is displayed when you right-click in the drawing area.

Figure 1-35  Parallelogram at an angleFigure 1-34  Rectangle at an angle
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Figure 1-36  The Polygon PropertyManager

rotation angle of the polygon will be displayed above the polygon cursor as you drag it. Using
the left mouse button, specify a point on the screen after you get the desired length and
rotation angle of the polygon. You will notice that based on whether you selected the Inscribed
circle or the Circumscribed circle radio button in the Polygon PropertyManager, a
construction circle will be drawn inside or outside the polygon. After you have drawn the
polygon, you can modify the parameters such as the center point of the polygon, the diameter
of the construction circle, the angle of rotation, and so on using the Polygon PropertyManager.
If you want to draw another polygon, choose the New polygon button provided below the
Angle spinner in the Polygon PropertyManager.

Figure 1-37 shows a six-sided polygon with the construction circle inscribed inside the polygon
and Figure 1-38 shows a five-sided polygon with the construction circle circumscribed outside
the polygon. Note that the reference circle is retained with the polygon. Remember that this
circle will not be considered while converting the polygon into a feature.
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Figure 1-37  Six-sided polygon with construction circle
inscribed inside the polygon

DRAWING SPLINES

In SolidWorks, you can draw a spline by continuously specifying the endpoints of
the spline segments using the left mouse button. This method of drawing splines
is similar to that of drawing continuous lines. After specifying all points of the
spline, right-click and choose Select to exit the Spline tool. Choosing End Spline

Figure 1-38  Five-sided polygon with construction
circle circumscribed outside the polygon

CommandManager: Sketch > Spline
Menu: Tools > Sketch Entities > Spline
Toolbar: Sketch > Spline
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Figure 1-39  Sketched spline with its start point at the origin

Tip. After creating the spline, when you select it using the Select tool, the Spline
PropertyManager is displayed. The current handle will be displayed with a cyan
filled square and its number and the corresponding X and Y coordinates will be
displayed in the Spline PropertyManager. You can modify these coordinates to
modify the selected spline. A double-sided arrow will also be displayed along with
the handle. You will learn more about this in the later chapters.

CommandManager: Sketch > Point
Menu: Tools > Sketch Entities > Point
Toolbar: Sketch > Point

will exit the current spline but the Spline tool will still be active and you can draw another
spline. Figure 1-39 shows a spline drawn with its start point at the origin.

Note
Handles are provided on the spline where points are specified to draw a spline. These handles
are displayed when you select the spline using the Select tool. You will learn more about these
handles in the later chapters while editing splines.

Similar to drawing individual lines, you can also create individual spline segments by specifying
the start point and then dragging the mouse to specify the endpoint.

PLACING SKETCHED POINTS

To place a sketched point, choose the Point tool from the CommandManager
and then specify the point on the screen where you want to place the sketched
point. The Point PropertyManager will be displayed with the X and Y coordinates
of the current point. You can modify the location of the point by modifying its X

and Y coordinates in the Point PropertyManager.
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Menu: Tools > Sketch Entities > Partial Ellipse

DRAWING ELLIPSES

In SolidWorks, an ellipse is drawn by specifying its center point and then specifying the two
ellipse axes by moving the mouse. To draw an ellipse, invoke the Ellipse tool from the menu
bar; the arrow cursor will be replaced by the ellipse cursor. Move the cursor to the point that
you want to specify as the center point of the ellipse. Press the left mouse button once at the
center point of the ellipse and then move the cursor to specify one of the ellipse axes. You
will notice that a reference circle is drawn and two values are displayed above the ellipse
cursor, see Figure 1-40. The first value that shows R = * is the radius of the first axis that you
are defining and the second value that shows r = * is the radius of the other axis. While
defining the first axis, the second axis is taken equal to the first axis. This is the reason why a
reference circle is drawn and not a reference ellipse.

Specify a point on the screen to define the first axis. Next, move the cursor to size the other
ellipse axis. You will notice that the Ellipse PropertyManager is displayed. As you move the
cursor, the second value above the ellipse cursor that shows r = * will change dynamically as
you move the cursor on the screen. Using the left mouse button, specify a point on the screen
to define the second axis of the ellipse, see Figure 1-41.

DRAWING ELLIPTICAL ARCS

In SolidWorks, the process of drawing an elliptical arc is similar to that of drawing an ellipse.
You will follow the same process of defining the ellipse first. The point that you specify on the
screen to define the second axis of the ellipse is taken as the start point of the elliptical arc.
You can define the endpoint of the elliptical arc by specifying a point on the screen, as shown
in Figure 1-42.

Menu: Tools > Sketch Entities > Ellipse

Figure 1-40  Dragging the cursor to define the first axis
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Figure 1-42  Drawing the elliptical arc

You can also set the parameters of the elliptical arc in the Ellipse PropertyManager shown in
Figure 1-43.

DRAWING PARABOLIC CURVES

In SolidWorks, you can draw a parabolic curve by specifying the focus point of the parabola
and then specifying two points on the guide of the parabolic curve. To draw a parabolic
curve, invoke the Parabola tool from the menu bar; the cursor will be replaced by the parabola
cursor. Move the cursor to the point that you want to specify as the focal point of the parabola.
Press the left mouse button once at the focal point and then move the cursor to define the
apex point and size the parabola. You will notice that a reference parabolic arc is displayed.
As you move the cursor away from the focal point, the parabola will be flattened. After you
get the basic shape of the parabolic curve, specify a point on the screen using the left mouse
button. This point is taken as the apex of the parabolic curve. Next, specify two points on the
screen with respect to the reference parabola to define the guide of the parabolic curve,
see Figure 1-44.

Figure 1-41  Defining the second axis of the ellipse

Menu: Tools > Sketch Entities > Parabola
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Figure 1-44  Drawing the parabola

As you move the mouse after specifying the focal point of the parabola, the Parabola
PropertyManager will be displayed. But the options in the Parabola PropertyManager will
not be available. These options will be available only after you have drawn the parabola.
Figure 1-45 shows a partial view of the Parabola PropertyManager.

DRAWING DISPLAY TOOLS
The drawing display tools are one of the most important tools provided in any of the solid
modeling software. These tools allow you to modify the display of a drawing by zooming or
panning it. Some of the drawing display tools available in SolidWorks are discussed in this
chapter. The remaining tools are discussed in the later chapters.

Figure 1-43  Partial view of the Ellipse PropertyManager
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Zoom to Fit

The Zoom to Fit tool is used to increase or decrease the drawing display area so that
all sketched entities or dimensions are fitted inside the current view.

Zoom to Area

The Zoom to Area tool is used to magnify a specified area so that the part of the
drawing inside the magnified area can be viewed in the current window. The area is
defined by a window that is created by dragging the cursor and specifying two opposite

corners of the window. When you choose this tool, the cursor is replaced by a magnifying
glass cursor. Press and hold the left mouse button down and drag the cursor to specify two
opposite corners of the window. The area enclosed inside the window will be magnified.

Zoom In/Out

The Zoom In/Out tool is used to dynamically zoom in or out of the drawing. When
you invoke this tool, the cursor is replaced by the zoom cursor. To zoom out of a
drawing, press and hold the left mouse button down and drag the cursor in the

downward direction. Similarly, to zoom in a drawing, press and hold the left mouse button

Figure 1-45  Partial view of the Parabola
PropertyManager

Menu: View > Modify > Zoom to Fit
Toolbar: View > Zoom to Fit

Menu: View > Modify > Zoom to Area
Toolbar: View > Zoom to Area

Menu: View > Modify > Zoom In/Out
Toolbar: View > Zoom In/Out
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Menu: View > Modify > Pan
Toolbar: View > Pan

Menu: View > Redraw

Tip. You can also invoke the Pan tool using the CTRL key and the arrow keys on
the keyboard. For example, to pan toward the right, press the CTRL key and then
press the right arrow key a few times. Similarly, to pan upward, press the CTRL
key  and then press the up arrow key a few times.

down and drag the cursor in the upward direction. As you drag the cursor, the drawing
display will be modified dynamically. After you get the desired view, exit this tool by choosing
the Select tool from the Sketch toolbar. You can also exit this tool by right-clicking and
choosing Select from the shortcut menu or by pressing the ESC key.

Zoom to Selection

The Zoom to Selection tool is used to modify the drawing display area such that the
selected entity is fitted inside the current display. After selecting the entity, choose
the Zoom to Selection button. The drawing display area will be modified such that

the selected entity fits inside the current view.

Pan

The Pan tool is used to drag the view in the current display. This process is similar to
changing the view by using the scroll bars available in the drawing area.

Redraw

The Redraw tool is used to refresh the screen. Sometimes when you draw a sketched entity,
some unwanted elements remain on the screen. To remove these unwanted elements from
the screen, choose this tool. The screen will be refreshed and all the unwanted elements will
be removed. You can also invoke this tool by pressing the CTRL+R keys from the keyboard.

DELETING SKETCHED ENTITIES
You can delete the sketched entities by selecting them using the Select tool and then pressing
the DELETE key from the keyboard. You can select the entities by selecting them individually
or select more than one entity by defining a window or crossing around the entities. When
you select the entities, they turn green. When they turn green, press the DELETE key from
the keyboard. You can also delete the sketched entities by selecting them and choosing the
Delete option from the shortcut menu that is displayed on right-clicking.

Menu: View > Modify > Zoom to Selection
Toolbar: View > Zoom to Selection

Tip. You can also use the keyboard shortcuts to invoke some of the drawing display
tools. For example, to invoke the Zoom to Fit tool, press the F key. Similarly, to
zoom out of a drawing, press the Z key and to zoom in, press the SHIFT+Z keys.
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TUTORIALS

In this tutorial, you will draw the sketch of the model shown in Figure 1-46. The sketch is
shown in Figure 1-47. You will not dimension the sketch. The solid model and the dimensions
are given only for your reference.     (Expected time: 30 min)

Figure 1-46  Solid model for Tutorial 1

Figure 1-47  Sketch of the model

Tutorial 1
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Figure 1-48  The New SolidWorks Document dialog box

The steps that will be followed to complete this tutorial are listed below:

a. Start SolidWorks and then start a new part document.
b. Switch to the sketching environment.
c. Draw the sketch of the model using the Line and Circle tools, refer to Figures 1-50

through 1-52.
d. Save the sketch and then close the document.

Starting SolidWorks and Starting a New Part Document
1. Start SolidWorks by choosing Start > Programs > SolidWorks 2006 > SolidWorks 2006

or by double-clicking on the shortcut icon of SolidWorks 2006 available on the desktop
of your computer.

The SolidWorks 2006 window is displayed along with the SolidWorks Resources Task
Pane on its right. The Getting Started, Online Resources, and Tip of the Day groups
are displayed in this Task Pane.

You can get many valuable tips from the Tip of the Day group. These tips are helpful to
make full utilization of this CAD package.

2. Choose the New Document option from the Getting Started group of the SolidWorks
Resources Task Pane to display the New SolidWorks Document dialog box.

4. The Part button is chosen by default. Choose the OK button from the New SolidWorks
Document dialog box shown in Figure 1-48; a new SolidWorks part document is started.
Also, the part modeling environment is active by default.
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Because you first need to draw the sketch of the feature, you need to invoke the sketching
environment.

5. Choose the Sketch button from the Standard toolbar; the Edit Sketch
PropertyManager is displayed and you are prompted to select a plane on which
you want to draw the sketch.

6. Select Front Plane from the drawing area; the sketching environment is invoked and the
plane is oriented normal to the view. You will notice that a red origin is displayed in the
center of the screen, indicating the sketching environment. The default screen appearance
of the sketching environment of SolidWorks is shown in Figure 1-49.

Tip. If the shortcut icon of SolidWorks is not created automatically on the desktop
of your computer when you install SolidWorks, you can create it manually. To
create the shortcut icon on the desktop, choose Start > Programs > SolidWorks
2006 to display the SolidWorks cascading menu. Right-click on SolidWorks 2006
in the cascading menu and then choose Send To > Desktop (create shortcut)
from the shortcut menu.

Figure 1-49  Screen display in the sketching environment
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Setting Units and Grid
It is assumed that while installing SolidWorks, you selected the option of measuring the
length in millimeters. This is the reason why the length will be measured in millimeter in
the current file. But if you selected some other unit, you need to make some initial
settings of changing the linear and angular units before you proceed with drawing the
sketch.

1. Choose Tools > Options from the menu bar to invoke the System Options - General
dialog box.

2. Choose the Document Properties tab; the name of the dialog box is changed to Document
Properties - Detailing.

3. Select the Units option from the area on the left to display the options related to linear
and angular units.

4. Select the MMGS (millimeter, gram, second) radio button from the Unit system area if
it is not selected by default. Also, select the Degrees option from the drop-down list
provided in the Angular units area.

Note
If you had selected Millimeters as the unit while installing SolidWorks, you can skip the points
discussed earlier in this section.

5. Select Grid/Snap from the area on the left. Set the value of the Major grid spacing
spinner to 100 and the value of the Minor-lines per major spinner to 20.

6. Now, choose the Go To System Snaps button; the system options related to relations and
snap are displayed.

7. Select the Grid check box from the Sketch Snaps area if it is cleared. Make sure that you
clear the Snap only when grid is displayed check box if it is selected. Choose OK to exit
the dialog box.

Drawing the Outer Loop of the Sketch
It is a good practice to draw the sketch on one side of the origin, preferably in the first
quadrant. This is because while generating the part program for manufacturing the part,
you will have a reference for work origin in advance.

The sketch of the model consists of an outer loop, two circles inside the outer loop, and
a cavity. Therefore, it will be drawn using the Line and Circle tools. You will first draw

Tip. If the grid is displayed on the screen when you invoke the sketching environment
for the first time, then you can set the option to turn off the grid display. Right-click
in the drawing area to display the shortcut menu. The Display Grid option has a
check mark on its left, indicating that this option is chosen. Select this option again
to turn the grids off.
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the outer loop and then the inner entities. Note that in the sketching environment, the
lower right corner of the SolidWorks window displays three areas. The first area displays
the X, Y, and Z coordinates of the current location of the cursor. These coordinates will
be modified as you move the cursor around the drawing area. You will use the coordinate
display to draw the sketch of the model.

You will start drawing the sketch from the lower left corner of the sketch and the outer
loop will be drawn using the continuous lines.

1. Choose the Line button from the Sketch CommandManager to invoke the
Line tool; the arrow cursor is replaced by the line cursor.

2. Move the cursor in the first quadrant close to the origin; the coordinates of the point are
displayed close to the lower right corner of the screen.

3. Press the left mouse button at the point whose coordinates are 10 mm, 10 mm, 0 mm and
then move the cursor horizontally toward the right.

You will notice that the symbol of the Horizontal relation is displayed below the line
cursor and the length of the line is displayed above the line cursor.

As the length of the first horizontal line at the lower left corner of the sketch is 10 mm,
you will move the mouse until the length of the line above the line cursor is shown as 10.

4. Press the left mouse button when the length of the line that is displayed above the line
cursor shows a value of 10. Make sure the Horizontal relation symbol is displayed below
the cursor.

The first horizontal line is drawn. Because you are drawing continuous lines, the endpoint
of the last line is automatically selected as the start point of the next line.

5. Move the line cursor vertically upward. The symbol of the Vertical relation is displayed
below the line cursor and the length of the line is displayed above the line cursor.

6. Press the left mouse button when the length of the line displayed above the line cursor
shows a value of 10 and the Vertical relation symbol is displayed below the cursor.

A vertical line of length 10 mm will be drawn and displayed in green. Also, as this is the
line that is selected now, the previous line will no longer be highlighted and therefore
will be displayed in blue.

7. Move the line cursor horizontally toward the right. Press the left mouse button when the
length of the line above the line cursor shows a value of 10. This draws the next horizontal
line of 10 mm length.

8. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor shows a value of 10.
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9. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor shows a value of 30.

10. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor shows a value of 10.

11. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor shows a value of 10.

12. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor shows a value of 10.

13. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor shows a value of 10.

14. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 40.

The next line that you need to draw is an inclined line that makes an angle of 135-degree.
To draw this line, you need to move the cursor in a direction that makes an angle of
135-degree.

15. Move the line cursor such that the line is drawn at an angle of 135-degree and the length of
the line displays a value of 14.14 above the cursor.

16. Press the left mouse button at this location to specify the endpoint of the inclined line.

17. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 50.

You will notice that some yellow inferencing lines are displayed when you move the cursor.

18. Move the line cursor in the direction diagonally downward where the value of the angle
displays a value of 135-degree and the length of the lines displays a value of 14.14.

19. Press the left mouse button at this location.

20. Move the cursor vertically downward to the start point of the first line.

You will notice that when you move the cursor close to the start point of the first line, a
red circle is displayed. Symbols of the Vertical and Coincident relations are displayed on
the right of the cursor. The length of the line shows a value of 40.

Tip. If by mistake you invoke the arc mode while drawing lines, move the cursor
back to the endpoint of the previous line and press the left mouse button. The line
mode will be invoked again.
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21. Press the left mouse button when the red circle is displayed. Right-click to display the
shortcut menu and choose the Select option to exit the Line tool.

This completes the sketch of the outer loop. Note that the display of the sketch is
small. Therefore, you need to modify the drawing display area such that the sketch fits
the screen. This is done using the Zoom to Fit tool.

22. Choose the Zoom to Fit button from the View toolbar to fit the current sketch on
the screen. The outer loop of the sketch is completed and is shown in Figure 1-50.
Note that in this figure, the display of grid is temporarily turned off for better
visibility. To do so, clear the Display grid check box from the Grid area of the Document
Properties - Grid/Snap dialog box.

Drawing Circles
The circles will be drawn using the Circle tool. You will use the inferencing line originating
from the start points and endpoints of the inclined lines to specify the center point of the
circles. At a given time, you can either snap to grid or use inferencing lines to draw the
sketches. Therefore, you need to turn off the snapping to grid.

1. Choose Tools > Options from the menu bar to invoke the System Options - General
dialog box. Select Relations/Snaps from the left of this dialog box. Clear the Grid check
box and choose the OK button from this dialog box.

2. Choose the Circle button from the Sketch CommandManager to invoke the
Circle tool.

As the Select tool was active earlier, the cursor earlier was the arrow cursor. But when you
invoke the Circle tool, the arrow cursor will be replaced by the circle cursor.

4. Move the circle cursor close to the lower endpoint of the right inclined line and then
move it toward the left. Remember that you will not press the left mouse button at this
moment.

Figure 1-50  Outer loop of the sketch
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An inferencing line is displayed originating from the lower endpoint of the right inclined
line. When you move the cursor toward the left, you will notice that at the point where
the cursor is vertically in line with the upper endpoint of the right inclined line, another
inferencing line originates from the upper endpoint of the right inclined line. This
inferencing line will intersect the inferencing line generated from the lower endpoint of
the inclined line.

5. Press the left mouse button at the point where the inferencing lines from both the
endpoints of the inclined lines intersect. Now, move the circle cursor toward the left to
define a circle.

6. Press the left mouse button when the radius of the circle displayed above the circle cursor
shows a value close to 5.

7. The Circle PropertyManager is displayed. Set the value of the Radius spinner to 5 from
this PropertyManager.

8. Similarly, draw the circle on the left using the inferencing lines generating from the
endpoints of the left inclined line. The sketch after drawing the two circles inside the
outer loop is shown in Figure 1-51. In this figure also, the grids are turned off for clarity.

9. Right-click in the drawing area and choose Select to exit the Circle tool.

Drawing the Sketch of the Inner Cavity
Next, you will draw the sketch of the inner cavity. You will start drawing this sketch with
the lower horizontal line. Before proceeding further, you need to invoke the snap to grid
option.

1. Select the Grid option from the System Options dialog box. Now, invoke the Line tool
by pressing the L key from the keyboard; the arrow cursor is replaced by the line cursor.

2. Move the line cursor to a location whose coordinates are 30 mm, 25 mm, 0 mm.

Figure 1-51  Sketch after drawing the two inner circles
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3. Press the left mouse button at this point and move the cursor horizontally toward the
right. Press the left mouse button when the length of the line above the line cursor shows
a value of 30.

4. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 10.

5. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 10.

6. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

7. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 10.

8. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 5.

9. Move the line horizontally toward the left and press the left mouse button when the
length of the line on the line cursor displays a value of 10.

10. Move the line cursor vertically downward to the start point of the first line. Press the left
mouse button when the red circle is displayed. The length of the line at this point will
show a value of 10.

11. Right-click and choose Select from the shortcut menu. This completes the sketch for
Tutorial 1.

12. Choose the Zoom to Fit button from the Standard toolbar to fit the display of the sketch
on the screen. The final sketch for Tutorial 1 is shown in Figure 1-52.

Saving the Sketch
It is recommended that you create a separate folder for saving the tutorial files of this
book. When you invoke the option to save a document, the default folder \My Documents
will be displayed. You will create a folder with the name SolidWorks in the My Documents
folder and then create the folder of each chapter inside the SolidWorks folder. As a result,
you can save the tutorials of a chapter in the folder of that chapter.

1. Choose the Save button from the Standard toolbar to invoke the Save As dialog
box. Create the SolidWorks folder inside the \My Documents folder and then create
the c01 folder inside the SolidWorks folder.

2. Enter the name of the document as c01tut1 in the File name edit box and choose the
Save button. The document will be saved in the \My Documents\SolidWorks\c01 folder.

3. Close the document by choosing File > Close from the menu bar.
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Figure 1-53  Revolved model for Tutorial 2

Tip. If you open a document that was saved in the sketching environment, it will
be opened in the sketching environment only and not in the part modeling
environment.

In this tutorial, you will draw the basic sketch of the revolved solid model shown in Figure 1-53.
The sketch of the revolved solid model is shown in Figure 1-54. Do not dimension the sketch.
The solid model and dimensions are given only for your reference.

    (Expected time: 30 min)

Figure 1-52  Final sketch for Tutorial 1

Tutorial 2
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The steps that will be followed to complete this tutorial are listed below.

a. Start a new part document.
b. Switch to the sketching environment.
c. Modify the settings of the snap and grid so that the cursor jumps through a distance of

5 mm instead of 10 mm.
d. Draw the sketch of the model using the Line tool, refer to Figure 1-55.
e. Save the sketch and then close the document.

Starting a New Document
1. Choose the New button from the Standard toolbar to invoke the New

SolidWorks Document dialog box.

2. The Part button is chosen by default in the New SolidWorks Document dialog box.
Choose OK.

A new SolidWorks part document is started. As mentioned earlier, when you start a new
part document, the part modeling environment is active by default. But, because you
first need to draw the sketch of the revolved model, you need to invoke the sketching
environment.

3. Choose the Sketch button from the Standard toolbar to display the Edit
Sketch PropertyManager. Select Front Plane.

A red origin and the Sketch CommandManager are displayed. Also, the confirmation
corner is displayed with the Exit Sketch and Delete Sketch options on the upper right
corner of the drawing area. This indicates that the sketching environment is activated.

Figure 1-54  Sketch for the revolved model
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Modifying the Snap and Grid Settings and the Dimensioning Units
Before you proceed with drawing the sketch, you need to modify the grid and snap
settings so that you can make the cursor jump through a distance of 5 mm.

1. Choose Tools > Options from the menu bar to invoke the System Options - General
dialog box. Choose the Document Properties tab.

2. Select the Grid/Snap option from the area on the left to display the options related to
linear and angular units. Set the value of the Major grid spacing spinner to 50. Make
sure the value of the Minor-lines per major spinner is 10.

The coordinates close to the lower left corner of the SolidWorks window will show an increment
of 5 mm instead of the default increment of 25 mm when you exit the dialog box.

If you had selected a unit other than millimeter while installing SolidWorks, you need to
change the unit for the current drawing.

3. Select the Units option from the area on the left of the Document Properties - Grid/
Snap dialog box.

4. Select the MMGS (millimeter, gram, second) radio button from the Unit system area.

5. Make sure the Grid check box is selected in the System Options - Relation/Snaps dialog
box. After setting all parameters, choose the OK button.

Drawing the Sketch
As evident from Figure 1-52, the sketch will be drawn using the Line tool. You will start
drawing the sketch from the lower left corner of the sketch.

1. Choose the Line button from the Sketch CommandManager; the arrow cursor
is replaced by the line cursor.

2. Move the line cursor to a location whose coordinates are 40 mm, 0 mm, 0 mm.

3. Press the left mouse button down at this point and move the cursor horizontally toward
the right. Press the left mouse button again when the length of the line above the line
cursor shows a value of 20.

4. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 20.

5. Move the cursor horizontally toward the left and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

6. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 25.
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7. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor displays a value of 20.

8. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 5.

9. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 50.

10. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

11. Move the line cursor horizontally toward the right and press the left mouse button when
the length of the line on the line cursor displays a value of 20.

12. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 25.

13. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 5.

14. Move the line cursor vertically downward to the start point of the first line. Press the left
mouse button when the red circle is displayed. The length of the line at this point will be
20 mm

15. Right-click and choose Select from the shortcut menu.

The sketch is completed but does not fit the screen. Therefore, you need to modify the
display area such that the sketch fits the screen.

16. Choose the Zoom to Fit button from the View toolbar to fit the sketch on the
screen. The final sketch for Tutorial 2 is shown in Figure 1-55. In this figure, the
display of the grid is turned off for clarity.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog

box.

2. Enter the name of the document as c01tut2 in the File name edit box and choose the
Save button.

The document will be saved in the \My Documents\SolidWorks\c01 folder.

Tip. You will notice that the bottom horizontal line in the sketch is black and the
remaining lines are blue. In the next chapter, you will learn about the reason why
some entities in the sketch have a different color.
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Figure 1-56  Solid model for Tutorial 3

3. Close the document by choosing File > Close from the menu bar.

In this tutorial, you will draw the basic sketch of the model shown in Figure 1-56. The sketch
to be drawn is shown in Figure 1-57. Do not dimension the sketch; the solid model and
dimensions are given only for your reference.     (Expected time: 30 min)

Figure 1-55  Final sketch for Tutorial 2

Tutorial 3

c01-solidworks-2006-eval.p65 9/8/2005, 2:28 PM52



Drawing Sketches for Solid Models        1-53

Ev
al

ua
ti

on
 C

ha
pt

er
. 

D
o 

no
t 

co
py

. 
Vi

si
t 

w
w

w
.c

ad
ci

m
.c

om
 f

or
 d

et
ai

ls

The steps that will be followed to complete this tutorial are listed below.

a. Start SolidWorks and then start a new part file.
b. Switch to the sketching environment.
c. Modify the settings of the snap and grid so that the cursor jumps through a distance of

5 mm instead of 10 mm.
d. Draw the outer loop of the sketch using the Line tool, refer to Figure 1-58.
e. Draw the inner circle using the Circle tool, refer to Figure 1-59.
f. Save the sketch and then close the file.

Starting a New File
1. Choose the New button from the Standard toolbar to invoke the New

SolidWorks Document dialog box.

2. The Part button is chosen by default in the New SolidWorks Document dialog box.
Choose the OK button.

A new SolidWorks part document will be started. As you first need to draw the sketch of
the revolved model, you need to invoke the sketching environment.

4. Choose the Sketch button from the Standard toolbar. The Edit Sketch
PropertyManager is displayed. Select Front Plane.

A red origin is displayed and the Sketch CommandManager is displayed above the
drawing area. Also, the confirmation corner with the Exit Sketch and Delete Sketch
options is displayed on the upper right corner of the drawing area. This indicates that
the sketching environment is activated.

Figure 1-57  Sketch for Tutorial 3
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Modifying the Snap and Grid Settings and Dimensioning Units
As the dimensions in the sketch are multiple of 5, you need to modify the grid and
snap settings so that you can make the cursor jump through a distance of 5 mm instead
of 10 mm.

1. Choose Tools > Options from the menu bar to invoke the System Options - General
dialog box. Choose the Document Properties tab.

2. Select the Grid/Snap option from the area on the left to display the options related to
linear and angular units. Set the value of the Major grid spacing spinner to 50. Make
sure the value of the Minor-lines per major spinner is 10.

The coordinates displayed close to the lower left corner of the SolidWorks window will
show an increment of 5 mm instead of the default increment of 10 mm when you close
the dialog box.

3. Choose OK to close the dialog box.

Drawing the Outer Loop
As evident from Figure 1-57, the sketch consists of an outer loop and an inner circle.
Therefore, this sketch will be drawn using the Line and Circle tools. You will start drawing
from the lower left corner of the sketch. As the length of the lower horizontal line is 150
mm, you need to modify the drawing display area such that the drawing area in the first
quadrant is increased. This can be done using the Pan tool.

1. Choose the Pan button from the View toolbar; the arrow cursor is replaced by
the pan cursor.

2. Press and hold the left mouse button down and drag the cursor toward the bottom left
corner of the screen.

You will notice that the origin also moves toward the bottom left corner of the screen,
thus increasing the drawing area in the first quadrant.

3. After dragging the origin close to the lower left corner, release the left mouse button.

4. Choose the Line button from the Sketch CommandManager; the pan cursor
is replaced by the line cursor.

5. Move the line cursor to a location whose coordinates are 40 mm, 0 mm, 0 mm.

6. Press and hold the left mouse button down at this point and move the cursor horizontally
toward the right. Press the left mouse button again when the length of the line above the
line cursor shows a value of 150.
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7. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 40.

The next entity that has to be drawn is a tangent arc. As mentioned earlier, you can draw
a tangent arc using the Line tool also. Drawing arcs from within the Line tool is a
recommended method when you need to draw a sketch that is a combination of lines and
arcs. This increases the productivity by reducing the time taken in invoking the tools for
drawing an arc and then invoking the Line tool to draw lines.

8. Move the line cursor away from the endpoint of the last line and then move it back to the
endpoint.

The arc mode is invoked and the line cursor is replaced by the arc cursor. Also, the Arc
PropertyManager is displayed in place of the Line Properties PropertyManager.

9. Move the arc cursor vertically upward to a small distance.

10. When the dotted line is displayed, move the cursor toward the left.

You will notice that a tangent arc is being drawn. The angle of the tangent arc and its
radius are displayed above the arc cursor.

11. Press the left mouse button when the angle value above the arc cursor shows 180 and the
radius shows a value of 30 to complete the arc.

The required tangent arc is drawn. As mentioned earlier, the line mode is automatically
invoked after you have drawn the arc using the Line tool. Therefore, the arc cursor will
be replaced by the line cursor and the Arc PropertyManager will be replaced by the
Line Properties PropertyManager.

12. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 20.

13. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 30.

14. Move the line cursor vertically downward and press the left mouse button when the
length of the line on the line cursor displays a value of 5.

15. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 25.

16. Move the line cursor vertically upward and press the left mouse button when the length
of the line on the line cursor displays a value of 5.

17. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor displays a value of 35.
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Figure 1-58  Sketch after drawing the outer loop

18. Move the line cursor to the start point of the first line. Press the left mouse button when
the red circle is displayed.

The length of the line at this point will be 20 mm

19. Right-click and choose Select from the shortcut menu to exit the Line tool.

20. Choose the Zoom to Fit button to fit the sketch on the screen. This completes the
outer loop of the sketch. The sketch, after drawing the outer loop, is shown in
Figure 1-58.

Drawing the Circle
The circle in the sketch will be drawn using the Circle tool. The center point of the circle
will be the center point of the arc, which will be displayed by a plus sign. This plus sign is
automatically drawn when you draw the arc. You can select this center point to draw the
circle.

1. Choose the Circle button from the Sketch CommandManager to invoke the
Circle tool; the arrow cursor is replaced by the circle cursor.

2. Move the circle cursor close to the center point of the arc and press the left mouse button
when the red circle is displayed.

3. Move the cursor toward the left and when the radius of the circle above the circle cursor
shows a value of 15, press the left mouse button. A circle of 15 mm radius is drawn.

4. This completes the sketch for Tutorial 3. Right-click and choose the Select option from
the shortcut menu to exit the Circle tool.
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The final sketch for Tutorial 3 is shown in Figure 1-59.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog box.

2. Enter the name of the document as c01tut3 in the File name edit box and choose the
Save button.

3. Close the document by choosing File > Close from the menu bar.

In this tutorial, you will draw the sketch of the model shown in Figure 1-60. The sketch of the
model is shown in Figure 1-61. Do not dimension the sketch. The dimensions and the solid
model are given only for your reference.     (Expected time: 30 min)

Figure 1-59  Final sketch for Tutorial 3

Tutorial 4
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Figure 1-61  Sketch for Tutorial 4

Figure 1-60  Model for Tutorial 4

The steps that will be followed to complete this tutorial are listed below.

a. Start SolidWorks and then start a new part document.
b. Switch to the sketching environment.
c. Modify the settings of the snap and grid so that the cursor jumps through a distance of

5 mm instead of 10 mm.
d. Draw the sketch using the Line tool, refer to Figure 1-62.
e. Save the sketch and then close the file.
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Opening a New File
1. Choose the New button from the Standard toolbar to invoke the New

SolidWorks Document dialog box.

2. The Part button is chosen by default in the New SolidWorks Document dialog box.
Now, choose the OK button.

As you first need to draw the sketch of the model, you need to invoke the sketching
environment.

4. Choose the Sketch button from the Standard toolbar and select the Front Plane
to invoke the sketching environment.

Modifying the Snap and Grid Settings and Dimensioning Units
As evident in Figure 1-61, the dimensions in the sketch are multiple of 5. Therefore, you
need to modify the grid and snap settings so that the cursor jumps through a distance of
5 mm instead of 10 mm.

1. Choose Tools > Options from the menu bar to invoke the System Options - General
dialog box. Choose the Document Properties tab.

2. Select the Grid/Snap option from the area on the left to display the options related to
linear and angular units. Set the value of the Major grid spacing spinner to 50 and the
value of the Minor-lines per major spinner to 10.

The coordinates displayed close to the lower left corner of the SolidWorks window show
an increment of 5 mm when you close this dialog box.

3. Choose OK to close the dialog box.

Drawing the Sketch
The sketch will be drawn using the Line tool. The arc in the sketch will also be drawn
using the same tool. You will start drawing from the lower left corner of the sketch.

1. Invoke the Line tool by pressing the L key from the keyboard; the arrow cursor is replaced
by the line cursor.

2. Move the line cursor to a point whose coordinates are 30 mm, 0 mm, 0 mm.

3. Press the left mouse button at this point and move the cursor horizontally toward the
right. Press the left mouse button again when the length of the line above the line cursor
shows a value of 60.

The bottom horizontal line of 60 mm length is drawn.
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4. Choose the Zoom to Fit button from the View toolbar to increase the display of
the line that is drawn.

As mentioned earlier, you can also invoke the drawing display tools while some other tool
is active. After modifying the drawing display, the tool that was active before invoking the
drawing display tool will be restored and you can continue using that tool. Therefore,
after the drawing display area is modified, the Line tool will be restored and you can
continue drawing lines.

5. Move the line cursor along a direction that makes an angle close to 98-degree with the
positive X axis direction. The angle can be checked from the spinner below the Length
spinner in the Line Properties PropertyManager.

6. Press the left mouse button when the length of the line displayed above the line cursor
shows a value of 35.36.

7. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line above the line cursor shows a value of 10.

8. Move the line cursor vertically downward and press the left mouse button when the
length of the line above the line cursor shows a value of 10.

9 Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line above the line cursor shows a value of 5.

Next, you need to draw the arc that is normal to the last line.

10. Move the line cursor away from the endpoint of the last line and then move it back close
to the endpoint.

The arc mode is invoked and the line cursor is replaced by the arc cursor. Also, the Line
Properties PropertyManager is replaced by the Arc PropertyManager.

11. Move the arc cursor vertically downward up to the next grid point.

12. Move the arc cursor toward the left.

You will notice that a normal arc is being drawn and the angle and radius of the arc is
displayed above the arc cursor.

13. Press the left mouse button when the angle value on the arc cursor is 180 and the radius
value is 10. An arc normal to the last line is drawn and the line mode is activated.

14. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor shows a value of 5.
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Figure 1-62  Final sketch for Tutorial 4

15. Move the line cursor vertically upward and press the left mouse button when the  length
of the line on the line cursor shows a value of 10.

16. Move the line cursor horizontally toward the left and press the left mouse button when
the length of the line on the line cursor shows a value of 10.

17. Move the line cursor to the start point of the first line and press the left mouse button
when the red circle is displayed.

18. Press the ESC key to exit the Line tool.

This completes the sketch. However, you need to modify the drawing display area such
that the sketch fits the screen.

19. Choose the Zoom to Fit button from the View toolbar to modify the drawing
display area. The final sketch for Tutorial 4, without the grid display, is shown in
Figure 1-62.

Saving the Sketch
1. Choose the Save button from the Standard toolbar to invoke the Save As dialog box.

2. Enter the name of the document as c01tut4 in the File name edit box and choose the
Save button.

3. Close the document by choosing File > Close from the menu bar.
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SELF-EVALUATION TEST
Answer the following questions and then compare your answers with those given at the
end of this chapter.

1. The base feature of any design is a sketched feature and is created by drawing the sketch.
(T/F)

2. You can also invoke the 3Pt Arc tool from within the Line tool. (T/F)

3. By default, the cursor jumps through a distance of 5 mm. (T/F)

4. When you save a file in the sketching environment, it is opened in the part modeling
environment when you open it the next time. (T/F)

5. You can convert a sketched entity into a construction entity by selecting the __________
check box provided in the PropertyManager.

6. To draw a rectangle at an angle, you need to use the __________ tool.

7. The __________ are the temporary lines that are used to track a particular point on the
screen.

8. You can also invoke the __________ tool or exit a sketching tool by pressing the ESC key.

9. When you select a tangent entity to draw a tangent arc, the __________ relation is applied
between the start point of the arc and the tangent entity.

10. The rectangle is considered as a combination of individual __________.

REVIEW QUESTIONS
Answer the following questions.

1. The three point arcs are those that are drawn by defining the start point of the arc, the
endpoint of the arc, and a point on the arc. (T/F)

2. You can also delete the sketched entities by selecting them and choosing the Delete
option from the shortcut menu, which is displayed on right-clicking. (T/F)

3. The origin is a blue icon that is displayed in the middle of the sketcher screen. (T/F)

4. In SolidWorks, circles are drawn by specifying the center point of the circle and then
entering the radius of the circle in the dialog box that is displayed. (T/F)
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5. When you open a new SolidWorks document, it is not maximized in the SolidWorks
window. (T/F)

6. In SolidWorks, a polygon is considered as a combination of which of the following entities?

(a) Lines (b) Arcs
(c) Splines (d) None

7. Which one of the following options is not displayed in the New SolidWorks Document
dialog box?

(a) Part (b) Assembly
(c) Drawing (d) Sketch

8. Which one of the following entities is not considered while converting a sketch into a
feature?

(a) Sketched circles (b) Sketched lines
(c) Construction lines (d) None

9. When you select a line of the rectangle, which of the following PropertyManagers will be
displayed?

(a) Line Properties PropertyManager (b) Line/Rectangle PropertyManager
(c) Rectangle PropertyManager (d) None

10. While drawing an elliptical arc, which of the following PropertyManagers will be
displayed?

(a) Arc PropertyManager (b) Ellipse PropertyManager
(c) Elliptical Arc PropertyManager (d) None

EXERCISES

Draw the sketch of the model shown in Figure 1-63. The sketch to be drawn is shown in
Figure 1-64. Do not dimension the sketch. The solid model and dimensions are given only
for your reference.     (Expected time: 30 min)

Exercise 1
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Figure 1-64  Sketch for Exercise 1Figure 1-63  Solid model for Exercise 1

Figure 1-66  Sketch for Exercise 2Figure 1-65  Solid model for Exercise 2

Exercise 2
Draw the sketch of the model shown in Figure 1-65. The sketch to be drawn is shown in
Figure 1-66. Do not dimension the sketch. The solid model and dimensions are given only
for your reference.     (Expected time: 30 min)

Answers to Self-Evaluation Test
1. T, 2. T, 3. F, 4. F, 5. For Construction, 6. Parallelogram, 7. inferencing lines, 8. Select,
9. Tangent, 10. lines
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