
Chapter 2

Drawing Sketches for 
Solid Models

  Learning Objectives 
After completing this chapter, you will be able to:
• Understand the need of the sketching environment.
• Open a new part document.
• Understand various terms used in the sketching environment.
• Use various sketching tools.
• Use the drawing display tools.
• Delete sketched entities.
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THE SKETCHING ENVIRONMENT
Most of the products designed by using SOLIDWORKS are a combination of sketched, placed, 
and derived features. The placed and derived features are created without drawing a sketch, 
but the sketched features require a sketch to be drawn first. Generally, the base feature of 
any design is a sketched feature and is created using the sketch. Therefore, while creating 
any design, the first and foremost requirement is to draw a sketch for the base feature. Once 
you have drawn the sketch, you can convert it into the base feature and then add the other 
sketched, placed, and derived features to complete the design. In this chapter, you will learn 
to create the sketch for the base feature using various sketching tools.

In general terms, a sketch is defined as the basic 
contour for a feature. For example, consider the 
solid model of a spanner shown in Figure 2-1. 

Figure 2-1  Solid model of a spanner

This spanner consists of a base feature, cut feature, 
mirror feature (cut on the back face), fillets, and 
an extruded text feature. The base feature of 
this spanner is shown in Figure 2-2. It is created 
using a single sketch drawn on the Front Plane, 
refer to Figure 2-3. This sketch is drawn in the 
sketching environment using various sketching 
tools. Therefore, to draw the sketch of the base 
feature, you first need to invoke the sketching 
environment where you will draw the sketch. 

Figure 2-2  Base feature of the spanner Figure 2-3  Sketch for the base feature of the spanner

Note
Once you are familiar with various options of SOLIDWORKS, you can also use a derived 
feature or a derived part as the base feature.

The sketching environment of SOLIDWORKS can be invoked anytime in the Part or Assembly 
mode. You just have to specify that you need to draw the sketch of a feature and then select 
the plane on which you need to draw the sketch.
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Note
You will learn to invoke the sketching environment in SOLIDWORKS 2015 later in this chapter.

STARTING A NEW SESSION OF SOLIDWORKS 2015
Double-click on the SOLIDWORKS 2015 icon; the SOLIDWORKS 2015 window will be 
displayed. If you are starting the SOLIDWORKS application for the first time after installing 
it, the SOLIDWORKS License Agreement dialog box will be displayed. Choose Accept 
from this dialog box; the Welcome to SOLIDWORKS dialog box will be displayed, as shown 
in Figure 2-4. This dialog box helps you customize various settings in SOLIDWORKS after 
installation. The options in this dialog box are discussed next.

Help customization Area
The options in this area are used to specify the type of help that you may need while working 
with SOLIDWORKS. By default, the I am a new user. Show Quick Tips to help me get started. 
radio button is selected in this area. Keep this radio button selected if you are a new user of 
SOLIDWORKS. As a result, the quick tips will appear on your screen to guide you through 
the process of starting as a new user. 

If you are an existing user of SOLIDWORKS, select the I am new to this version of 
SOLIDWORKS. Show me Interactive What’s New help radio button. This will ensure that 
the Interactive What’s New help is displayed while you work with the tools that are enhanced 
or newly introduced in this release of SOLIDWORKS.

If you do not want any dynamic help topic to appear on your screen, select the Do not show 
me any dynamic help. radio button.

Figure 2-4  The Welcome to SOLIDWORKS dialog box
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Since this textbook follows a beginner’s point of view, you need to accept the default setting 
as it is in the Help customization area. Next, choose the OK button in the Welcome to 
SOLIDWORKS dialog box; the Welcome to SOLIDWORKS dialog box will disappear and 
the SOLIDWORKS window will be displayed, as shown in Figure 2-5.

Figure 2-5  The SOLIDWORKS window

TASK PANES							           
In SOLIDWORKS, the task panes are displayed on the right of the window. These task panes 
contain various options that are used to start a new file, open an existing file, browse the related 
links of SOLIDWORKS, and so on. Various task panes in SOLIDWORKS are discussed next.

SOLIDWORKS Resources Task Pane
By default, the SOLIDWORKS Resources task pane is displayed when you start 
a SOLIDWORKS session. Different rollouts available in this task pane are discussed 
next.

Getting Started Rollout
The options in this rollout are used to start a new document, open an existing document, display 
tutorials, learn the new features in this release of SOLIDWORKS, and invoke the interactive 
help topics. If you are a new user of SOLIDWORKS, choose the Introducing SOLIDWORKS 
option to get an overview of SOLIDWORKS.

SOLIDWORKS Tools Rollout
The options in this rollout are used for customizing the tab, diagnosing and troubleshooting 
SOLIDWORKS, performing system maintenance, checking performance test, saving and 
restoring the customization settings of SOLIDWORKS, and so on.
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Community Rollout
The options in this rollout are used to invoke various SOLIDWORKS communities such as 
customer portal, discussion forum, user groups, and so on.

Online Resources Rollout
The options in this rollout are used to invoke the discussion forum of SOLIDWORKS, 
subscription services, partner solutions, manufacturing network, and print 3D web sites. In 
SOLIDWORKS, a search engine is provided in the Online Resources task pane. To find 
information about a particular topic, you need to enter the related term and then choose 
the Start searching button; you will be redirected to the web site of customer search engine.

Subscription Services Rollout
The options in this rollout are used to get direct access to the Dassault Systemes partner 
products website. This partner products website will help you to interact with the design 
partners and designers.   

Tip of the Day Message Box 
The Tip of the Day message box provides you with a useful tip that will help you to fully utilize 
the tools available in SOLIDWORKS. Click on the Next Tip text provided at the lower right 
corner of the Tip of the Day message box to view the next tip.

Design Library Task Pane
The Design Library task pane is invoked by choosing the Design Library tab from the 
task pane. This task pane is used to browse the default Design Library and the toolbox 

components, and also to access the 3D ContentCentral web site. To access the toolbox 
components, you need to install Toolbox Add-ins in your computer. To add this add-in, choose 
Tools > Add-ins from the SOLIDWORKS menus; the Add-Ins dialog box will be displayed. 
Select the SOLIDWORKS Toolbox Browser check box in this dialog box and then choose 
OK. To access the 3D ContentCentral website, your computer needs to be connected to the 
Internet.

File Explorer Task Pane
The File Explorer task pane is used to explore the files and folders that are saved in 
the hard disk of your computer.

View Palette Task Pane
The View Palette task pane is used to drag and drop the drawing views into a drawing 
sheet. This task pane is available only when you are in the drafting environment.

Appearances, Scenes, and Decals Task Pane
The Appearances, Scenes, and Decals task pane is used to change the appearance of 
model or display area. On choosing the Appearances, Scenes, and Decals button from 

the task pane, you will notice three nodes, Appearances(colors), Scenes, and Decals in the 
Appearances, Scenes, and Decals task pane. The Appearances(colors) node is used to change 
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the appearance texture of model, the Scenes node is used to change the background of the 
graphics area, and the Decals node is used to apply decals to a model. To assign appearance 
to the model, expand the Appearances(colors) node and Metal node under it and then select 
the required material. Different types of appearances for the selected material will be displayed 
in bottom area of the task pane. Now, drag and drop the required appearance on the model 
in the graphics area by selecting and holding the left-mouse button; the Appearance Target 
toolbar will be displayed. Select the required button from this toolbar to apply the selected 
appearance. You can change the properties of the appearance added by using the corresponding 
appearance PropertyManager. You will learn about this PropertyManager in later chapters.

To change the background of the graphics area, expand the Scenes node from the Appearances, 
Scenes, and Decals task pane and select a category; the preview of different backgrounds 
available for this category will be displayed. Drag and drop the background in the graphics 
area; the background of the graphics area will be changed. You can also click the down-arrow 
next to the Apply Scene button in the View (Heads-Up) toolbar and select an option from 
this toolbar to change the background of the drawing area. 

Similarly, to apply an image as a decal, expand the Decals node and select the logos subnode; 
the default logos will be displayed. Drag and drop the image on the model; the Decals 
PropertyManager will be displayed. Set the properties in this PropertyManager and choose 
the OK button.

Custom Properties Task Pane
The Custom Properties task pane is displayed on choosing the Custom Properties tab 
from the task pane. This task pane is used to view the properties of the files. If you do 

not have a property template for the files, then you can create it by choosing the Create now 
button from the Custom Properties task pane. On choosing this button, the Property Tab 
Builder window will be displayed. Set the properties in this window and save it. After saving 
the properties, you can view them in the Custom Properties task pane. To do so, choose Tools 
> Options from the SOLIDWORKS menus; the System Options - General dialog box will 
be displayed. Choose the File Locations option from this dialog box. The options related to 
the File Locations option will be displayed on the right of the dialog box. Select the Custom 
Property Files option from the Show folders for drop-down list. Next, browse the property 
template in the Folders area by choosing the Add button. Choose the OK button from the 
dialog box to exit. Now, you can view these properties in the Custom Properties task pane.

SOLIDWORKS Forum Task Pane
The SOLIDWORKS Forum task pane is displayed on choosing the SOLIDWORKS  
Forum tab from the task pane. The SOLIDWORKS Forum task pane is used to 

participate in the online discussions about SOLIDWORKS. You can start a new discussion with 
other users or search the topics posted by them in the discussion forums.

Tip. To expand the task pane at any stage of the design cycle, choose any one of the tabs 
provided on the task pane. Choose the Auto Show button to pin the task pane. To collapse 
the task pane, click anywhere in the drawing area when the Auto Show button is not chosen.
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Note
In assemblies, you can assign properties to multiple parts at the same time. 

STARTING A NEW DOCUMENT IN SOLIDWORKS 2015
To start a new document in SOLIDWORKS 2015, select the New Document option from the 
Getting Started rollout of the SOLIDWORKS Resources task pane; the New SOLIDWORKS 
Document dialog box will be displayed, as shown in Figure 2-6. You can also invoke this 
dialog box by choosing the New button from the Menu Bar. The options in this dialog box 
are discussed next.

Part
The Part button is chosen by default in the New SOLIDWORKS Document dialog box. On 
choosing the OK button from this dialog box; the Part mode will be invoked. In this mode, 
you can create solid models, surface models, or sheet metal components.  

Figure 2-6  The New SOLIDWORKS Document dialog box

Assembly
Choose the Assembly button and then the OK button from the New SOLIDWORKS Document 
dialog box to start a new assembly document. In the assembly document, you can assemble 
the components created in the part documents. You can also create components or new layout 
in the assembly document.

Drawing
Choose the Drawing button and then the OK button from the New SOLIDWORKS Document 
dialog box to start a new drawing document. In a drawing document, you can generate or 
create the drawing views of the parts created in the part documents or the assemblies created 
in the assembly documents.
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Note
While starting a new file in SOLIDWORKS, the What would you like to do? window is 
displayed. This window assists you in working with SOLIDWORKS. You can close this window 
by choosing the ? button available at the lower right corner of the SOLIDWORKS window. 
You can invoke the What would you like to do? window at any point of your design process 
by choosing the ? button again.

Tip. If you invoke the New SOLIDWORKS Document dialog box using the task pane and 
start a new document, the task pane will remain expanded even when the new document 
is started. If you invoke the New SOLIDWORKS Document dialog box using the 
SOLIDWORKS menus or the Menu Bar, the task pane will collapse and remain collapsed 
after starting the new document. 

UNDERSTANDING THE SKETCHING ENVIRONMENT
Whenever you start a new part document, by default, you are in the part modeling environment. 
But you need to start the design by first creating the sketch of the base feature in the 
sketching environment. To invoke the sketching environment, choose the Sketch tab from 
the CommandManager. Next, choose the Sketch button from the Sketch CommandManager 
tab. For your convenience, you can add the Sketch button to the Menu Bar and invoke the 
sketching environment using this button. To do so, right-click on any toolbar and choose 
the Customize option from the shortcut menu; the Customize dialog box will be displayed. 
Choose the Commands tab and select the Sketch option from the Categories list box; all tools 
in the sketch categories will be displayed in the Buttons area. Press and hold the left mouse 
button on the Sketch tool and then drag it to the Menu Bar. Figure 2-7 shows the Sketch tool 
added to the Menu Bar.

When you choose the Sketch tool from the Menu Bar or invoke any tool from the Sketch 
CommandManager tab, the Edit Sketch PropertyManager is displayed on the left in the 
drawing area and you are prompted to select the plane on which the sketch will be created. 
Also, the three default planes (Front Plane, Right Plane, and Top Plane) are temporarily 
displayed on the screen, as shown in Figure 2-8.

You can select a plane to draw the sketch of the base feature depending on the requirement 
of the design. The selected plane will automatically be oriented normal to the view, so that 
you can easily create the sketch. Also, the CommandManager will display various sketching 
tools to draw the sketch.

The default screen appearance of a SOLIDWORKS part document in the sketching environment 
is shown in Figure 2-9.



Drawing Sketches for Solid Models 				    2-9                                                               
E
va

lua
tion C

opy. D
o not reproduce. For inform

a
tion visit w

w
w

.ca
dcim

.com

Figure 2-7  SOLIDWORKS 2015 screen displaying Sketch tool in the Menu Bar

Figure 2-8  The three default planes displayed on the screen 
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Figure 2-9  Default screen display of a part document in the sketching environment

SETTING THE DOCUMENT OPTIONS
When you install SOLIDWORKS on your computer, you will be prompted to specify the 
dimensioning standards and units for measuring linear distances. The settings specified at 
that time will become the default settings and will be applied on any new SOLIDWORKS 
document opened thereafter. However, if you want to modify these settings for a particular 
document, you can do so easily by using the Document Properties dialog box. To invoke this 
dialog box, choose the Options button from the Menu Bar; the System Options - General 
dialog box will be displayed, as shown in Figure 2-10. Alternatively, choose Tools > Options 
from the SOLIDWORKS menus to invoke the System Options - General dialog box. In this 
dialog box, choose the Document Properties tab; the name of this dialog box will change to 
the Document Properties - Drafting Standard dialog box. The procedure to set the options 
for the current document using this dialog box is discussed next.

Modifying the Drafting Standards
To modify the Drafting standards, invoke the System Options dialog box and then choose 
the Document Properties tab. You will notice that the Drafting Standard option is selected 
by default in the area available on the left of the dialog box to display the drafting options.

The default drafting standard that was selected while installing SOLIDWORKS will be displayed 
in the drop-down list in the Overall drafting standard area. You can select the required 
drafting standard from this drop-down list. The standards available in this drop-down list are 
ANSI, ISO, DIN, JIS, BSI, GOST, and GB. You can select any one of these drafting standards 
for the current document. 
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Figure 2-10  The System Options - General dialog box

Modifying the Linear and Angular Units
To modify the linear and angular units, invoke the System Options dialog box and then 
choose the Document Properties tab. In this tab, choose the Units option from the area 
available on the left in the dialog box to display the options related to the linear and angular 
units, as shown in Figure 2-11. The default option that was selected for measuring the linear 
distances while installing SOLIDWORKS will be available in the Length field under the Unit 
column. You can set the units for the current document from the options in the Unit system 
area. To specify the units other than the standard unit system in this area, select the Custom 
radio button; the options in the tabulation will be enabled. Select the cell corresponding to 
the Length and Unit parameter; a drop-down list will be displayed. Set the units from the 
drop-down list. 

The units that can be selected for Length are angstroms, nanometers, microns, millimeters, 
centimeters, meters, microinches, mils, inches, feet, and feet & inches. To change the units for 
angular dimensions, select the cell corresponding to Angle and Unit; a drop-down list will be 
displayed. The angular units that can be selected from this drop-down list are degrees, deg/
min, deg/min/sec, and radians. Set the number of decimal places in the corresponding field 
under the Decimals column.
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Figure 2-11 Setting the dimensioning standards

In SOLIDWORKS 2015, you can also change the unit system for the current document by 
using the Unit system button that is located next to the Quick Tips Help button in the status 
bar, refer to Figure 2-12. To change the unit system using this option, click on the Unit system 
button; a flyout will be displayed with a tick mark next to the unit system of the activated 
document, refer to Figure 2-12. Now, you can select the required unit system for the activated 
document from this flyout. You can also invoke the Document Properties - Units dialog box 
by choosing the Edit Document Units option from this flyout.

Figure 2-12  Flyout displayed after choosing the Unit 
system button
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Modifying the Snap and Grid Settings
In the sketching environment of SOLIDWORKS, you can make the cursor jump through a 
specified distance while creating the sketch. Therefore, if you draw a sketched entity, its length 
will change in the specified increment. For example, while drawing a line, if you make the cursor 
jump through a distance of 10 mm, the length of the line will be incremented by a distance of 
10 mm. To modify the snap and grid settings, choose the Options button from the Menu Bar 
to display the System Options-General dialog box. To ensure that the cursor jumps through 
the specified distance, you need to invoke the snap option. Select the Relations/Snaps branch 
of the Sketch option to display the related options. From the options available on the right, 
select the Grid check box. Next, clear the Snap only when grid is displayed check box, if it 
is selected. If this check box is selected, then the cursor will snap the sketched entities only 
when the grid is displayed.

Next, choose the Go To Document Grid Settings button to invoke the Document 
Properties - Grid/Snap dialog box, as shown in Figure 2-13. The distance through which 
the cursor jumps is dependent on the ratio between the values in the Major grid spacing 
and Minor-lines per major spinners available in the Grid area. For example, if you want the 
coordinates to increment by 10 mm, you will have to make the ratio of the major and minor 
lines to 10. This can be done by setting the value of the Major grid spacing spinner to 100 
and that of the Minor-lines per major spinner to 10. Similarly, to make the cursor jump 
through a distance of 5 mm, set the value of the Major grid spacing spinner to 50 and that 
of the Minor-lines per major spinner to 10.

Figure 2-13  The Document Properties - Grid/Snap dialog box
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Note
Remember that these grid and snap settings will be applicable for the current documents only. 
When you open a new document, it will have the settings that were defined while installing 
SOLIDWORKS.

Tip. If you want to display the grid in the sketching environment, select the Display 
grid check box from the Grid area of the Document Properties - Grid/Snap dialog 
box. Alternatively, choose Hide/Show Items > View Grid from the View (Heads-Up) 
toolbar.

While drawing a sketched entity by snapping through grips, the grips symbol will be 
displayed below the cursor on the right.

LEARNING SKETCHER TERMS
Before you learn about various sketching tools, it is important to understand some terms that 
are used in the sketching environment. These tools and terms are discussed next.

Origin
The origin is represented by a red colored point displayed at the center of the sketching 
environment screen. By default, there are two arrows at the origin displaying the horizontal  
and vertical directions of the current sketching plane. The point of intersection of these two 
axes is the origin point and the coordinates of this point are 0,0. To display or hide the origin, 
choose Hide/Show Items > View Origins from the View (Heads-Up) toolbar.

Inferencing Lines
The inferencing lines are the temporary lines that are used to track a particular point on the 
screen. These lines are the dashed lines and are automatically displayed when you select a 
sketching tool in the sketching environment. These lines are created from the endpoints or 
the midpoint of a sketched entity or from the origin. For example, if you want to draw a line 
from the point where two imaginary lines intersect, you can use the inferencing lines to locate 
the point and then draw the line from that point. Figure 2-14 shows the use of inferencing 
lines to locate the point of intersection of two imaginary lines. Figure 2-15 shows the use of 
inferencing lines to locate the center of a circle. Notice that the inferencing lines are created 
from the endpoint of the line and from the origin.

Note
The inferencing lines that are displayed on the screen will be either blue or yellow. The blue 
inferencing lines indicate that the relations are not added to the sketched entity and the yellow 
inferencing lines indicate that the relations are added to the sketched entity. You will learn about 
various relations in the later chapters.

Inferencing lines will be displayed only when a sketching tool is active. 
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Figure 2-15  Using inferencing lines to locate the 
center of a circle

Figure 2-14  Using inferencing lines to locate 
a point

Tip. You can disable the inferencing line temporarily by pressing the CTRL key.

Select Tool
  SOLIDWORKS menus:  Tools > Select	

The Select tool is used to select a sketched entity or exit any sketching tool that is active. 
You can select the sketched entities by selecting them one by one using the left mouse 
button. You can also hold the left mouse button and drag the cursor around the multiple 

sketched entities to define a box and select the multiple entities. There are two methods of 
selection, box selection and cross selection. You can also select multiple entities by pressing 
the SHIFT and CTRL keys. These selection methods are discussed next.

Note
When a sketching tool is active, you can invoke the Select tool or press the ESC key to exit the 
sketching tool. You can also right-click and choose the Select option from the shortcut menu to 
exit the tool.

Selecting Entities Using the Box Selection
A box is a window that is created by pressing the left mouse button and dragging the cursor 
from left to right in the drawing area. The selection box will be displayed by continuous lines. 
When you create a box, the entities that lie completely inside it will be selected. The selected 
entities will be displayed in light blue and a pop-up toolbar will be displayed near the cursor.

Selecting Entities Using the Cross Selection
When you press the left mouse button and drag the cursor from right to left in the drawing 
area, a box of dashed lines is drawn. The entities that lie completely or partially inside this 
box or the entities that touch the dashed lines of the box will be selected. The selected entities 
will be displayed in light blue and a pop-up toolbar will be displayed near the cursor. This 
method of selection is known as cross selection.
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Selecting Entities Using the Lasso Selection
Lasso selection is a freehand selection. To make a freehand selection, click-drag the mouse 
pointer; a continuous loop will be displayed. The entities that lie completely inside the loop will 
be selected and highlighted. Also, a pop-up toolbar will be displayed near the mouse pointer.

Selecting Entities Using the SHIFT and CTRL Keys
You can also use the SHIFT and CTRL keys to manage the selection procedure. To select 
multiple entities, press and hold the SHIFT key and select the entities. After selecting some 
entities, if you need to select more entities using the windows or cross selection, press and 
hold the SHIFT key. Now, create a window or a cross selection; all the entities that touch the 
crossing or are inside the window will be selected. 

If you need to remove a particular entity from a group of selected entities, press the CTRL 
key and select the entity. You can also invert the current selection using the CTRL key. To do 
so, select the entities that you do not want to be included in the selection set. Next, press the 
CTRL key and create a window or a cross selection.

Note
In SOLIDWORKS, when you select an entity, a pop-up toolbar will be displayed with options 
to edit the sketch. You will learn about these options in the later chapters.

Invert Selection Tool 
  SOLIDWORKS menus:	  Tools > Invert Selection			   
  Toolbar:		    Selection Filter > Invert Selection	

The Invert Selection tool will be active only when an entity is selected and is used to 
invert the selection set. This tool is used to remove entities from the current selection 
set and select all other entities that are not in the current selection set. To invert the 

selection, select the entities that you do not want to be included in the final selection set and 
then choose Tools > Invert Selection from the SOLIDWORKS menus. You can also invoke 
the Invert Selection tool from the shortcut menu. All entities that were not selected earlier 
will now be selected and the entities that were in the selection set earlier will now be removed 
from the selection set.

Now, you are familiar with the important sketching terms. Next, you will learn about the 
sketching tools available in SOLIDWORKS.

DRAWING LINES
  CommandManager:	   Sketch > Line			    
  SOLIDWORKS menus:	  Tools > Sketch Entities > Line	  
  Toolbar:		    Sketch > Line			 

Lines are one of the basic sketching entities available in SOLIDWORKS. In general 
terms, a line is defined as the shortest distance between two points. As mentioned 
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earlier, SOLIDWORKS is a parametric solid modeling tool. This property allows you to draw 
a line of any length and at any angle so that it can be forced to the desired length and angle.

To draw a line in the sketching environment of SOLIDWORKS, invoke the Line tool from the 
Sketch CommandManager; the Insert Line PropertyManager will be displayed, as shown in 
Figure 2-16.  Alternatively, right-click in the drawing area; a shortcut menu will be displayed 
with tools and options. Choose the Line tool from the shortcut menu to display the Insert 
Line CommandManager. You will notice that the cursor, which was an arrow, is replaced by 
the line cursor. The line cursor is actually a pencil-like cursor with a small inclined line below 
the pencil. You can also invoke the Line tool by pressing the L key.

Figure 2-16  The Insert 
Line PropertyManager

The Message rollout of the Insert Line PropertyManager informs 
you to edit the settings of the next line or sketch a new line. The 
options in this PropertyManager can be used to set the orientation 
and other sketching options to draw a line. All these options are 
discussed next.

Orientation Rollout
The Orientation rollout is used to define the orientation of the line 
to be drawn. By default, the As sketched radio button is selected, 
so that you can draw the line in any orientation. If you need to 
draw only horizontal lines, select the Horizontal radio button. On 
selecting this radio button, the Parameters rollout will be displayed 
and you can specify the length of the line in the Length spinner 
provided in this rollout. You will learn more about dimensioning 
in the later chapters. After specifying the parameters, choose the 
start point and the endpoint in succession to create the horizontal 
line. Choose OK twice to exit the Line tool.

Similarly, to draw a vertical line, select the Vertical radio button, specify the parameters in the 
Parameters rollout, and then choose the start point and the endpoint in succession.

Note
If the value 0 is set in the Length spinner of the Parameters rollout, you can draw horizontal/
vertical line of any length. 

The Angle radio button is selected to draw lines at a specified angle. When you select this 
radio button, the Parameters rollout will be displayed, where you can set the values of the 
length of the line and the angle or the orientation of the line.

Options Rollout
Select the For construction check box available in this rollout to draw a construction line. You 
will learn more about construction lines later in this chapter. To draw a line of infinite length, 
select the Infinite length check box. Select the Midpoint line check box to draw a line by 
defining its midpoint and one of its endpoints.
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On selecting the As sketched radio button in the Orientation rollout, you can draw lines by 
using two methods. The first method is to draw continuous lines and the second method is 
to draw individual lines. Both these methods are discussed next.

Drawing Continuous Lines
This is the default method of drawing lines. In this method, you have to specify the start point 
and the endpoint of the line using the left mouse button. As soon as you specify the start point 
of the line, the Line Properties PropertyManager will be displayed. The options in the Line 
Properties PropertyManager will not be available at this stage. 

After specifying the start point, move the cursor away from it and specify the endpoint of the 
line using the left mouse button. A line will be drawn between the two points. You will also 
notice that the line has filled squares at the two ends. The line will be displayed in light blue 
color because it is still selected. 

Move the cursor away from the endpoint of the line and you will notice that another line 
is attached to the cursor. The start point of this line is the endpoint of the last line and the 
length of this line can be increased or decreased by moving the cursor. This line is called a 
rubber-band line as this line stretches like a rubber-band when you move the cursor. The point 
that you specify next on the screen will be taken as the endpoint of the new line and a line will 
be drawn such that the endpoint of the first line is taken as the start point of the new line and 
the point you specify is taken as the endpoint of the new line. Now, a new rubber-band line 
is displayed starting from the endpoint of the last line. This is a continuous process and you 
can draw a chain of as many continuous lines as needed by specifying the points on the screen 
using the left mouse button.

You can exit the process of drawing continuous line by pressing the ESC key, by double-clicking 
on the screen, or by invoking the Select tool from the Menu Bar. You can also right-click to 
display the shortcut menu and choose the End chain or Select option to exit the Line tool.

Figure 2-17 shows a sketch drawn using continuous lines. You need to draw this sketch from 
the lower left corner and in this sketch, the horizontal line has to be drawn first. Draw the 
other lines and to close the loop, move the cursor attached to the last line close to the start 
point of the first line; you will notice that a orange colored circle will be displayed at the 
start point. If you specify the endpoint of the line at this stage, the loop will be closed and 
no rubber-band line will be displayed now. This is because the loop is already closed and you 
may not need another continuous line now. However, the Line tool is still active and you can 
draw other lines.

Note
When you terminate the process of drawing a line by double-clicking on the screen or by choosing 
End chain from the shortcut menu, the current chain ends but the Line tool still remains active. 
As a result, you can draw other lines. However to exit the Line tool, you can choose Select from 
the shortcut menu.
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Figure 2-17  Sketch drawn using continuous lines

Drawing Individual Lines
This is the second method of drawing lines. This method is used to draw individual lines in 
which the start point of the new line will not necessarily be the endpoint of the previous line. 
To draw individual lines, you need to press and hold the left mouse button to specify the start 
point, and then drag the cursor without releasing the mouse button. Once you have dragged 
the cursor to the endpoint, release the left mouse button; a line will be drawn between the 
two points.

To make the sketching process easy in SOLIDWORKS,

Figure 2-18  Partial view of the Line 
Properties PropertyManager

 
you are provided with the PropertyManager. The 
PropertyManager is a table that will be displayed on 
the left of the screen as soon as you select a sketched 
entity. The PropertyManager has all parameters 
related to the sketched entity such as the start point, 
endpoint, angle, length, and so on. You will notice 
that as you start dragging the mouse, the Line 
Properties PropertyManager is displayed on the left 
of the drawing area. All options in the Line 
Properties PropertyManager will be available when 
you release the left mouse button. Figure 2-18 shows 
a partial view of the Line Properties PropertyManager.

Note
The Line Properties PropertyManager also displays additional options about relations. You 
will learn more about relations in the later chapters.

After you have drawn the line, modify the parameters in the Line Properties PropertyManager 
to make the line to the desired length and angle. You can also modify the line dynamically by 
selecting its endpoints and then dragging them. 
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Line Cursor Parameters
When you draw lines in the sketching environment

Figure 2-19  The length of the line displayed 
on the screen while drawing the line

 
of SOLIDWORKS, you will notice that a numeric 
value is displayed above the line cursor, see Figure 
2-19. This numeric value indicates the length of 
the line you draw. This value is the same as that in 
the Length spinner of the Line Properties 
PropertyManager. The only difference is that in 
the Line Properties PropertyManager, the value 
will be displayed with more precision.

The other thing that you will notice while drawing 
horizontal or vertical line is that two symbols are 
displayed below the line cursor. These are the 
symbols of the Vertical and Horizontal relations. SOLIDWORKS applies these relations 
automatically to lines. These relations ensure that the lines you draw are vertical or horizontal. 
Figure 2-20 shows the symbol of the Vertical relation on a line and Figure 2-21 shows the 
symbol of the Horizontal relation on a line.

Figure 2-21  Symbol of the Horizontal relationFigure 2-20  Symbol of the Vertical relation

Note
In addition to the Horizontal and Vertical relations, you can apply a number of other relations 
such as Tangent, Concentric, Perpendicular, Parallel, and so on. You will learn about all 
these relations and other options in the Line Properties PropertyManager in the later chapters.

Drawing Tangent or Normal Arcs Using the Line Tool
SOLIDWORKS allows you to draw tangent or normal arcs originating from the endpoint of 
the line while drawing continuous lines. Note that these arcs can be drawn only if you have 
drawn at least one line, arc, or spline. To draw such arcs, draw a line by specifying the start 
point and the endpoint. Move the cursor away from the endpoint of the last line to display the 
rubber-band line. Now, when you move the cursor back to the endpoint of the last line, the 
arc mode will be invoked. The angle and the radius of the arc will be displayed above the arc 
cursor. You can also invoke the arc mode by right-clicking and choosing Switch to arc from 
the shortcut menu or pressing the A key on the keyboard.
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To draw a tangent arc, invoke the arc mode by moving the cursor back to the endpoint of the 
last line. Now, move the cursor through a small distance along the tangent direction of the 
line; a dotted line will be drawn. Next, move the cursor in the direction in which the arc should 
be drawn. You will notice that a tangent arc is drawn. Specify the endpoint of the tangent arc 
using the left mouse button. Figure 2-22 shows an arc tangent to an existing line.

To draw a normal arc, invoke the arc mode. Next, move the cursor through a small distance 
in the direction normal to the line and then move it in the direction of the endpoint of the 
arc; the normal arc will be drawn, as shown in Figure 2-23.

Figure 2-23  Drawing a normal arc using the 
Line tool

Figure 2-22  Drawing a tangent arc using the 
Line tool

As soon as the endpoint of the tangent or the normal arc is defined, the line mode will be 
invoked again. You can continue drawing lines using the line mode or move the cursor back 
to the endpoint of the arc to invoke the arc mode.

Note
If the arc mode is invoked by mistake while drawing lines, you can cancel the arc mode and 
invoke the line mode again by pressing the A key. Alternatively, you can right-click and choose 
Switch to Line from the shortcut menu or move the cursor back to the endpoint and press the 
left mouse button to invoke the line mode.

Drawing Construction Lines or Centerlines
  CommandManager:       Sketch > Line flyout > Centerline	  
  SOLIDWORKS menus:   Tools > Sketch Entities > Centerline	  
  Toolbar:                         Sketch > Line flyout > Centerline	

The construction lines or the centerlines are the ones that are drawn only for the aid 
of sketching. These lines are not considered while converting the sketches into features. 

You can draw a construction line similar to the sketched line by using the Centerline tool. You 
will notice that when you draw a construction line, the For construction check box in the 
Options rollout of the Line Properties PropertyManager is selected. You can also draw a 
construction line using the Line tool. To do so, invoke the Insert Line PropertyManager by 
choosing the Line tool, select the For construction check box in the Options rollout, and 
draw the line.
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Drawing Midpoint Line                                            
  CommandManager:  	   Sketch > Line flyout > Midpoint Line		   
  SOLIDWORKS menus:   Tools > Sketch Entities > Midpoint Line		  
  Toolbar:                        Sketch > Line flyout > Midpoint Line		

The Midpoint Line tool is used to draw a line by specifying its midpoint and end point. 
To invoke this tool, choose the Midpoint Line tool from the Line flyout of the Sketch 
toolbar. 

Drawing the Lines of Infinite Length 
SOLIDWORKS allows you to draw lines of infinite length. Note that these lines can be drawn 
only if the Line or Centerline tool is invoked. To draw lines of infinite length, invoke the 
Insert Line PropertyManager and then select the Infinite length check box available in the 
Options rollout of this PropertyManager. Next, specify two points in the drawing area; a line 
of infinite length will be drawn.

To convert the solid infinite length line to a construction infinite length line, you need 
to select the For construction check box in the Options rollout of the Line Properties 
PropertyManager. You can also set the angle value for infinite lines in the Angle spinner 
available in the Parameters rollout of this PropertyManager.   

Tip. When you select a line, a pop-up toolbar will be displayed. Choose the Construction 
Geometry option from this toolbar to convert the line into a construction line. 

DRAWING CIRCLES
In SOLIDWORKS, there are two methods to

Figure 2-24  The Circle PropertyManager

 
draw circles. In the first method you can 
specify the center point of a circle and then 
defining its radius. In the second method you 
can draw a circle by defining three points that 
lie on its periphery. The tools for drawing a 
circle are grouped together in the Circle 
flyout in the Sketch CommandManager. To 
draw a circle, select the down arrow on the 
Circle tool; a flyout with both the tools will be 
displayed. Invoke a tool from this flyout; the 
Circle PropertyManager will be displayed, as 
shown in Figure 2-24. Alternatively, right-click 
and then choose the Circle option from the 
shortcut menu to display the Circle PropertyManager. You can also invoke the Circle tool 
by using the Mouse Gesture. After invoking the Circle PropertyManager, select the appropriate 
method from the Circle Type rollout to draw the circle. Both methods to draw the circles are 
discussed next. 
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Drawing Circles by Defining Their Center Points
  CommandManager:	  Sketch > Circle flyout > Circle	     
  SOLIDWORKS menus:	 Tools > Sketch Entities > Circle	     
  Toolbar:		   Sketch > Circle			     

When you invoke the Circle PropertyManager, the Circle button is chosen by default 
in the Circle Type rollout. Also, the arrow cursor is replaced by the circle cursor. The 
circle cursor consists of a pencil and a circle below the pencil. Specify the center point 

of the circle and then move the cursor away from the point to define its radius. The current 
radius of the circle will be displayed above the circle cursor. This radius will change as you 
move the cursor. Click on the drawing area away from the center point to define the radius. 
This radius can be modified by using the Circle PropertyManager. Also, the coordinates of 
the center point of the circle can be modified by using the Circle PropertyManager. Figure 
2-25 shows a circle being drawn using the Circle tool by specifying the center point and 
dragging the cursor.

Figure 2-25  Drawing a circle by specifying the centerpoint

Drawing Circles by Defining Three Points
  CommandManager:	  Sketch > Circle flyout > Perimeter Circle		  
  SOLIDWORKS menus:	 Tools > Sketch Entities > Perimeter Circle	  
  Toolbar:		   Sketch > Circle flyout > Perimeter Circle		

The Perimeter Circle tool is used to draw a circle by defining three points that lie on 
the periphery of a circle. To draw a circle using this method, choose the Perimeter 
Circle tool from the Circle flyout. Alternatively, invoke the Circle PropertyManager 

and choose the Perimeter Circle button from the Circle Type rollout; the select cursor will 
be replaced by a three-point circle cursor. Specify the first point of the circle in the drawing 
area. Next, specify the other two points of the circle. The resulting circle will be highlighted 
in light blue and you can modify the circle by setting its parameters in the Circle 
PropertyManager. Figure 2-26 shows a circle being drawn by specifying three points.
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Figure 2-26  Drawing a circle by specifying 
three points

Drawing Construction Circles
If you want to sketch a construction circle, draw a circle using the Circle tool and then select 
the For construction check box in the Options rollout of the Circle PropertyManager. 

Tip. To convert a construction entity back to a sketched entity, invoke the Select tool 
and then select the construction entity; a popup toolbar will be displayed. Deactivate the 
Construction Geometry button in this toolbar.

DRAWING ARCS
In SOLIDWORKS, you can draw arcs by using three tools: Centerpoint Arc, Tangent 
Arc, and 3 Point Arc. All these tools are grouped together in the Arc flyout in the Sketch 
CommandManager. You can invoke these tools from the flyout displayed on choosing the 
down arrow on the right of the Centerpoint Arc tool. The methods used to create arcs using 
these tools are discussed next.

Drawing Tangent/Normal Arcs
  CommandManager:	   Sketch > Arc flyout  > Tangent Arc	   
  SOLIDWORKS menus:	  Tools > Sketch Entities > Tangent Arc	   
  Toolbar:		    Sketch > Arc flyout > Tangent Arc	  

The tangent arcs are the ones that are drawn tangent to an existing sketched entity. 
The existing sketched entities include the sketched and construction lines, arcs, and 
splines. The normal arcs are the ones that are drawn normal to an existing entity. You 

can draw tangent and normal arcs using the Tangent Arc tool. 

To draw a tangent arc, invoke the Tangent Arc tool; the arrow cursor will be replaced by the 
tangent arc cursor. Move the arc cursor close to the endpoint of the entity that you want to select 
as the tangent entity. You will notice that an orange colored dot is displayed at the endpoint. 
Also, a yellow symbol displaying two concentric circles appears below the pencil. Now, press 
the left mouse button once and move the cursor along the tangent direction through a small 
distance and then move the cursor to size the arc. The arc will start from the endpoint of the 
tangent entity and its size will change as you move the cursor. Note that the angle and radius 
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of the tangent arc are displayed above the cursor, as shown in Figure 2-27. Click when the 
radius and angle values are closer to the desired values.

To draw a normal arc, invoke the Tangent Arc tool. Move the cursor close to the endpoint of 
the entity that you want to select as the normal entity; an orange colored dot will be displayed at 
the endpoint. Also, a yellow symbol displaying two concentric circles appear below the pencil. 
Now, press the left mouse button once and move the cursor along the normal direction through 
a small distance and then move the cursor to size the arc, refer to Figure 2-28. Click when the 
radius and angle values are closer to the desired values.

Figure 2-28  Drawing a normal arcFigure 2-27  Drawing a tangent arc

On invoking the Tangent Arc tool, the Arc PropertyManager will be displayed. However, the 
options in the Arc PropertyManager will not be enabled at this stage. These options will be 
enabled on selecting the completed tangent or normal arc. 

You can draw an arbitrary arc and then modify its value using the Arc PropertyManager. 
Figure 2-29 shows the partial view of the Arc PropertyManager.

Figure 2-29  Partial view of the Arc 
PropertyManager
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Note
When you select a tangent entity to draw a tangent arc, the Tangent relation is applied between 
the start point of the arc and the tangent entity. Therefore, if you change the coordinates of the 
start point of the arc, the tangent entity will also be modified accordingly.

Drawing Centerpoint Arcs
  CommandManager:		  Sketch > Arc flyout > Centerpoint Arc		   
  SOLIDWORKS menus: 	 Tools > Sketch Entity > Centerpoint Arc 		   
  Toolbar: 			   Sketch > Arc flyout > Centerpoint Arc		

The center point arcs are the ones that are drawn by defining the centerpoint, start point, 
and endpoint of the arc. When you invoke this tool, the arrow cursor is replaced by the 
arc cursor. An arc cursor consists of a pencil and a centerpoint arc below the pencil.

To draw a center point arc, invoke the Centerpoint Arc tool and then move the arc cursor to 
the point that you want to specify as the center point of the arc. Press the left mouse button 
once at the location of the center point and then move the cursor to the point from where 
you want to start the arc. You will notice that a dotted circle is displayed on the screen. The 
size of this circle will modify as you move the mouse. This circle is drawn for your reference 
and the center point of this circle lies at the point that you specified as the center of the arc. 
Press the left mouse button once at the point that you want to select as the start point of the 
arc. Next, move the cursor to specify the endpoint of the arc. You will notice that the reference 
circle is no longer displayed and an arc is being drawn with the start point as the point that 
you specified after specifying the center point. Also, the Arc PropertyManager, similar to the 
one that is shown in the tangent arc, is displayed on the left of the drawing area. Note that 
the options in the Arc PropertyManager will not be available at this stage. 

If you move the cursor in the clockwise direction, the resulting arc will be drawn in the clockwise 
direction. However, if you move the cursor in the counterclockwise direction, the resulting arc 
will be drawn in the counterclockwise direction. Specify the endpoint of the arc using the left 
mouse button. Figure 2-30 shows the reference circle displayed when you move the mouse 
button after specifying the center point of the arc and Figure 2-31 shows the resulting center 
point arc.

Figure 2-30  Specifying the center point 
and start point of the center point arc

Figure 2-31  The resulting center point arc
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Drawing 3 Point Arcs
  CommandManager:		  Sketch > Arc flyout > 3 Point Arc		  
  SOLIDWORKS menus:		 Tools > Sketch Entities > 3 Point Arc	  
  Toolbar:			   Sketch > Arc flyout > 3 Point Arc		

The three point arcs are the ones that are drawn by defining the start point and 
the endpoint of the arc, and a point on the circumference or the periphery of the arc. 
On invoking this tool, the arrow cursor is replaced by the three-point arc cursor.

To draw a 3 point arc, invoke the 3 Point Arc tool and then move the three-point arc cursor to 
the point that you want to specify as the start point of the arc. Press the left mouse button once 
at the location of the start point and then move the cursor to the point that you want to specify 
as the endpoint of the arc. As soon as you invoke the 3 Point Arc tool, the Arc PropertyManager 
will be displayed. Note that when you start moving the cursor after specifying the start point, 
a reference arc will be displayed.  However, the options in the Arc PropertyManager will not 
be available at this stage. 

Specify the endpoint of the arc using the left mouse button. You will notice that the reference 
arc is no longer displayed. Instead, a solid arc is displayed and the cursor is attached to it. As 
you move the cursor, the arc will also be modified dynamically. Using the left mouse button, 
specify a point on the screen to create the arc. The last point that you specify will determine 
the direction of the arc. The options in the Arc PropertyManager will be displayed once 
you draw the arc. You can modify the properties of the arc using the Arc PropertyManager. 
Figure 2-32 shows the reference arc drawn by specifying the start point and endpoint of the 
arc and Figure 2-33 shows the third point being specified for drawing the arc.

Figure 2-32  Specifying the start point and 
endpoint of the arc

Figure 2-33  Specifying the third point for 
drawing the arc

DRAWING RECTANGLES
In SOLIDWORKS, the tools that are used to draw rectangles are grouped together in the 
Rectangle flyout. On invoking a tool from this flyout, the Rectangle PropertyManager will be 
displayed. Select an appropriate method to draw a rectangle from the Rectangle Type rollout. 
Alternatively, right-click and then choose the Corner Rectangle option from the shortcut 
menu to display the Rectangle PropertyManager. You can also invoke this PropertyManager 
by using the Mouse Gesture. Various methods to create a rectangle are discussed next.
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 Drawing Rectangles by Specifying Their Corners
  CommandManager:		  Sketch > Rectangle flyout > Corner Rectangle	  
  SOLIDWORKS menus:		 Tools > Sketch Entities > Corner Rectangle	  
  Toolbar:    			   Sketch > Rectangle flyout > Corner Rectangle	

To draw a rectangle by specifying the two diagonally opposite corners, choose the 
Corner Rectangle button from the Rectangle Type rollout in the Rectangle 
PropertyManager, if it is not chosen by default. Next, move the cursor to the point 

that you want to specify as the first corner of the rectangle and then click the left mouse button 
once to specify the first corner. Now, move the cursor diagonally away from it. You will notice 
that the length and width of the rectangle are displayed above the rectangle cursor. The length 
is measured along the X-axis and the width is measured along the Y-axis. Next, specify the 
other corner of the rectangle using the left mouse button. Figure 2-34 shows a rectangle being 
drawn by specifying two diagonally opposite corners.

Figure 2-34  Drawing a rectangle by specifying two diagonally opposite corners

Drawing Rectangles by Specifying the Center and a Corner
  CommandManager:		  Sketch > Rectangle flyout > Center Rectangle	  
  SOLIDWORKS menus:		 Tools > Sketch Entities > Center Rectangle	  
  Toolbar:			   Sketch > Rectangle flyout > Center Rectangle	

To draw a rectangle by specifying the

Figure 2-35  Drawing a rectangle by specifying its 
center and one of the corners

 
center and one of the corners, choose 
the Center Rectangle button from the 

Rectangle Type rollout in the Rectangle 
PropertyManager. Next, move the cursor to 
the point that you want to specify as the 
center of the rectangle and click the left 
mouse button. Then, move the cursor and 
specify one of the corners of the rectangle 
using the left mouse button. You will notice 
that the length and width of the rectangle 
are displayed above the rectangle cursor. The length is measured along the X-axis and the 
width is measured along the Y-axis. Figure 2-35 shows a rectangle being drawn by specifying 
its center and one of the corners.
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Drawing Rectangles at an Angle
  CommandManager:		  Sketch > Rectangle flyout > 3 Point Corner Rectangle	  
  SOLIDWORKS menus:		 Tools > Sketch Entities > 3 Point Corner Rectangle	  
  Toolbar:			   Sketch > Rectangle flyout > 3 Point Corner Rectangle	

To draw a rectangle at an angle, choose the 3 Point Corner Rectangle button from the 
Rectangle Type rollout in the Rectangle PropertyManager. Move the cursor to the 
point that you want to specify as the start point of one of the edges of the rectangle. 

Click the left mouse button at this point and move the cursor to size the edge. You will notice 
that a reference line is being drawn. Depending on the current position of the cursor, the 
reference line will be horizontal, vertical, or inclined. The current length of the edge and its 
angle will be displayed above the rectangle cursor. Specify the second point as the endpoint 
of the edge such that the reference line is at an angle.

Next, move the cursor to specify the width

Figure 2-36  Drawing a rectangle at an angle

 
of the rectangle. You will notice that a 
reference rectangle is drawn at an angle. 
Also, irrespective of the current position of 
the cursor, the width will be specified normal 
to the first edge, either above or below it. 
Specify the third point using the left mouse 
button to define the width of the rectangle, 
as shown in Figure 2-36; the reference 
rectangle will be converted into a sketched 
rectangle.
 

Drawing Centerpoint Rectangles at an Angle
  CommandManager:		  Sketch > Rectangle flyout > 3 Point Center Rectangle	  
  SOLIDWORKS menus:		 Tools > Sketch Entities > 3 Point Center Rectangle	  
  Toolbar:			   Sketch > Rectangle flyout > 3 Point Center Rectangle	

To draw a centerpoint rectangle at an angle, choose the 3 Point Center Rectangle 
button from the Rectangle Type rollout in the Rectangle PropertyManager. Next, 
move the cursor to the point that you want to specify as the center point of the rectangle. 

Click the left mouse button once at this point and move the cursor to a distance that is equal 
to half the length of the rectangle to be drawn. You will notice that a reference line is being 
drawn. Depending on the current position of the cursor, the reference line can be horizontal, 
vertical, or inclined. The current length of the edge and its angle will be displayed above the 
rectangle cursor. Specify the second point using the left mouse button. Next, specify the third 
point to define the width of the rectangle. 

You can select the From Corners or From Midpoints radio button from the Rectangle Type 
rollout to specify the third point of the rectangle  at the corner or at the midpoint of one side 
of the rectangle, respectively, as shown in Figures 2-37 and 2-38. 
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Figure 2-37  Specifying the third point when 
the From Corners radio button is selected

Figure 2-38  Specifying the third point when 
the From Midpoints radio button is selected

Drawing Parallelograms
  CommandManager:		  Sketch > Rectangle flyout > Parallelogram	  
  SOLIDWORKS menus:		 Tools > Sketch Entities > Parallelogram		   
  Toolbar:			   Sketch > Rectangle flyout > Parallelogram	

To draw a parallelogram, choose the  Parallelogram button from the Rectangle Type 
rollout of the Rectangle PropertyManager. Specify two points on the screen to define 
one edge in the parallelogram. Next, move the mouse to define the width of the 

parallelogram. As you move the mouse, a reference parallelogram will be drawn. The size and 
shape of the reference parallelogram will depend on the current location of the cursor.

Specify a point on the screen to define the parallelogram. Figure 2-39 shows the parallelogram  
cursor specifying the third point to draw a parallelogram.

Figure 2-39  Drawing a parallelogram

Note
In SOLIDWORKS, a rectangle is considered as a combination of four individual lines. Therefore, 
after drawing the rectangle by using the Rectangle PropertyManager, if you select one of the 
lines of the rectangle, the Line Properties PropertyManager will be displayed instead of the 
Rectangle PropertyManager. You can modify the parameters of the selected line using the 
Line Properties PropertyManager.



Drawing Sketches for Solid Models 				    2-31                                                               
E
va

lua
tion C

opy. D
o not reproduce. For inform

a
tion visit w

w
w

.ca
dcim

.com

Remember that because the relations are applied to all four corners of the rectangle, on modifying the 
parameters of one of the lines using the Line Properties PropertyManager, the other three lines will 
also be modified accordingly.

You can convert a rectangle into a construction rectangle by selecting all lines together using a window 
and then selecting the For construction check box from the PropertyManager.

DRAWING POLYGONS
  CommandManager:		  Sketch > Polygon			    
  SOLIDWORKS menus:		 Tools > Sketch Entities > Polygon	  
  Toolbar:                      	 Sketch > Polygon			 

A regular polygon is defined as a multisided geometric figure in which the length of 
all sides and the angle between them are same. In SOLIDWORKS, you can draw a 
regular polygon with the number of sides ranging from 3 to 40. The dimensions of a 

polygon are controlled by using the diameter of a construction circle that is inscribed inside 
the polygon or circumscribed outside the polygon. If the construction circle is inscribed inside 
the polygon, the diameter of the construction circle will be taken from the edges of the polygon. 
If the construction circle is circumscribed about the polygon, the diameter of the construction 
circle will be taken from the vertices of the polygon.

To draw a polygon, invoke the Polygon tool; the Polygon PropertyManager will be displayed, 
as shown in Figure 2-40.

Figure 2-40  The Polygon PropertyManager

Set the parameters such as the number of sides, inscribed or circumscribed circle, and so on, 
in the Polygon PropertyManager. You can also modify these parameters after drawing the 
polygon. When you invoke this tool, the arrow cursor will be replaced by the polygon cursor. 
Click the left mouse button at the point that you want to specify as the center point of the 
polygon and then move the cursor to size the polygon. The length of each side and the rotation 
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angle of the polygon will be displayed above the polygon cursor as you drag it. Using the 
left mouse button, specify a point on the screen after you get the desired length and rotation 
angle of the polygon. You will notice that based on whether you selected the Inscribed circle 
or the Circumscribed circle radio button in the Polygon PropertyManager, a construction 
circle will be drawn inside or outside the polygon. After you have drawn the polygon, you can 
modify the parameters such as the center point of the polygon, the diameter of the construction 
circle, the angle of rotation, and so on using the Polygon PropertyManager. If you want to 
draw another polygon, choose the New Polygon button provided below the Angle spinner in 
the Polygon PropertyManager.

Figure 2-41 shows a six-sided polygon with the construction circle inscribed inside the polygon 
and Figure 2-42 shows a six-sided polygon with the construction circle circumscribed about 
the polygon. Note that the reference circle is retained with the polygon. Remember that this 
circle will not be considered while converting the polygon into a feature.

Tip. You can invoke the list of recently used tools by using the shortcut menu. To do so, 
right-click in the drawing area and choose the Recent Commands option from the shortcut 
menu; a cascading menu will be displayed with the ten most recently used tools. 

Figure 2-42  Six-sided polygon with the 
construction circle circumscribed about it

Figure 2-41  Six-sided polygon with the 
construction circle inscribed inside it

DRAWING SPLINES
  CommandManager:		  Sketch > Spline flyout > Spline		   
  SOLIDWORKS menus:		 Tools > Sketch Entities > Spline		   
  Toolbar:    			   Sketch > Spline flyout > Spline		

To draw a spline, choose the Spline tool from the Sketch CommandManager. Then, 
using the left mouse button continuously, specify the points through which the spline 
will pass. This method of drawing splines is similar to that of drawing continuous lines. 

After specifying all points of the spline, right-click to invoke the shortcut menu. Now, you can 
draw a new spline. If you need to exit the Spline tool, choose the Select option. Figure 2-43 
shows a spline drawn with its start point at the origin.
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Figure 2-43  Spline with its start point at the 
origin

Note
When you select a spline using the Select tool, handles are displayed on the points. These 
handles are used to edit a spline. You will learn more about these handles in the later chapters 
while editing splines.

Similar to individual line, you can also create individual spline segments by specifying the start 
point and then dragging the mouse to specify the endpoint.

Tip. After creating a spline, if you select it by using the Select tool, the Spline 
PropertyManager will be displayed. Also, the control points will be displayed with a blue 
filled square. The number of the current control point and its X and Y coordinates will be 
displayed in the Parameters rollout of the Spline PropertyManager. You can modify 
these coordinates to modify the position of the selected control point. A double-sided arrow 
along with the handle will also be displayed. You will learn more about the handle in later 
chapters.

DRAWING SLOTS
In SOLIDWORKS, the tools used to draw slot profile are grouped together in the Slot flyout. 
To draw a slot profile, invoke the Slot PropertyManager by choosing the Slot button from 
the Slot flyout and select an appropriate method to draw a slot profile from the Slot Type 
rollout. Alternatively, right-click and then choose an option from the shortcut menu to draw 
a slot profile. Various methods to create a slot profile are discussed next. 

Creating a Straight Slot
  CommandManager:		  Sketch > Slot flyout > Straight Slot		   
  SOLIDWORKS menus:		 Tools > Sketch Entities > Straight Slot		   
  Toolbar:   			   Sketch > Slot flyout > Straight Slot		

To create a straight slot, choose the Straight Slot button from the Sketch 
CommandManager; the Slot PropertyManager will be displayed. Next, move the 
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cursor where you want to specify the first endpoint of the straight slot. Press the left mouse 
button once at the first endpoint, and then move the cursor and specify the second endpoint 
of the straight slot; a preview of the slot will be attached to the cursor. Move the cursor and 
specify the width of the straight slot, as shown in Figure 2-44. The options in the Slot 
PropertyManager will be enabled once you draw the straight slot. You can modify the properties 
of the straight slot using the options available in the Slot PropertyManager. 

Creating a Centerpoint Straight Slot
  CommandManager:		  Sketch > Slot flyout > Centerpoint Straight Slot		   
  SOLIDWORKS menus:		 Tools > Sketch Entities > Centerpoint Straight Slo	t	  
  Toolbar:			   Sketch > Slot flyout > Centerpoint Straight Slot		

To draw a centerpoint straight slot, choose the Centerpoint Straight Slot button from 
the Slot flyout; the Slot PropertyManager will be displayed. Specify the center point 
of the slot by using the left mouse button. Next, move the cursor and specify the 

endpoint of the slot; a preview of the slot will be attached to the cursor. The options in the 
Slot PropertyManager will not be enabled at this stage. Move the cursor and specify the width 
of the centerpoint straight slot, as shown in Figure 2-45. The options in the Slot 
PropertyManager will be enabled once you draw the centerpoint straight slot. You can modify 
the properties of the centerpoint straight slot using the options in the Slot PropertyManager. 

Figure 2-45  Specifying the points to create a 
centerpoint straight slot

Figure 2-44  Specifying the points to create 
a straight slot

Creating a 3 Point Arc Slot
  CommandManager:		  Sketch > Slot flyout > 3 Point Arc Slot		   
  SOLIDWORKS menus:		 Tools > Sketch Entities > 3 Point Arc Slot		  
  Toolbar:			   Sketch > Slot flyout > 3 Point Arc Slot		

To create a 3 point arc slot, choose the 3 Point Arc Slot button from the Slot flyout; 
the Slot PropertyManager will be displayed. You need to specify three points in the 
drawing area to create a 3 point arc slot. Move the cursor to the point where you want 

to specify the start point of the slot and then specify the start point of the slot by using the 
left mouse button. Note that as soon as you specify the start point, a reference arc will be 
attached to the cursor. Move the cursor to the location where you want to specify the second 
point of the slot and then click to specify the second point of the slot. Next, specify the third 
point of the slot; a preview of the 3 point arc slot will be attached to the cursor. The options 
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in the Slot PropertyManager will not be enabled at this stage. Move the cursor and specify 
the width of the 3 point arc slot, as shown in Figure 2-46. The options in the Slot 
PropertyManager will be enabled once you draw the 3 point arc slot. You can modify the 
properties of the 3 point arc slot using the options available in the Slot PropertyManager. 

Creating a Centerpoint Arc Slot
  CommandManager:		  Sketch > Slot flyout > Centerpoint Arc Slot	  
  SOLIDWORKS menus:		 Tools > Sketch Entities > Centerpoint Arc Slot	  
  Toolbar:			   Sketch > Slot flyout > Centerpoint Arc Slot	

To create a centerpoint arc slot, choose the Centerpoint Arc Slot button from the Slot 
flyout; the Slot PropertyManager will be displayed. Specify the center point of the 
slot; a reference circle will be attached to the  cursor. Move the cursor and specify the 

start point of the slot. Next, specify the endpoint of the slot by using the left mouse button; 
the preview of the centerpoint arc slot will be attached to the cursor. Next, move the cursor 
and specify the point to create the centerpoint arc slot, as shown in Figure 2-47. 

Tip. If you select the Add Dimension check box while creating slots, the dimensions will 
be added to them. Also, while creating straight slots, you can specify whether the center to 
center distance or the overall length of the slot is to be dimensioned.

Figure 2-46  Specifying points to create a 
3 point arc slot

Figure 2-47  Specifying points to create a 
centerpoint arc slot

PLACING SKETCHED POINTS
  CommandManager:		  Sketch > Point 			     
  SOLIDWORKS menus:		 Tools > Sketch Entities > Point	   
  Toolbar:   			   Sketch > Point			    

To place a sketched point, choose the Point button from the Sketch CommandManager 
and then specify the point on the screen where you want to place it; the Point 
PropertyManager will be displayed with the X and Y coordinates of the current point. 

You can change/shift the location of the point by modifying its X and Y coordinates in the 
Point PropertyManager.
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DRAWING ELLIPSES
  CommandManager:		  Sketch > Ellipse 		       
  SOLIDWORKS menus:		 Tools > Sketch Entities > Ellipse	     
  Toolbar:   			   Sketch > Ellipse			      

In SOLIDWORKS, an ellipse is drawn by specifying its centerpoint and two ellipse axes 
by moving the mouse. To draw an ellipse, choose the Ellipse button from the Sketch 
CommandManager; the arrow cursor will be replaced by the ellipse cursor. Move the 

cursor to the point that you want to specify as the centerpoint of the ellipse. Press the left 
mouse button at that point and then move the cursor to specify one of the ellipse axes. You 
will notice that a reference circle is drawn and two values are displayed above the ellipse cursor, 
see Figure 2-48. The first value that shows R = * is the radius of the first axis or the major 
axis that you are defining and the second value that shows r = * is the radius of the other axis 
or minor axis of the ellipse. While defining the first axis, the second axis is taken equal to the 
first axis. That is why a reference circle is drawn and not a reference ellipse.

Specify a point on the screen to define the first axis. Next, move the cursor to size the 
other ellipse axis. As you move the cursor, the second value above the ellipse cursor that 
shows r = * and the value in the Radius 2 spinner in the Ellipse PropertyManager will change 
dynamically. Specify a point in the drawing area to define the second axis of the ellipse, refer 
to Figure 2-49.

Figure 2-48  Dragging the cursor to define the ellipse axis 
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Figure 2-49  Defining the second axis of the ellipse

DRAWING ELLIPTICAL ARCS 
  CommandManager:		  Sketch > Ellipse flyout > Partial Ellipse	     
  SOLIDWORKS menus:		 Tools > Sketch Entities > Partial Ellipse	     
  Toolbar:			   Sketch > Ellipse flyout > Partial Ellipse	    

In SOLIDWORKS, the process of drawing an elliptical arc is similar to that of drawing 
an ellipse. You will follow the same process of defining the ellipse first. The point that 
you specify on the screen to define the second axis of the ellipse is taken as the start 

point of the elliptical arc. You can define the endpoint of the elliptical arc by specifying a point 
on the screen, as shown in Figure 2-50.

After drawing the elliptical arc, you can also modify its parameters in the Ellipse 
PropertyManager, as shown in Figure 2-51. 

Figure 2-50  Drawing an elliptical arc
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Figure 2-51  Partial view of the Ellipse PropertyManager

Tip. In SOLIDWORKS, when you are in the sketching environment, press the S key to 
invoke the shortcut bar that contains the tools for sketching.

DRAWING PARABOLIC CURVES
  CommandManager:		  Sketch > Ellipse flyout > Parabola      	  
  SOLIDWORKS menus:		 Tools > Sketch Entities > Parabola	  
  Toolbar:   			   Sketch > Ellipse flyout > Parabola	

In SOLIDWORKS, you can draw a parabolic curve by specifying the focus point, apex 
point, and then two endpoints of the parabolic curve. To draw a parabolic curve, choose 
the Parabola button from the Ellipse flyout; the cursor will be replaced by the parabola 

cursor. Move the cursor to the point that you want to specify as the focal point of the parabola. 
Press the left mouse button once at that point. You will notice that a reference parabolic arc 
is displayed. Then, move the cursor to define the apex point and to size the parabola. As you 
move the cursor away from the focal point, the parabola will be flattened. After getting the 
basic shape of the parabolic curve, specify a point by using the left mouse button. This point 
is taken as the apex of the parabolic curve. Next, specify two points with respect to the reference 
parabola to define the guide of the parabolic curve, see Figure 2-52.

As you move the mouse after specifying the focal point of the parabola, the Parabola 
PropertyManager will be displayed with the options inactive. These options will be available 
only after you have drawn the parabola. Figure 2-53 shows a partial view of the Parabola 
PropertyManager.

Tip. To dislodge the task pane, choose the Auto Show button and double-click on the gray 
bar at the top where its name is displayed. Now, you can move it at the desired location. 
To place it back on its original position, again double-click on the gray bar or choose the 
Dock Task Pane button provided at the top right corner of the task pane.
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Figure 2-52  Parabola and its parameters Figure 2-53  Partial view of the Parabola 
PropertyManager

DRAWING CONIC CURVES				        
  CommandManager:		  Sketch > Ellipse flyout > Conic   	 
  SOLIDWORKS menus:		 Tools > Sketch Entities > Conic	  
  Toolbar:   			   Sketch > Ellipse flyout > Conic	

In SOLIDWORKS, you can draw a conic curve by specifying the endpoints and the 
Rho value. To create the conic curve, choose Tools > Sketch Entities > Conic from 
the Solidworks menus; the cursor will be replaced by the conic cursor. Click to specify 

the first end point of the conic curve and move the cursor away from it; a reference line will 
get attached to the cursor. Next, click to specify the second endpoint of the conic curve and 
move the cursor away from it; the preview of the conic curve will get attached to the cursor 
and will be displayed in yellow color and the Conic PropertyManager will be displayed with 
its options inactive. As you move the cursor, the curve will change dynamically with the cursor 
movement, refer to Figure 2-54. Move the cursor to a distance and click to specify the top 
vertex of the conic curve to be drawn. A reference line will be generated and the Rho value 
will be displayed above the cursor. As you move the cursor, the Rho value of the conic curve 
will be modified accordingly. Click the left mouse button when the required Rho value is 
displayed above the conic cursor; the conic curve will be created and the options of the Conic 
PropertyManager will be activated, refer to Figure 2-55. You can also modify the parameters 
of the conic curve drawn by using this PropertyManager.
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Figure 2-54  Conic and its parameters Figure 2-55  Partial view of the Conic 
PropertyManager

DRAWING DISPLAY TOOLS
The drawing display tools are one of the most important tools provided in any of the solid 
modeling software. These tools allow you to modify the display of a drawing by zooming or 
panning it. In SOLIDWORKS, some of these tools are displayed in the drawing area in the 
View (Heads-Up) toolbar. Some of the drawing display tools available in SOLIDWORKS are 
discussed in this chapter. The remaining tools will be discussed in the later chapters.

Zoom to Fit
 View (Heads-Up):   Zoom to Fit				     
 SOLIDWORKS menus:  View > Modify > Zoom to Fit	

You can find this tool in the View (Head-up) toolbar. Choose the Zoom to Fit tool to 
increase or decrease the drawing display area so that all the sketched entities or 
dimensions are fitted inside the current view. You can also press the F key to invoke 

this tool. Alternatively, double-click the middle mouse button in the drawing area to invoke 
this tool. 

Zoom to Area
 View (Heads-Up):    Zoom to Area			    
 SOLIDWORKS menus:  View > Modify > Zoom to Area	

You can find this tool in the View (Head-up) toolbar. The Zoom to Area tool is used 
to magnify a specified area so that the part of the drawing inside the magnified area 
can be viewed in the current window. The area is defined inside a window that is created 

by dragging the cursor. When you choose this button, the cursor is replaced by a magnifying 
glass cursor. Press and hold the left mouse button and drag the cursor to specify the opposite 
corners of the window. The area enclosed inside the window will be magnified. 
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Zoom In/Out
  SOLIDWORKS menus:  View > Modify > Zoom In/Out	

The Zoom In/Out tool is used to dynamically zoom in or out the drawing. When you 
invoke this tool, the cursor will be replaced by the Zoom In/Out cursor. To zoom out 
of a drawing, press and hold the left mouse button and drag the cursor in the downward 

direction. Similarly, to zoom in a drawing, press and hold the left mouse button and drag the 
cursor in the upward direction. As you drag the cursor, the drawing display will be modified 
dynamically. After you get the desired view, exit this tool by choosing the Select tool from the 
Sketch toolbar. You can also exit this tool by right-clicking and choosing Select from the 
shortcut menu or by pressing the ESC key. If you have a mouse with scroll wheel, then scroll 
the wheel to zoom in/out of the drawing. You can also press the Z key to zoom out of a drawing 
and press the SHIFT+Z keys to zoom in the drawing.

Zoom to Selection
  SOLIDWORKS menus:  View > Modify > Zoom to Selection       

The Zoom to Selection tool is used to modify the drawing display area such that the 
selected entity fits inside the current display. After selecting the entity, choose the Zoom 
to Selection tool; the drawing display area will be modified such that the selected entity 

fits inside the current view. Press and hold the CTRL key while selecting multiple entities. In 
SOLIDWORKS, if you select an entity, a pop-up toolbar will be displayed in the drawing area and 
you can invoke the Zoom to Selection tool from it. 

Pan
 View (Heads-Up):  Pan (Customize to Add)        

The Pan tool is used to drag the view in the current display. You can also press the 
CTRL key and the middle mouse button and then drag the cursor to move the entities.

Tip. You can also invoke the Pan tool using the CTRL key and the arrow keys on the 
keyboard. For example, to pan toward the right, press the CTRL key and then press the right 
arrow key. Similarly, to pan upward, press the CTRL key and then press the up arrow key.

Previous View
   View (Heads-Up):  Previous View    

This tool is used to display the last view of the model and can be useful if you have 
zoomed the model at many levels. You can view the last ten views using this tool. You 
can invoke this tool from the drawing area or press the CTRL+SHIFT+Z keys.

Tip. You can also invoke some of the drawing display tools from the shortcut menu. To do 
so, right-click and choose Zoom/Pan/Rotate; a flyout will be displayed with the display 
tools.
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Redraw
 SOLIDWORKS menus:	 View > Redraw	   

The Redraw tool is used to refresh the screen. Sometimes when you draw a sketched 
entity, some unwanted elements remain on the screen. To remove these unwanted 
elements from the screen, use this tool. The screen will be refreshed and all the unwanted 

elements will be removed. You can invoke this tool by pressing the CTRL+R keys.

DELETING SKETCHED ENTITIES
You can delete the sketched entities by selecting them using the Select tool and then pressing 
the DELETE key on the keyboard. You can select the entities individually or select more than 
one entity by defining a window or crossing around the entities. When you select the entities, 
they turn light blue. When they turn light blue, press the DELETE key. You can also delete the 
sketched entities by selecting them and choosing the Delete option from the shortcut menu 
that is displayed on right-clicking.

TUTORIALS
Tutorial 1

In this tutorial, you will draw the basic sketch of the revolved solid model shown in Figure 2-56. 
The sketch of this model is shown in Figure 2-57. Do not dimension the sketch. The solid 
model and its dimensions are given for your reference only.	   (Expected time: 30 min)

Figure 2-57  Sketch of the revolved solid modelFigure 2-56  Revolved solid model for Tutorial 1

	 The following steps are required to complete this tutorial:

a.	 Start a new part document.
b.	 Invoke the sketching environment.
c.	 Modify the settings of the snap and grid so that the cursor jumps through a distance of 

5 mm.
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d.	 Draw the sketch of the model using the Line tool.
e.	 Save the sketch and then close the document.

Opening a New Part Document 
1.	 Start SOLIDWORKS by double-clicking on the shortcut icon of SOLIDWORKS available 

on the desktop of your computer; the SOLIDWORKS 2015 window along with the 
SOLIDWORKS Resources task pane on its right is displayed. The Getting Started 
Community, Online Resources, and Tip of the Day are displayed in this task pane.

	 You can get valuable tips from the Tip of the Day message box. These tips help you fully 
and properly utilize this CAD package.

2.	 Choose the New Document option from the Getting Started rollout of the SOLIDWORKS 
Resources task pane; the New SOLIDWORKS Document dialog box is displayed, as 
shown in Figure 2-58.

Figure 2-58  The New SOLIDWORKS Document dialog box

3.	 In the New SOLIDWORKS Document dialog box, the Part button is chosen by default. 
Therefore, choose the OK button; a new SOLIDWORKS part document starts.  

	 You need to invoke the sketching environment to draw the sketch.

4.	 Choose the Sketch tab from the CommandManager and then the Sketch button in
the Sketch CommandManager; the Edit Sketch PropertyManager is displayed 
and you are prompted to select a plane on which you want to draw the sketch.  
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5.	 Select the Front Plane from the drawing area; the sketching environment is invoked and 
the plane gets oriented normal to the view. You will notice that red colored arrows are 
displayed at the center of the screen, indicating that you are in the sketching environment. 
Also, the confirmation corner with the Exit Sketch and Cancel options is displayed on the 
upper right corner in the graphics area. The screen display in the sketching environment 
of SOLIDWORKS 2015 is shown in Figure 2-59.

Figure 2-59  Screen display in the sketching environment 

Modifying the Snap, Grid, and Dimensioning Unit Settings
	 It is assumed that while installing SOLIDWORKS, you have selected the MMGS 

(millimeters, gram, second) option for measuring the length. Therefore, the length of 
an entity will be measured in millimeters in the current file. But, if you select some other 
unit at the time of installation, you need to change the linear and angular units before 
drawing the sketch. For this tutorial, you need to modify the grid and snap settings so 
that the cursor jumps through a distance of 5 mm.

1.	 Choose the Options button from the Menu Bar; the System Options - General dialog 
box is displayed.

2.	 Choose the Document Properties tab; the name of the dialog box changes to the Document 
Properties - Drafting Standard. 

Note
If you have selected millimeters as the unit of measurement while installing SOLIDWORKS, 
skip steps 3 and 4 in this section.

3.	 Select the Units option from the area on the left to display the options related to the 
linear and angular units.
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4.	 Select the MMGS (millimeter, gram, second) radio button in the Unit system area. Also, 
select the degrees option from the Angle area in the Units column, if it is not selected 
by default. You can also change the unit system using the Unit system button, which is 
located at the right-side of the status bar.

	 It is evident from Figure 2-57 that the dimensions in the sketch are multiples of 5. Therefore, 
you need to modify the grid and snap settings so that the cursor jumps through a distance 
of 5 mm instead of 10 mm.

5.	 Select the Grid/Snap option from the area on the left to display grid options. Set the 
value in the Major grid spacing spinner to 50 and the value in the Minor-lines per major 
spinner to 10. 

6.	 Select the Display grid check box if it is cleared. Next, choose the Go To System Snaps 
button; the system options related to relations and snaps are displayed.

7.	 Select the Grid check box from the Sketch snaps area and clear the Snap only when grid 
is displayed check box. Choose OK to exit the dialog box.

	
	 Note that in the sketching environment, the lower right corner of the drawing area 

displays the information about the status of sketch and location of the cursor in the X, Y, 
and Z coordinates. You will use the coordinates displayed to draw the sketch of the model. 
These coordinates will be modified as you move the cursor around the drawing area. If 
you move the cursor after initial settings, the coordinates will show an increment of 5 mm 
instead of the default increment of 10 mm.

Drawing the Sketch
	 It is evident from Figure 2-57 that the sketch will be drawn using the Line tool. Therefore, 

you need to start drawing the sketch from the lower left corner of the sketch.

1.	 Choose the Line tool from the Sketch CommandManager; the arrow cursor is 
replaced by the line cursor.

2.	 Move the line cursor to the origin.

3.	 Left-click at this point and move the cursor horizontally toward the right. You will notice 
that the symbol of the Horizontal relation is displayed below the line cursor and the length 
and angle of the line are displayed above the line cursor. 

4.	 Left-click again when the length of the line above the line cursor shows 20.

	 The first horizontal line is drawn. As you are drawing continuous lines, the endpoint of 
the line drawn is automatically selected as the start point of the next line.

5.	 Move the line cursor vertically upward. The symbol of the Vertical relation is displayed 
on the right of the line cursor and the length of the line is displayed above the line cursor. 
Click when the length of the line on the line cursor is displayed 20.
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6.	 Move the cursor horizontally toward the left and click when the length of the line on the 
line cursor is displayed as 5.

7.	 Move the line cursor vertically upward and press the left mouse button when the length 
of the line on the line cursor is displayed as 25.

8.	 Move the line cursor horizontally toward the right and click when the length of the line 
on the line cursor is displayed as 20.

9.	 Move the line cursor vertically upward and click when the length of the line on the line 
cursor is displayed as 5.

10.	 Press F on the keyboard to fit the sketch on the screen.

11.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 50.

12.	 Move the line cursor vertically downward and click when the length of the line on the line 
cursor is displayed as 5.

13.	 Move the line cursor horizontally toward the right and press the left mouse button when 
the length of the line on the line cursor is displayed as 20.

14.	 Move the line cursor vertically downward and click when the length of the line on the line 
cursor is displayed as 25.

15.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 5.

16.	 Move the line cursor vertically downward to the start point of the first line. Click when an 
orange circle is displayed; the final sketch for Tutorial 1 is created, as shown in Figure 2-60. 
In this figure, the grid display is turned off for clarity.

Figure 2-60  Final sketch for Tutorial 1
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17.	 Right-click and then choose Select from the shortcut menu to exit the Line tool. 

Note
In Figure  2-60, the display of relations is turned on. To turn off the display of relations, choose 
the View Sketch Relations button from the Hide/Show Items flyout in the View (Head-Up) 
toolbar.

Tip. To turn off the grid display, right-click in the drawing area to display a shortcut menu. 
Choose the Display Grid button to turn off the grid display. This is a toggle button.

Saving the Sketch
	 It is recommended that you create a separate folder for saving the tutorial files of this 

book. Next, you can save the tutorials of a chapter in the folder of that chapter.

1.	 Choose the Save button from the Menu Bar to invoke the Save As dialog box. 
Create the SOLIDWORKS folder inside the \Documents folder and then create the 
c02 folder inside the SOLIDWORKS folder.

2.	 Enter c02_tut01 as the name of the document in the File name edit box and choose the 
Save button. The document is saved at the location \Documents\SOLIDWORKS\c02. 

3.	 Close the document by choosing File > Close from the SOLIDWORKS menus.

Tutorial 2
In this tutorial, you will draw the sketch of the solid model shown in Figure 2-61. The sketch 
of the model is shown in Figure 2-62. Do not dimension the sketch. The solid model and the 
dimensions are given for your reference only.			     (Expected time: 30 min)

Figure 2-62  Sketch for Tutorial 2 Figure 2-61 Solid model for Tutorial 2 	
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The following steps are required to complete this tutorial:

a.	 Start SOLIDWORKS and then start a new part document.
b.	 Invoke the sketching environment.
c.	 Modify the snap and grid settings so that the cursor jumps through a distance of 5 mm.
d.	 Draw the sketch using the Line tool, refer to Figure 2-63.
e.	 Save the sketch and then close the file.

Opening a New File                                                                       
1.	 Choose the New button from the Menu Bar to invoke the New SOLIDWORKS 

Document dialog box.
	
	 The Part button is chosen by default in the New SOLIDWORKS Document dialog 

box.

2.	 Choose the OK button from the dialog box.

	 You need to invoke the sketching environment to draw the sketch of the model first.

3.	 Choose the Sketch button from the Sketch CommandManager and select the Front 
Plane to invoke the sketching environment. 

Modifying the Snap, Grid, Dimensioning Unit Settings
	 It is evident from Figure 2-62 that the dimensions in the sketch are multiples of 5. Therefore, 

you need to modify the grid and snap settings so that the cursor jumps through a distance 
of 5 mm.

1.	 Choose Options from the Menu Bar to invoke the System Options - General dialog box. 
In this dialog box, choose the Document Properties tab.

2.	 Select the Grid/Snap option from the area on the left to display the options related to 
the linear and angular units. Set the value in the Major grid spacing spinner to 50 and  
in the Minor-lines per major spinner to 10.

3.	 Choose the Go To System Snaps button to display the System Options - Relations/
Snaps dialog box. Make sure that the Grid check box is selected in the System Options 
- Relations/Snaps dialog box. Next, choose the OK button.

	 When you move the cursor, the coordinates displayed close to the lower right corner of 
the drawing area show an increment of 5 mm.

Drawing the Sketch
	 The sketch will be drawn using the Line tool. The arc in the sketch will also be drawn using 

the same tool. You need to start the drawing from the lower left corner of the sketch.

1.	 Invoke the Line tool by pressing the L key; the arrow cursor is replaced by the line 
cursor.
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2.	 Move the line cursor to origin.

3.	 Click at this point and move the cursor horizontally toward the right. Click again when 
the length of the line above the line cursor displays 60; a horizontal line of 60 mm length 
is drawn.

4.	 Move the line cursor vertically upward and click when the length above the line cursor is 
displayed as 35.

5.	 Choose the Zoom to Fit button from the View (Heads-Up) toolbar to fit the sketch 
into the screen. 

	 As mentioned earlier, you can invoke the drawing display tools while some other tool is 
still active. After modifying the drawing display area, the Line tool that was active before 
invoking the drawing display tool will be restored and you can continue drawing lines 
using the Line tool.

6.	 Move the line cursor horizontally toward the left and press the left mouse button when 
the length of the line above the line cursor shows the value 10.

7.	 Move the line cursor vertically downward and click when the length of the line above the 
line cursor is displayed as 10.

8.	 Move the line cursor horizontally toward the left and click when the length of the line 
above the line cursor is displayed as 10.

	 Next, you need to draw an arc normal to the last line using the Line tool. It is recommended 
to use the Line tool when you need to draw a sketch that is a combination of lines and 
arcs. This increases productivity by reducing the time taken in invoking tools for drawing 
an arc and a line.

9.	 Move the line cursor away from the endpoint of the last line and then move it back close 
to the endpoint; the arc mode is invoked. 

10.	 Move the arc cursor vertically downward up to the next grid point.

11.	 Move the arc cursor toward the left.

	 You will notice that a normal arc is being drawn and the angle and radius of the arc are 
displayed above the line cursor.

12.	 Move the cursor to the left and click when the angle value on the arc cursor is displayed 
as 180 and the radius value is displayed as 10; an arc normal to the last line is drawn and 
the line mode is invoked.

13.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 10.
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14.	 Move the line cursor vertically upward and click when the length of the line on the line 
cursor is displayed as 10.

15.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 10.

16.	 Move the line cursor to the start point of the first line and click when an orange circle is 
displayed.

17. Press the ESC key to exit the Line tool.

	 This completes the sketch. However, you need to modify the drawing display area such 
that the sketch fits the screen.

18.	 Press the F key to modify the drawing display area. The final sketch for Tutorial 2 with the 
grid display turned off is shown in Figure 2-63.

Figure 2-63  Final sketch for Tutorial 2

Saving the Sketch
1.	 Choose the Save button from the Menu Bar to invoke the Save As dialog box.      	

    
2.	 Enter c02_tut02 as the name of the document in the File name edit box. Choose the Save 

button and then save the file at the location \Documents\SOLIDWORKS\c02.

3.	 Close the document by choosing File > Close from the SOLIDWORKS menus.
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Tutorial 3
In this tutorial, you will draw the basic sketch of the model shown in Figure 2-64. The sketch 
to be drawn is shown in Figure 2-65. Do not dimension the sketch; the solid model and its 
dimensions are given for your reference only.			     (Expected time: 30 min)

	 The following steps are required to complete this tutorial:

a.	 Start SOLIDWORKS and then start a new part file.
b.	 Invoke the sketching environment.
c.	 Modify the snap and grid settings so that the cursor jumps through a distance of 5 mm.
d.	 Draw the outer loop of the sketch using the Line tool.
e.	 Draw the inner circle using the Circle tool, refer to Figure 2-65.
f.	 Save the sketch and then close the file.

Figure 2-65  Sketch for Tutorial 3Figure 2-64  Solid model for Tutorial 3

Starting a New File
1.	 Choose the New button from the Menu Bar to invoke the New SOLIDWORKS 

Document dialog box; the Part button is chosen by default in the New 
SOLIDWORKS Document dialog box. 

2.	 Choose the OK button from this dialog box; a new SOLIDWORKS part document is 
started. To draw the sketch of the model, you need to invoke the sketching environment.

3.	 Choose the Sketch button from the Sketch CommandManager; the Edit Sketch 
PropertyManager is displayed. 

4.	 Select Front Plane from the drawing area; the sketching environment is invoked. Also, the 
confirmation corner is displayed with the Exit Sketch and Cancel options at the upper 
right corner of the drawing area. 
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Modifying the Snap, Grid, and Dimensioning Unit Settings
	 As the dimensions in the sketch are multiples of 5, you need to modify the grid and snap 

settings so that the cursor jumps through a distance of 5 mm.

1.	 Choose Options from the Menu Bar to invoke the System Options - General dialog box. 
Next, choose the Document Properties tab from this dialog box.

2.	 Select the Grid/Snap option from the area on the left to display the options related to the 
linear and angular units. Set the value in the Major grid spacing spinner to 50 and the 
value in the Minor-lines per major spinner to 10.

3.	 Next, choose the Go To System Snaps button to invoke the System Options - Relations/
Snaps dialog box. Make sure that the Grid check box is selected in this dialog box and 
choose OK to close the dialog box.

Drawing the Outer Loop
	 It is evident from Figure 2-65 that the sketch consists of an outer loop and an inner 

circle. Therefore, this sketch will be drawn using the Line and Circle tools. You will start 
drawing from the lower left corner of the sketch. As the length of the lower horizontal 
line is 150 mm, you need to modify the drawing display area such that the drawing area 
in the first quadrant is increased. This can be done by using the Pan tool.

1.	 Press the CTRL key and the middle mouse button, and then drag the cursor toward the 
bottom left corner of the screen.

	 You will notice that the origin is also moved toward the bottom left corner of the screen, 
thus increasing the drawing area in the first quadrant.

2.	 After dragging the origin close to the lower left corner, release the left mouse button.

3.	 Choose the Line button from the Sketch CommandManager.		       

4.	 Move the line cursor to a location whose coordinates are 40 mm, 0 mm, and 0 mm. Click 
to specify the start point of the line.

5.	 Move the cursor horizontally toward the right and click when the length of the line above 
the line cursor is displayed as 150.

6.	 Next, move the line cursor vertically upward and click when the length of the line on the 
line cursor is displayed as 40.

	 The next entity to be drawn is a tangent arc. The tangent arc will be drawn by invoking 
the arc mode using the Line tool.

7.	 Move the line cursor away from the endpoint of the last line and then move it back to the 
endpoint; the arc mode is invoked and the line cursor is replaced by the arc cursor. 
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8.	 Move the arc cursor vertically upward to a small distance and then move it to the left  
when the dotted line is displayed.

	 You will notice that a tangent arc is being drawn. The angle of the tangent arc and its 
radius are displayed above the arc cursor.

9.	 Click when the angle value above the arc cursor is displayed as 180 and the radius is 
displayed as 30 to complete the arc.

	 The required tangent arc is drawn. As mentioned earlier, the line mode is automatically 
invoked after you have drawn the arc by using the Line tool. 

10.	 Move the line cursor vertically downward and click when the length of the line on the line 
cursor is displayed as 20.

11.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 30.

12.	 Move the line cursor vertically downward and click when the length of the line on the line 
cursor is displayed as 5.

13.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 25.

14.	 Move the line cursor vertically upward and click when the length of the line on the line 
cursor is displayed as 5.

15.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 35.

16.	 Move the line cursor to the start point of the first line. Click when an orange circle is 
displayed.

	 The length of the line at this point is 20 mm.

17.	 Right-click and then choose Select from the shortcut menu to exit the Line tool. 

18.	 Choose the Zoom to Fit button from the View (Heads-Up) toolbar to fit the sketch  
into the screen. This completes the outer loop of the sketch. The sketch after 
drawing the outer loop appears, as shown in Figure 2-66.

Tip. If the arc mode is invoked by mistake while drawing continuous lines, press the A key; 
the line mode will be invoked again.
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Drawing the Circle
	 The circle in the sketch will be drawn using the Circle tool. The centerpoint of the circle 

will be the centerpoint of the arc, which is represented by a plus sign. The plus sign is 
automatically drawn when you draw an arc. You can select this centerpoint to draw the 
circle.

1.	 Choose the Circle button from the Circle flyout in the Sketch CommandManager; 
the Circle PropertyManager is invoked. 

2.	 Move the circle cursor close to the centerpoint of the arc and click when an orange circle 
is displayed.

3.	 Move the cursor toward the left and click when the radius of the circle above the circle cursor 
shows 15; a circle of 15 mm radius is drawn. This completes the sketch for Tutorial 3.

4.	 Right-click and then choose the Select option from the shortcut menu to exit the Circle 
tool. 

	 The final sketch for Tutorial 3 is shown in Figure 2-66.

Figure 2-66  Final sketch for Tutorial 3

Tip. You will notice that the bottom horizontal line in the sketch is black and the remaining 
lines are blue. In the next chapter, you will learn why some entities in a sketch have different 
colors.

Saving the Sketch
1.	 Choose the Save button from the Menu Bar to invoke the Save As dialog box.   

2.	 Enter c02_tut03 as the name of the document in the File name edit box. Choose Save 
and save the file at the location \Documents\SOLIDWORKS\c02.

3.	 Close the document by choosing File > Close from the SOLIDWORKS menus.
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Tutorial 4
In this tutorial, you will draw the sketch of the model shown in Figure 2-67. The sketch of 
the model is shown in Figure 2-68. Do not dimension the sketch. The solid model and the 
dimensions are given for your reference only.			     (Expected time: 30 min)
	
	 The following steps are required to complete this tutorial:

a.	 Start SOLIDWORKS and then start a new part document.
b.	 Invoke the sketching environment.
c.	 Draw the outer loop of the sketch, refer to Figures 2-69 and 2-70.
d.	 Draw circles and sketch of inner cavity, refer to Figures 2-71 through 2-73
e.	 Save the sketch and then close the document.

Figure 2-68  Sketch of the model for Tutorial 4Figure 2-67  Solid model for Tutorial 4

Starting a New File
1.	 Choose the New button from the Menu Bar to invoke the New SOLIDWORKS Document 

dialog box; the Part button is chosen by default in the New SOLIDWORKS Document 
dialog box.

2.	 Choose the OK button from the New SOLIDWORKS Document dialog box; a new 
SOLIDWORKS part document is started. To draw the sketch of the model, you need to 
invoke the sketching environment.

3.	 Choose the Sketch button from the Sketch CommandManager; the Edit Sketch 
PropertyManager is displayed. 

4.	 Select Front Plane from the drawing area; the sketching environment is invoked. Also, the 
confirmation corner with the Exit Sketch and Delete Sketch options at the upper right 
corner of the drawing area is displayed.
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Modifying the Unit and Grid Settings
	 You need to modify the initial settings to change the linear and angular units before 

drawing the sketch.

1.	 Choose the Options button from the Menu Bar to invoke the System Options - General 
dialog box.

2.	 Choose the Document Properties tab; the name of the dialog box is changed to Document 
Properties - Drafting Standard. 

Note
If you have selected Millimeters as the unit of measurement while installing SOLIDWORKS, 
skip steps 3 and 4 in the section.

3.	 Choose the Units option from the area on the left to display the options related to the 
linear and angular units.

4.	 Select the MMGS (millimeter, gram, second) radio button from the Unit system area, 
if it is not selected by default. Also, select the degrees option from the Angle area, if it is 
not selected by default.

5.	 Select Grid/Snap from the area on the left and select the Display Grid check box, if it is 
cleared. 

6.	 Set the value in the Major grid spacing spinner to 100 and the value in the Minor-lines 
per major spinner to 20. Next, choose the Go To System Snaps button; the system options 
related to relations and snaps are displayed.

7.	 Select the Grid check box from the Sketch snaps area, if it is cleared. Make sure you clear 
the Snap only when grid is displayed check box, if it is selected. Choose OK to exit the 
dialog box.

Tip. If the grid is displayed on the screen when you invoke the sketching environment for 
the first time, you can set the option to turn off the grid display. To do so, right-click in the 
drawing area to display the shortcut menu. The Display Grid option has a check mark on 
its left, indicating that this option is chosen. Choose this option again to turn the grid off.

Drawing the Outer Loop of the Sketch
	 The sketch of the model consists of an outer loop that has two circles and a cavity inside 

it. You will first draw the outer loop and then the inner entities. The sketch will be drawn 
by using the Line and Circle tools. 

	 The outer loop will be drawn using continuous lines. You will start drawing the sketch 
from the lower left corner of the sketch.

1.	 Choose the Line button from the Sketch CommandManager to invoke the Line 
tool; the arrow cursor is replaced by the line cursor. 
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2.	 Move the cursor in the first quadrant close to the origin; the coordinates of the point are 
displayed close to the lower left corner of the screen.

3.	 Click at the point whose coordinates are 10 mm, 10 mm, and 0 mm, and then move the 
cursor horizontally toward the right.

4.	 Click when the length of the line above the line cursor is displayed as 10; a horizontal 
line is created. Refer to Line 1 in Figure 2-69.

5.	 Move the line cursor vertically upward. The symbol of the Vertical relation is displayed 
below the line cursor and the length of the line is displayed above the line cursor.

6.	 Click when the length of the line above the line cursor is displayed as 10; a vertical line 
is created. Refer to Line 2 in Figure 2-69.

7.	 Move the line cursor horizontally toward the right. Click when the length of the line above 
the line cursor is displayed as 10; the next horizontal line of 10 mm length is drawn. Refer 
to Line 3 in Figure 2-69.

8.	 Move the line cursor vertically downward and click when the length of the line on the line 
cursor is displayed as 10. Refer to Line 4 in Figure 2-69.

9.	 Move the line cursor horizontally toward the right and click when the length of the line 
on the line cursor is displayed as 30. Refer to Line 5 in Figure 2-69.

10.	 Move the line cursor vertically upward and click when the length of the line on the line 
cursor is displayed as 10. Refer to Line 6 in Figure 2-69.

11.	 Move the line cursor horizontally toward the right and click when the length of the line 
on the line cursor is displayed as10. Refer to Line 7 in Figure 2-69.

12.	 Move the line cursor vertically downward and click when the length of the line on the line 
cursor is displayed as 10. Refer to Line 8 in Figure 2-69.

13.	 Move the line cursor horizontally toward the right and click when the length of the line 
on the line cursor is displayed as 10. Refer to Line 9 in Figure 2-69.

14.	 Move the line cursor vertically upward and

Figure 2-69  Partial outer loop of the sketch

click when the length of the line on the 
line cursor is displayed as 40. Refer to 
Line 10 in Figure 2-69.

	 The next line that you need to draw is an 
inclined line at an angle of 135-degree. 
To draw this line, you need to move the 
cursor in a direction that makes an angle 
of 135-degree.
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15.	 Move the line cursor such that a line is drawn at an angle of 135-degree and the length of 
the line is displayed as 14.14 above the cursor. The angle can be checked from the Angle 
spinner in the Parameters rollout of the Line PropertyManager.

16.	 Click at this location to specify the endpoint of the inclined line.

17.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 50.

	 You will notice that some yellow inferencing lines are displayed when you move 
the cursor.

18.	 Move the line cursor diagonally in the downward direction where the angle value is 
135-degree and the length of the lines is 14.14.

19.	 Click at this location and then move the cursor vertically downward to the start point of 
the first line.

	 You will notice that when you move the cursor close to the start point of the first line, an 
orange circle is displayed. Also, the symbols of the Vertical and Coincident relations are 
displayed on the right of the cursor. The length of the line is displayed as 40.

20.	 Click when the orange circle is displayed and right-click; a shortcut menu is displayed. 
Choose the Select option from the shortcut menu to exit the Line tool.

	 This completes the sketch of the outer loop. Since the display of the sketch is small, you 
need to modify the drawing display area such that the sketch fits the screen. The drawing 
display area is modified by using the Zoom to Fit tool.

21.	 Choose the Zoom to Fit tool from the View (Heads-Up) toolbar to fit the current sketch 
into the screen. The outer loop of the sketch is completed and is shown in Figure 2-70. 
Note that in this figure, the grid display is turned off for better visibility. To turn off the 
grid display, right-click in the drawing area and then choose the Display grid option from 
the shortcut menu displayed. 

Figure 2-70  Outer loop of the sketch
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Drawing Circles
	 In this section, you will invoke the Circle tool by using the Mouse Gesture to draw two 

circles. You will use the inferencing lines originating from the start points and endpoints 
of the inclined lines to specify the centerpoint of circles. At a given time, you can snap 
to grid or use inferencing lines to draw sketches. In this tutorial, you will use inferencing 
lines to draw the sketch. So, you need to turn off the snapping to grid option.

1.	 Right-click in the drawing area and then choose the Relations/Snaps Options option 
from the shortcut menu; the System Options - Relations/Snaps dialog box is displayed 
with the Relations/Snaps option chosen. Clear the Grid check box and choose the OK 
button in this dialog box.

2.	 Press and hold the right mouse button in the drawing area and drag the mouse; a set of tools 
is displayed. Move the cursor on the Circle tool; the Circle PropertyManager is displayed. 
Choose the Circle button from the Circle Type rollout, if it has not already been chosen. 

	 When you invoke the Circle tool, the arrow cursor is replaced by the circle cursor.

3.	 Move the circle cursor close to the lower endpoint of the right inclined line and then move it 
toward the left. Remember that you should not press the left mouse button at this moment. 
An inferencing line is displayed originating from the lower endpoint of the right inclined 
line. On moving the cursor toward the left, you will notice that another inferencing line 
originates at the point where the cursor is vertically in line with the upper endpoint of 
the right inclined line. This inferencing line will intersect the inferencing line generated 
from the lower endpoint of the inclined line, refer to Figure 2-71.

Figure 2-71  Drawing a circle with the help of inferencing lines

4.	 Click at the point where the inferencing lines from both the endpoints of the inclined 
lines intersect. Next, move the circle cursor toward the left to define a circle. 

5.	 Click when the radius of the circle displayed above the circle cursor shows a value close 
to 5; a circle is created.



2-60  			          				         SOLIDWORKS for Designers
E
va

lu
a

ti
on

 C
op

y.
 D

o 
no

t 
re

pr
od

uc
e.

 F
or

 i
nf

or
m

a
ti

on
 v

is
it

 w
w

w
.c

a
dc

im
.c

om

6.	 Now, the options in the Circle PropertyManager are activated. Set the value in the Radius 
spinner to 5 in the Parameters rollout of the PropertyManager and press ENTER.

7.	 Similarly, draw the circle on the left using the inferencing lines generating from the 
endpoints of the left inclined line. The sketch after drawing the two circles inside the 
outer loop is shown in Figure 2-72.

Figure 2-72  Sketch after drawing the two inner circles

8.	 Right-click in the drawing area and then choose Select from the shortcut menu displayed 
to exit the Circle tool.

Drawing the Sketch of the Inner Cavity
	 Next, you will draw the sketch of the inner cavity. You will start drawing the sketch with 

the lower horizontal line. Before proceeding further, you need to invoke the snap to grid 
option.

1.	 Right-click and then choose the Relations/Snaps Option option from the shortcut menu 
displayed. Then, select the Grid check box in the System Options - Relations/Snaps 
dialog box and choose the OK button. 

2.	 Invoke the Line tool by pressing the L key; the arrow cursor is replaced by the line cursor.

3.	 Move the line cursor to a location whose coordinates are 30 mm, 25 mm, and 0 mm, and 
then click to specify the start point of the line.

4.	 Click at this point and move the cursor horizontally toward the right. Click again when 
the length of the line above the line cursor is displayed as 30.

5.	 Move the line cursor vertically upward and click when the length of the line on the line 
cursor is displayed as 10.

6.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 10.
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7.	 Move the line cursor vertically downward and click when the length of the line on the line 
cursor is displayed as 5.

8.	 Move the line cursor horizontally toward the left and click when the length of the line on 
the line cursor is displayed as 10.

9.	 Move the line cursor vertically upward and click when the length of the line on the line 
cursor is displayed as 5.

10.	 Move the line horizontally toward the left and click when the length of the line on the 
line cursor is displayed as 10.

11.	 Move the line cursor vertically downward to the start point of the first line. Click when an 
orange circle is displayed. The length of the line at this point is displayed as 10.

12.	 Right-click and then choose Select from the shortcut menu. This completes the sketch 
for Tutorial 4. 

13.	 Choose the Zoom to Fit button from the View (Heads-Up) toolbar to fit the display of 
the sketch into the screen. The final sketch for Tutorial 4 is shown in Figure 2-73.

Figure 2-73  Final sketch for Tutorial 4

Saving the Sketch								          
1.	 Choose the Save button from the Menu Bar to invoke the Save As dialog box.  

2.	 Enter c02_tut04 as the name of the document in the File name edit box and choose the 
Save button; the document is saved at the location \Documents\SOLIDWORKS\c02.

3.	 Close the document by choosing File > Close from the SOLIDWORKS menus.
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SELF-EVALUATION TEST
Answer the following questions and then compare them to those given at the end of this 
chapter:

1.	 The base feature of any design is a sketched feature and is created by drawing a sketch. 
(T/F)

2.	 You can invoke the arc mode using the Line tool. (T/F)

3.	 By default, the cursor jumps through a distance of 5 mm when the grid snap is on. (T/F)

4.	 If you save a file in the sketching environment and then open it the next time, it will open 
in the part modeling environment. (T/F)

5.	 You can convert a sketched entity into a construction entity by selecting the __________ 
check box provided in the PropertyManager.

6.	 To draw a rectangle at an angle, you need to use the __________ tool.

7.	 __________ are temporary lines that are used to track a particular point on the screen.

8.	 You can invoke the __________ tool or press the ESC key to exit the sketching tool.

9.	 When you select a tangent entity to draw a tangent arc, the __________ relation is applied 
between the start point of the arc and the tangent entity. 

10.	 In SOLIDWORKS, a rectangle is considered as a combination of individual __________.

REVIEW QUESTIONS
Answer the following questions:

1.	 A three point arc is drawn by defining the start point, the endpoint, and a point on the 
arc. (T/F)

2.	 You can delete the sketched entities by right-clicking on them and then choosing the 
Delete option from the shortcut menu. (T/F)

3.	 The origin is a blue icon that is displayed in the middle of the sketcher screen. (T/F)

4.	 In SOLIDWORKS, circles are drawn by specifying the centerpoint of the circle and then 
entering the radius of the circle in the dialog box displayed. (T/F)

5.	 When you open a new SOLIDWORKS document, it is not maximized in the SOLIDWORKS 
window.  (T/F)
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6.	 In SOLIDWORKS, a polygon is considered as a combination of which of the following 
entities? 	

		
		  (a) Lines			   	 (b) Arcs
		  (c) Splines				    (d) None of these

7.	 Which of the following options is not displayed in the New SOLIDWORKS Document 
dialog box?

		  (a) Part				   	 (b) Assembly
		  (c) Drawing				    (d) Sketch
	
8.	 Which of the following entities is not considered while converting a sketch into a feature?

		  (a) Sketched circles		  	 (b) Sketched lines
		  (c) Construction lines			   (d) None of these

9.	 Which of the following PropertyManagers is displayed when you select a line of a rectangle?

		  (a) Line Properties PropertyManager	 (b) Line/Rectangle PropertyManager
		  (c) Rectangle PropertyManager		 (d) None of these

10.	 Which of the following PropertyManagers is displayed while drawing an elliptical arc?

		  (a) Arc PropertyManager	 	 (b) Ellipse PropertyManager
		  (c) Elliptical Arc PropertyManager	 (d) None of these
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EXERCISES
Exercise 1

Draw the sketch of the model shown in Figure 2-74. The sketch to be drawn is shown in 
Figure 2-75. Do not dimension the sketch. The solid model and its dimensions are given for 
your reference only.					                    (Expected time: 30 min)

Figure 2-75  Sketch for Exercise 1Figure 2-74  Solid model for Exercise 1

Exercise 2
Draw the sketch of the model shown in Figure 2-76. The sketch to be drawn is shown in 
Figure 2-77. Do not dimension the sketch. The solid model and its dimensions are given for 
your reference only.						        (Expected time: 30 min)

Figure 2-76  Solid model for Exercise 2 Figure 2-77  Sketch for Exercise 2
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Exercise 3
Draw the sketch of the model shown in Figure 2-78. The sketch to be drawn is shown in 
Figure 2-79. Do not dimension the sketch. The solid model and its dimensions are given for 
your reference only.						        (Expected time: 30 min)

Figure 2-79  Sketch for Exercise 3Figure 2-78  Solid model for Exercise 3

Exercise 4
Draw the sketch of the model shown in Figure 2-80. The sketch to be drawn is shown in 
Figure 2-81. Do not dimension the sketch. The solid model and its dimensions are given for 
your reference only.						        (Expected time: 30 min)

Figure 2-81  Sketch for Exercise 4Figure 2-80  Solid model for Exercise 4
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Answers to Self-Evaluation Test
1. T, 2. F, 3. F, 4. F, 5. For construction, 6. 3 Point Corner Rectangle, 7. Inferencing lines, 
8. Select, 9. Tangent, 10. lines


